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Identification

Document Identification

Document Title: JCSS Technical Reference
Version: 10.0 Final

Software Identification

Product Name: JCSS
Product Release: 10.0

Documentation Conventions

This documentation uses specific formatting and typographic conventions to 
present the following types of information:

• Objects, examples, and system I/O

• Object hierarchies

• Computer commands

• Lists and procedures

Objects, Examples, and System I/O

• Directory paths and file names are in standard Courier typeface:

C:\JCSS\User_Data\Projects

• Function names in body text are in italics:

op_dist_outcome()

• The names of functions of interest in example code are in bolded Courier 
typeface:

/* determine the object ID of packet’s creation module */
src_mod_objid = op_pk_creation_mod_get (pkptr);

• Variables are enclosed in angle brackets (< >):

<JCSS path>\Scenario_Builder\op_admin\err_log

Object Hierarchies

Menu hierarchies are indicated by right angle brackets (>); for example:
Edit > Preferences > Advanced
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Computer Commands

These conventions apply to Windows systems and navigation methods that use 
the standard graphical-user-interface (GUI) terminology such as click, drag, and 
dialog box.

• Key combinations appear in the form “press <button>+x”; this means press 
the <button> and x keys at the same time to do the operation.

• The mouse operations left-click (or click) and right-click indicate that you 
should press the left mouse button or right mouse button, respectively.

Lists and Procedures

Information is often itemized in bulleted (unordered) or numbered (ordered) 
lists:

• In bulleted lists, the sequence of items is not important.

• In numbered lists, the sequence of items is important.

Procedures are contained within procedure headings and footings that indicate 
the start and end of the procedure. Each step of a procedure is numbered to 
indicate the sequence in which you should do the steps.
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Document Revision History

Table FM-1   Document Revision History

Release Date Product Version Chapter Description of Change

April 2010 10.0 Final All • Updated references from 9.0 to 10.0

• Updated references from 15.0 to 16.0

• Changed from Draft to Final version

1 • Added introduction for DoDAF Editor

3 • Added note to “Filter > Devices” regarding 
application types supported.

• Added menu items “Page Setup” and “Print 
Scenario”

• Removed menu item “Traffic Flow Thresholds”

• Added “Display Recorded Routes” and “Hide 
Routes” features

• Added Visualize Protocol Configuration options: 
“ATM Routing Domains”, “VLAN Configurations”, 
“HAIPE Versions”, and “Clear Visualization”

• Enhanced descriptions of “Set View for Subnet” and 
“Set View for Network”

• Added topology import feature “From Circuit Switch 
Text Files”

• Added topology feature “Generate IP Cloud Metrics 
Files> From Router Metrics Information”

• Added topology feature “Role Assignment > Assign 
Roles”

• Added topology feature “Import STK Orbit”

• Updated Edge Connectivity Wizard screenshot

• Updated figures for “Deploy Broadcast Network”

• Updated “Export IER Report” 

• Removed steps under “Flows > Open Flows 
Browser”

• Updated Table 3-5 to represent all current protocols 
in menu

• Updated graphics for MOP options post-simulation
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March 2010 10.0 Draft All • Converted PDF files of JCSS Technical Reference 
into Adobe FrameMaker 7.0. and applied 
commercial OPNET product documentation style 
template to improve quality and update manual. 
Reformatted text as needed to fit new format and 
style.

4 • Revised “Creating IERs” section to include dialog 
box changes and new Record Routes feature

• Added “Creating Threads from ACE Analyst”

• Revised Integrating DoDAF Views

• Updated Procedure 4-21: Create IERs from DoDAF 
Editor

• Added Procedure 4-22: Create and Deploy Standard 
Applications from the DoDAF Editor

• Added Procedure 4-23: Creating Threads from 
DoDAF Editor

• Added section “Generating DoDAF Visio Reports”

• Added descriptions of new DoDAF views available 
for Visio output

6 • Updated “Running a Simulation” to include Record 
IER Route feature

• Revised Procedure 6-5 for clarity

• Added “Viewing Recorded IER Routes”

Glossary • Added note and revised documentation references 
for Process Registry

March 2009 9.0 Final 3 • Added reference to additional OPNET 
documentation available for applicable features.

• Removed View > Zoom > To Window.

• Added View > IERs submenu.

• Removed Traffic > Set Aggregate Traffic 
Preferences, Traffic >

• Show Aggregate Traffic, and Traffic > Hide 
Aggregate Traffic.

• Added Protocols > IPv4 submenu.

• In Configuration OPFAC, changed name of Standard 
NETWARS Node to IER Firing Rules Node.

Table FM-1   Document Revision History (Continued)

Release Date Product Version Chapter Description of Change
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January 30, 2009 9.0 Draft Front matter • Updated JCSS Logo and text to reflect name change 
from Joint Communications Simulation System to 
Joint Communication Simulation System

All • Updated document footers and applicable figures to 
reflect new JCSS version 9.0

• Changed applicable figures to reflect update from 
env_db14.5 to env_db15.0, and file path names from 
14.5.A to 15.0.A

2 • Added Help > Web - JCSS Home Page and Help > 
Web - JCSS Support Center

3 • Removed File > Refresh IER Text Files

• Removed Edit > Project Defaults > IER.

• Updated View > Background > Set Properties to 
reflect changes to dialog box options

• Added options to View > Layout submenu: Lay Out 
Nodes (Circular), Lay Out Nodes (Hierarchical), Lay 
Out Nodes (Schematic), Move Selected Nodes to 
Non-Geographic Positions, and Move Selected 
Nodes to Geographic Positions

• Added View > Visualize Network Configuration 
submenu with the following options: Link Datarate, 
Link Technology, WLAN connectivity (in 3DNV), 
Clear Visualization, and Show Interactively

• Changed View > Visualize Link Loads menu to View 
> Visualize Link Usage, and added Reset Utilization 
Value Label Positions option

• Added View > Set View for Subnet and View > Set 
View for Network submenus

• Added Scenarios > User-Defined Reports submenu 
with the following options: Open Live Report Table, 
and Generate Report from Template

• Added Scenarios > DoDAF Integration

• Added Scenarios > Network Difference Report 
submenu with the following options: Generate 
Report, Launch Last Web Report, and Open 
Network Difference Log

Table FM-1   Document Revision History (Continued)

Release Date Product Version Chapter Description of Change
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• Added Scenarios > Object/Attribute Difference 
Report submenu with the following options: 
Generate Report, Define Report, View Last Report, 
and Launch Last Web Report with the following 
options: Specify Behavior, Stop Comparing, Global 
Preferences, Select Objects With Differences, and 
Select Objects Only In This Network, Reconcile 
Selected Object Differences, Track Changes From 
Object Defaults, Track Changes From Last Save, 
Track Changes From Now, Compare to Network, 
and Compare to Scenario

• Added Scenarios > Model Completeness Analysis 
submenu with the following options: Generate 
Report, and Configure/Run

• Added Scenarios > View Associated Output Tables

• Added Topology > Import > From VNE Server

• Added Topology > Export > To Spreadsheet, 
Topology > Export > To Visio, and Topology > Export 
> To Network Whiteboard

• Added Topology > Export > Subnet Hierarchy to 
VNE Server as Groups submenu with the following 
options: Entire Network, and Selected Subnets

• Added Topology > Import Performance Metrics 
submenu with the following options: From Text File, 
and Open Import Log

• Added Topology > Configure Link Delays submenu 
with the following options: From Measured Delay 
Information, and Show Output Log

• Added Topology > Rapid Configuration, Topology > 
Delete Unconnected Nodes, Topology > Deploy 
Wireless Network, and Topology > Open Edge 
Connectivity Wizard

• Added Topology > 3DNV submenu with the following 
options: Display 3D Network View, Play 3DNV 
History, Add ‘3DNV Mapping’ Attribute to Selected 
Nodes, Manage 3DNV Entities, Show Trajectories of 
Selected Nodes in 3D Visualizer, Hide Trajectories 
of Selected Nodes in 3D Visualizer, Manage 3D 
Visualization of Trajectories, Show Pathloss 
between Selected Nodes in 3D Visualizer, Hide 
Pathloss between Selected Nodes in 3D Visualizer, 
Manage 3D Visualization of Pathloss, and Visualize 
Antenna Coverage.

• Added Topology > Clear Trajectory 

Table FM-1   Document Revision History (Continued)

Release Date Product Version Chapter Description of Change
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• Added Topology > Random Mobility submenu with 
the following options: Set Mobility Profile, Clear 
Mobility Profile, and Set Trajectory Created From 
Random Mobility

• Added Topology > Shared Risk Groups submenu 
with the following options: New, Import, Export, and 
Visualize Operational Status

• Reorganized Traffic > IERs submenu

• Added Traffic > Flows > Export > To TR2

• Added Traffic > Flows > Merge Traffic Flows

• Removed Traffic > Convert Traffic > Link Loads to 
Flows submenu.

• Added NetMapper section

• Removed DES > IER Results submenu

• Added DES > Results > Compare Results

4 • Added procedure to Edit JCSS Attributes for 
Assignment. template OPFAC/organizations

August 11, 2008 8.0 Final All • Removed all IER Database references

August 1, 2008 8.0 Final 2 • Updated System Editor figures to reflect removal of 
IER Database menu

• Removed reference to setting an equipment list in 
the New Project Wizard

3 • Updated Figures 3-1 and 3-6

• Corrected file path to template model list files

• Updated Export Scenario > To Visio section to reflect 
only one .vdx file is created

4 • Corrected file path to icon databases

Appendix A • Removed Promina Circuits and Satellite Links 
sections

July 11, 2008 8.0 Draft All • Updated figures to reflect product name change to 
JCSS from NETWARS

2 • Added File > Import Packaged Project

• Added File > Manage Model Files > Expand Project 
File Archive

• Added Help > Documentation > JCSS Models User’s 
Guides

Table FM-1   Document Revision History (Continued)

Release Date Product Version Chapter Description of Change
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3 • Added File > Manage Model Files > Expand Project 
File Archive

• Added File > Manage Model Files > Create Project 
File Archive...

• Removed Edit > Projects Defaults > Mission 
Analysis

• Added View > Visualize Protocol Configuration > 
IPv4 Interface Metrics > (options).

• Added View > Visualize Protocol Configuration > 
HAIPE Versions.

• Removed Scenarios > Reports > Mission Analysis 
Questions

• Removed Scenarios > Reports > Task Organization

• Added Scenarios > Generate Network Inventory 
Summary

• Removed Topology > Configuration Utilities > TSSP 
> (options)

• Removed Topology > Configuration Utilities > 
Multiplexer > (options)

• Changed Topology > Import Topology > (options) to 
Topology > Import > (options)

• Added Traffic > Convert Traffic > Link Loads to 
Flows > (options)

• Added IER-specific sample figures to DES > Results 
> View Application Delay Tracking

December 13, 2006 6.2 Final 2 • Removed refs to User’s Guides 1-4, since they are 
no longer built into the NETWARS software

3 • Clarified use of Rules folders (pg TR-3-22)

• Removed unnecessary step (old step 2) from View > 
Set Area of Interest section.

• Removed reference to Map menu (changed to 
View > Background > Map Edit Mode).

• Added Topology > Define Trajectory.

• Updated Figure 3-151, Traffic Flows Import dialog 
box (now Figure 3-155), and accompanying text 
description.

• Removed ref to 
traffic_import_suppress_unrecognized_ 
sources_dialog preference from Unrecognized 
Traffic Assistant section.

• Removed Traffic > Specify Core/Edge Devices.

• Updated list of Capacity Planning web reports (pg 
TR-3-145).

4 • Updated instructions for accessing Icon Database 
and locating files.

December 8, 2006 6.2 Final 1 • Removed descriptions of editors that are not 
provided with standard NETWARS

Table FM-1   Document Revision History (Continued)

Release Date Product Version Chapter Description of Change
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2 • Updated “Open Project” section to direct users to 
use the Project directory.

• Updated Figure 2-13 to reflect version 12.0.

• Updated Figure 2-19 and associated text to reflect 
new Preferences Editor

3 • Removed duplicate step from “Edit > Preferences > 
Device Model Map > New” section, and added ref to 
specific directory

• Updated figures 3-38, 3-79, 3-87, 3-88, 3-92, 3-170, 
3-171, 3-179, 3-180, and 3-181

• Added “DES > IER Results” section

Appendix C • Updated refs from 11.5 to 12.0

November 3, 2006 6.2 Final 3 • Provided updated figures: 3-1 (Scenario Builder with 
a project open); 3-3, 3-5, 3-7, and 3-33 (removed 
references to old UserGuide_SB_Scenario); 3-6 
(removed Add Logical View button); 3-34 (removed 
Type of View drop-down list, and Re-use/Re-create 
options); 3-35 (added new Settings drop-down); 3-79 
(names in CCSD Summary Report); 3-87 and\ 3-88 
(clearer); 3-101 (Library treeview changes); 3-113 
(added Classification drop-down); 3-111, 3-117, 
3-187, and 3-188 (reflect new toolbar buttons)

• Added new figures 3-36 and 3-37 for network 
showcase feature

• Removed Map Menu (moved Map > Set Area of 
Interest to View > Set Area of Interest, moved Map > 
Background > <options> to View > Background > 
<options>, removed Map > Background > Add 
CADRG/CIB Raster catalog directories, moved and 
renamed Map > Background > Toggle Map Edit 
Mode to View > Background > Map Edit Mode, 
moved Map > LOS Settings to View > Show LOS > 
LOS Settings, moved Map > Clear LOS Ranges to 
View > Show LOS > Clear LOS Ranges, moved Map 
> Display LOS Legend to View > Show LOS > 
Display LOS Legend, moved Map > View OPFAC 
Distances to View > OPFAC Distances > View 
OPFAC Distances, moved Map > Remove OPFAC 
Distances to View > OPFAC Distances > Remove 
OPFAC Distances, removed Map > Define 
Trajectory, moved Map > Animate to Scenarios > 
Animate)

• Added Topology > Configuration Utilities > UHF 
DAMA SATCOM and Topology > Configuration 
Utilities > Cut-through > <options>

• Moved Terrain menu options to Topology menu

• Added Ctrl+W shortcut keys to Traffic Wizard section

Appendices B, C, 
and D

• Updated NETWARS System Adminstrator’s Manual 
and moved to new Appendices in this manual

October 13, 2006  6.2 Draft 1 • Removed references to the IER Editor

Table FM-1   Document Revision History (Continued)

Release Date Product Version Chapter Description of Change
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2 • Updated System Editor and Sign-in figures to reflect 
version 6.2

• Removed File > Open Editor and Open Editor dialog 
box

• Added File > New Project, File > Open Project, File > 
Open Subordinate Query, File > New Other, File > 
Open Other, File > Manage Model Files, and File > 
Recent Projects

• Added IER Database menu and options

• Added Help > Show All Logs

3 • Added File > Close, File > Page Setup, File > Print 
Graphs, and File > Manage Model Files

• Removed File > Close Project and File > Close 
Subordinate Query

• Added Edit > Save Object Selection Set, Edit > Load 
Object Selection Set, Edit > Edit Objects Using 
Template, and Edit > Edit Attribute Template

• Replaced Advanced Preferences dialog box with 
new Preferences Editor dialog box

• Added View > Show Logical Views, View > Show 
Network Topology, View > Show Network 
Showcase, View > Open Network Showcase 
Window, View > Demands, View > Paths, View > 
Annotations, View > Layout > Lay Out Nodes 
Interactively, View > Zoom > To Window, and View > 
Zoom > To All

• Updated Edit Visualization Preferences dialog box

• Changed View > Layout > Scale Selected Icons to 
View > Layout > Scale Node Icons Interactively

• Removed View > Network Views > Logical

• Updated Scenario menu to reflect name change to 
Scenarios menu. Added Scenarios > Scenario 
Components, Scenarios > Reports > CCSD 
Summary, and Scenarios > Reports > SLD 
Summary

• Added Protocols > Servers, Protocols > Mainframes, 
Protocols > TCP, Protocols > MPLS, Protocols > 
Ethernet, Protocols > FDDI, Protocols > MANET, 
Protocols > UMTS, and Protocols > Wireless LAN

• Removed Topology > Import > Template OPFAC 
into Library from XML

• Added DES > Choose Statistics (Advanced), DES > 
Expert Service Prediction, DES > Configure/Run 
Discrete Event Simulation (Advanced), DES > 
Restart Discrete Event Simulation, DES > Results > 
View Application Delay Tracking, and DES > Panel 
Operations > Reload Data Into All Panels

• Removed DES > Results > Compare Results

• Updated Choose Results dialog box

4 & 5 • Removed IER Editor chapter (functionality now 
accessible via System Editor’s IER Database menu) 
and renumbered chapters

Glossary • Removed references to the Scenario Conversion 
Module

Table FM-1   Document Revision History (Continued)

Release Date Product Version Chapter Description of Change
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March 30, 2006 6.1 Final 3 Updated Traffic Flow Preferences dialog box figure to 
reflect checkbox options design

Removed “Rename Scenarios “ feature from Manage 
Scenarios section

Added Import Scenario > TNAPS to XML

Removed Import Scenario > From Visio

Added shortcut keys for configuring/viewing TSSP 
circuits

Added Configuration Utilities > Multiplexer > Configure 
Multiplexer Circuits and View Multiplexer Circuits

Noted the default username and password for the IER 
database

Appendix A Removed Multiplexer Utility Nodes section

March 3, 2006 6.1 Draft 2 • Updated System Editor and Sign-in figures to reflect 
version 6.1

• Added Edit > Preferences > Device Model Map > 
(options)

• Removed Help > Generate Support Info

• Renamed Help > Error Log > View as Help > Error 
Log > Open

• Renamed Help > Message Log > View as Help > 
Message Log > Open

• Added Help > Session Log > (options)

3 • Updated “Deploying Satellite Links” section to reflect 
new tabbed design of Satellite Bent Pipe Link 
Deployment dialog box

• Updated TSSP Circuit Deployment dialog box figure 
(and corresponding text description) to reflect new 
tabbed design

• Updated View TSSP Circuits dialog box figure (and 
corresponding text description) to reflect new column 
names

• Removed Traffic > Convert Traffic > Flows to IERs

4 • Added Edit > Preferences

5 • Updated figure (and text) to reflect name change 
from “Icon Editor” to “Icon Database”, and new 
toolbar buttons

• Added File > Exit

November 14, 2005  5.2 Final Front Matter Changed refs in Documentation Conventions section 
to be NETWARS-specific rather than OPNET-specific 
(i.e, changed <opnet_user_home>\... ref to 
<NETWARS path>\Scenario_Builder\.)

2 • Added statement (“Please contact NETWARS CM to 
register your license.”) to Starting License Manager 
section

• Changed Express method description to “(Requires 
authorized access.)” in Adding a License section

• Updated Task Tracking Workflow GUI figure.

Table FM-1   Document Revision History (Continued)

Release Date Product Version Chapter Description of Change
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3 • Updated Edit > Project Defaults > IER figure

• Updated View > Visualize Link Loads > Color by Link 
Load figure

• Updated View > Network Views > Logical figure

• Added Map > Background > Add CADRG/CIB 
Raster catalog directories

• Renamed Scenario > Scenario Documentation as 
Scenario > Set Scenario Documentation

• Corrected ref to old command (Topology > Import > 
Subordinate Response) in Scenario > Import 
Scenario > Subordinate Response.

• Updated Object Palettes to include Tree view and 
reflect new icons

• Updated Annotation Palette

• Removed Topology > Link Operations > Deploy 
TSSP Groups

• Added Deploying Satellite Links section

• Added Topology > Configuration Utilities > TSSP > 
Configure TSSP Groups (Circuits)

• Added Topology > Configuration Utilities > TSSP > 
View TSSP Group Configs (Circuits)

• Updated Topology > Import Device Configuration 
Files

• Removed Advanced Traffic Wizard

• Updated Traffic Wizard figure

• Removed Traffic > Convert Traffic > Link Loads to 
Flows

• Removed Traffic > Convert Traffic > Open 
Conversion Log

• Removed Traffic > Convert Traffic > Clear 
Conversion Log

• Updated Terrain > Edit Parameter Sets figure

October 10, 2005 5.2 Draft All • Updated document footers and applicable 
screenshots to reflect new NETWARS version 
number

1 • Added (optional) Server Characterization and 
Mainframe Characterization options to System Editor 
(File > Open Editor)

Table FM-1   Document Revision History (Continued)
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2 • Added Edit > User Level options

• Updated Figure 2-4 (Open Editor dialog box) to 
reflect addition of (optional) Server and Mainframe 
Characterization editors

• Updated Figure 2-9 (Security Classifications dialog 
box) to reflect addition of Set Default button

• Updated Figure 2-11 (Advanced Preferences dialog 
box) to reflect new prefs and correct CORE version 
in title bar)

• Removed figure of License Manager Help dialog box 
(not necessary to document since Help changes with 
each version)

• Added Previous Editor and Circulate Editors options 
to Windows menu.

• Added Help > Documentation > User’s Guides 
options

3 • Removed references to ‘demands’

File Menu • Updated File > Close Project to reflect that both the 
project and the Scenario Builder window close 
(instead of the project only)

• Updated Figure 3-6 (Briefings dialog box) to reflect 
addition of Add Logical View button

• Added Figure 3-7 (Print Preview dialog box)

• Renamed File > Package as File > Package Project 
Files, and old File > Package submenu ‘Project Files’ 
as ‘Project’

• Added File > Recent Projects (with submenu) to 
replace old list of recent projects

• Removed File > Close Scenario Builder

• Renamed File > Exit NETWARS as File > Exit

Edit Menu • Renamed Edit > Select All in Subnet as Edit > Select 
All

• Added Edit > Find Node/Link

• Renamed Edit > Select as Edit > Group 
Selection/Action > Selection Filter

• Renamed Edit > Apply Action as Edit > Group 
Selection/Action > Action Filter

• Renamed Edit > Object Palette as Topology > Open 
Object Palette

• Renamed Edit > Annotation Palette as Topology > 
Open Annotation Palette

• Moved Edit > Device Model Map submenu to Edit > 
Preferences > Device Model Map.

• Added Edit > Preferences > Device Model Map > 
Open

• Renamed Edit > Defaults > Device Model Map as 
Edit > Preferences > Device Model Map > Choose.

• Removed Edit > Defaults > Demands, Edit > 
Defaults > Bandwidth Requirements, and Edit > 
Defaults > Application Conversion

Table FM-1   Document Revision History (Continued)
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View Menu • Added View > Show Scenario Treeview

• Added View > Layout > Geographic Positioning

• Added View > Layout > Layout Nodes Automatically 
(Balanced)

• Renamed & moved View > Edit Visualization 
Preferences to View > Layout > Edit Display 
Preferences

• Renamed & moved View > Zoom In to View > 
Zoom > To Rectangle

• Renamed & moved View > Zoom to Selection to 
View > Zoom > To Selection

• Renamed & moved View > Zoom Out to View > 
Zoom > Unzoom

• Renamed View > Redraw as View > Refresh 
Workspace

• Removed View > Network Views > Organization 
Systems and View > Network Views > Device 
Systems

• Renamed View > Network Views > Logical Views as 
View > Network Views > Logical

• Renamed Figure 3-42 (View Filtering dialog box) as 
Logical View Selection dialog box & added detail to 
dialog box options

• Renamed & moved View > Set View Properties to 
Map > Background > Set Properties

• Added View > Visualize Protocol Configuration > IP 
Tunnel Configuration

Map Menu • Renamed Map > Set Area of Operations as Map > 
Set Area of Interest

• Replaced Figure 3-45 (Set Area of Operations dialog 
box) with new Set Area of Interest dialog box

• Updated Figure 3-46 (Setting background view 
properties) to reflect addition of Translucency 
column and Edit CADRG/CIB Properties button

• Replaced Figure 3-47 (Set Area of Operations dialog 
box) with new Choose Border Map dialog box

• Renamed Map > Background > Import Image as 
Map > Background > Add Image Map

• Renamed Map > Background > Import Background 
Image as Map > Background > Add Image

• Removed Map > Background > Import JMTK Data

• Renamed Map > Background > Import MIF Data as 
Map > Background > Add MIF Map

• Added Figure 3-50 (MIF Import Log dialog box)

• Updated Figure 3-57 (Define Trajectory dialog box) 
to reflect changes

• Added Figure 3-58 (Trajectory Segment Information 
dialog box)

Table FM-1   Document Revision History (Continued)
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Scenario Menu • Added Scenario > Manage Scenarios and Figure 
3-64 (Manage Scenarios dialog box)

• Removed Scenario > Remove Scenario

• Renamed Scenario > Import as Scenario > Import 
Scenario

• Renamed Scenario > Import > NETWARS Scenario 
as Scenario > Import Scenario > From NETWARS

• Renamed Scenario > Import > OPNET Modeler 
Scenario as Scenario > Import Scenario > From 
OPNET Modeler

• Renamed Scenario > Import > Scenario from XML 
as Scenario > Import Scenario > From XML

• Renamed Scenario > Import > Scenario from Visio 
XML as Scenario > Import Scenario > From Visio

• Removed Scenario > Export > Export to HTML

• Renamed Scenario > Export as Scenario > Export 
Scenario

• Renamed Scenario > Export > Scenario to XML as 
Scenario > Export Scenario > To XML

• Added Scenario > Export Scenario > To JNMS

• Renamed Scenario > Export > Scenario to Visio 
XML as Scenario > Export Scenario > To Visio

• Renamed Scenario > Summary Tables as 
Scenario > Reports

• Renamed Scenario > View Task Organization 
Report as Scenario > Reports > Task Organization

• Added Scenario > Reports > User-Defined Reports > 
Open Live Report Table and Scenario > Reports > 
User-Defined Reports > Generate Report from 
Template.

• Added Scenario > Generate Scenario Web Report 
and Scenario > Generate Scenario Bitmap

• Added Figures 3-87 (Generate Scenario Web Report 
dialog box), 3-88 (Displaying Scenario Web Report 
in Web Browser), and 3-89 (Model Image Capture 
Preview dialog box)

Topology Menu • Added Topology > Open Library Treeview and 
Figure 3-95 (Library Treeview)

• Renamed Topology > Device Creator as Topology > 
Create Custom Device Model

• Renamed Topology > Import > Subordinate 
Response as Scenario > Import Scenario > 
Subordinate Response

• Renamed Topology > Export > Subordinate 
Response as Scenario > Export Scenario > 
Subordinate Response

• Added Topology > Link Operations > Deploy TSSP 
Groups and Figure 3-101 (TSSP Circuit Deployment)

• Removed Topology > Link Operations > Redeploy 
Link
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Traffic Menu • Added Traffic submenus for Traffic Wizard, IERs, 
Flows Device/Link Loads, and Convert Traffic

• Added descriptions of Traffic Wizards (Simple & 
Advanced)

• Removed Traffic > Collector Import Settings and 
Traffic > Visualize submenus

• Renamed Traffic > IER/Demand Import Options as 
Traffic > IERs > Set Import Options

• Renamed Traffic > Specify Demands as Traffic > 
IERs > Specify IERs

• Added Traffic > IERs > Import from IER Report

• Renamed Traffic > Visualize > Export Traffic Report 
as Traffic > IERs > Export IER Report

• Added Traffic > IERs > Export IERs to XML

• Renamed Traffic > Import Flows > (options) as 
Traffic > Flows > Import > (options).

• Renamed Traffic > Create Traffic Flows as Traffic > 
Flows > Create Flows.

• Replaced Create Traffic Demands dialog box in 
Figure 3-132 with Create IP Unicast Traffic Flows 
dialog box

• Renamed Traffic > Visualize > Open Flows Browser 
as Traffic > Flows > Open Flows Browser

• Renamed Traffic > Visualize > Export Traffic Flows 
as Traffic > Flows > Export to Spreadsheet

• Updated Figure 3-139 (Export Traffic Flows dialog 
box)

• Renamed Traffic > Import Device/Link Baseline 
Loads > (options) as Traffic > Device/Link Loads > 
Import > (options)

• Removed Traffic > Convert NETWARS Applications 
to Demands

• Renamed Traffic > Convert Applications to Flows as 
Traffic > Convert Traffic > Applications to Flows

• Updated Figure 3-140 (Convert Applications to 
Flows dialog box) to remove Time Step settings

• Renamed Traffic > Convert Link Loads to Flows > 
Configure/Convert as Traffic > Convert Traffic > Link 
Loads to Flows

• Renamed Traffic > Convert Traffic Flows to 
NETWARS Demands as Traffic > Convert Traffic > 
Flows to IERs

• Renamed Traffic > Convert Link Loads to Flows > 
Open Conversion Log as Traffic > Convert Traffic > 
Open Conversion Log

• Renamed Traffic > Convert Link Loads to Flows > 
Clear Conversion Log as Traffic > Convert Traffic > 
Clear Conversion Log.

• Added Traffic > Generate Traffic Web Report

• Renamed Traffic > Visualize > Visualization 
Aggregate Traffic Preferences as Traffic > Set 
Aggregate Traffic Preferences

• Renamed Traffic > Collector Import Settings > 
Specify Core/Edge Devices as Traffic > Specify 
Core/Edge Devices.
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Protocols Menu • Added Protocols > LDP, Protocols > RSVP, 
Protocols > VLAN, and Protocols > STP

• Removed Protocols > MPLS and Protocols > DPT

• Updated Figure 3-149 (Terrain Data Directory 
Preferences dialog box) to reflect addition of Format 
drop-down list and support for terrain data type 
‘OpenFlight’

• Updated Figure 3-151 (Import Elevation Lines dialog 
box) to reflect reorganization of dialog box fields, etc.

• Updated Figure 3-153 (Evaluation Settings dialog 
box) to reflect reorganization of dialog box buttons.

NetDoctor Menu • Added NetDoctor > Auto-Generate Report 
Template..., NetDoctor > Suppress Messages, 
NetDoctor > Rule Development..., and NetDoctor > 
Options

• Removed NetDoctor > Security

DES Menu • Removed DES > Record Animation for Subnet

• Added DES > Record Packet Flow Animation for 
Subnet and DES > Record Node Movement 
Animation for Subnet

• Removed DES > Color Links by Utilization.

• Removed DES > Clear Link Visualization.

• Removed DES > Panel Operations > Export Panels 
> To HTML.

Windows Menu • Added Previous Editor and Circulate Editors options 
to Windows menu

Glossary • Removed ‘Demands’ from Glossary

April 1, 2005 5.1 Final Cover • Changed release date to April 1, 2005, and removed 
OPNET contact info from Identification section

March 21, 2005  5.1 Final 1 • Added ACE to ACE Whiteboard section

2 • Added ACE option to System Editor (File > Open 
Editor)

2 & 3 • Corrected definition of functional names in Edit > 
Preferences > Functional Profiles.

3 • Added View > Zoom to Selection and View > Layout 
options

• Added Scenario > New/Duplicate/Previous/Next 
Scenario

• Updated Figure 3-18 to reflect new button placement
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February 21, 2005  5.1 Final • No changes

February 7, 2005  5.1 Draft All • Ported existing Word document (NETWARS v 4.2) 
into Adobe FrameMaker 7.1, and applied 
commercial OPNET product documentation style 
template to improve quality and update manual. 
Reformatted text as needed to fit new format and 
style.

Content changes:

• Updated applicable screenshots to reflect new 
NETWARS version number

• Added reference to ACE doc in chapter 1, and added 
ACE Whiteboard option to System Editor (File > 
Open Editor) and Scenario Builder (Traffic > Import 
Flows)

• Removed Capacity Planning > Restore Link Colors 
and Capacity Planning > Show Link Legend

• Removed Alternate Link Cost field from Capacity 
Optimization Settings Advanced Parameters dialog 
box
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1 Introduction

The JCSS Technical Reference Manual is a comprehensive reference and 
guide that covers all aspects of JCSS operation and use. It contains over 200 
figures that provide visual examples of the JCSS interfaces, step-by-step 
procedures, and other important JCSS features and concepts. 

Organization of the chapter topics is menu-based, meaning topics are grouped 
and ordered according to the various menus and menu options available in the 
respective JCSS interfaces. 

Editor Interfaces 

The capabilities of the JCSS software are organized into separate editors: 

• The System Editor

• The Scenario Builder, and

• Other optional editors that require an extra license (To learn more about 
available editors, refer to the IT Guru documentation suite.) 

System Editor 

The System Editor acts as an entry point to the remaining editors. It allows you 
to access user and profile information as well as the task assistant interface. 

Scenario Builder 

The Scenario Builder allows you to build template OPFACs and organizations, 
define infrastructure and Information Exchange Requirements (IERs) between 
OPFACs and organizations, specify movement and geographical context for 
OPFACs and organizations, and run discrete event simulations for developed 
scenarios. You can open and work with multiple projects simultaneously, and 
easily cut, copy, and paste supported objects (Organizations, OPFACs, 
devices, links, etc.) between them. 

Additionally, the Scenario Builder provides you with the option of deploying a 
communications infrastructure using a top-down approach. More specifically, 
the Lead Planner sets up the planning view and sends the initial scenario to the 
Subordinate Planners. The Subordinate Planners modify their portion of the 
initial plan and then send it back to the Lead Planner who integrates them into 
a complete plan. 

The Scenario Builder allows you to optimize link and broadcast network 
capacities as well as traffic load. The optimization of the link and broadcast 
network capacities is implemented by changing the size of links and broadcast 
networks while the optimization of the traffic load is implemented by changing 
the load caused by the IERs. 
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This editor also allows you to view results of the simulation. After the simulation 
is complete, the Simulation Domain creates text files that capture the results of 
the simulation. The Scenario Builder reads these files and displays the results 
graphically as Measures of Performance (MOPs). The MOPs focus on the 
ability of selected communication equipment to send and receive information 
(e.g. file transfers, situation awareness updates, e-mail messages, etc.). 

Finally, this editor integrates with other independent frameworks, such as the 
Department of Defense Architecture Framework (DoDAF). Using these 
integrations, you can easily import and export network information between 
JCSS and other software tools. JCSS can then be used to expedite and improve 
standardized processes by providing more detailed communications results 
through simulations versus other estimation methods.
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2 System Editor

The System Editor is the editor that opens first when you start JCSS. From the 
System Editor, you can open any of the other JCSS editors, like the Scenario 
Builder. The System Editor allows you to access user and profile information, as 
well as the task assistant interface. 

Accessing the System Editor 

Starting up the JCSS software launches the System Editor and a Sign In dialog 
box, as shown below. 

Figure 2-1   System Editor

Figure 2-2   Sign-in Dialog Box
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Procedure 2-1   Creating a New Login Profile

1 Launch the New Profile dialog box, shown below, by clicking the New button in the 
Sign In dialog box. The * designates a required field and must be filled-in to 
continue the sign-in process. 

Figure 2-3   New Profile Dialog Box 

2 Enter required information and any optional information. 

3 Click OK.

JCSS will save up to five (5) user names so that multiple users can use the 
software without re-typing their user information. This information is used to track 
the changes made in the scenario by each planner. Subordinate Planners also use 
this information when they need to send the subordinate response files back to the 
Lead Planner. If you have logged in before, select your name from the drop-down 
menu. To enable the Task Assistant to open upon sign-in, ensure that the Use 
Task Assistant at Startup is checked. 

➥ The Sign In dialog box displays again with the new user name in the Profile field. 

4 Sign in by clicking the Sign In button or, if you elect to edit your profile, you may do 
so at this time by clicking the Edit button. 

End of Procedure 2-1
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File Menu 

Figure 2-4   System Editor's File Menu 

New Project File > New Project... Opens a new Scenario Builder and displays the Create 
Project dialog box. Create a new project, the first step in the Lead Planner's 
workflow. You can simply name and launch a generic project, or use the New 
Project Wizard to select and set the area of operations, top-level units (including 
their locations and templates), an owner for each unit, and the types of 
equipment to use in the new project. 

Procedure 2-2   Creating a New Project

1 Specify the names for the project and the initial scenario in the Create Project 
dialog box. 

Figure 2-5   Creating a New Project 

2 Select a classification level for the project in the Create Project dialog box. 
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3 Click OK. If Launch New Project Wizard is not checked, then JCSS creates a 
generic project using the names you have designated. If Launch New Project 
Wizard is checked, then JCSS displays a sequence of dialog boxes that enable you 
to make selections specific to your new project. 

Note—The names for both the project and the scenario cannot contain any spaces 
or special characters. In addition, the scenario name cannot be the same as any 
existing OPFAC; it must be unique. 

End of Procedure 2-2

Open Project File > Open Project... Displays the Open Project dialog box in which you can 
select a project file to open, and then opens the selected file in a new Scenario 
Builder.

Procedure 2-3   Opening an Existing Project

1 Navigate to the Project directory, and select the .prj file corresponding to the project 
that you wish to open.

Figure 2-6   Project File Chooser

End of Procedure 2-3

Open Subordinate
Query

File > Open Subordinate Query... Displays the Open Subordinate Query dialog 
box in which you can select a query file to open, and then opens the selected 
file in a new Scenario Builder.
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New Other File > New Other... Displays the New dialog box which lists standard OPNET 
editors from which you can select to create.

Figure 2-7   New Other Dialog Box

Open Other File > Open Other... Displays the Open dialog box which lists standard OPNET 
files from which you can select to open.

Import Packaged
Project...

File > Import Packaged Project... Displays the Zip File Browser dialog box in 
which you can select a zip file to open, and then opens the selected file in a new 
Scenario Builder.

Manage Model Files File > Manage Model Files > (option) This submenu lists options which allow you 
to manage model files.
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Manage Model
Files > Delete Model

Files

File > Manage Model Files > Delete Model Files Displays a list of models from 
which you can select to delete files, as shown.

Figure 2-8   Delete Models Dialog Box 

Manage Model
Files > Add Model

Directory

File > Manage Model Files > Add Model Directory Displays the Directory 
Browser in which you can create a new directory for models. 

Manage Model
Files > Refresh

Model Directories

File > Manage Model Files > Refresh Model Directories JCSS maintains a list of 
folders called the model directories (or mod_dirs for short) where the models are 
stored. Models include OPFACs, organizations, projects and scenarios, icon 
databases, and device models. When you move such models around on the 
hard drive using Windows Explorer, the software does not recognize the 
change. To make the software aware of the changes, use this option. 

Manage Model
Files > Expand

Project File Archive

File > Manage Model Files > Expand Project File Archive Displays the Files > 
Expand Select OPNET Components File Archive dialog box in which you can 
select an Project File .opcfa file to expand. Archive 

Recent Projects File > Recent Projects > (option): This submenu lists recently opened projects 
for easy re-opening. 

Exit JCSS File > Exit JCSS Exits JCSS.
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Edit Menu 

Figure 2-9   System Editor's Edit Menu 

Login Information Edit > Login Information: Lets you edit user profile information. After modifying 
profile information, click OK. 

Figure 2-10   Select User Dialog Box

Change User Edit > Change User Change the current signed in user and sign in information 
at any time by using the System Editor.

Procedure 2-4   Changing User

1 To change the user’s profile, choose the user’s name from the drop-down menu, 
as shown in the figure below.

Figure 2-11   Select User Dialog Box
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2 Click OK when modifications are complete.

End of Procedure 2-4

User Level Edit > User Level > (option) Switch between JCSS interfaces (simple to 
complex) by selecting one of the available User Level options. JCSS menus 
change to reflect the selected User Level. Higher User Levels display more 
menu items and menu headers. You can switch between User Levels at any 
time, so that all menu items can be available if you so choose. Switching the 
User Level affects all open editors.

User Level >
Beginner

Edit > User Level > Beginner Select this User Level to access a simplified JCSS 
interface. The Beginner interface hides access to many of the functionalities of 
the system without removing the capabilities themselves. This results in an 
interface that is reduced in complexity, and is easier to navigate for beginner 
JCSS users.

User Level >
Intermediate

Edit > User Level > Intermediate Select this User Level to access a JCSS 
interface that exposes more functionalities of the system than the Beginner 
level, but less than the Advanced level. This results in an interface that is 
reduced in complexity, and is easier to navigate for intermediate users.

User Level >
Advanced

Edit > User Level > Advanced Select this User Level to access the full-featured 
JCSS interface. The Advanced interface exposes all of the functionalities of the 
system. This results in an interface that is more complex, and best utilized by 
more experienced JCSS users.

Preferences Edit > Preferences > (option) Display and edit JCSS preference settings.

Note—These menu options perform the same functions as the Preferences 
options under the Edit menu in the Scenario Builder.

Preferences >
Device Model Map

Edit > Preferences > Device Model Map > (option) Set default device model map 
files.
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Preferences >
Device Model Map >

New...

Edit > Preferences > Device Model Map > New... Using the Choose Source and 
Target Model Name Lists dialog box, select the paths to where you want new 
source and target model list .txt files to reside, and then click OK.

Figure 2-12   Choose Source and Target Model Name Lists Dialog Box

Preferences >
Device Model Map >

Open...

Edit > Preferences > Device Model Map > Open... Using the Device Model Map 
Browser, navigate to and select an existing JCSS device model map .xml file to 
open, and then click Open.

Figure 2-13   Device Model Map Browser

Preferences >
Device Model Map >

Choose...

Edit > Preferences > Device Model Map > Choose... Using the Device Model 
Map Preferences dialog box, navigate to and select a device model map .xml 
file to import into JCSS as needed, and then click OK.

Figure 2-14   Device Model Map Preferences Dialog Box
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Preferences >
Functional Profiles

Edit > Preferences > Functional Profiles Set default functional profiles and 
functional names. Every OPFAC has one or more functional names. A 
functional name maps an IER or series of IERs to a producer/consumer OPFAC 
pair. A collection of such functional names is called a functional profile. A 
functional profile can be defined locally on an individual OPFAC, or globally, so 
that it is available to all OPFACs and across different scenarios. 

Figure 2-15   Functional Profile Dialog Box 

From this dialog box, you can do the following; when finished, click OK.

• Add, rename, or remove functional profiles as needed

• Insert, delete, or edit functional names as needed.

Preferences >
Geographical

Coordinates

Edit > Preferences > Geographical Coordinates Sets the default Geographical 
geographical coordinate system view displayed in the workspace of the 
Coordinates Scenario Builder. There are three types of geographical coordinate 
systems available in JCSS: Lat/Long, UTM, and MGRS. 

Figure 2-16   Geographical Coordinates Dialog Box 

Procedure 2-5   Setting Geographical Coordinates

1 Choose Edit > Preferences > Geographical Coordinates.

2 Select the Lat/Long, UTM, or MGRS radio button.

3 Click OK.

End of Procedure 2-5
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Preferences >
Owners List

Edit > Preferences > Owners List Sets owner information for units marked for 
subordinate query.

Figure 2-17   Owner List Dialog Box 

Owner information contains four fields: Last Name, First Name, Title and 
Organization. All fields, except the Title field, are required fields. Modify existing 
records or add/delete records to the list as needed. 

Preferences >
Security

Classifications

Edit > Preferences > Security Classifications Sets security classification for a 
variety of items in a scenario, such as devices and IERs. This dialog allows you 
to add, remove, or change values in the list of recognized security classification 
values. The list is used to populate drop-down lists in edit fields and table cells 
that specify security classification values. Since some fields and cells only allow 
values from this list, you will need to modify this list in order to specify custom 
security classifications. Any value is permitted, although duplicates are not 
allowed in the list. 

The list order indicates the classifications' levels of restriction. Less restrictive 
classifications appear toward the top of the list. 

Figure 2-18   Security Classifications Dialog Box 

A value in the list may be modified by selecting and editing it

• The Up button moves the selected value toward the top of the list

• The Down button moves the selected value toward the bottom of the list
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• The Insert button inserts a blank entry above the selected value

• The Delete button deletes the selected value

• The Set Default button sets the selected classification as your default

• The Save button saves all changes. Once saved, the changes will affect all 
edit fields and table cells, but the values stored in those attributes will not be 
modified. 

Preferences > Traffic
Flow Thresholds

Edit > Preferences> Traffic Flow Thresholds Specify a minimum value and the 
colors to be used for each threshold; traffic flow thresholds are used in 
conjunction with the Aggregate Traffic Flows feature. Flows are colored based 
on the threshold they fall under. If the load of an aggregate flow is more than the 
highest threshold, the flow is colored black. If the load is lesser than the 
minimum threshold, the flow is not displayed. The default minimum value is 0 
Kbps.

Figure 2-19   Traffic Flow Thresholds Dialog Box 

Set desired traffic load/color combinations, and then click OK. 
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Preferences >
Advanced

Edit > Preferences > Advanced View and/or set environment attributes, or 
“preferences”, that control program operation. These values are stored in the 
environment database file (env_db for short).

Figure 2-20   Sample Preferences Editor 

Procedure 2-6   Editing Preferences (Advanced)

1 Use the Search for field (and drop-down list) to search for preferences that contain 
specific words or values (Anywhere specifies to search Tags, Names, Values and 
Descriptions; In Names specifies to search Tags and Names only; In Values 
specifies to search Values only.) 

2 Use the Arrange by drop-down list to display preferences by category (Groups 
specifies to arrange preferences by group; Source specifies to arrange 
preferences by source.) 

3 Check (or uncheck) the Advanced view checkbox to toggle between showing an 
advanced or basic view of the preferences table (basic view shows the name and 
value of each preference; advanced view shows the name, tag, source of the 
preference's value and the value itself.) 

4 Edit desired preference values by clicking in the corresponding Value cell, 
selecting or typing the new value, and then pressing the <Enter> key on your 
keyboard. 

5 Click OK to save edits and close the Preferences Editor. 

End of Procedure 2-6
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License Menu

Figure 2-21   System Editor's License Menu 

License
Management

License > License Management A license conveys the right to use an 
application. A single license typically bundles one or more applications (such as 
Modeler), the simulation program, and one or more modules. 

Licenses are allocated on a per-component basis. A component that is part of a 
license (perhaps a module such as TMMGUI) may be free and can be given to 
any requester, even if another component of the same license (most likely an 
application program) is in use. 

License Terminology 

• Add license—Add a license to the machine's license file

• Deregister License—Remove a license from a machine's license file (it is 
then free to be installed on a different machine)

• License—Authorization to use an OPNET product

• License Manager—Software interface for performing license operations

• License Server—A service running on a machine that will distribute licenses 
to other computers
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• Revoke License—Free a license that is currently in use

• Standalone Mode—A licensing mode in which only the local machine can 
obtain the licenses

License Attributes 

• License number—Specifies the software license. A single license may 
bundle several programs (for example, 100/1 that includes the programs IT 
Guru, Expert Service Prediction, and Multi-Vendor Import will be shown as 
three separate lines in the License Manager interface.) 

• Program name—Specifies which programs are included in the license (such 
as IT Guru and the Radio module). 

• Status—Identifies the state of the program. 

— A free program (shown in green) is available to the next user who 
requests it

— An in use program (shown in white) is unavailable. 

— An expired program (shown as yellow with red X) is no longer valid

• License expiration—Displays a date or the word "permanent," depending on 
the type of license purchased

• Maintenance expiration—An expiration date. It is not possible to buy 
perpetual maintenance. 

• User—Shows the user 's name if the license is in use

• Host—Shows the machine where the license is being used

License Files 

Files for dedicated licenses (as opposed to floating licenses) are stored in the 
OPNET_license directory. 

Note—When it is time to install a new version of the software, do not delete the 
license files. 

Starting License Manager 

The License Manager can be accessed from the Start Menu or the System 
Editor. If you need to perform license maintenance, it is better to access the 
License Manager from the Start Menu (JCSS does not need to obtain a license). 

Note—Please contact JCSS CM to register your license. 
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• To access License Manager from the Start Menu, simply select it from the 
Start/Programs/JCSS/License Manager menu option 

• To access License Manager from the System Editor, select it from the 
License menu

Figure 2-22   License Manager: Requested Server Dialog Box 

The License Manager contains details about the license server that you 
requested during the installation of JCSS. The License Manager also provides 
a Help menu that can be accessed by clicking the Help button. 

Procedure 2-7   Adding a License 

1 Click the Add License button on the License Manager to display the Choose 
Transaction Method dialog box. 

Figure 2-23   Choose Transaction Method Dialog Box 

2 Choose from one of four transaction methods:
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• Express —Automatic via the Internet (Requires authorized access)

• Browser—Through a Web browser if the Express method does not work

• Email—Exchange Codes with OPNET via Email

• Offline—Exchange codes with OPNET via Telephone or Fax

End of Procedure 2-7

Product Modules License > Product Modules Select active modules. Product Modules refer to 
additional licensed OPNET functionality. For example, JCSS uses the Terrain 
Modeling Module GUI (TMMGUI) and Multi-Vendor Import (MVI) product 
options, which are licensed under the JCSS license. (JCSS can also make use 
of NetDoctor and Simulation licenses to further enable the JCSS-resident 
functionality.) 

If a module is deactivated using this option (by deselecting the checkbox next 
to a module name) the corresponding features of that module will not be active 
in JCSS. For example, the Terrain menu will not be available in JCSS if the 
TMMGUI module is deactivated. 

Windows Menu 

Figure 2-24   System Editor’s Windows Menu

Previous Editor Windows > Previous Editor Make the previously displayed editor the current 
editor.
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Circulate Editors Windows > Circulate Editors One at a time, make each open editor the current 
editor.

Hide This Editor Windows > Hide This Editor Hide the current editor. If another editor is open, 
that editor is made the current editor.

Hide Other Editors Windows > Hide Other Editors Hide all open editor windows except the current 
one.

Show All Editors Windows > Show All Editors Re-display any hidden editors.

Help Menu 

Figure 2-25   System Editor's Help Menu 

Task Assistant Help > Task Assistant Display a list of workflows available to the planners. A 
workflow is simply an outline of steps to guide the planner through the flow of 
tasks associated with the particular mission being addressed. 
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The Task Assistant dialog box is shown below. The treeview on the left hand 
side of the dialog box shows the list of workflows available, and the explanation 
for those is provided in the pane on the right. 

Figure 2-26   Task Assistant Dialog Box

The list of workflows displayed in the Task Assistant dialog box are organized 
based on categories of user tasks and most recently used workflows. 

1) To start a workflow, first select the workflow and then use either the Start 
Workflow button or simply double-click the workflow of interest. 

2) To review the items within each workflow, click the plus sign to the left of 
the workflow category. 
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Assume that you have decided to develop a communications plan. You would 
select Develop Communications Plan by double-clicking the icon to the left of 
the text. This calls the Develop Communications Plan task. 

Figure 2-27   Develop Communications Plan Task

In the figure above, each line item of the workflow has a letter to the left of the 
text indicating whether it is a milestone (M), an optional (O) or a required (R) 
task. In addition, many of the tasks can be expanded, by clicking the plus sign 
to reveal details on what steps are necessary to complete each task. 
Additionally, each line of the workflow is supplemented by details on how to 
complete that task in the Explanation pane located on the right side of the Task 
Assistant dialog.

1) If you do not find the workflow of interest, choose the Browse for Workflow 
option under the Recent Workflows in the Task Assistant dialog box to 
locate the desired workflow. 
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Figure 2-28   Task Assistant Browse for Workflow 

2) If you chose not to use the Task Assistant workflows, exit by clicking the 
Close button. 

Task Tracking 

This feature, available from the Task Assistant, provides you with the capability 
to track timeline, dates due, milestones, and percent done for the planning tasks 
associated with the plan being developed. Task tracking information is available 
from the Task Tracking dialog box. 

Procedure 2-8   Using Task Tracking

1 Right-click on a particular task or on the workflow in the Task Assistant, and select 
Task Tracking Information. If you click on the workflow name and select Task 
Tracking Information, the workflow dialog box launches. 

2 Check Edit Workflow Time Information and enter the number of days for the entire 
workflow. 

3 Click OK to save changes and close the dialog box. 

➥ The figure below shows workflow time information. 

Figure 2-29   Entering Number of Days for Entire Workflow 
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4 Right-click on a task and choose Task Tracking Information to launch the Task 
Tracking dialog box, as shown below. 

Figure 2-30   Task Tracking Dialog Box 

The Task Tracking dialog box shows the milestone information, and the percent 
task completion. The Task Tracking dialog box provided above shows that the 
selected task is a milestone task (also known from the "M" icon for this task). The 
task is currently 50% complete. It has a task weight of 1, and days to finish (from 
start of the workflow) is 1. 

5 To edit this milestone information, check Edit Milestone Information. You can then 
change task weight and days to finish. 

6 Update the percent task completed accordingly. 

A particular task can be completed by setting its task completion percent to 100 
(from the Task Tracking dialog box, as shown above), or by double-clicking the 
task from the Task Assistant. When a milestone task is completed, the icon in the 
Task Assistant dialog box changes from "M" to display a check mark. 

In order to complete a milestone task, all of its required and milestone sub-tasks 
need to be complete. If they are not complete, you will be prompted to do so. 
Similarly, a completed task can be marked incomplete, either by entering a value 
for task completion percent that is less than 100, or by double-clicking the 
completed task from the Task Assistant dialog box. 

In the figure below, task Create a New Project is complete (as indicated by the 
check-mark). Percent task completion is set to 100 in the Task Tracking 
Information dialog box. 
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Figure 2-31   Completing a Task 

➥ If a milestone is overdue, it is flagged with a red "X". 

7 Toggle the milestone display on or off using the Show Milestones checkbox at the 
bottom of the Task Assistant. This will display/hide the completion percentage and 
days remaining for the milestone tasks, and for the entire workflow. The completion 
percentage for the entire workflow is calculated as a function of the completion 
percentage of each of the milestone tasks, and their relative task weights. 



2—System Editor

JCSS/Release 10.0 JCSS-2-24

Figure 2-32   Show Milestones

8 Click the Export button to be prompted for a filename and location to save the task 
information as a tab-delimited text file. This file can be opened in MS Project 
(choose Default Task Information for the Import Mapping when opening the file).

End of Procedure 2-8

Documentation Help > Documentation > (option) Access the JCSS documents discussed 
below:

User’s Manual Help > Documentation > User’s Manual Open the JCSS User’s Manual using 
Adobe Acrobat Reader. Acrobat Reader software can be optionally installed 
with JCSS. The JCSS User’s Manual is a guide that covers basic aspects of 
JCSS operation and use. It contains figures that provide visual examples of the 
JCSS interfaces, step-by-step procedures, and other important JCSS features 
and concepts.

Technical Reference
Manual

Help > Documentation > Technical Reference Manual Opens this document, the 
JCSS Technical Reference Manual, using Adobe Acrobat Reader. 

Software Release
Bulletin (SRB)

Help > Documentation > Software Release Bulletin (SRB) Opens the JCSS 
Software Release Bulletin using Adobe Acrobat Reader. Acrobat Reader 
software can be optionally installed with JCSS. The SRB contains release notes 
for the current version of JCSS.
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JCSS Acronyms Help > Documentation > JCSS Acronyms Opens the JCSS Acronyms table 
using Adobe Acrobat Reader. Acrobat Reader software can be optionally 
installed with JCSS. The JCSS Acronyms table contains definitions for 
acronyms commonly used with JCSS.

JCSS Models User’s
Guides

Help > Documentation > JCSS Models User’s Guides > (option) Opens the 
JCSS Models User’s Guides using Adobe Acrobat Reader. These guides cover 
CTP, EPLRS, H.323, Link 16, PEP, Promina, UHF SATCOM, and Voice 
Models.

IT Guru
Documentation

Help > Documentation > IT Guru Documentation Open the complete IT Guru 
document set. IT Guru is an OPNET commercial-off-the-shelf (COTS) product 
that models the behavior of networks—many JCSS features are based on IT 
Guru features. In this JCSS Technical Reference Manual, many references will 
ask you to access the IT Guru documentation for further details on certain 
features.

The IT Guru documentation contains a global index and a search query feature 
that enables you to quickly find needed information.

Show All Logs Help > Show All Logs... Launches the Log Viewer.

Figure 2-33   Log Viewer

Error Log Help > Error Log > (option) If errors occur during the operation of JCSS, they 
are logged in this error log file.

Error Log > Open Help > Error Log > Open Using this menu option, you can open the error log file 
to view the error messages in a text editor.

Error Log > Clear... Help > Error Log > Clear... Clear the error log file of the selected range of error 
messages.
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Message Log Help > Message Log > (option) Status updates that monitor the performance of 
JCSS are logged in this message log file.

Message Log >
Open

Help > Message Log > Open Using this menu option, you can open the 
message log file to view the status messages in a text editor.

Message Log > Clear Help > Message Log > Clear Clear the message log file of all status messages.

Session Log Help > Session Log > (option) Basic file operations during the current session 
are logged in this session log file.

Session Log > Open Help > Session Log > Open Using this menu option, you can open the session 
log file to view the session messages in a text editor.

Session Log >
Clear...

Help > Session Log > Clear.. Clear the session log file of the selected range of 
session messages.

Web - JCSS Home
Page

Help > Web - JCSS Home Page Launches DISA’s JCSS Home Page in your 
browser window.

Web - JCSS Support
Center

Help > Web - JCSS Support Center Launches DISA’s JCSS Support Center 
Home Page in your browser window. You need a network Username and 
Password to access this site.

About JCSS Help > About JCSS View information about the OPNET core software version, 
the models version, and copyright information.
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3 Scenario Builder

The Scenario Builder is the JCSS interface for creating, modifying, and saving 
projects and scenarios; it allows you to develop a complete communications 
plan. 

The Scenario Builder is also used to evaluate and optimize network 
performance. Given a network and the traffic, it runs the optimization and comes 
up with suggestions for optimal link and network capacities. 

Additionally, this interface analyzes the results of a simulation session. It 
converts output from a simulation session into data that is viewable and grouped 
into Measures of Performance (MOPs). 

Accessing the Scenario Builder 

When you choose to either open an existing project in JCSS or create a new 
project, the Scenario Builder displays. 

Figure 3-1   Scenario Builder 
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File Menu

New Project File > New Project Creates a new project, the first step in the Lead Planner’s 
workflow. You can simply name and launch a generic project, or use the New 
Project Wizard to set equipment types, area of operations, and top-level units 
and locations to use in the new project. Use the following procedure to create a 
new project.

Procedure 3-1   Creating a New Project

1 Select File > New Project.

➥ A new Scenario Builder opens and the Create New Project dialog box appears.

2 Specify the names for the project and the initial scenario in the Create Project 
dialog box.

Figure 3-2   Creating a New Project

Note—The names for both the project and the scenario cannot contain any spaces 
or special characters. In addition, the scenario name cannot be the same as any 
existing OPFAC; it must be unique. 

3 Select a classification level for the project in the Create Project dialog box. 

4 Click OK. 

If Launch New Project Wizard is not checked, then JCSS creates a generic project 
using the names you have designated. You can skip the remaining steps in this 
procedure. 

OR 

If Launch New Project Wizard is checked, then the Initial Topology dialog box 
displays. 
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Figure 3-3   Initial Topology Dialog Box 

5 Choose to create an empty scenario or import from one of the various data 
sources, and then click Next. 

5.1 If you choose Create empty scenario, a blank scenario is created. The Select 
Equipment Types dialog box displays. 

Figure 3-4   Select Equipment Types Dialog Box 

Select the types of equipment that you will use in your project, and then click 
Finish. 

5.2 If you choose Import from JCSS/NETWARS, a file chooser dialog box 
displays. Select the appropriate nt.m file. 

5.3 If you choose Import from OPNET Modeler, a file chooser dialog box displays. 
Select the appropriate nt.m file. 

5.4 If you choose Import from Device Configurations, the Import Device 
Configurations dialog box displays. 
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Figure 3-5   Import Device Configurations Dialog Box 

Specify the location of the device configuration files and how these files 
should be integrated into the existing topology (if it already exists), and then 
click Import. 

5.5 If you choose Import from VNE Server, the VNESI process begins. VNESI is 
a COTS feature which allows you to create a network model based on 
information imported from VNE Server. You can import both topology and 
traffic information using imported VNE Server data. 

Enter your VNE Server hostname in the Import from VNE Server dialog box, 
and then click OK. 
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A second Import from VNE Server dialog box displays. Specify the import 
mode you want to use, based on the following table, and then click Import.. 

 

6 If you choose Import from XML, a file chooser dialog box displays. Select the 
appropriate xml file. 

6.1 If you choose Import from JCSS Templates, the Set Area of Operations dialog 
box displays. 

Figure 3-6   Set Area of Operations Dialog Box 

Note—The Set Area of Operations dialog box provides the coordinates where the 
template Organizations/OPFACs will reside inside the scenario. The Area of the 
View and Center of the View are updated depending on the selected View. The 
Top-Level Units and Location utilize this information to provide base coordinates 
for any imported Organizations/OPFACs. 

Table 3-1   VNE Server Import Modes

Import Mode Usage Description

Create/Replace network 
using the most recent VNE 
Server data

Use when starting a new 
scenario or when you want 
to erase all existing 
information in the current 
model to replace with VNE 
Server data.

If checked, the current VNE 
Server data is used to create 
a network model. "Create" 
appears if you are in a new 
scenario; "Replace" appears 
if you are in an existing 
scenario

Incrementally update 
network using the most 
recent VNE Server data

Use when you want to 
update the current model 
with any changes that have 
occurred in VNE Server 
since the last import.

If checked, VNE Server 
updates the current network 
model with all recorded 
changes in VNE Server 
since the original import.

Replace network using an 
existing archive

Use when you want to 
replace the current model 
with information contained in 
a VNE Server archive file.

If checked, a network model 
is created using the archived 
network specified in the 
drop-down menu. This menu 
is populated based on 
available archives from VNE 
Server.
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Select the Area of the View and Center of the View, and then click Next. The 
Top Level Unit dialog box displays. 

Figure 3-7   Top Level Unit Dialog Box 

6.2 Choose an existing project template from the Project Template drop-down list, 
or type the number of units in the Number of Top Level Units field, and then 
click Next. 

7 At the end of the import, the Select Equipment Types dialog box displays. Select 
the types of equipment that you will use in your project, and then click Finish. 

End of Procedure 3-1

Open Project File > Open Project Use the following procedure to open an existing project in 
the Scenario Builder.

Procedure 3-2   Opening a Project in Scenario Builder

1 Select File > Open Project or click the Open Existing Project toolbar button.

➥ The Open Project dialog box displays.

2 Double-click on the project folder of interest, select the corresponding .prj file, and 
then click Open. 
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Figure 3-8   Opening a Project in Scenario Builder 

End of Procedure 3-2

Save Project/ Save
Project As

File > Save Project or File > Save Project As: Save changes to existing projects 
in the Scenario Builder by using either the Save or Save As option. 

1) To save the changes you made to an existing project in the Scenario 
Builder, select the Save option, or

To save the changes you made as a separate project in the Scenario 
Builder, select the Save As option. 

2) Specify the desired name in the subsequent dialog box, and then click OK. 

Open Subordinate
Query

File > Open Subordinate Query Use the following procedure to open a 
subordinate query.

Procedure 3-3   Opening a Subordinate Query

1 Select File > Open Subordinate Query. 

➥ The Open Subordinate Query dialog box appears, and then opens the selected 
subordinate query file in a new Scenario Builder. The Subordinate Planner is 
prompted to select the appropriate file to be edited. 

2 Select the file by double-clicking on it. 

➥ The project that you selected opens in a new Scenario Builder. The green "e" 
icon on top of the units indicates that the Senior-level Planner has marked these 
units to be edited by the Subordinate Planner. Other units that have a red lock 
icon on top indicate that the Subordinate Planner may only view these units and 
cannot edit them. Lock units are hidden by default upon opening. 
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Figure 3-9   Opened Subordinate Query

End of Procedure 3-3

Close File File > Close Close the open project or subordinate query file. You will be 
prompted to save your project. Choose the desired option. The selected project 
and its Scenario Builder window close.

Figure 3-10   Closing a Project 

Generate Scenario
Briefing

File > Generate Scenario Briefing Exports scenario information directly to a 
PowerPoint (.ppt) file. Customize the briefings by selecting desired components 
from a set of elemental briefing components. A graphical user interface (GUI) is 
provided to enable you to choose the briefing components that you want to 
include, and then generate the briefings. 

Procedure 3-4   Generating a Scenario Briefing

1 Select File > Generate Scenario Briefing.

➥ The Briefings dialog box opens.
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Figure 3-11   Briefings Dialog Box 

2 Choose from the available components shown on the left side of the dialog box. 
The explanation of the selected components displays on the right side text box. 
Some of the components may not be available and will be shown disabled in the 
dialog box accordingly. 

Figure 3-12   Print Preview Dialog Box

3 From the preview, browse through the pages and make choices about the 
following: 

3.1 Set the header to be used on each printed page 

3.2 Use the background color as it appears on the workspace, or click the White 
background checkbox to use a white background. 
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3.3 If you check Fit to single page, the contents of a subnet print in one page; if 
not, each subnet prints across multiple pages. The total number of pages 
displays at the top right corner of the preview window. 

3.4 Choose to either scale the image directly, or adjust for printer resolution. 

3.5 Click Page Setup if you want to select the mode (landscape or portrait), paper 
size, etc. 

4 Click Print, and select the desired printer. 

End of Procedure 3-4Page 

Page Setup File > Page Setup Selects the page size and orientation for printing.

Print Scenario File > Print Scenario Allows you to print out different subnet views for the 
current scenario as shown in the Project Editor. Opens a print preview window 
that allows you to specify print parameters and send to a printer. 

Print Graphs File > Print Graphs After you have defined and displayed graph panels, you can 
print the visible graphs. 

Manage Model Files File > Manage Model Files > (option) This submenu lists options which allow 
Files you to manage model files. 

Manage Model
Files > Delete Model

Files

File > Manage Model Files > Delete Model Files Displays a list of all models Files 
> Delete from which you can select to delete files. 

Manage Model
Files > Add Model

Directory

File > Manage Model Files > Add Model Directory Displays the Directory Files > 
Add Model Browser in which you can create a new directory for models. 

Manage Model
Files > Refresh

Model Directories

File > Manage Model Files > Refresh Model Directories JCSS maintains a list of 
folders called the model directories (or mod_dirs for short) where models are 
stored. Models include OPFACs, organizations, projects and scenarios, icon 
databases, and device models. When you move models around on the hard 
drive using Windows Explorer, the software does not recognize the change. To 
make the software aware of the changes, use this option. 

Manage Model
Files > Expand

Project File Archive

File > Manage Model Files > Expand Project File Archive Displays the Select 
OPNET Components File Archive dialog box in which you can select an Project 
File .opcfa file to expand. 

Manage Model
Files > Create

Project File Archive

File > Manage Model Files > Create Project File Archive Displays the Package 
Project Components dialog box in which you can package files into an .opcfa 
file. Archive 
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Recent Projects File > Recent Projects This submenu lists recently opened projects for easy 
re-opening. 

Package Project
Files

File > Package Project Files Provides you with the ability to package and import 
JCSS data files. It serves as a convenient mechanism to exchange JCSS data 
with other users and with JCSS Support. 

There are different options for including different files in the package. These 
various options are available from the Package Project Files menu. Four 
different options are available for packaging the files; and there is one menu 
item for importing packaged files. 

A zipped archive is created as a result of choosing one of the package menu 
items. The zipped archive contains the following files for the various options:

• Project—Project, scenario, subordinate query, traffic, trajectory, OPFAC and 
organization files, simulation model files (if they exist)

• Project with Simulation Results—Project files as indicated in the Project Files 
option and simulation results files

• Project for JCSS Support—Project files as indicated in the Project Files 
option and other files needed by JCSS Support (env_db files, various log files 
etc.)

• Custom OPFACs and Organizations—All OPFAC and organization files 
under the Custom OPFACs and Custom Organizations folders

• Import—Displays the Zip File Browser dialog box in which you can select a 
zip file to open, and then opens the selected file in a new Scenario Builder. 
To import package file, choose Import from the Package Project Files menu. 
A file chooser is presented to browse for the zipped archive containing JCSS 
files. After you select the archive file to be imported, a dialog box with the 
different import options displays (see figure below.)  

Figure 3-13   Import Package Options

Backup copies of files being replaced are created by default. You can disable 
this by deselecting the checkbox in the dialog box shown above. 
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If you choose to be prompted for each file separately, then for every conflicting 
file, a dialog box displays. From this dialog box, you can choose to not overwrite 
the existing file, to replace the existing file, or to quit the import process. 

Note—Info-ZIP's Zip and UnZip1 are used to create and import the zip file. 

Exit File > Exit Shut down the entire JCSS program. If there are editors that are 
open, you will be prompted to save the contents of those editors. When all open 
editors have been acknowledged and closed, the software is shut down. 

Edit Menu 

Undo Edit > Undo Undo editing operations. 

Only the following actions can be undone: 

• Adding a unit (includes OPFAC and organization), device, or association 
(includes intra OPFAC link, inter OPFAC link, satellite link, broadcast 
network, relationship and circuit) from the palette or library. 

• Moving a unit, device, association, or any group of these objects in the 
workspace. 

• Deleting a unit, device, association, or any group of these objects in the 
workspace or using Scenario Builder treeview. 

• Modifying attributes on devices; all attribute changes made while the Edit 
Attributes dialog box is open will be considered a single action. 

Some actions may prevent certain, or all, prior actions from being undone (for 
example, saving a project file.) Immediately following a save to disk, there will 
be no undoable actions. 

There is no limit on the number of actions that can be undone; however, the 
actions can only be undone in the reverse order in which they were performed. 

Redo Edit > Redo Redo the undone operations. The actions can only be redone in the 
reverse order in which they were undone, which means that the last undone 
action will be the first one to be redone. 

1. Copyright (c) 1990-1999 Info-ZIP.  All rights reserved. "Info-ZIP" software is provided 
"as is," without warranty of any kind, express or implied. In no event shall Info-ZIP or 
its contributors be held liable for any direct, indirect, incidental, special or consequential 
damages arising out of the use of or inability to use this software. Info-ZIP retains the 
right to use the names "Info-ZIP," "Zip," "UnZip,""WiZ," "Pocket UnZip," "Pocket 
Zip," and "MacZip" for its own source and binary releases. 
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Any action (editing operation which includes add, delete, move, modify) 
performed after performing Undo will clear the Redo stack, and the undone 
operations cannot be redone. 

Cut Edit > Cut Cut selected, supported objects on the workspace to the clipboard, 
and remove them from the workspace. If unsupported objects are attached to a 
supported object, then the unsupported objects are also removed from the 
workspace but not maintained on the clipboard. 

Supported Objects: 

• Organizations 

• OPFACs 

• Devices 

• External links 

• Internal links 

• Satellite links 

• Broadcast networks 

• OPNET demand objects 

Unsupported Objects: 

• Radio links 

• Circuits 

• Relationships 

• OE 

• Configuration OPFAC 

Copy Edit > Copy Copy selected, supported objects on the workspace to the 
clipboard. 

Supported Objects: 

• Organizations 

• OPFACs 

• Devices 

• External links 

• Internal links 
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• Satellite links 

• Broadcast networks 

• OPNET demand objects 

Unsupported Objects: 

• Radio links 

• Circuits 

• Relationships 

• OE 

• Configuration OPFAC 

Paste Edit > Paste Paste all objects on the clipboard to the workspace. 

Delete Edit > Delete Delete the objects selected on the workspace. 

1) Select the objects that need to be deleted. To select multiple objects, press 
the <Ctrl> key on the keyboard while clicking on the objects. 

2) Once the objects are selected, use this menu option or use the <Del> key 
on the keyboard to delete them. 

3) Confirm the deletion. 

Select All Edit > Select All Select all the objects in the current subnet. Once the objects 
are selected, perform edit operations (like move, delete, etc) on these objects 
as needed. 

Find Node/Link Edit > Find Node/Link You can search for an object (such as a node, 
subnetwork, link, or path) based on its name (part or all of the name.) Every 
object whose name contains the string you specified is selected and listed. Or 
you can leave the search field blank to find all objects in the network. Use the 
following procedure to find a node or link.

Procedure 3-5   Finding a Node/Link

1 Select Edit > Find Node/Link.

➥ The following dialog box appears.
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Figure 3-14   Find Node/Link Dialog Box

2 Enter a text string in the Name contains field to search for specific names. Leave 
this field blank to find all objects in the network.

3 Click Find. 

➥ Found objects are highlighted in the display (any objects in the display that were 
previously highlighted are de-selected.) The Find Node/Link dialog box displays 
a list of the searched objects, including their names, subnet names, and types.

4 Select the name of an object in the list, and click Locate Node/Link. 

➥ The display changes to locate and highlight the selected object.

End of Procedure 3-5

Group
Selection/Action >

Selection Filter

Edit > Group Selection/Action > Selection Filter Select multiple objects based 
on their attributes.

Procedure 3-6   Using a Selection Filter

1 Select Edit > Group Selection/Action > Selection Filter.

2 Select the type of object by clicking the appropriate check box.

3 Choose the attribute to be used for selecting objects from the drop-down menu. 
The list of attributes changes dynamically with the type of objects chosen for 
selection. 

4 From this list, select one or more attributes and specify the matching criteria. If 
there are objects of the selected type that match the attribute selection criteria 
specified, they are marked as selected. 



3—Scenario Builder

JCSS/Release 10.0 JCSS-3-16

Figure 3-15   Selection Filter Dialog Box 

The table used for specifying the matching criteria has four columns. 

• PROP - If set to Require, an object must satisfy all attribute criteria for selection; 
if set to Consider, an object must satisfy at least one of the attribute criteria for 
selection. 

• Attr Name - Name of the attribute used as the selection criteria. 

• ?= - Specifies the type of matching to be used. For a string, the only option is a 
complete match or equal to. For numeric values, the satisfying condition could be 
less than, greater than, or equal to the specified value. 

• VALUE - Value that the attribute must match for selection. 

Multiple attributes can be used as matching criteria. Attributes can also be deleted 
as needed. 

5 Click the OK button; the software goes through all the objects in the scenario 
looking for those that match the specified criteria. When it finds objects that match 
the given criteria, it marks those objects as selected. 

End of Procedure 3-6

Group
Selection/Action >

Action Filter

Edit > Group Selection/Action > Action Filter Used in conjunction with the object 
selection feature. A similar interface is provided for applying action on the 
selected objects. 

Procedure 3-7   Using Group Actions

1 Select Edit > Group Selection/Action > Action Filter. 

➥ The following dialog box appears.
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Figure 3-16   Group Action Dialog Box

2 Select the type of object to which you want to apply group action.

3 Select the attribute that needs to be changed. In the above example, the Opfac 
Name attribute is selected.

4 Specify the value. In the previous example, JTF is specified as the name to be set 
on all selected OPFACs.

5 Click OK. The software goes through all the selected organization objects in the 
scenario and sets the trajectory attribute on them.

End of Procedure 3-7

Save Object
Selection Set

Edit > Save Object Selection Set... Allows you to save an object selection set to 
a .selset file in the SB_Data directory.

Load Object
Selection Set

Edit > Load Object Selection Set... Allows you to choose a saved object 
selection set file from the SB_Data directory to load.
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Edit Objects Using
Template

Edit > Edit Objects Using Template... Allows you to specify the content you want 
to include in your report. When you generate a report (by clicking Generate), 
your content settings are saved and will be reloaded the next time you generate 
a report.

Figure 3-17   Edit Objects Using Template Dialog Box 

• Select tables to include in user report (treeview)—Specifies which tables of 
which categories should be included in the report. To select an entire 
category of tables, click on the top-level category entries. To select an 
individual table, expand the top-level category subtree and click on the table 
entry. Selected tables and categories show a green check mark. Categories 
with some but not all of its tables selected display a green dot instead. 

• Include only selected objects in report (checkbox)—Indicates that table data 
will be collected only for objects that are currently selected in the network. 

• Ignore views (checkbox)—Indicates that table data will be collected even for 
objects that are not in the current view or views of the network. 

• Generate (button)—Generates the table data for all of the selected tables. 

• Close (button)—Closes the dialog box but retains any table selections. 
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Edit Attribute
Template

Edit > Edit Attribute Template... Allows you to edit the objects in your attribute 
Template templates. 

Figure 3-18   Edit Attribute Template Dialog Box

1) Select the Category name and Template name of the attribute template that 
you want to edit. 

2) Use the buttons on the right-hand side of the table to create new or 
duplicate table rows, edit or delete rows, move rows up or down, and add 
drilldown. 

3) Click Edit Objects... to open the dialog box to edit objects in the template.

4) Click Preview to view the edited template. 5) Click Save As... to save the 
edited template. 
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Project Defaults >
Link

Edit > Project Defaults > Link Specify the default values for a link's attributes 
based on the link type. 

Figure 3-19   Link Defaults Dialog Box 

1) Specify the desired default values for a particular link type. 

2) If needed, change the default values for another type by choosing the 
desired type from the Defaults for Link Type drop-down menu. 

3) Click the OK button to save the default values. 

Project Defaults >
Network

Edit > Project Defaults > Network Specify the default values for a broadcast 
network's attributes based on the network type. 

Figure 3-20   Network Defaults Dialog Box

1) Specify the desired default values for a particular network type. 
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2) If needed, change the default values for another type by choosing the 
desired type from the Defaults for Network Type drop-down menu. 

3) Click the OK button to save the default values. 

Project Defaults >
Requirements Matrix

Edit > Project Defaults > Requirements Matrix Edit the default requirements 
matrix questions that are applied to all new projects and scenarios created in 
the Scenario Builder. All fields are editable and can be modified by clicking on 
a cell and entering new values. 

The Applications column displays application names for the specified service. If 
there is more than one application for the service, a comma separates 
application names with no space after the comma separator. 

Figure 3-21   Default Requirements Matrix Dialog Box 

Clicking on the buttons below the table displays different functional areas. 
Questions can be added or deleted via the Add Question and Delete Question 
buttons. 

By default, the Save button saves the changes and replaces the ReqMatrix.gdf 
file located in the Rules directory. To change the default file, click the Choose 
Defaults File button. Selecting this button launches a file chooser dialog box. 
Select the desired default file; the contents of the alternate file import into the 
Defaults Requirements Matrix dialog box. 
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Figure 3-22   Specifying the Requirements Matrix Defaults File

Project Defaults >
Distance Between

OPFACs

Edit > Project Defaults > Distance Between OPFACs Configure the preferences 
for the Distance Between OPFACs feature. See field descriptions OPFACs 
below. 

Figure 3-23   Distance Between OPFACs Defaults 

• Display Duration—Specifies the amount of time that the OPFAC Distance 
Links will display if you do not have the Do not hide "distance links" 
preference enabled. 

• Do not hide "distance links"—Specifies whether the Scenario Builder will 
automatically hide the OPFAC Distance Links after a specified amount of 
time (refer to the Display Duration field above). 

• Display Units—Sets the units in which the OPFAC Distance Links will display 
their distances. 

• Elevation Threshold—Determines whether the distance calculation will 
consider the Earth's curvature. If both OPFACs' altitudes fall below this 
value, it will consider the Earth's curvature, but it will not if either OPFACs' 
altitude exceeds or equals this value. 
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Preferences >
Device Model Map >

New

Edit > Preferences > Device Model Map > New Bridge the differences in model 
names/naming conventions that exist between JCSS and Network Engineer. 
Device model mapping allows you to define a mapping between two sets of 
device model names. During export of data, the JCSS XML processing code 
can substitute model names in the source data with alternate names in the 
target data. Use the following procedure to create a new model map.

Procedure 3-8   Creating a New Model Map

1 From the Scenario Builder, select Edit > Preferences > Device Model Map > New. 

➥ The Choose Source and Target Model Name Lists displays. Use this dialog box 
to select a source model list and a target model list; this means that device model 
names in the source list will be replaced with designated model names in the 
target list. 

Figure 3-24   Choose Source and Target Model Name Lists Dialog Box

2 Click the Browse button for the Source Model List.

➥ The Source Model List Browser dialog box displays. 

Figure 3-25   Source Model List Browser 

3 Open the appropriate Rules folder. 

Note—JCSS provides template source and target model list files from which you 
can choose in the JCSS/Scenario_Builder/14.5.A/netwars/rules directory. You can 
select a template file, modify it, and save it under a new name in the 
User_Data/Rules folder to use again. Remember: Save your rules files to the 
default User_Data/Rules folder so you can easily find them again. 

4 Select the desired input file and then click Open. 
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5 Click the Browse button for the Target Model List. Repeat steps 3-4, this time 
selecting an output file as the target model list. 

6 Click OK. 

➥ The Edit Device Model Mapping File dialog box displays. 

Figure 3-26   Edit Device Model Mapping File Dialog Box 

Devices in the Unmapped Source Model Names panel (from the source model list) 
can be mapped to only one device in the Mapped Target and Source Model Names 
panel (from our target model list). However, it is possible to map more than one 
source name to the same target name (many-to-one mapping). 

7 Select the desired model in the Unmapped Source Model Names panel. Next, in 
the Mapped Target and Source Model Names panel, select one or more models. 

8 Click the Map>> button. 

➥ The source device name displays under the target device name in the Mapped 
Target and Source Model Names panel. 
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Figure 3-27   Mapped Devices

9 Click the Save button. The Device Model Map Browser dialog displays. Name the 
file in the File Name field and then click Save.

End of Procedure 3-8

Preferences >
Device Model Map >

Open

Edit > Preferences > Device Model Map > Open Launches the Device Model 
Map Browser dialog box which enables you to select a previously created 
device model map to edit using the Edit Device Model Mapping File dialog box.

Preferences >
Device Model Map >

Choose
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Edit > Preferences > Device Model Map > Choose

Use this dialog box to select an import map (source model list) and an export 
map (target model list) defaults for device model mapping.

Figure 3-28   Device Model Map Preferences Dialog Box

Click the Browse buttons for the Import Map and Export Map fields to select 
desired device model maps. Click OK when finished selecting. 

Preferences >
Functional Profiles

Edit > Preferences > Functional Profiles Set default functional profiles and 
functional names. Every OPFAC has one or more functional names. A 
functional name maps an IER or series of IERs to a producer/consumer OPFAC 
pair. A collection of such functional names is called a functional profile. A 
functional profile can be defined locally on an individual OPFAC, or globally, so 
that it is available to all OPFACs and across different scenarios. 

Figure 3-29   Functional Profile Dialog Box 

1) Add, rename, or remove functional profiles as needed. 

2) Insert, delete, or edit functional names as needed. 

3) Click OK. 



3—Scenario Builder

JCSS/Release 10.0 JCSS-3-27

Preferences >
Geographical

Coordinates

Edit > Preferences > Geographical Coordinates Sets the default geographical 
coordinate system view displayed in the workspace of the Scenario Builder. 
There are three types of geographical coordinate systems available in JCSS: 
Lat/Long, UTM, and MGRS. 

Figure 3-30   Geographical Coordinates Dialog Box

1) Select the Lat/Long, UTM, or MGRS radio button.

2) Click OK.

Preferences >
Owners List

Edit > Preferences > Owners List Set owner information for units marked for 
subordinate query. Modify existing records or add/delete records to the list as 
needed.

Figure 3-31   Owner List Dialog Box

Owner information contains four fields: Last Name, First Name, Title and 
Organization. All fields, except the Title field, are required fields. 

Preferences >
Security

Classifications

Edit > Preferences > Security Classifications Set security classification for a 
variety of items in a scenario, such as devices and IERs. This dialog allows you 
to add, remove, or change values in the list of recognized security classification 
values. The list is used to populate drop-down lists in edit fields and table cells 
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that specify security classification values. Since some fields and cells only allow 
values from this list, you will need to modify this list in order to specify custom 
security classifications. Any value is permitted, although duplicates are not 
allowed in the list. 

Figure 3-32   Security Classifications 

The list order of an entry indicates the classification's level of restriction. Less 
restrictive classifications appear toward the top of the list. 

A value in the list may be modified by selecting and editing it. The Up button 
moves the selected value toward the top of the list. The Down button moves the 
selected value toward the bottom of the list. The Insert button inserts a blank 
entry above the selected value. The Delete button deletes the selected value. 
The Set Default button sets the selected classification as your default. The Save 
button saves all changes. Once saved, the changes will affect all edit fields and 
table cells, but the values stored in those attributes will not be modified. 
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Preferences >
Advanced

Edit > Preferences > Advanced Display the Preferences Editor and set 
environment attributes that control program operation. These values are stored 
in a file called the environment database file (env_db for short). 

Figure 3-33   Preferences Editor Dialog Box

• Search for—Enables you to search for preferences. The system searches for 
words or values containing the specified text in whole or in part (a wildcard 
search is assumed.) From the drop-down menu, select the preference 
information to include in the search: Anywhere specifies to search Tags, 
Names, Values and Descriptions; In Names specifies to search Tags and 
Names only; and In Values specifies to to search Values only. 

• Arrange by—Enables you to display preferences by category. From the 
drop-down menu, select Groups to arrange preferences by group (filters the 
list of displayed preferences to a specific group by selecting the group in the 
treeview,) or Source to arrange preferences by source (preferences are 
classified based on the source of their values.) 

• Advanced view (checkbox)—Toggles between showing an advanced or 
basic view of the preferences table. In the basic view, the table shows the 
name and value of each preference. In the advanced view, the table shows 
the name, tag, source of the preference's value and the value itself. 

• OK (button)—Saves changes and closes the Preferences Editor. 
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• Cancel (button)—Closes the Preferences Editor without saving changes. 

• Apply (button)—Saves changes. 

View Menu

Show Logical Views View > Show Logical Views... Specify filtering parameters for logical views. 

Figure 3-34   Logical View Selection Dialog Box

• Network Layer Filters—Enables you to hide all devices except for those of a 
particular layer of the network. (Note that this doesn't necessarily mean OSI 
network layer, but instead, it means the various devices that use a particular 
protocol.) Network Layer Filters shown are only those which apply to the 
deployed network.

• Security Classification Filters—Enables you to filter elements of the network 
based on their security classifications. Any custom classifications added in 
the Operational view will be available here as well for filtering. 

• Duration and Start Time—These parameters are used to get the Capacity 
Planner graphs that are used for filtering for various layers.

• Consider Link Capacities (checkbox)—This is another parameter used to get 
the Capacity Planner graphs. A link capacity considered filter will result in the 
Capacity Planner creating a graph that may not show complete physical 
connectivity of the devices due to link load.  A link capacity ignored filter will 
result in a graph that shows complete physical connectivity of the devices 
regardless of link load. 
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• Create View (button)—Creates the type of view that you specified and loads 
it into a Network Showcase window. The filter specifications are applied to 
the logical view model. 

• Save Settings (button)—This button is available from the Operational View 
and gives you the option to save the settings instead of creating a logical 
view network with the specified settings at this time. 

• Close (button)—Closes the dialog without making any changes to the model. 

Show Network
Browser

View > Show Network Browser Use the Network Browser, a pane that lists 
objects (organizations, OPFACs, nodes, devices, links, etc.) in the network, to 
locate objects in the workspace and edit their attributes. 

Figure 3-35   Network Browser

You can modify the object list by applying filters. Available filters include the 
following:

• Classification—Filters based on the classification attribute on each device

• Equipment Type—Filters based on the equipment type attribute on each 
device

• Ownership—Shows the associated owner for each device in the scenario. 
Used with Collaborative Planning

• Broadcast Networks—Shows all of the broadcast networks in the scenario 
and to which OPFACs/devices they are attached
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• Relationships—Shows all of the relationships in the scenario and to which 
OPFACs they apply 

• Satellite Links or Radio Links—Shows all of the satellite (or radio) links in the 
scenario and to which OPFACs/devices they are attached

Click on an object in the object list to display it in the workspace (upper-right.) 
Select and check an object to display it in a Showcase window (lower-right.) Use 
options provided on the right-click menu to modify object attributes. 

Figure 3-36   Network Browser with Showcase Window and Right-Click Menu 

If you have an OPNET Modeler license, you can easily open node models in 
Modeler by double-clicking on a device in the workspace. Use the following 
procedure to open a node model.

Note—For derived models, you must open the parent instead. 

Procedure 3-9   Open a Node Model

1 Double-click on a node model. The following message dialog displays. 
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Figure 3-37   Open Node Editor Message Dialog Box

2 Click OK. 

➥ OPNET Modeler launches and displays the node model. 

Note—Note that Modeler will not launch if you do not have a license for it. 

Figure 3-38   Opening a Node Model in OPNET Modeler 

End of Procedure 3-9

Using the Preferences Editor in JCSS, you can set preferences for the Modeler 
launch feature: 

• modeler_ipc.enable—Enables (set to TRUE) or disables (set to FALSE) the 
Modeler launch capability. 
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• modeler_ipc.port—Sets your port preference for Modeler launch. Specify the 
port number you want to use to connect to Modeler when opening node 
models. 

• modeler_ipc.show_dialog—Shows (set to TRUE) or hides (set to FALSE) the 
Open Node Editor message dialog on Modeler launch. 

Consult the documentation for OPNET Modeler for instructions on using 
Modeler with node models. 

Show Network
Topology

View > Show Network Topology Toggles the view of the network topology on 
and off in the Scenario Builder workspace. 

Show Network
Showcase

View > Show Network Showcase Toggles the showcase display on and off in 
the Scenario Builder window. Allows you to choose to use the default showcase 
(or select another showcase to use from the Showcase drop-down menu) and 
the default view (or select another view from the View drop-down menu.) You 
can also create a new showcase, and import, duplicate, rename or delete a 
showcase using options in the Showcase drop-down menu. 

Figure 3-39   Show Network Showcase in Scenario Builder
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Open Network
Showcase Window

View > Open Network Showcase Window Allows you to select a saved network 
showcase and display it in a separate window.

Figure 3-40   Network Showcase Window

Show Time
Controller

View > Show Time Controller Displays the Time Controller dialog box that 
allows you to change the current network time visualized in the editor and 
animate the time change effect.

Figure 3-41   Time Controller Dialog Box

The Time Controller dialog box shows the current network time (text field), value 
for the time step which is used for stepping forward or backward using the 
animation buttons, animation control buttons (to Jump to start to reset the 
network time to the slider start time, Step backward to decrease network time 
by one time step, Play forward or Pause animation, Step forward to increase 
network time by one time step, Jump to end to set network time to slider end 
time, Slow down play and Speed up animation), and a time slider which provides 
an alternative way to change the current network time. 



3—Scenario Builder

JCSS/Release 10.0 JCSS-3-36

Click the Configure button to display the Time Controller Settings dialog box, 
which allows you to set and change Time Controller values. 

Figure 3-42   Time Controller Settings Dialog Box 

Set Area of Interest 

• Slider start time, Slider end time, and Time step—Specifies the source 
plug-in for the slider start time, end time, and time step values. If 
User-Defined is selected, you can enter the value in the corresponding field. 

• Real time between steps field—Specifies the speed of the animation. 

• Loop checkbox—If checked, animation restarts after completion.

• Start modeling at calendar time—Check and type a value if you want to 
specify a calendar time for the network start time. Otherwise, the start time is 
assigned the symbolic value of 0.0. 

Set Area of Interest View > Set Area of Interest Provide geographical context to the scenario. 

Figure 3-43   Set Area of Interest Dialog Box 

The geographic focus can be specified by entering values for Area of the View 
and Center of the View. These attributes determine the location and size of the 
displayed view of the map. For example, if the center of view is (0,0) and the 
area of view is (width = 100, height = 50), then the portion of the map that would 
be displayed will be from (50W, 25N) to (50E, 25S). 



3—Scenario Builder

JCSS/Release 10.0 JCSS-3-37

The geographic focus also determines the relative range at which OPFACs (and 
their devices) are located from each other. This is of significance when 
exchanging IERs/traffic during a simulation. While TSC-85 radios and wire links 
have no range limitations, TRC-170 radios and tactical broadcast networks only 
work within a limited range of each other. For example, if two TRC-170 radios 
are more than 150 miles apart, then all packets transmitted between them will 
be dropped, resulting in failed IERs. 

Go to Parent
Organization

View > Go to Parent Organization or click the Go to Parent Organization toolbar 
button Change the view in the workspace to the next higher level in the network. 
For example, if this option were selected inside an OPFAC, the next level up 
would include the parent OPFAC. Similarly, if this option were selected for an 
OPFAC inside an organization, the next level up would be the parent 
organization. 

Figure 3-44   Go to Parent Organization

Setting Background
View Properties

View > Background > Set Properties Control the display properties and other 
characteristics of the current subnetwork.

Figure 3-45   Setting Background View Properties 
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• Define units and other characteristics of the current subnet:

— Units drop-down menu-Sets the scale of the network display grid. By 
default, the units are the same as the parent subnet. The units can be 
degrees, meters, kilometers, feet, miles, or logical. Units in the top subnet 
are always in degrees. 

— Move when subnet moves checkbox-Specifies whether objects in the 
subnet are moved when the subnet itself is moved. Uncheck this option 
if you want objects to remain in the same global location when the parent 
subnet is moved. This option is available only when subnet units is in 
degrees. 

— Auto-layout objects moved into this subnet-Specifies whether to 
automatically reposition nodes moved into the subnet to produce an 
aesthetically pleasing layout. Uncheck this option if you want objects 
moved into subnet to remain at their current global position. 

• Define the grid line properties: 

— Drawing drop-down menu-Sets the style of the grid lines as disabled 
(hidden), solid, or dashed. 

— Division drop-down menu-Sets the number of units between each grid 
line. 

— Color button-Sets the color of the grid lines. 

• Specify the subnet layers to display in the network view and the order in 
which they appear: 

— Visible column-Specifies whether the subnet layers are visible. A green 
checkmark indicates that the subnet layer is visible. By default, all subnet 
layers are set to visible. To change the setting, click the checkbox or the 
Show/Hide button. 

— Description column-Identifies the subnet layers that can be shown in the 
network view. 

— Translucency column-Specifies the level of layer content translucency 
with a value between 0 (opaque) and 100 (transparent). Note that only 
layers with CADRG/CIB and MrSID raster images support translucency. 
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• Set the order and visibility of the subnet layers: 

— Move Back button-Moves the selected subnet layer from front to back in 
the display. 

— Move Forward button-Moves the selected subnet layer from back to front 
in the display. 

— Show button-Sets the selected subnet layer as visible in the display. 

— Hide button-Sets the selected subnet layer as hidden in the display.

— Remove button-Removes the selected subnet layer from the display. 

— Edit CADRG/CIB Properties… button-Opens a dialog box with 
configurations of background slices with CADRG/CIB rasters. Requires 
a Terrain Modeling Module license. 

— Close button-Closes the dialog box. Move layers backward and forward 
to indicate the layer ordering in the workspace. 

Background > Set
Border Map

View > Background > Set Border Map Specify a border map for a scenario. 
Border maps use stylized lines to define political and geographical areas. JCSS 
comes with a library of border maps that represent a geographic area described 
by latitude and longitude.

Use the following procedure to specify a border map.

Procedure 3-10   Setting Border Map

1 Select View > Background > Set Border Map.

2 Choose the border map from the drop-down menu. Note that the border map list is 
a finite list and may not be modified. 

Figure 3-46   Selecting a Border Map 
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3 If the desired map is not in the list, select the world map and zoom in to the desired 
location. 

End of Procedure 3-10

Background > Add
Image Map

View > Background > Add Image Map Import an image into the scenario using 
the following procedure:

Procedure 3-11   Adding an Image Map

1 Choose an option of importing an existing map or specifying the file path to an 
image map located on the hard drive; select desired map. 

2 Click OK. 

Figure 3-47   Importing an Image Map

End of Procedure 3-11

Background > Add
MIF Map

View > Background > Add MIF Map Import MIF maps, which are files that 
provide additional geographical information on a border map, such as 
roadways, waterways, regions, and counties. Several MIF maps come standard 
with JCSS. Use the following procedure to import MIF maps:

Procedure 3-12   Adding a MIF Map

1 From the MIF menu, select the desired MIF map. 

Figure 3-48   Importing MIF Data
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2 Click Close. The MIF map automatically imports. 

End of Procedure 3-12

Background > Show
MIF Log

View > Background > Show MIF Log Display the MIF Import Log dialog box.

Figure 3-49   MIF Import Log Dialog Box

Background > Add
Image

View > Background > Add Image Import ordinary background images, i.e., 
those images that do not include geographical information, into a scenario. 
Background images differ from background image maps in that they are 
described by referencing points on an x-y axis. Use the following procedure to 
add images in the Scenario Builder:

Procedure 3-13   Adding a Background Image

1 Select View > Background > Add Image.

2 In the Add Background Image dialog box, select the Import background image 
radio button, and then click Browse to select the TIFF file to import. 

Figure 3-50   Importing a Background Image 

3 Select Open and then OK to import the image. 

4 Next, JCSS enters Map/Background Editing mode. In this mode, you can edit 
image maps and backgrounds, but not border maps. To select/move/resize image 
maps or backgrounds, simply click, right-click or drag them. You can also copy, cut 
and paste maps/backgrounds.
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5 After you are done, exit Map/Background Editing mode by right-clicking on one of 
the maps or backgrounds and choosing Exit Map Editing Mode, or by selecting 
View > Background > Map Edit Mode.

End of Procedure 3-13

Background > Add
CADRG/CIB Raster
Catalog Directories

View > Background > Add CADRG/CIB Raster Catalog Directories... Select a 
raster catalog directory from which to import. 

Background > Add
MrSID Image

View > Background > Add MrSID Image... Select a MrSID image file (*.sid) to 
import. 

Note—For more information about this feature, please refer to the OPNET IT 
Guru documentation set, available via Help > Documentation > IT Guru 
Documentation.) 

Background > Map
Edit Mode

View > Background > Map Edit Mode Modify background images. Once this 
mode is selected, edit the image as desired using techniques described in the 
following table. 

t

Table 3-2   Edit Image Map Operations

To... Follow These Steps

Resize an image map Right-click on the image map and drag one of 
the handles on the image map.

Right-click on the image map and choose Set 
Location and Size and fill in the desired 
values

Move an image map Drag the object to the desired location.

Right-click on the image map and choose Set 
Location and Size and fill in the desired 
values.

Remove an image map from the workspace Click on the image map and press the 
<Delete> key.

Exit map edit mode Right-click on the image map and select Exit 
Map Editing Mode.
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Edit Display
Preferences

View > Edit Display Preferences Edit preferences that control the visualization 
of the network. Preferences can be controlled on either the global or subnet 
level. Those preferences specified at the subnet level take precedence over any 
global settings. The subnet preferences are retained per subnet and can only 
be changed from this dialog box for the active subnet.

Figure 3-51   Edit Visualization Preferences Dialog Box—Global Tab

Global preferences are available on the Global tab: 

• Minimize icons that are X pixels or smaller—Determines at what size icons 
become minimized. If an object appears smaller than the specified number 
of pixels, it is drawn using its minimized icon, as specified by its minimized 
icon attribute. This setting also changes the 
network_visualization.minimized_icon_pixel_threshold environment 
preference. 

• Size of minimized icons—Determines the size, in pixels, of all minimized 
icons in the network. It also changes the 
network_visualization.minimized_icon_size environment preference. 

• Size of minimized balloons—Determines the size, in pixels, of all minimized 
balloons in the network. It also changes the 
network_visualization.minimized_balloon_size environment preference. 

• Icon style—Specifies the model icon style to display. Select Symbolic or 
Chassis. 
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• Show node/subnet labels for—Specifies which nodes and subnet objects 
display labels. It also changes the network_visualization.show_node_labels 
environment preference. The selections have the following effects: 

— All icons—Labels appear on all objects. 

— No icons—No labels appear on any node or subnet objects. 

— Full-size icons only—Labels only appear on objects that have not been 
scaled below their original full size. 

— Non-minimized icons—Labels appear on any icons that have not been 
minimized. 

• Icons larger than X pixels—Labels appear on any icons that are larger than 
the specified number of pixels. It also changes the 
network_visualization.show_labels_icon_pixel_threshold environment 
preference. 

• Show link arrowheads—Specifies which links have arrowheads. It also 
changes the network_visualization.show_link_arrowheads environment 
preference. The selections have the following effects: 

— Never—No arrowheads appear on any link objects. 

— As specified by attributes—The appearance of arrowheads is determined 
beach link object's arrowheads attribute. 

— For simplex links only—For all simplex links, the appearance of 
arrowheads is determined by each link object's arrowheads attribute. For 
all other link types, no arrowheads display. 

• Show link labels—Specifies which links have labels. It also changes the 
network_visualization.show_link_labels environment preference. The 
selections have the following effects: 

— Never—No link labels appear on any link objects. 

— Always—Link labels appear on all link objects. 

— For off-page links only—Link labels appear on links that are drawn out of 
the active subnet. 

• Show demand labels—Specifies which demands have labels. It also 
changes the network_visualization.show_demand_labels environment 
preference. The selections have the following effects: 

— Never—No demand labels appear on any demand objects. 

— Always—Demand labels appear on all demand objects. 

• Show path labels—Specifies which paths have labels. It also changes the 
network_visualization.show_path_labels environment preference. The 
selections have the following effects: 

— Never—No path labels appear on any path objects. 

— Always—Path labels appear on all path objects. 
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Figure 3-52   Edit Visualization Preferences Dialog Box—Subnet Tab

Subnet preferences are available on the Subnet tab.

• Default to Global Visualization Settings checkbox—Determines if the subnet 
inherits the global preferences, or uses the subnet settings specified in the 
dialog box. If checked, the subnet-level dialog box controls are disabled. If 
unchecked, the subnet settings can be specified for the active subnet. 

• Minimize icons that are X pixels or smaller—Determines at what size icons 
become minimized in the subnet. If an object appears smaller than the 
specified number of pixels, it is drawn using its minimized icon, as specified 
by its minimized icon attribute. 

• Size of minimized icons—Determines the size, in pixels, of all minimized 
icons in the active subnet. 

• Size of minimized balloons—Determines the size, in pixels, of all minimized 
balloons in the active subnet. 

• Icon style—Specifies the model icon style to display. Select Symbolic or 
Chassis. 
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• Show node/subnet labels for—Specifies which nodes and subnet objects 
display labels in the active subnet. 

— All icons—Labels appear on all objects. 

— No icons—No labels appear on any node or subnet objects. 

— Full-size icons only—Labels only appear on objects that have not been 
scaled below their original full size. 

— Non-minimized icons—Labels appear on any icons that have not been 
minimized. 

— Icons larger than X pixels—Labels appear on any icons that are larger 
than the specified number of pixels. 

• Show link arrowheads—Specifies which links have arrowheads in the active 
subnet. The selections have the following effects: 

— Never—No arrowheads appear on any link objects. 

— As specified by attributes—The appearance of arrowheads is determined 
by each link object's arrowheads attribute. 

— For simplex links only—For all simplex links, the appearance of 
arrowheads is determined by each link object's arrowheads attribute. For 
all other link types, no arrowheads display.

• Show link labels—Specifies which links have labels in the active subnet. The 
selections have the following effects:

— Never—No link labels appear on any link objects. 

— Always—Link labels appear on all link objects. 

— For off-page links only—Link labels appear on links that are drawn out of 
the active subnet. 

• Show demand labels—Specifies which demands have labels in the active 
subnet. The selections have the following effects:

— Never—No demand labels appear on any demand objects.

— Always—Demand labels appear on all demand objects.

• Show path labels—Specifies which paths have labels in the active subnet. 
The selections have the following effects:

— Never—No path labels appear on any path objects.

— Always—Path labels appear on all path objects.

• OK button—Closes the dialog box. All settings take effect immediately, 
including modification of global environment preferences and subnet-level 
settings.
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• Cancel button—Closes the dialog box and returns to the original display 
without making changes to the visualization settings, global environment 
attributes, or subnet-level settings.

• Preview button—All of the settings changed take effect immediately, 
although the environment preferences and subnet settings are not retained 
unless you click OK.

Refresh Workspace View > Refresh Workspace Redraw/refresh the workspace view.

Layout View > Layout > (option) You can customize the appearance of objects in your 
workspace by scaling the icons to a larger or smaller size, and moving icon 
labels that overlap. JCSS provides commands that will perform these functions 
automatically for you, or you can make adjustments manually to selected icons 
using the Scale Selected Icons dialog box..

Automatic Icon
Scaling

View > Layout> Automatic Icon Scaling Toggle on and off the ability to adjust 
icon sizes automatically to minimize overlap.

Layout > Automatic
Label Placement

View > Layout> Automatic Label Placement Toggle on and off the ability to 
adjust label positions automatically to prevent overlap with adjacent icons.

Layout > Scale Node
Icons Interactively

View > Layout > Scale Node Icons Interactively Scale/change the size of 
node/subnet icons. For example, if an icon is 12 x 12 pixels at full size, you can 
scale the icon to 50% so that it appears at half-size (6 x 6 pixels).

If you scale an icon below a certain size, the icon becomes minimized—that is, 
it appears as a simple shape rather than as a bitmap.

Procedure 3-14   Scaling Node Icons Interactively

1 Choose View > Layout > Scale Node Icons Interactively. 

➥ The Scale All Icons dialog box displays. 

Figure 3-53   Scale All Icons Dialog Box

2 Scale the selected icons by the desired amount. 
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• Select the Fix icons at full size radio button to scale selected icons to their full 
size (as defined by the icon bitmaps). When zooming in or out in the workspace, 
the icons remain at full size regardless of the zoom level. This behavior is 
achieved by setting the "threshold" attribute on the selected objects to a value of 
0. Selecting this option disables the icon scaling slider and the uniform size 
button. 

• Select the Scale icons, minimize overlap radio button to use the Scale Factor 
slider and field to scale all of the selected icons, except those that would overlap 
other icons if they were scaled any larger. The size can range from 1% to the 
percentage at which all of the icons will appear full size. This maximum 
percentage will vary, depending on the icon size when you open this dialog box. 

• Select the Scale icons, ignore overlap radio button to use the Scale Factor slider 
and field to scale all of the selected icons equally, even those that overlap. The 
size can range from 1% to the percentage at which all of the icons will appear full 
size. This maximum percentage will vary, depending on the icon size when you 
open this dialog box. 

• To scale all selected icons to the same size (that is, to the current size of the 
smallest icon in the selection set), click the Set Icons to Uniform Size button and 
then use the slider. A progress bar appears as the icons are updated. 

3 Click OK to change the selected icons as specified and close the dialog box. A 
progress bar appears as the icons are updated. If no changes are necessary, the 
dialog box will simply close. 

4 Click Cancel to close the dialog box without making any of the specified changes.

End of Procedure 3-14

Layout > Lay Out
Nodes Interactively

View > Layout > Lay Out Nodes Interactively... Use this option to change the 
position of various node/subnet/utility objects.

Figure 3-54   Layout Network Objects Dialog Box 
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• Algorithm drop-down menu—Specifies the currently selected layout 
algorithm. The layout algorithm determines how the positions of the selected 
objects will change when the Run button is clicked. The algorithms are:

— Expand/Contract—Moves the selected network objects away from or 
toward the Mark icon (the movable green cross icon in the Project Editor 
workspace). 

— Expand/Contract Horizontally—Moves the selected network objects 
horizontally away from or toward the Mark icon. 

— Expand/Contract Vertically—Moves the selected network objects 
vertically away from or toward the Mark icon. 

— Rotate—Moves the selected network objects as if they were rotated 
about the Mark icon. 

— Disperse—Moves the selected network objects with the specified layout 
region. 

• Layout region drop-down menu—Specifies a rectangular region for the 
algorithm to operate on. This element will be disabled if the selected 
algorithm does not use a particular layout region. 

• Percentage/Degrees combo field—Specifies a variable parameter to 
customize the behavior of the selected layout algorithm. The label changes 
between Percentage and Degrees, depending on the selected algorithm. 
You can either drag the slider or enter a number directly to specify the value. 
This is disabled, if the selected algorithm does not use a parameter value. 

• OK button: Closes the dialog box—The position changes become permanent 
and a single undo command is added to the editor's undo stack. 

• Cancel button—Closes the dialog box after undoing all position changes that 
were made while this dialog box was open. 

• Run button—Performs the selected layout algorithm upon the current 
selection set or, if no objects are selected, all objects in the current subnet. 

• Undo button—Undoes the effect of the last algorithm run or the last object 
drag. The dialog box maintains a local undo stack since the time it was 
opened, so you can undo repeatedly to return to any earlier state. This button 
is disabled if there are no operations that can be undone. 
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• Redo button—Redoes the effect of the last local undo operation. Until you 
run another algorithm or directly drag objects, you can redo repeatedly to 
return to any previously undone state. This button is disabled if there are no 
operations that can be redone. 

• Undo All button—Undoes the effect of all algorithm runs and object drags 
since the dialog box was opened. This has the same effect as repeatedly 
clicking the Undo button until it becomes disabled.

Note—While the Layout Network Objects dialog box is open, the toolbar and the 
menu bar of the editor window are disabled. However, the editor workspace is 
still active. You can change the selection set, and you can directly drag selected 
objects around. Any drags are considered part of the interactive layout 
operation and will be undone if you cancel out of this dialog box. Also, while this 
dialog box is open, the Mark icon (a green cross) is present at the center of the 
current selection set. This icon represents the Mark point used by various 
algorithms. You can drag this icon around without dragging any network objects 
and without changing the current selection set. 

Layout > Lay Out
Nodes (Balanced)

View > Layout> Lay Out Nodes (Balanced) Selecting this option automatically 
balances the layout of nodes in the current view. The sites in the current subnet 
are repositioned to produce an aesthetic layout. This operation can make a 
crowded network easier to work with and is faster than manually repositioning 
sites. You can control which sites are moved as follows: 

• If no sites are selected, every site in the current subnet is considered for 
repositioning. 

• If one or more sites are selected, only the selected sites are considered for 
repositioning. 

If there are unconnected groups of sites in the subnet, this operation also 
balances the spacing between the groups. This step can be disabled with the 
network_layout.adjust_unconnected_groups preference. 

Layout > Lay Out
Nodes (Simple)

View > Layout> Lay Out Nodes (Simple) Selecting this option automatically 
simplifies the layout of nodes in the current view. The sites in the current subnet 
are repositioned to produce an illustrative, but not necessarily aesthetic, layout. 
The algorithm used by this operation is faster and uses less memory than the 
balanced algorithm used by the Lay Out Nodes (Balanced) operation. Thus, it 
is better for subnets with large numbers of sites. 

Layout > Lay Out
Nodes (Core

Centric)

View > Layout> Lay Out Nodes (Core Centric)... Use this option to create a 
meaningful network layout, based on core nodes. The layout places core nodes 
in the center. All other nodes are placed around the core nodes based on the 
quantity of links. Nodes attached to the network with only one link are placed 
furthest from the core nodes. Nodes with no link attachments to the network are 
placed on the left side of the workspace. 
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Core nodes are determined using one of the following methods: 

• Select Core Nodes with Most Connections-Core nodes are determined 
based on the quantity of links. Nodes with the highest quantity of links are 
designated as core nodes. 

• Use Selected Nodes-Select one or more nodes, subnets, and/or utility 
objects. Selected objects are designated as core nodes. 

Layout > Lay Out
Nodes (Circular)

View > Layout> Lay Out Nodes (Circular) Selecting this option automatically 
lays out nodes in the current view circularly. The nodes in the current subnet are 
repositioned to produce a circular network layout that shows interconnected ring 
and star topologies. The circular layout emphasizes group and tree structures 
with a network. 

Layout > Lay Out
Nodes (Hierarchical)

View > Layout> Lay Out Nodes (Hierarchical) Selecting this option automatically 
lays out nodes in the current view hierarchically. The nodes in the current subnet 
are repositioned to produce a hierarchical layout that shows a precedence 
relationship. The hierarchal layout emphasizes flow. 

Layout > Lay Out
Nodes (Schematic)

View > Layout> Lay Out Nodes (Schematic)... Selecting this option 
automatically lays out nodes in the current view schematically. The nodes in the 
current subnet are repositioned to produce a schematic layout with right-angled 
links. The overlapping of links is kept to a minimum, depending on the size and 
complexity of the network. 

Layout > Geographic
Positioning

View > Layout > Geographic Positioning Toggle on and off the current view 
mode to logical/physical. 

Layout > Move
Selected Nodes to

Non-Geographic
Positions

View > Layout > Move Selected Nodes to Non-Geographic Positions Toggle on 
and off the current view mode for the selected nodes to non-geographic mode. 

Layout > Move
Selected Nodes to

Geographic
Positions

View > Layout > Move Selected Nodes to Geographic Positions Toggle on and 
off the current view mode for the selected nodes to geographic mode. 

Zoom > To
Rectangle

View > Zoom > To Rectangle or press <Ctrl>+<I>, or use the Zoom In option 
from the shortcut menu, or click the Zoom In toolbar button: Get a close-up view 
of the object in question in the workspace. Apply this option multiple times to 
obtain an ever-closer view.
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To use this feature, select the Zoom > To Rectangle command, and then drag 
the cursor to define a rectangular shaped region to be magnified.

Figure 3-55   Zoom to Rectangle

Zoom > To Selection View > Zoom > To Selection or press <Ctrl>+<Shift>+<Z>: Get a close-up view 
of a selected area or object in the workspace. Drag the cursor to define a 
rectangular shaped region to be magnified, and then select the Zoom > To 
Selection command.

Zoom > Unzoom View > Zoom > Unzoom or press <Ctrl>+<U>, or use the Zoom Out option from 
the shortcut menu, or click the Zoom Out toolbar button: Restore the workspace 
view to the previous zoom level.

Zoom > To All View > Zoom > To All or press <Ctrl>+<Alt>+<Z>: Zoom out on the workspace 
so it shows active areas in the window.

Filter View > Filter > (option) Apply a number of different filters to the scenario.

Filter > Selected
Objects

View > Filter > Selected Objects Filters can be applied on objects that have 
been selected on the workspace. The objects could have been selected by 
manually clicking on them, or by the use of the selection filter.

Figure 3-56   Filter Map Dialog Box

Using this option, you can hide the selected objects or show only the selected 
objects. An option is also provided to redisplay all objects. 
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Filter > Devices View > Filter > Devices Filters can be applied to devices based on the type of 
applications they support. Filtering can be done based on the functional area or 
the service. For example, if you are interested in viewing just the SIPRNET 
portion of the scenario, you can apply a device filter and specify SIPRNET as 
the service of interest. All other devices will be hidden. If an OPFAC has no 
visible devices, the OPFAC is hidden as well. 

Figure 3-57   Filter OPFACs and Devices Dialog Box

You can display the result of this filtering operation either on the workspace or 
in a table. The table displays the OPFAC name, device name, application name, 
functional area and service. 

Note—This feature does not work with the standard applications. Instead, it 
works with the applications specified in the Requirements Matrix, which is a part 
of the Collaborative Planning feature.

Filter >
Infrastructure

View > Filter > Infrastructure Show or hide the different types of infrastructure 
like relationships, links, broadcast networks and satellite links. By default, all 
infrastructures are displayed and all the options are checked. If you want to hide 
a certain type of infrastructure, uncheck that option and all infrastructure of that 
type will be hidden. 

Figure 3-58   View Infrastructure Dialog Box 

For example, if you do not want to view relationships in the scenario, you can 
go to this interface and uncheck the option View Relationships.
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Filter > Hide Locked
Units

View > Filter > Hide Locked Units Hide all locked units in the Subordinate 
Planner query file.

Filter > Restore Full
View

View > Filter > Restore Full View View all locked units. In the Subordinate 
Planner query file, all locked units are hidden by default. 

Network Views View > Network Views > (option) JCSS offers a number of different views of the 
scenario. Each of these views offers the user a different perspective of the 
network.

Network Views >
Planning

View > Network Views > Planning This view is useful for someone working in a 
collaborative planning environment. Using this view, the planner can display 
only the planning portions of the scenario and hide all others. Organizations, 
OPFACs and planning links are all part of the planning view. Devices and 
connectivity links are hidden in this view.

Network Views >
Connectivity

View > Network Views > Connectivity If a planner is not interested in the 
planning links and just wants to view the connectivity links in the network, he can 
choose this menu option. Planning links and OPFACs without any devices are 
hidden in this view. For example, if you do not want to view relationships in the 
scenario, you can go to this interface and uncheck the option View 
Relationships.

Filter > Hide Locked
Units

View > Filter > Hide Locked Units Hide all locked units in the Subordinate 
Planner query file.

Filter > Restore Full
View

View > Filter > Restore Full View View all locked units. In the Subordinate 
Planner query file, all locked units are hidden by default.

Network Views View > Network Views > (option) JCSS offers a number of different views of the 
scenario. Each of these views offers the user a different perspective of the 
network.

Network Views >
Planning

View > Network Views > Planning This view is useful for someone working in a 
collaborative planning environment. Using this view, the planner can display 
only the planning portions of the scenario and hide all others. Organizations, 
OPFACs and planning links are all part of the planning view. Devices and 
connectivity links are hidden in this view.

Network Views >
Connectivity

View > Network Views > Connectivity If a planner is not interested in the 
planning links and just wants to view the connectivity links in the network, he can 
choose this menu option. Planning links and OPFACs without any devices are 
hidden in this view.

Network Views >
Planning and
Connectivity

View > Network Views > Planning and Connectivity The planner can use this 
menu option to return to the default view, which includes the planning and 
connectivity elements in the scenario.
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Network Views >
Operational

View > Network Views > Operational Selecting this menu item will switch from a 
Systems or Logical View back to the default view of the scenario, the same view 
that loads when you first open the scenario in Scenario Builder.

Network Views >
OPFAC Systems

View > Network Views > OPFAC Systems Selecting this menu item will switch 
from the current view, the Operational View or some other type of Systems 
View, to the OPFAC Systems View. The OPFAC Systems View expands the 
contents of the organizations, collapses the contents of the OPFACs, and 
redraws the links to connect to their respective devices.

Save Current Unit
View

View > Save Current Unit View Set a default view to which you can return.

Restore Saved Unit
View

View > Restore Saved Unit View Return to the saved view.nterested in the 
planning links and just wants to view the connectivity links in the network, he can 
choose this menu option. Planning links and OPFACs without any devices are 
hidden in this view.

LOS Settings View > Show LOS > LOS Settings Set the parameters for the editor to control 
what LOS visualizations are displayed and how they appear.

Note—The LOS that you see takes into account the position as well as the 
altitude for that device. You can set the altitude for an OPFAC via the OPFAC 
Attributes dialog box (right-click on the OPFAC and select Edit JCSS Attributes.) 
By default, altitude is set by terrain and measured in meters. You can enter an 
altitude value in another unit of measurement (such as kilometers, feet, yards, 
or miles), and JCSS will automatically convert the measurement to meters the 
next time you open the OPFAC Attributes dialog box. 

Figure 3-59   LOS Settings 

• LOS Range Radius—Measured in meters, this specifies the size of the circle 
that may appear around an organization or OPFAC. It is a nominal range, 
and this single setting affects all LOS Visualization in the editor. For 
reference, 10,000 meters is the typical transmission limit when terrain 
elevation data is not available. Transmitters assisted by elevation could 
transmit many times this distance. 
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• LOS Terrain Shading Density—Specifies the number of samples to check 
within the LOS Range Radius for determining LOS Terrain Effects Shading. 
More samples give a more accurate representation, but can also slow display 
as more information must be considered to update Terrain Effects Shading. 

• Enable LOS Connectivity—Allows the editor to display LOS Connectivity 
links when selected for organizations or OPFACs. Enabled by default. 

LOS Connectivity is a thick, dashed, double-headed arrow. The color of the 
arrow indicates whether the two objects could communicate. Connectivity is 
bi-directional and independent of specific device characteristics. 
Connectivity is based on signal loss between the transmitter and receiver 
positions as determined by the Longley-Rice signal propagation model. 

LOS Connectivity exists between OPFACs. Organizations that contain 
OPFACs may display LOS Connectivity links when they are collapsed. 
Enabling LOS Connectivity on an organization enables LOS Connectivity on 
all subordinate organizations and OPFACs. An organization that contains no 
subordinate OPFACs will not display any LOS Connectivity links (it would not 
be able to join a broadcast network or connect via point-to-point links either). 

LOS Connectivity works through broadcast networks and point-to-point 
transmission links to determine all of the OPFACs to which a selected 
Organization or OPFAC could possibly communicate and designates the 
state of that communication link. LOS Connectivity links are attributes of their 
end points. The existence of LOS Connectivity links indicates that one or 
both of the objects at an end of the link has LOS Connectivity enabled. LOS 
Connectivity links disappear when neither end point has LOS Connectivity 
enabled, in either the top-level organization or any subordinate organization 
or OPFAC. LOS Connectivity link coloration is automatically updated when 
either end point moves for any reason, including mouse dragging, attribute 
changes, or animation, to reflect the LOS closure state at the new location. 

Figure 3-60   LOS Connectivity 

• Enable Scenario LOS Range—Allows the editor to display LOS Range 
circles and Terrain Effects Shading for selected organizations or OPFACs. 
Enabled by default. 
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LOS Range is a circle of a fixed radius placed around the organization or 
OPFAC in question. The circle represents a ground distance and is used as 
a reference for the distance from a particular object. There is a single setting 
for the range that pertains to all LOS Ranges displayed in the entire scenario. 
The LOS Range is a nominal indicator, having no direct connection to a 
particular device's transmission range. The LOS Range does indicate the 
limit of the area within which locations may be sampled for determining LOS 
Terrain Shading. 

Any organization or OPFAC may display an LOS Range without regard for 
the type of device contained within or even if an OPFAC or device is 
contained. The LOS range simply indicates a distance. 

Figure 3-61   LOS Range 

• Enable LOS Terrain Shading—Allows the editor to display Terrain Effects 
Shading if LOS Range is also enabled. Disabled by default. 

• Terrain Effects Shading indicates portions of the area around an organization 
or OPFAC where a radio receiver could not receive a hypothetical 
transmission from the object. 

Since the LOS Range defines the limit of the area where LOS Terrain 
Shading is tested, LOS Range must be enabled to view LOS Terrain 
Shading. Disabling LOS Range on an object also disables LOS Terrain 
Shading. 

Like LOS Range, LOS Terrain Shading does not indicate anything about the 
specific OPFACs or devices contained within the designated object. It simply 
indicates that if the object contained a radio transmitter, that radio transmitter 
would or would not be able to communicate with a generic radio device at a 
particular location. 

LOS Terrain Shading works by testing for LOS closure at a predetermined 
number of sample locations evenly spaced throughout the circle formed by 
the LOS Range. You can select the number of samples to take. 

LOS Terrain Shading updates when the selected object moves for any 
reason, whether by mouse dragging, attribute change, or animation. 
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Figure 3-62   Terrain Effects Shading

Show LOS > Clear
LOS Ranges

View > Show LOS > Clear LOS Ranges Clears LOS range circles and terrain 
effects shading for all units. 

Show LOS > Display
LOS Legend

View > Show LOS > Display LOS Legend Display the LOS Legend, which 
explains the color-coding of LOS Connectivity as well as LOS Ranges and 
Terrain Shading. The Auto-Display Legend checkbox determines whether the 
LOS Legend will automatically appear following the activation of LOS 
visualization. Clearing the checkbox will prevent this automatic display. 

Figure 3-63   LOS Legend

OPFAC Distances >
View OPFAC

Distances

View > OPFAC Distances > View OPFAC Distances Create OPFAC Distance 
Links (LOS Connectivity Links with a label showing the distance between each 
pair of OPFACs) between all selected OPFACs. 

OPFAC Distances >
Remove OPFAC

Distances

View > OPFAC Distances > Remove OPFAC Distances Remove any OPFAC 
Distance Links currently existing in the scenario. 

Links View > Links > (option) Sub-menu allows you to select whether or not you want 
to show or hide all links from the view.

Demands View > Demands > (option): Sub-menu allows you to select whether or not you 
want to show or hide all demands from the view.

IERs View > IERs > (option): Sub-menu allows you to select whether or not you want 
to show all, show selected, or hide all IERs from the view. You can also color 
IERs by aggregate load (or hide aggregate load coloring), and set IER color 
thresholds.
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IERs > Show All View > IERs > Show All Select this option to show all IERs in the view.

IERs > Show Only
Selected

View > IERs > Show Only Selected Select this option to show selected IERs in 
the view.

IERs > Hide All View > IERs > Hide All Select this option to hide all IERs from the view.

IERs > Color by
Aggregate Load

View > IERs > Color by Aggregate Load Select this option to color IERs in the 
view by aggregate load.

IERs > Hide
Aggregate Load

Coloring

View > IERs > Hide Aggregate Load Coloring Select this option to hide 
aggregate load coloring from the view.

IERs > Set IER Color
Thresholds

View > IERs > Set IER Color Thresholds Sub-menu allows you to select whether 
or not you want to show all, show selected, or hide all IERs from the view. You 
can also color IERs by aggregate load (or hide aggregate load coloring), and set 
IER color thresholds. Specify a minimum value and the colors to be used for 
each threshold. This feature is used in conjunction with the Aggregate Traffic 
Flows feature. Flows are colored based on the threshold they fall under. If the 
load of an aggregate flow is more than the highest threshold, the flow is colored 
black. If the load is lesser than the minimum threshold, the flow is not displayed. 
The default minimum value is 0 Kbps. 

Figure 3-64   Traffic Flow Thresholds Dialog Box

Set IER color thresholds, and then click OK. 

IERs > Display
Recorded Routes

(DES)...

View > IERs > Display Recorded Routes (DES) Opens the Route Report for IER 
Routes window. If you have recorded IER routes during a simulation, you can 
view the results using this option.

IERs > Hide Routes View > IERs > Hide Routes When you have displayed recorded routes in the 
workspace, use this option to hide the recorded routes visualization.
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Circuits View > Circuits > (option) Sub-menu allows you to select whether or not you 
want to show or hide all circuits from the view. 

Paths View > Paths > (option) Sub-menu allows you to select whether or not you want 
to show or hide all paths from the view. 

Wireless Domains View > Wireless Domains > (option) Sub-menu allows you to select whether or 
not you want to show or hide all wireless domains from the view. 

Annotations View > Annotations > (option) Sub-menu allows you to select whether or not 
you want to show annotations in the subnet, and show, hide, minimize or clear 
annotation balloons from the view. 

Visualize Protocol
Configuration

View > Visualize Protocol Configuration > (option) Control the display of 
protocol configuration using the following options: 

• IP Interface Status—Shows whether the connected interface is active or 
shutdown. A green up arrow indicates that interface is active whereas a red 
down arrow indicates that the interface is shutdown. 

• IP Routing Protocols—Shows the routing protocols that are configured on 
the router interfaces. 

• IP Address Types—Shows the IP address types on the network by color, 
along with a legend to explain the color-coding. 

• IP QoS Configuration—Shows the IP QoS configuration on the links. 

• IP Security Configuration—Shows the packet filtering security configured on 
the links. 

• IP Tunnel Configuration—Shows the router tunneling configured on the 
network. 

• BGP Peers—Shows the BGP peering (neighbor) relationships in the 
network. EBGP confederation peers are shown in dark green, EBGP peers 
are shown in blue, all other colors indicate IBGP peers. You can view the tool 
tip of a peering visualization for more information about the peers. For 
networks using route reflection, the visualization also indicates if a router is 
a reflector or a client. 

• OSPF Area Configuration—Shows the OSPF areas configured on the router 
interfaces. 

• IPv4 Interface Metrics—Shows legends for IGP, OSPF, ISIS, IGRP, EIGRP, 
and MPLS TE metrics

• ATM Routing Domains—Shows which ATM routing protocols are configured 
on the switch ports.

• VLAN Configuration—Shows the VLANs configured in the network.
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• HAIPE Versions—Shows the HAIPE versions deployed in the network.

Note—For more information about this feature, please refer to the OPNET IT 
Guru documentation set, available via Help > Documentation > IT Guru 
Documentation.) 

Clear Visualization View > Visualize Protocol Configuration > Clear Visualization Removes all 
protocol configuration visualizations from the workspace.

Visualize Network
Configuration

View > Visualize Network Configuration > (option) Control the display of 
network configuration using the following options:

• Link Datarate—Designate the colors to use by data rate when visualizing link 
usage.

Figure 3-65   Link Datarate Visualization Dialog Box 

• Link Datarate—Designate the colors to use by data rate when visualizing link 
usage. 

• Link Technology—Designate the colors to use by technology when 
visualizing link usage. 
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Figure 3-66   Link Technology Visualization Dialog Box

• WLAN connectivity (in 3DNV)—View WLAN connectivity in 3DNV. 

• Clear Visualization—Removes all network configuration visualizations from 
the workspace. 

• Show Interactively—Show network configuration visualizations interactively.

Visualize Link Usage View > Visualize Link Usage > (option) •Control the display of link usage with 
the options discussed below.

Visualize Link Usage
> Settings

View > Visualize Link Usage > Settings Designate your choice of link usage 
colors and thickness.

Figure 3-67   Link Visualization Settings Dialog Box
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• Color Settings table—Lists the colors to use when visualizing link usage, and 
shows the utilization value that corresponds to each color. The Lower Limit 
number represents the percentage of the link that is utilized. Click Insert to 
add a new row to the table, or Delete to delete the selected row from the 
table. 

• Width Settings table—Lists the link thickness to use when visualizing link 
usage. The Lower Limit number represents the throughput value that 
corresponds to each link thickness. 

• Preview button—Applies the current settings to the network. This button 
appears only if link load visualization is enabled. 

• OK button—Saves the specified settings and closes the dialog box. 

• Cancel button—Closes the dialog box without saving the current settings. 

• Restore Defaults button—Resets the dialog box to the default link 
visualization settings. 

Visualize Link Usage
> Color by Link

Usage

View > Visualize Link Usage > Color by Link Usage Set the link colors and 
thickness based on the link's peak, average, or current utilization (depending 
upon which one you choose in the Color links based on data from and using the 
drop-down list boxes) and throughput statistics respectively. 

The recorded statistic values and the peak time are reported in the display that 
appears when you move your mouse over any link. These statistics were 
collected from a Capacity Planning Evaluation. The link statistics are computed 
taking into consideration the entire duration of the Capacity Planning 
Evaluation. 

You must first run a Capacity Planning Evaluation before you can visualize 
utilization. 

Figure 3-68   Color by Link Usage

Visualize Link Usage
> Clear Visualization

View > Visualize Link Usage > Clear Visualization Removes all link usage 
visualizations from the workspace.

Visualize Link Usage
> Show Legend

View > Visualize Link Usage > Show Legend Displays a legend that explains the 
current link usage visualization settings.
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Visualize Link Usage
> Reset Utilization

Value Label
Positions

View > Visualize Link Usage > Reset Utilization Value Label Positions: Resets 
the utilization value label positions for link usage visualizations.

Set View for Subnet View > Set View for Subnet > (option) Sub-menu allows you to select and apply 
a network view to the current subnet. You can apply a view to the current subnet 
only or to the entire network. If you add, remove, or change the properties of any 
network object, choose View > Refresh Workspace; this ensures that Project 
Editor reflects the current view accurately. When the scenario or subnetwork 
has a view applied, the view name appears in the title bar.

Set View for Network View > Set View for Network > (option) Sub-menu allows you to select and 
apply a network view to the current network. If you add, remove, or change the 
properties of any network object, choose View > Refresh Workspace; this 
ensures that Project Editor reflects the current view accurately. When the 
scenario or subnetwork has a view applied, the view name appears in the title 
bar.

Scenarios Menu

New Scenario Scenarios > New Scenario or press <Ctrl>+<Shift>+<N> Create a new blank 
scenario as described below:

Procedure 3-15   Creating a New Scenario

1 Select Scenarios > New Scenario.

2 Enter a name for the new scenario in the New Scenario Name field, and then click 
OK.

Figure 3-69   Creating a New Scenario

➥ The new scenario is blank and contains no data. The Scenario Builder indicates 
in the title bar the current open scenario. 

End of Procedure 3-15
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Duplicate Scenario Scenarios > Duplicate Scenario or press <Ctrl>+<Shift>+<D>: Create an exact 
duplicate of an existing scenario under a new name. Enter a name for the new 
scenario in the Duplicate Scenario Name field, and then click OK. 

Figure 3-70   Duplicating a Scenario 

The new scenario is an exact copy of the current scenario, which can serve as 
the baseline scenario. The Scenario Builder indicates in the title bar the current 
open scenario. 

Manage Scenarios Scenarios > Manage Scenarios View each scenario in the project and its status. 
Buttons and drop-down menus enable you to do the following: 

• Add new scenarios, 

• Duplicate scenarios, 

• Delete scenarios, 

• Run a simulation, 

• Change the simulation duration, 

• Delete results, and 

• Reorder scenarios in the list. 

Click in each table cell to edit its contents. Brackets indicate a change to the 
scenario is requested, and will be applied when you click OK.

Figure 3-71   Manage Scenarios Dialog Box
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• Project Name field—Saves the project under a different name. If you enter a 
new name and save your project, the project is saved under the new name. 
This is similar to the File > Save Project As... feature.Scenario Table 
columns: 

— #—Changes the order of the scenarios in the table. 

— Scenario Name—Lists the name of each scenario. 

— Saved—Shows if a scenario is saved or unsaved. Clicking within a cell 
also lets you delete a scenario. 

— Results—Shows the state of the results of each scenario simulation. 
"Uncollected" means that a probe file exists, but you have not run a 
simulation. "Out of date" means that the set of chosen results, simulation 
configuration, or network model has changed since the results file was 
created. 

— Sim Duration—Specifies the length of time to run the simulation. Use it 
with the Time Units column. 

— Time Units—Specifies the time units that apply to the simulation exam: 
seconds, minutes, hours, days, or weeks. Used with the Sim Duration 
column. 

• Delete—Deletes scenarios that you select. 

• Discard Results—Deletes results from a scenario. 

• Collect Results—Runs the simulation and collects statistics you specify. 

• OK—Closes the Manage Scenarios dialog box, and runs any simulations 
that are waiting. 

• Cancel—Closes the Manage Scenarios dialog box without making changes. 

Click in each table cell to edit its contents. Brackets indicate a change to the 
scenario is requested, and will be applied when you click OK. 

Previous Scenario Scenarios > Previous Scenario or press <Ctrl>+<Up>: Display the previous 
scenario in the project.provides a quick way of surveying the relevant attributes 
of a number of network objects without generating a full report and searching for 
the rows of interest. It can also sometimes be more handy than, for example, 
opening the Edit Attributes dialog box for each of the objects of interest. 

Next Scenario Scenarios > Next Scenario or press <Ctrl>+<Down>: Display the next scenario 
in the project.
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Switch To Scenario Scenarios > Switch To Scenario Switch between the scenarios associated with 
a project, as a project can have scenarios. A black bullet indicates the current 
scenario open in the Scenario Builder. Select the desired scenario.

Figure 3-72   Switch Between Scenarios

When the project is saved, the scenario that is currently open is set as the 
default scenario.

Set Classification Scenarios > Set Classification Set the classification of a scenario. Every project 
in JCSS has a classification. The default classification is Unclassified. Select a 
classification from a drop-down list or specify a user-defined classification. Once 
the classification is set, the classification string will always appear at the top-left 
and bottom-right hand corners of the workspace.

User-Defined
Reports

Scenarios > User-Defined Reports > (option) Sub-menu allows you to select to 
open live report table, or generate report from template.

User-Defined
Reports > Open Live

Report Table

Scenarios > User-Defined Reports > Open Live Report Table Open one or more 
user-defined report tables in “live” mode. This means the tables will not only 
show the corresponding values given the current selection set, but will also 
automatically repopulate themselves whenever the selection set changes. This 
provides a quick way of surveying the relevant attributes of a number of network 
objects without generating a full report and searching for the rows of interest. It 
can also sometimes be more handy than, for example, opening the Edit 
Attributes dialog box for each of the objects of interest.

Figure 3-73   Live User-Defined Report Tables Dialog Box
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• Select tables to open treeview—Specifies which table of which category 
should be opened. Expand the top-level category subtree and left-click on 
the desired table entry. You can select multiple tables by holding down the 
control key while left-clicking or by clicking-and-dragging a rectangular 
selection. Selecting a top-level category tree row itself does not imply 
selecting all or any of its tables; it is simply ignored. 

• Show button—Builds and opens individual user-defined report table dialog 
boxes for each of the tables you have selected. 

• Close button—Closes this dialog box but not any of the user-defined report 
tables you might have opened. 

User-Defined
Reports > Generate

Report from
Template

Scenarios > User-Defined Reports > Generate Report from Template Specify 
the content you want to include in your report.

Figure 3-74   Generate User-Defined Report Dialog Box 

• Select tables to include in user report treeview—Specifies which tables of 
which categories should be included in the report. To select an entire 
category of tables, click on the top-level category entries. To select an 
individual table, expand the top-level category subtree and click on the table 
entry. Selected tables and categories show a green checkmark. Categories 
with some but not all of its tables selected display a green dot instead. 

• Include only selected objects in report checkbox—Indicates that table data 
will be collected only for objects that are currently selected in the network. 

• Ignore views checkbox—Indicates that table data will be collected even for 
objects that are not in the current view or views of the network. 
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• Send reports to the Report Server (<host>) checkbox—Indicates that reports 
should be sent to Report Server. This option is active only when a Report 
Server license is available. 

— Report name as it will appear on the Report Server text field—Specifies 
a name for the report in Report Server. 

• Generate button—Generates the table data for all of the selected tables. 
Content settings are saved and will be reloaded the next time you generate 
a report. 

• Close button—Closes the dialog box but retains any table selections. 

Set Scenario
Documentation

Scenarios > Set Scenario Documentation Access a free-form text box to enter 
scenario purpose, traffic, and topology notes to be stored with the scenario for 
documentation purposes. The scenario's Operational Scenario In Time (OPSIT) 
name is also entered here. 

Figure 3-75   Scenario Documentation Dialog Box 

1) Type desired text in the Scenario Documentation field. 

2) Enter desired value in the OPSIT Name field. 

3) Click OK. 

DoDAF Integration Scenarios > DoDAF Integration (option) Sub-menu allows you to integrate 
select Department of Defense Architecture Framework (DoDAF) views using 
the DoDAF editor or generate a Microsoft Visio diagram of a given view.
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DoDAF Integration >
DoDAF Editor...

Scenarios > DoDAF Integration > DoDAF Editor... Integrate select Department 
of Defense Architecture Framework (DoDAF) views:

• OV-3 Operational Information Exchange Matrix—Information exchanged 
between nodes and the relevant attributes of that exchange such as media, 
quality, quantity, and the level of interoperability required. 

• SV-6 Systems/Services Data Exchange Matrix—Specifies the 
characteristics of the system data exchanged between systems. This 
product focuses on automated information exchanges (from OV-3) that are 
implemented in systems. Non-automated information exchanges, such as 
verbal orders, are captured in the OV products only. 

You can import the traffic (IERs) defined by either of the two views and use it in 
simulations. You can also modify the IERs and export the new traffic as OV-3 
and SV-6 views. 

1) Create a network model in JCSS that represents the topology (not the 
traffic) of the network to be modeled. The model should contain all the 
OPFACs will be used by the OV-3 and SV-6 views.

Note—You can still manually create any IERs which would not be imported from 
DoDAF documents. 

2) Choose Scenarios > DoDAF Integration > DoDAF Editor.... The DoDAF 
Editor displays. 

Figure 3-76   DoDAF Editor 

The DoDAF Editor controls all operations regarding import, modification, 
and export of DoDAF-defined traffic. Each row of the opened table shows 
the properties of one of the existing IERs (if any) in the network. 
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3) Click Import to import the traffic defined in an OV-3 or SV-6 view. Select the 
format of the DoDAF view from the list of supported formats in the DoDAF 
Import Format dialog box, click Import, and then select the file containing 
the OV-3 or SV-6 view from the Open dialog box. 

Note—IERs, threaded IERs, and standard applications can be managed in this 
editor, as well.

4) After the import, all the traffic defined in the DoDAF file displays in the table 
in the DoDAF Editor. Investigate the traffic and its properties and make 
changes, if desired. 

5) Use the OV-3 and SV-6 radio buttons at the bottom-left corner of the 
DoDAF Editor to switch between the OV-3 and SV-6 display modes and 
see traffic properties from both view points. 

6) Add or delete IERs, threaded IERs, or standard applications using the 
Insert Row, Duplicate Row, and Delete Row buttons. 

7) Click OK. All IERs in the table are deployed in the network. Any required 
information for any traffic source, which may not have been specified in the 
DoDAF view and has not been corrected, will be filled by its default value 
by the system. Additionally, any devices or OPFACs specified in the table 
will be created automatically if they didn't exist in the scenario before.

8) Run the scenario and analyze the performance of the network under the 
traffic defined by the DoDAF views. Choose Scenarios > 
DoDAF Integration > DoDAF Editor... to open the table again, make 
changes to the IERs if necessary, and re-deploy the modified traffic in the 
network. Repeat the procedure in this way until satisfactory results are 
obtained. 

9) Create a new OV-3 or SV-6 representation of the traffic in the network by 
selecting the desired view through the OV-3 and SV-6 radio buttons and 
clicking Export. Select from a list of supported formats for creating the 
DoDAF views. 

DoDAF Integration >
Generate Visio

Reports...

Scenarios > DoDAF Integration > Generate Visio Reports... Generate Microsoft 
Visio diagrams to represent a given view of the network. Supported views 
include the following:

• OV-6c—The OV-6c view provides a time-ordered examination of the 
information exchanges between participating operational nodes as a result 
of a particular scenario. 

• SV-10c—The SV-10c view provides a time-ordered examination of the 
system data elements exchanged between participating systems (external 
and internal), system functions, or human roles as a result of a particular 
scenario.



3—Scenario Builder

JCSS/Release 10.0 JCSS-3-72

• OV-2—The OV-2 view graphically depicts the operational nodes (or 
organizations) with needlines between those nodes that indicate a need to 
exchange information. The graphic includes internal operational nodes 
(internal to the architecture) as well as external nodes.

• SV-2—The SV-2 view depicts pertinent information about communications 
systems, communications links, and communications networks. SV-2 
documents the kinds of communications media that support the systems and 
implements their interfaces as described in SV-1. Thus, SV-2 shows the 
communications details of SV-1 interfaces that automate aspects of the 
needlines represented in OV-2.

1) Select Scenarios > DoDAF Integration > Generate Visio Reports.... The 
Generate DoDAF Visio Reports dialog box appears.

Figure 3-77   Generate DoDAF Visio Reports Dialog Box

2) Select the view for which you want to generate a report. 

3) Change the default Diagram Title, if desired.

4) Change the default Diagram Name and output location, if desired.

5) Change the Page Size and Orientation, if desired.

6) Click the Edit Options button if you wish to change the diagram properties. 
The General tab contains basic elements for the diagram, while the 
view-specific tab contains view-specific elements, such as line thickness 
and Subnet/Node Icons specification. Click OK when done editing to close 
the Edit Options dialog box and return to the DoDAF Visio Reports dialog 
box.
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Figure 3-78   DoDAF Visio Reports Edit Options

7) Click Run to generate the Visio diagram.

Import Scenario Scenarios > Import Scenario > (option) Import scenarios from the sources 
discussed below. 

Import Scenario >
Subordinate

Response

Scenarios > Import Scenario > Subordinate Response The Lead Planner 
imports subordinate response files from the Subordinate Planners into the 
original scenario. 

1) Open the original project (or the subordinate query file if you are an 
Intermediate Planner.) 

2) Select Scenarios > Import Scenario > Subordinate Response, and choose 
a response file received from a subordinate. The dialog box below displays. 
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Figure 3-79   Response File Information Dialog Box 

The edit area at the top of the dialog box will display the message that the 
Subordinate Planner entered when generating the response (this will 
contain the string "<none>" if the subordinate did not enter a message). The 
other edit area will display the hierarchical names of the units in the 

subordinate response that still have outstanding queries (once again this 
will contain the string "<none>" if there are no such units). These are shown 
to the Lead Planner because they are an indication that the response is an 
interim response. The Display list of changes during import checkbox 
controls whether or not the Changes dialog box will appear, as discussed 
later in this section. 

3) Click the Continue button to proceed with the import. During the import, if 
the subordinate has made any changes to external associations (links, 
satellite links, and broadcast networks that connect an editable unit to a 
locked unit), the Lead Planner will be given options to import or ignore the 
changes. This will be accomplished through a treeview dialog box that 
breaks down the different types of external associations according to the 
type of change (add, delete, or modify). 
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Figure 3-80   External Associations 

Items that are checked off will be imported, and unchecked items will be 
ignored. All items will be checked by default when the dialog box opens. 
Note that this dialog box will not appear if no changes were made to 
external associations. 

4) Proceed with the import by clicking the Continue button. If the Display list 
of changes during import checkbox was checked on the Message dialog 
box, the next step in the import process will be to display the Changes Made 
to the Original Scenario dialog box, which is shown below. 

Figure 3-81   Changes Made to the Original Scenario 
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Note that this dialog box will display directly after the Response File 
Information dialog box if there were no modifications to external 
associations. Otherwise, it will display after clicking the Continue button on 
the External Associations dialog box. The main feature of this dialog box is 
a treeview that displays all of the changes that will be made to the Lead 
Planner's scenario if the import is completed. For each object that was 
changed by the subordinate, the treeview lists whether it was added, 
deleted, or modified. If it was modified, you will be able to expand the entry 
to see more information about the modifications that were made. For most 
objects, this will be a list of the attributes that changed, along with the old 
and new values. However, organizations and OPFACs are more complex 
since they can have child objects. So, expanding one of those entries will 
show a listing of the types of child objects that were changed, and inside 
each of those will be more information about the exact changes that were 
made to the child objects. The above example shows how the individual 
changes within an organization can be viewed. 

a) The contents of the treeview can be exported to HTML by clicking the 
Export To HTML button. Clicking the Cancel Import button will stop the 
import process. 

5) Click the Continue button to perform the actual import. After the import is 
complete, a "Subordinate Response import complete" message will be 
printed in the message buffer. 

After this import process is repeated for each of the subordinate response 
files, the Lead Planner will have a consolidated view of the entire scenario 
based on the requirements specified by his subordinates. 

Import Scenario >
From

JCSS/NETWARS

Scenarios > Import Scenario > From JCSS/NETWARS Combine the 
organization structures of different scenarios automatically, thereby eliminating 
the need to duplicate another scenario's organization structure manually. The 
organization structure of the imported scenario is added to the top level of the 
current scenario. 

1) In the Import Scenario dialog box, select the scenario for which the 
organization structure is to be imported. 

2) Click Open. The newly added organization structure displays both in the 
treeview and in the workspace. 

Import Scenario >
From OPNET

Modeler

Scenarios > Import Scenario > From OPNET Modeler Import scenarios already 
developed in the OPNET Modeler and create the JCSS specific 
objects/hierarchy. The location information is intact in the newly created 
OPFACs and organizations. The new structure is below the newly created 
scenario to which the modeler scenario is imported. 

1) Create a new Scenario. 

2) Select Scenarios > Import Scenario > From OPNET Modeler. 
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3) In the subsequent Import Scenario from OPNET Modeler dialog box, select 
the scenario for which the organization structure is to be imported. 

4) When prompted to save OPFACs, click OK. Saving the OPFACs is 
necessary to reuse the OPFACs in other scenarios and to run simulation. 
The newly added organization structure displays both in the treeview and 
in the workspace. 

Import Scenario >
From XML

Scenarios > Import Scenario > From XML Import a scenario in XML format into 
JCSS. 

1) Create a new project (or start with an already existing project). Import 
Scenario > TNAPS to XML 

2) Choose Scenarios > Import Scenario > From XML. 

3) Select the XML file to be imported and then click Open to start the import 
process. At the end of this process, the scenario represented by the XML 
file has been imported into the current project. 

Import Scenario >
TNAPS to XML

Scenarios > Import Scenario > TNAPS to XML Convert a TNAPS file into an 
equivalent JCSS XML representation of the network. 

The converter reads transmission nodes, data network, circuit switch network, 
links, circuits, transmission node layout, site mux plan, site equipment inventory, 
mode and link properties/configurations, and ports. It does not read message 
switch network, local long circuits, unrouted circuits, circuits with sub-groups 
and sub-channels, and TNAPS annotations. 

1) Select Scenarios > Import Scenario > TNAPS to XML to run the TNAPS 
converter. The TNAPS to NETWARS Converter dialog box displays. 
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Figure 3-82   TNAPS to NETWARS Converter Dialog Box 

2) Select a TNAPS 6.0 file to open and an XML filename to which you want to 
save, and then click OK. 

The TNAPS file converts into XML, and a message box displays to inform 
you of its success. Click OK to close the message box. 

3) Now you can create a new project in the Scenario Builder and import the 
new XML file into it (select Scenarios > Import Scenario > From XML.) 

Export Scenario Scenarios > Export Scenario > (option): Export scenarios to the formats 
discussed below.

Export Scenario >
Subordinate Query

Scenarios > Export Scenario > Subordinate Query Export a subordinate query 
file and send it to Subordinate Planners to get the subscriber requirements. 
Various Subordinate Planners fill different portions of the scenario. The Lead 
Planner marks portions of the scenario to be editable by a Subordinate Planner 
by setting owner information on units. Units will be editable for the subordinate 
if the organization of the Subordinate Planner matches the organization field in 
the owner information. Otherwise, units will be locked; therefore, the Lead 
Planner must remember to set the correct owner information on units before 
exporting the subordinate query file.  

1) If the scenario contains any units that do not have owner information set, 
the planner will be warned and given a chance to set the owner information 
before the subordinate query file is created. The dialog box shown below 
contains un-owned units in the current scenario in a treeview format. 
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Figure 3-83   Unowned Units Dialog Box 

Double-click on a unit to set owner information, which will display the Set 
Owner dialog box. Expand the treeview on an organization and set owner 
on individual sub-units. Note that you can continue the export process with 
un-owned units in the scenario, however, those un-owned units will become 
locked to the Subordinate Planners. 

2) Specify a name for the subordinate query file, option to automatically send 
the subordinate query file via email, and the functional areas that will be 
available to the Subordinate Planner in the following dialog box. 

Figure 3-84   Export Subordinate Query File

The Lead Planner has the option in the dialog box to email the exported 
subordinate query to a recipient. If the email option is selected and the 
recipient's email address specified, not only is the file saved to the disk, but 
it is sent to the Lead Planner's default email application using MAPI. If the 
email application is configured for MAPI server support, an email message 
is created addressed to the recipient's email address with the subordinate 
query file attached to the email. Preview the message and click the Send 



3—Scenario Builder

JCSS/Release 10.0 JCSS-3-80

button. If the email application is configured for MAPI to automatically send 
the email, the email is sent without the preview option. Much of the behavior 
of MAPI is dependent on the particular email application and its MAPI 
configuration. If the auto-email option is not selected, send it to the 
Subordinate Planners by whatever means available, such as FTP or use a 
location on a shared network drive. 

3) Click OK; the subordinate query file is written to the disk and is located in 
<JCSS path>\User_Data\Projects\<current project>\<current 
phase>\Subordinate_Queries\. 

4) Save the project directly by clicking the Yes button. Once the subordinate 
query file has been generated, all units with yellow marked icons will 
change to an orange folder icon indicating that there's an outstanding 
query. 

Figure 3-85   Outstanding Query in a Scenario 

Export Scenario >
Subordinate

Response

Scenarios > Export Scenario > Subordinate Response Send the scenario back 
to the Lead Planner after the Subordinate Planner has elaborated the network 
and specified the subscriber requirements.

1) A check will be performed to see if there are any empty Requirements 
Matrix entries on any editable units. Any Requirements Matrix entries that 
have zero requested bandwidth and an empty answer field are considered 
to be empty. If there are empty entries, an alert dialog box as shown below 
will display.

Figure 3-86   Alert Dialog Box when Exporting Response 

This dialog box alerts the Subordinate Planner with a list of organizations 
and OPFACs that have at least one empty Requirements Matrix entry. 
Continue the export process or cancel the export. 
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2) If the Subordinate Planner clicks the Continue button, or if there were no 
empty fields, the Export Subordinate Response dialog box displays. 

Figure 3-87   Export Subordinate Response Dialog Box 

This dialog box serves three purposes: specify the save location for the 
response file, enter a message for the receiving planner, and email the 
response file.

3) To specify the save location, either type the full path in the Save Location 
field, or click the Browse button and choose the path from the resulting file 
chooser.

4) To enter a message for the receiving planner, type the message in the 
Message for the receiving planner field. The message will be shown to the 
receiving planner during the response import process.

5) To automatically email the response file that is generated, check the Email 
this response file checkbox and enter the destination email address in the 
Recipient email address field. If the recipient’s email address is specified, 
MAPI is used to create a new email message in the Subordinate Planner’s 
default email application. The subordinate response file is attached to this 
email. Depending on the MAPI configuration of the default email 
application, the email may or may not be previewed by the Subordinate 
Planner. Much of the behavior of MAPI is dependent on the particular email 
application and its MAPI configuration. If the auto-email option is not 
selected, send it to the Subordinate Planners by whatever means available, 
such as FTP or use a location on a shared network drive.

6) Click OK.

Export Scenario > To
XML

Scenarios > Export Scenario > To XML Export the contents of a scenario to 
XML. This allows for easy transfer of projects and scenarios between 
computers. The XML file is written to the folder that contains the scenario file. 
The exported XML file contains all the information in the scenario, except for 
some traffic information.
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Export Scenario > To
JNMS

Scenarios > Export Scenario > To JNMS Export the scenario to JNMS.

Export Scenario > To
Visio

Scenarios > Export Scenario > To Visio Export the scenario to Visio XML. A 
<scenario name>.vdx file is created in the scenario folder.

Network Difference
Report

Scenarios > Network Difference Report > (option) Use the network difference 
report to identify real-world network differences between two network scenarios, 
such as network protocol and device configuration. Network difference reports 
are useful when you want to know exactly how a network has evolved from one 
scenario to the next or how networks imported from different sources vary.

Network Difference
Report > Generate

Report

Scenarios > Network Difference Report > Generate Report Create a web report 
of the network topology changes between two scenarios.

Figure 3-88   Configure/Run Network Differences Dialog Box

• Report Title field—Specify the title for the report generated. 

• Current field—Indicates the name of the current project/scenario. 

• Previous drop-down lists—Specify the project/scenario that you want to 
compare to the current one. 

• Send report to Report Server checkbox—Select this to send this report to the 
Report Server specified in the user's report_server_name preference. This is 
disabled if no Report Server is specified. 

• Automation—Opens a dialog box to specify settings for reports generated by 
automation. This option is only available to users with Automation module 
licenses. 

• Run—Creates a web report of the network topology changes between the 
current and specified scenarios. 

• Cancel—Closes the dialog box without saving any changes. 

Network Difference
Report > Launch
Last Web Report

Scenarios > Network Difference Report > Launch Last Web Report Opens the 
last network difference report that you generated. 
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Network Difference
Report > Open

Network Difference
Log

Scenarios > Network Difference Report > Open Network Difference Log: Open 
the network difference log for the last network difference report that you 
generated.

Reports Scenarios > Reports > (option) Access the reports to view summary information 
in a table format. These options, as well as steps for working with these 
features, are discussed below. 

Reports > CCSD
Summary

Scenarios > Reports > CCSD Summary View a CCSD Summary report. 

Figure 3-89   CCSD Summary Report 
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Reports > Free-Text
Questions

Scenarios > Reports > Free-Text Questions View a summary report of free-text 
questions attached to organizations, OPFACs, and devices. This provides a 
mechanism for the planners to communicate with each other using free text. 
This is especially useful when a Subordinate Planner wants to communicate 
with a Lead Planner since the mission analysis question interface cannot import 
back new questions added by the Subordinate Planner. 

Figure 3-90   Free-Text Questions Report 

These questions and answers are stored as attributes on the objects and can 
be accessed by right-clicking on the object and selecting Edit Attributes and 
clicking the Value column next to the Free-Text Questions attribute. 

Figure 3-91   Free-text Questions Stored as Object Attributes 



3—Scenario Builder

JCSS/Release 10.0 JCSS-3-85

Reports > IP
Addresses

Scenarios > Reports > IP Addresses Examine the IP addresses for all 
connected interfaces on the devices. The IP Address Summary report contains 
the device name, interface name, IP address and subnet mask information. 
Buttons at the bottom of the table export the contents to an Excel file or to a 
HTML file, and print the contents to the default printer, respectively. You cannot 
edit any of the fields in this table. 

Figure 3-92   IP Address Summary Report 

Reports > Links Scenarios > Reports > Links View a list of all links in the scenario along with 
some of the key attributes like name, bandwidth, type of link, etc. Buttons at the 
bottom of the table export the contents to an Excel file or to a HTML file, and 
print the contents to the default printer, respectively. 

Figure 3-93   Links Summary Report 

Reports >
Requirements

Scenarios > Reports > Requirements View a summary report of the bandwidth 
requirements for all the organizations in the scenario. When this table is 
launched, there is one row for every top-level organization in the scenario. Each 
row has the name of the organization followed by the required bandwidth for 
each service type. The default functional area is Voice. 

1) View the requirements summary for a different functional area by clicking 
on the appropriate button. 
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Figure 3-94   Requirements Summary Report 

a) Click on the organization name to view its sub-organizations examine a 
breakdown of the bandwidth requirement for each sub-organization. 

b) Export the contents of the table to an Excel spreadsheet, to HTML, or 
send it directly to a printer. 

Reports > SLD
Summary

Scenarios > Reports > SLD Summary View a list of all SLDs in the scenario 
along with some of the key attributes like name, location, equipment, etc. 
Buttons at the bottom of the table export the contents to an Excel file or to a 
HTML file, and print the contents to the default printer, respectively. 

Figure 3-95   SLD Summary Report

Reports >
User-Defined

Reports

Scenarios > Reports> User-Defined Reports > (option) Select from these 
options to open user-defined reports in live mode, and specify the content you 
want to include in your reports. 
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Reports >
User-Defined

Reports > Open Live
Report Table...

Scenarios > Reports> User-Defined Reports > Open Live Report Table... Open 
one or more user-defined report tables in live mode. This means the tables will 
not only show the corresponding values given the current selection set, but will 
also automatically repopulate themselves whenever the selection set changes. 
This provides a quick way of surveying the relevant attributes of a number of 
network objects without generating a full report and searching for the rows of 
interest. It can also sometimes be more handy than, for example, opening the 
Edit Attributes dialog box for each of the objects of interest. 

Note—This functionality is supported independently of the Generate Report 
from Template... functionality, so it will neither create a new report nor discard 
any existing report information. 

1) Select Scenarios > Reports> User-Defined Reports > Open Live Report 
Table... The Live User-Defined Report Tables dialog box displays. 

Figure 3-96   Live User-Defined Report Tables Dialog Box 

2) Expand the top-level category subtree and left-click on the desired table 
entry to select it for opening. You can select multiple tables by holding down 
the <Ctrl> key while left-clicking or by clicking-and-dragging a rectangular 
selection. Selecting a top-level category tree row itself does not imply 
selecting all or any of its tables; it is simply ignored. 

3) Click Show to build and open individual user-defined report table dialog 
boxes for each of the tables you have selected. Click Close to close this 
dialog box but not any of the user-defined report tables you might have 
opened. 

Reports > Generate
Report from
Template...

Scenarios > Reports> User-Defined Reports > Generate Report from Template...
Specify the content you want to include in your report.

1) Select Scenarios > Reports> User-Defined Reports > Generate Report 
from Template... The Generate User-Defined Report dialog box displays.
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Figure 3-97   Generate User-Defined Report Dialog Box

2) Specify which tables of which categories should be included in the report 
by selecting them in the treeview. To select an entire category of tables, 
left-click on the top-level category entries. To select an individual table, 
expand the top-level category subtree and left-click on the table entry. 
Selected tables and categories show a green check mark. Categories with 
some but not all of its tables selected will display a green dot instead. 

3) Click the Include only selected objects in report checkbox if you want table 
data to be collected only for objects that are currently selected in the 
network. 

4) Click the Ignore views checkbox if you want table data to be collected even 
for objects that are not in the current view or views of the network. 

5) Click the Send reports to the Report Server (<host>) checkbox if you want 
to send reports to the Report Server. This option is active only when a 
Report Server license is available. 

a) Specify a name for the report in the Report Server in the Report name 
as it will appear on the Report Server text field. 

6) Click Generate to generate the table data for all of the selected tables. Your 
content settings are saved and will be reloaded the next time you generate 
a report.

7) Click Close to close this dialog box but retain any table selections.
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Object/Attribute
Difference Report

Scenarios > Object/Attribute Difference Report > (option) Use the 
object/attribute difference report to identify differences between two networks 
that you want to compare. 

Object/Attribute
Difference Report >

Generate Report

Scenarios > Object/Attribute Difference Report > Generate Report Specify the 
networks that you want to compare, and generate an object/attribute difference 
report. 

1) Select Scenarios > Object/Attribute Difference Report > Generate Report. 
The Generate Object/Attribute Difference Report dialog box displays. 

Figure 3-98   Generate Object/Attribute Difference Report Dialog Box

2) Compare the active project and scenario to drop-down menus—Specify 
which project and scenario to use when generating the report. Begin by 
selecting a project from the Project drop-down menu, and then use the 
Scenario drop-down menu to choose the scenario. The selected scenario 
is always compared to the currently active scenario. 

3) Specified project, and the scenario with given base name that was created 
checkbox—Indicates that the scenario should be chosen based on the 
specified name and the date the scenario was created. If the checkbox is 
not selected, the scenario is chosen based on the name chosen in the 
Scenario drop-down menu. This option is available only to users with an 
Automation module license. 

4) Most recently radio button—Indicates that the most recent version of the 
scenario should be used for the comparison. This option is available only to 
users with an Automation module license. 
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5) At least radio button—Indicates the version of the scenario that should be 
used for the comparison. OPNET will select the scenario that was created 
some specified time period ago. The time period can be expressed in days 
or weeks. For example, if a user sets the time period to 1 week, OPNET will 
choose the version of the scenario that was created 1 week before the 
difference report generation began. This option is available only to users 
with an Automation module license. 

6) Difference behavior file drop-down menu—Specify the behavior file that 
should be used when generating the report. Behavior files control which 
objects and attributes are included or omitted when comparing the two 
scenarios. To view a behavior file, select Scenarios > Object/Attribute 
Difference Report > Define Report. 

7) Place output in—Specify where the report will be saved. 

8) Browse button—Opens a browser, which allows you to choose where the 
report will be saved. 

9) Send reports to the Report Server checkbox—Indicates that the report will 
be sent to the Report Server specified in the user's report_server_name 
preference. 

10) Report name as it will appear on the Report Server—Specifies the name of 
the report as it will appear on the Report Server. The special value < project 
> will be replaced with the actual project name when the report is published. 
Similarly, < scenario > will be replaced with the name of the scenario used 
to generate the report. 

11) Automation button—Saves the current settings to an automation file that 
may be used when creating automation tasks. This option is available only 
to users with an Automation module license. 

12) Load button—Loads the settings from a previously saved automation file. 
This option is available only to users with an Automation module license. 

13) Generate button—Generates the report. 

14) Cancel button—Closes the dialog box. 

Object/Attribute
Difference Report >

Define Report

Object/Attribute Scenarios > Object/Attribute Difference Report > Define Report
Specify the Difference Report content you want to include in your 
object/attribute difference report. 

1) Select Scenarios > Object/Attribute Difference Report > Define Report. The 
Define Object/Attribute Difference Report:unnamed dialog box displays. 
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Figure 3-99   Define Object/Attribute Difference Report Dialog Box 

2) Select objects to compare, and specify objects to exclude by identifying 
specific attributes to ignore. 

3) Click Save As to save your report definition to a file for repeat use. 

4) Click Generate. The Generate Object/Attribute Difference Report dialog 
box displays. In the Generate Object/Attribute Difference Report dialog 
box, click Generate to generate the report. 
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Object/Attribute
Difference Report >

View Last Report

Scenarios > Object/Attribute Difference Report > View Last Report Opens the 
last object/attribute difference report that you generated in an Object/Attribute 
Difference Tree dialog box.

Figure 3-100   Object/Attribute Difference Tree Dialog Box 

Object/Attribute
Difference Report >

Launch Last Web
Report

Scenarios > Object/Attribute Difference Report > Launch Last Web Report
Opens the last object/attribute difference report that you generated in a web 
browser. 

Live Object/Attribute
Difference

Scenarios > Live Object/Attribute Difference> (option) The Live Object/Attribute 
Difference view option is a visualization mode that uses icons to identify 
changes in a network scenario and in individual objects. Use the Live 
Object/Attribute Difference option to identify and track: 

• Object/Attribute Differences—Includes differences between the current 
scenario and a reference scenario, changes to the current scenario since the 
last saved, and future changes to the current scenario (Track Changes from 
Now operation.) 

• Object Differences—Includes attribute changes that differ from an object's 
creation defaults, and 

• Text Differences—Includes text object changes, such as an annotation or a 
text-based attribute. 

When Live Object/Attribute Difference mode is enabled, the current scenario is 
compared with a reference scenario. The reference scenario is one of the 
following, depending on the view mode: 

• A separate scenario (Compare to Network or Compare to Scenario) 

• A previous state of the current scenario (Track Changes from Last Save or 
Track Changes from Now) 
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The workspace and the Network Browser mark changed objects in the network 
and show icons to identify:

• Objects with relevant differences—You can specify the criteria used to 
determine a “relevant difference” between two objects.

• Objects with no counterparts—An “object with no counterpart” is an object 
that exists in the current scenario only, and has no corresponding object in 
the reference scenario.

• Subnets with changed objects—If any object in a subnet has changed, an 
icon appears over the subnet.

• Subnets that contain objects with no counterparts.

• Objects with no relevant differences—These icons appear only when you 
compare two scenarios, not when you track changes in one scenario.

Select from the available Scenarios > Live Object/Attribute Difference options to 
specify object/attribute difference behavior, stop comparing, set global 
preferences, select and reconcile objects, track changes, and compare 
networks or scenarios.

Live Object/Attribute
Difference > Specify

Behavior

Scenarios > Live Object/Attribute Difference > Specify Behavior Specify the 
criteria used to define object/attribute differences. You can exclude irrelevant 
object types and attributes from the comparison and thereby track differences 
of interest only. 

1) Select Scenarios > Live Object/Attribute Difference > Specify Behavior. 
The Specify Live Object/Attribute Difference Behavior dialog box displays. 

Figure 3-101   Specify Live Object/Attribute Difference Behavior Dialog Box 

2) In the Objects to Compare section, select objects of interest to compare. 
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3) In the Attributes to Ignore During Comparison section, specify attributes to 
ignore: 

a) Ignore all non-modeling attributes checkbox-Ignore attributes that do not 
affect discrete event simulation or Flow Analysis results (examples: 
"color", "line style", "creation source".) 

b) Ignore position attributes checkbox-Ignore attributes that specify 
physical locations of objects (examples: "x position", "y position", 
"trajectory".) 

c) Ignore transmitter and receiver attributes checkbox-Ignore attributes 
specific to wireless objects (examples: "channel", "ragain model", "ber 
model".) 

4) In the Ignore specific attributes table, ignore specific attributes during the 
comparison. Ignored attributes are excluded from the final report. In 
addition, these attributes are ignored when comparing the same object 
between scenarios. 

5) Click Load to load difference settings from a template file. 

6) Click Save As to save your difference settings to a template file for repeat 
use. 

7) Click OK to close the dialog box. 

Live Object/Attribute
Difference > Stop

Comparing

Scenarios > Live Object/Attribute Difference > Stop Comparing Turn off Live 
Difference mode and clear all difference visualizations from the workspace. 

Live Object/Attribute
Difference > Global

Preferences

Scenarios > Live Object/Attribute Difference > Global Preferences > (options):
Specify global preference settings for Live Object/Attribute Difference. Choose 
from the following options: 

• Suppress Legend—Specifies whether to display the legend that appears in 
the lower-left corner of the workspace while Live Object/Attribute Differences 
is active. The legend describes the active tracking mode and meaning of 
each icon used to mark the various network objects. 

Note—This operation sets the network_diff.suppress_live_legend preference. 

• Use Icons in Workspace and Browser, Use Icons in Workspace Only, or Use 
Icons in Browser Only—Specifies where to use the icons for Live 
Object/Attribute Differences.

Note—This operation sets the network_diff.live_icon_use preference. 
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Live Object/Attribute
Difference > Select

Objects With
Differences

Scenarios > Live Object/Attribute Difference > Select Objects With Differences
Select all objects, in all subnets, that are marked as changed. A subnet object 
is selected only if it has relevant attribute changes.

Live Object/Attribute
Difference > Select

Objects Only in This
Network

Scenarios > Live Object/Attribute Difference > Select Objects Only In This 
Network Select all objects, only in this network, that are marked as changed.

Live Object/Attribute
Difference >

Reconcile Selected
Object Differences

Scenarios > Live Object/Attribute Difference > Reconcile Selected Object 
Differences Reconcile differences for all objects that meet the following 
conditions:

• Are currently selected, or reside within a selected subnet

• Have counterparts in the reference scenario

In this case, “reconcile differences for an object” means that all relevant settings 
for the current object are set so that it becomes equivalent to its counterpart in 
the reference scenario. 

If a subnet is selected, this operation reconciles all objects in that subnet that 
have counterparts in the reference scenario. 

You can undo and redo this operation using the corresponding operations in the 
Edit menu.

Live Object/Attribute
Difference > Track

Changes From
Object Defaults

Scenarios > Live Object/Attribute Difference > Track Changes From Object 
Defaults Track all attribute settings that differ from the creation defaults for an 
object. The "creation default" settings for an object are the initial settings of an 
object when it is created manually (for example, by dragging from the object 
palette). 

Note—This view mode marks changes in an object's Attributes dialog box only, 
not in the workspace. 

Live Object/Attribute
Difference > Track

Changes From Last

Scenarios > Live Object/Attribute Difference > Track Changes From Last Save:
Track past changes in the current scenario (since the last time the project was 
saved). 

Live Object/Attribute
Difference > Track

Changes From Now

Scenarios > Live Object/Attribute Difference > Track Changes From Now: Track 
future changes in the current scenario.

Live Object/Attribute
Difference >

Compare to Network

Scenarios > Live Object/Attribute Difference > Compare to Network: Compare 
the current scenario to a scenario in a different project.
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Live Object/Attribute
Difference >
Compare to

Scenario

Scenarios > Live Object/Attribute Difference > Compare to Scenario: 
<scenario_name> Compare the current scenario to a scenario in the same 
project.

Model
Completeness

Analysis

Scenarios > Model Completeness Analysis > (option) Configure and run a 
Model Completeness Analysis.

The Model Completeness Analysis is an option that you can specify during or 
after import, which can be used to validate configuration information that you 
import from VNE Server. The reports produced by Model Completeness 
Analysis can help you assess your imported model before you go on to perform 
other analyses.

Note—This manual does not discuss in detail how to use and understand Model 
Completeness Reports. The discussion is limited to general workflow from the 
JCSS point of view. Consult the IT Guru documentation set, available via Help 
> Documentation > IT Guru Documentation, for complete details.

Model
Completeness

Analysis > Generate
Report

Scenarios > Model Completeness Analysis > Generate Report Run an analysis 
and generate a Model Completeness Report.

The Model Completeness Analysis is based on tests, contained in templates, 
that are applied to the network model. A default template is included in JCSS, 
but you can customize it or create new templates.

The report will launch in a web browser and will be sent to your Report Server, 
if so configured.

Model
Completeness

Analysis >
Configure/Run

Model Scenarios > Model Completeness Analysis > Configure/Run Select a 
template to run.

Figure 3-102   Run Model Completeness Analysis Dialog Box 

• Report Template drop-down list—Select from a list of available predefined 
templates to run the Model Completeness Report.

• Report title field—Specifies the title for the reports generated for the current 
template.

• Send report to Report Server:—Select this checkbox if you want to send this 
report to the Report Server defined in your installation.
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• Automate—Saves settings for automation.

• Advanced—Opens the advanced dialog box, which lets you specify more 
options or create and save new templates.

• Run—Saves the current template and runs the Model Completeness Report. 
Launches report after execution completes.

• Cancel—Closes the dialog box without saving any of the information you 
entered. Prompts you to confirm the cancel operation if template settings 
have changed since loading.

Generate Network
Inventory Summary

Scenarios > Generate Network Inventory Summary: Launch a Network Inventory 
Summary report. After an import, and on a periodic basis, you may want to see 
how many devices are in your network and of what type. If you have a rather 
small imported network model, it is a simple task to visually gather this 
information. For larger networks, however, it is a time-consuming, error-prone 
task to take inventory. The Network Inventory Summary report is available at 
any time after an import. Running a Network Inventory Summary report after an 
incremental import allows you to keep your inventory files up-to-date.

1) Choose Scenarios > Generate Network Inventory Summary. The Network 
Inventory Summary dialog box displays. 

Figure 3-103   Network Inventory Summary Dialog Box 

The report includes: 

a) Devices—A total count of devices, and a breakdown by device type.

b) Vendors—A count by vendor. 

c) Physical Links—A total count of physical links, and a breakdown by type.

d) Virtual Links—A total count of virtual links, and a breakdown by type.
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e) Other—A total count of other types of devices in the model, including 
network clouds, application models, configuration utilities, etc. 

2) If a count listing is in blue text, you can click it to drill down even further. 

3) To export the report to a spreadsheet, ASCII file, web report, or XML, 
choose File > Export > (option) in the Network Inventory Summary dialog 
box. Exporting the report makes it easier to use the information for analysis, 
management reporting, and other requirements. 

Generate Scenario
Web Report

Scenarios > Generate Scenario Web Report Choose the location where you 
Web Report want to save the scenario web report, and then generate the report. 

Figure 3-104   Generate Scenario Web Report Dialog Box

Click Generate to create the scenario web report. Navigate to the folder in which 
you saved the web report, and open it in your chosen web browser. 

Figure 3-105   Displaying Scenario Web Report in Web Browser 
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Generate Scenario
Bitmap

Scenarios > Generate Scenario Bitmap Export a bitmap image of the model in 
the active window and set parameters of the export file.

Figure 3-106   Model Image Capture Preview Dialog Box 

Use the bitmap image controls to set the elements of the bitmap: 

• Image width—Lets you set the bitmap width using the up and down arrows. 
The height is adjusted accordingly. 

• Capture visible area only—Captures only the area visible in the editor 
window. When unselected, the entire subnetwork or model is captured. 

• White background—Sets the bitmap background color to white, which 
improves contrast and visibility. 

• Scale image directly—Sets the bitmap to the same level of detail as seen in 
the editor, regardless of the bitmap size. 

• Adjust resolution—Adjusts the level of detail based on the target bitmap size, 
that is, reduces the level of detail in smaller bitmaps and increases detail in 
larger ones. 

Click Save to open the Select Captured Image Location dialog box, and select 
the directory to which the bitmap file is saved and name the file. Click Close to 
close the Model Image Capture Preview dialog box. 
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View Associated
Output Tables

View Associated Scenarios > View Associated Output Tables Select output 
table files to view Output Tables in the Results Browser. 

Figure 3-107   Select Output Table Files to View Dialog Box 

Click View, and the Results Browser displays your generated results. The 
Results Browser is used to view simulation and analysis results and to perform 
parametric studies. With the Results Browser, you can use any collected 
statistics available on your computer to create new graphs, add statistics to 
existing graphs, or view tabular results. 

In the Results Browser, click Generate Web Report to send your results to a 
Web Report. 

Topology Menu

Open Object Palette Topology > Open Object Palette or click the Open Object Palette toolbar button 
to access object palettes. JCSS provides a variety of object palettes which 
contain nodes, devices, links, and paths (circuits.) Once a new project is 
created, start building the network topology using the models provided in the 
object palettes. All of these objects are easily added to a scenario using the 
drag-and-drop technique.
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Displaying Object Palettes 

The object palettes display in either a treeview style or an Icon view style, 
depending upon how your environment preferences are set. 

Figure 3-108   Object Palette by Treeview

In the Object Palette Tree view, click the Open Palette In Icon View icon button 
(upper left corner) to replace this dialog box with the Object Palette Icon view 
that displays only a single palette file at a time. The palette file initially displayed 
will be either the default palette of the scenario or, if the tree selection is within 
a particular palette file tree element, the palette that contains the current tree 
selection. 

Figure 3-109   Object Palette by Icon View 
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Note—The view style in which the object palettes display changes based on the 
value specified for the network_palette.style environment preference. You may 
set the object palette view style preference via Edit > Preferences > Advanced. 

Adding Objects to a Scenario 

Adding an instance of a device model to a network (from either style object 
palette) is as simple as dragging an icon to the workspace. 

1) Select and drag an icon from the palette to the workspace to create a new 
object. The newly created object in the network is an instance of the 
corresponding model. 

Whenever possible, planners are encouraged to use the JCSS standard 
models as opposed to the more generic models contained in the other 
model palettes. The JCSS models are designed to gather specific 
Measures of Performance (MOPs), which will be useful when modeling the 
network at a later point. 

Note—JCSS device models must be used as endpoints for sending and 
receiving traffic. If generic device models are used as endpoints, JCSS will not 
be able to produce the traffic. 

2) Once you drag an icon from the palette to the workspace, you may continue 
creating objects of the same type and model by clicking again in the 
workspace as needed. 

3) Right-click in the workspace to stop creating new objects. 

Some object types, like paths and demands, use a right-click menu during 
the creation process. In those cases, you should pick the appropriate menu 
operation to complete or cancel the object creation. 

4) Right-click a device icon in the workspace, and open a shortcut menu to set 
the name of the device or set different model attributes that influence the 
behavior of the model. Device attributes can be changed by clicking on a 
cell and typing or selecting a new value. 
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Using Dynamic Listing Option for Object Palettes 

The software provides you with the option of displaying the object palettes in two 
modes: alphabetical or dynamic. In alphabetical mode, the palettes display in 
alphabetical order; in dynamic mode, the five most recently used object palettes 
display at the top followed by the alphabetical listing. 

Figure 3-110   Dynamic Palette Listings Mode

The order in which the palettes display changes based on the value specified 
for the palette_listing environment preference. You may set this preference via 
Edit > Preferences > Advanced. 

Configuring Custom Palettes 

1) Click the Configure Palette button located at the upper-right corner of an 
Object Palette Icon view dialog box. The Configure Palette dialog box 
displays. 

Figure 3-111   Configure Palette Dialog Box 

2) Click the appropriate Models button to add or remove specific models or 
units from the palette. 
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3) Toggle the Status column to either included or not included to add or 
remove models units from the palette. To conclude, click OK, specify the 
name of the palette in the Save As dialog box, and then click OK to save 
the new configuration. 

Figure 3-112   Select Included Entries Dialog Box 

Open Library
Treeview

Topology > Open Library Treeview Add Organizations and OPFACs to 
scenarios by dragging and dropping them from the Library Treeview onto the 
Scenario Builder window.

Figure 3-113   Library Treeview

Open Annotation
Palette

Topology > Open Annotation Palette Add graphic elements to a scenario to help 
organize it visually or call attention to key elements. The annotation palette 
includes five types of objects: Box, Ellipse, Line, Text, and Icon. 

1) Click on the desired annotation object in the annotation palette. 
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Figure 3-114   Annotation Palette 

2) Create

a) A box or an ellipse by dragging an outline of the shape in the workspace.

b) A line by clicking in the workspace for the start of the line and each 
vertex (direction change) and then double-clicking to end. 

c) Text by clicking on the workspace where the text is to be inserted, and 
then entering text in the text edit pad that displays. 

d) An icon annotation by clicking in the workspace where you want the 
annotation to appear. To specify the icon to use, right-click on the 
annotation object and choose Edit Attributes; then set the "icon name" 
attribute. You can specify an icon from any icon database included in 
your model directories. 

3) When you have finished creating an annotation object, you can: 

a) Click to define another box, ellipse, line, or icon. 

b) Right-click to stop creating boxes, ellipses, lines, or icons. 

c) Click in the annotation palette to create a different type of annotation. 

4) Modify the annotation object's attributes to customize its appearance. 
Select the object, and then right-click and select Edit Attributes to display 
the Attributes dialog box and make your changes. 

Adding an annotation object does not affect a scenario's functionality in 
any way. 

Import Topology > Import > (option) Import various files relating to topology. The 
following import options are discussed in the sections below: 

• From Device Configurations 

• From VNE Server 

• Circuits

• Link Specification 

• From Configlets 

Import > From
Device

Configurations

Topology > Import > From Device Configurations Device Imports (DCI) lets you 
generate a network model by importing configuration 
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Configurations data for Juniper routers, Cisco routers, and Cisco Catalyst 
switches. DCI uses the data in the configuration files to set the OPNET 
attributes that control routing and switching behavior. 

OPFACs that are created as part of the import process will house a single 
device; the icon of that OPFAC will be same as the icon of the device inside. 

Note—This section does not discuss in detail how the device configurations are 
converted to the network topology from the OPNET core software point of view. 
The discussion is limited to general workflow from the JCSS point of view. 
Consult the IT Guru documentation set, available via Help > Documentation > 
IT Guru Documentation, for complete details. 

1) The device configuration files can be imported in a new scenario or on top 
of an existing scenario. To perform a new import, create a new project. If 
you want to import these files on top of an existing network and then 
selectively add the various imported components to this network, open the 
relevant project. 

2) Select Topology > Import > From Device Configurations. The Import Device 
Configurations dialog box displays. 

Figure 3-115   Import Device Configurations Dialog Box 

3) Select how this import affects the existing topology (if one exists): 

a) Replace entire model radio button—Use this option when creating a new 
project or scenario, or when you want to overwrite the existing topology. 
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b) Merge with existing model radio button—Use this option to add devices 
to the existing topology. If some of the devices are already in the 
topology, these devices are replaced (that is, re-imported) using the 
configuration files of this import. The Mapping Editor displays upon 
import so that users can map devices to the current network. 

c) Reimport configurations for selected devices radio button—Select this 
option to reimport the device configuration files of the nodes that are 
currently selected in the workspace. DCI imports the files from the same 
location specified in the original import. 

d) Reimport configurations for modified devices radio button—Select this 
option to reimport any device configuration files in the current topology 
that were modified since the last import. DCI imports the files from the 
same location specified in the original import. 

4) Specify where the configuration files are located by vendor(s), directory 
path and whether to include subfolders in this directory path table. If you 
previously imported device configuration files, your previous selection is 
configured; you can keep the selection or change it. Multiple directories are 
supported. 

5) Select the desired import options: 

a) Create nodes to represent external ASes—Creates dummy objects to 
represent missing external BGP (EBGP) neighbors. 

b) Create nodes to represent edge LANs—Creates LAN objects for active 
router interfaces that are not connected. By connecting these interfaces 
to LAN objects, no active router interfaces are left unconnected after the 
import. 

c) Create PVCs—Creates PVCs based on network data, if available; if this 
is not available, PVCs are created for all possible pairs of devices in the 
network. 

d) Generate import log—Creates a log of actions during the import. You 
can access the log through the object or workspace pop-up menus after 
the import. 

6) Specify one or more model assistant files. These files can be model 
assistant files, which have a .ma extension, or import assistance files, 
which have an .ia extension. Consult the IT Guru documentation set, 
available via Help > Documentation > IT Guru Documentation, for 
information about model assistant files. 
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7) Click Import. During the import process, various nodes can be created by 
the core DCI process for the end devices. The following table lists the 
corresponding JCSS models that will be created:. 

8) If the Merge with existing model import option was selected, the Node Map 
Editor displays. 

Figure 3-116   Node Map Editor Dialog Box 

a) Add—Adds a node (router) from the imported network to the original 
network. Successful addition of the node requires that you select a node 
in the Source Network treeview and an OPFAC/organization in the 
target network before the addition can be performed. 

Table 3-3   DCI And JCSS End Station Models 

DCI End Station Models JCSS End Station Models

ppp_wkstn_adv nw_ppp_wkstn_adv

10BaseT_LAN nw_ethernet_wkstn_adv

100BaseT_LAN nw_ethernet_wkstn_adv

1000BaseX_LAN nw_ethernet_wkstn_adv

fr_wkstn_adv No current support

atm_wkstn_adv No current support

16TR_LAN No current support

FDDI_LAN No current support
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b) Assign—Assigns or map a node (router) from the imported network to 
the original network. Successful assignment of the node requires that 
you select a node in the source network treeview and another node in 
the target network before the addition can be performed. 

c) OK—Closes the mapping editor dialog box and performs any link 
creation as necessary. 

d) Cancel Import—Cancels any changes made to the network due to 
mapping or assignment and brings you back to the original scenario. 

e) Auto-Mapping Feature—Performs the mapping if router configuration 
files have been previously imported into this scenario. The Perform 
Auto-Mapping dialog box displays to confirm the mapping of the nodes 
based on the mapping performed in the previous imports. 

Figure 3-117   Perform Auto-Mapping 

f) Manual or Auto—Continues with the auto mapping or manual mapping. 
The main dialog box for the node mapping will still display allowing you 
to map any nodes that were not mapped as part of the auto-mapping 
operation. 

g) Cancel Import—Cancels the import procedure. 

Import > From VNE
Server

Topology > Import > From VNE Server Create a network model based on 
information imported from VNE Server. 

1) Choose Topology > Import > From VNE Server. The Import from VNE 
Server dialog box displays. 

Figure 3-118   Import from VNE Server Dialog Box 

2) Specify the name of the VNE Server from which you want to import, and 
then click OK. A second Import from VNE Server dialog box displays. 

3) In the VNE Server Name field, specify the hostname or IP address and port 
for the VNE Server. 

a) If you are running import on the same machine as the VNE Server, use 
"localhost" as the server name. 
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b) If the VNE Server is in the same domain in which you are running import, 
enter the hostname without domain extension or enter the IP address of 
the VNE Server.

c) If the VNE Server is in a different domain, enter the server name as 
hostname.domain, i.e. vneserver.opnet.com, or enter the IP address of 
the VNE Server. 

d) The default port number is 900. If you are importing from a VNE Server 
installed on Linux, change the port number to 3001. If you are importing 
from VNE Server on any port other than 900, enter the server name as 
hostname:port (or hostname.domain:port) or IP address and port (i.e., 
ip_address:port). 

4) Specify the import mode you want to use: 

a) Create network using VNE Server data radio button—Use when starting 
a new scenario or when you want to erase all existing information in the 
current model to replace with VNE Server data. If selected, the current 
VNE Server data is used to create a network model. "Create" appears if 
you are in a new scenario; "Replace" appears if you are in an existing 
scenario. 

b) Incrementally update network using the most recent VNE Server data 
radio button—Use when you want to update the current model with any 
changes that have occurred in VNE Server since the last import. If 
selected, VNE Server updates the current network model with all 
recorded changes in VNE Server since the original import. 

c) Create network using an existing archive radio button—Use when you 
want to replace the current model with information contained in a VNE 
Server archive file. If selected, a network model is created using the 
archived network specified in the drop-down menu. This menu is 
populated based on available archives from VNE Server. 

5) On the Options tab, specify the import options as follows: 

a) Include collected configuration files checkbox—Gathers the 
configuration files of the devices to be imported along with all other 
import data. When this option is used, you can right-click on any 
imported node for which a configuration file exists and select View 
Device Configuration Source Data. 

b) Append operational data checkbox—When you include collected 
configuration files, you can also choose to append the operational data. 
This lets you append operational data to the configuration file collected 
by VNE Server in the import. The operational data can include CDP data 
and other data that can be used in a subsequent import using Device 
Configuration Import. 

c) Generate import log checkbox—Creates a log of actions during the 
import. You can access the log through the object or workspace pop-up 
menus after the import. 
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d) Generate Model Completeness Report checkbox—Runs a Model 
Completeness Report on the imported model based on the last template 
you used. If you have never generated a Model Completeness Report, 
the default template is used. 

e) Use the following model assistant file(s) checkbox and list box—Choose 
model assistant files that specify certain import-related information (i.e., 
data rates, connectivity). 

6) On the Topology tab, specify topology-related import options as follows: 

a) Group nodes into subnets (based on VNE Server groups) 
checkbox—Uses the VNE Server groups to create node grouping, in 
subnets, in the imported model. 

b) Create tunnel based connections checkbox—Infers logical tunnel clouds 
based on tunnel end-point information when there is no physical path 
inferred 

c) Create nodes to represent external ASes checkbox—Creates dummy 
objects to represent missing external BGP (EBGP) neighbors. 

d) Create nodes to represent edge LANs checkbox—Creates LAN objects 
for active router interfaces that are not connected. By connecting these 
interfaces to LAN objects, no active router interfaces are left 
unconnected after the import. 

e) Filters—Specify the amount of data to include in the import. 

7) On the Traffic tab, traffic that is available from the VNE Server is displayed, 
such as link loads or flows. Specify traffic-related import options as follows: 

a) Include?—Click on the value in this column to enable or disable the 
inclusion of the available traffic data. 

b) Traffic type—Displays the available traffic type you can configure in this 
row. 

c) Traffic information—Displays the available traffic information gathered 
from the VNE Server. 

d) Modify?—Click on "Edit..." in this field to open the Rollup Configuration 
dialog box. Customize the way in which you want to rollup the available 
information, depending on what exists in VNE Server. 

8) On the Metrics tab, performance metrics, CPU utilization, and RAM 
utilization data for the following device types are available and can be 
configured when the data is collected on the VNE Server: 

— Acme Packet Net-Net 4000 Session Border Controllers (SBC) 

— Cisco devices using IOS and IOS XR 

9) Click Import. 
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Import > From
Circuit Switch Text

Files

Topology > Import > From Circuit Switch Text Files Import circuit information 
from a tab-delimited text file. Depending on the information contained in the file, 
the import process may do one of the following:

• All circuit switch data files use the following formatting conventions:

• Each line in the file describes one node, trunk link, or call.

• The attributes in each line are separated by tabs.

• The import process ignores any line beginning with a number sign (#).

1) Select Topology > Import > From Circuit Switch Text Files. The following 
dialog box appears.

Figure 3-119   Import from Circuit Switch Text Files

2) To specify a data file, click the Browse button for the corresponding file, 
then specify the directory and file in the Select File dialog box. Alternatively, 
you can type a path directly into the edit field.

3) Click OK to import the entries. Your circuit switch data is imported, a 
network topology is created, and the relevant attributes are set in the 
nodes, links, and call demand objects. The import process is complete

Import > Link
Specification

Topology > Import > Link Specification Import link information from text files. 
The link specification is separated into two sections—the JCSS attributes and 
the standard OPNET attributes. If a link with the specified hierarchical name 
already exists in the scenario, the changes are applied to the existing link. If 
there are no links with the specified hierarchical name, a new link is created with 
the specifications provided in the text file.

Import > From
Configlets

Topology > Import > From Configlets Import topology from configlets 
(configuration files.) Only those devices which have configuration files 
associated with them can be re-imported via this feature.

Export Topology > Export > (option) Export various file types relating to topology.
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Export > Circuits Topology > Export > Circuits Export information about all circuits in the 
scenario to a tab-delimited file. JCSS examines all devices in the scenario that 
have circuits defined and writes the circuit information to a text file in the project 
directory with the following naming convention: 
<project>-<scenario>-circuits.txt.

Each section of the text file starts with a circuit_type field, followed by a field 
listing the name of the circuit type. The sections of the file are sorted by circuit 
type.

Export > To
Spreadsheet

Topology > Export > To Spreadsheet Export the topology to a spreadsheet.

Export > To Visio Topology > Export > To Visio Export showcase(s) and subnet(s) to Visio .vdx 
(Visio XML drawing) format files.

Figure 3-120   Export to Visio Dialog Box 

• Subnets drop-down list—Specify the subnet(s) to export. Choose one of the 
following: None, Current subnet, or All subnets. 

• Showcases drop-down list—Specify the showcase(s) to export. Choose one 
of the following: None, Current showcase, or All showcases. 

• Generate user-defined tables checkbox—Specify whether to export 
user-defined tables for generating reports. 

• Page Layout—Specify the page layout orientation and size. Choose one of 
the following: 

— Portrait radio button—Specifies 8.5 x 11 inches. 

— Landscape radio button—Specifies 11 x 8.5 inches. 

— Custom radio button—Specifies a custom size. When selected, specify 
the height and width.

• Launch Visio on export checkbox—Specifies to open the exported file 
automatically after exporting a file.
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• Export button—The Export file selection dialog box displays to specify the file 
name, type (.vdx or .vsx), and the location for the file.

• Cancel button—Closes the dialog box without saving any changes.

Export > To Network
Whiteboard

Topology > Export > To Network Whiteboard Export showcase(s) and subnet(s) 
to the Network Whiteboard editor.

Figure 3-121   Export to Network Whiteboard Dialog Box

• Subnets drop-down list—Specify the subnet(s) to export. Choose one of the 
following: None, Current subnet, or All subnets.

• Showcases drop-down list—Specify the showcase(s) to export. Choose one 
of the following: None, Current showcase, or All showcases.

• Generate user-defined tables checkbox—Specify whether to export 
user-defined tables for generating reports.

• Page Layout—Specify the page layout orientation and size. Choose one of 
the following:

— Portrait radio button—Specifies 8.5 x 11 inches.

— Landscape radio button—Specifies 11 x 8.5 inches.

— Custom radio button—Specifies a custom size. When selected, specify 
the height and width.

• Export button—The Generate User-Defined Report dialog box appears if you 
are exporting user-defined tables. After selecting tables or if user-defined 
reports are not exported, the Network Whiteboard editor appears with the 
exported topology.

• Cancel button—Closes the dialog box without saving any changes.

Export > Subnet
Hierarchy to VNE
Server as Groups

Topology > Export > Subnet Hierarchy to VNE Server as Groups > (option): 
Export entire network or selected subnets to VNE Server. 
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Export > Subnet
Hierarchy to VNE

Server as Groups>
Entire Network

Topology > Export > Subnet Hierarchy to VNE Server as Groups > Entire 
Network Export the entire network to VNE Server.:. 

Figure 3-122   Export to VNE Server Dialog Box

In the Export to VNE Server dialog box, specify the name and port of the VNE 
Server to which you want to export the network, and then click OK. 

Export > Subnet
Hierarchy to VNE

Server as Groups>
Selected Subnets

Topology > Export > Subnet Hierarchy to VNE Server as Groups > Selected 
Subnets Export the selected subnets to VNE Server. 

Export > Attributes
for Selected Objects

Topology > Export > Attributes For Selected Objects Export the selected object 
attributes to text files. 

1) Select the objects of interest (e.g., nodes and links). 

2) Choose the Topology > Export > Attributes for Selected Objects option. The 
Export Attributes for Selected Objects dialog box displays. 

Figure 3-123   Export Attributes for Selected Objects Dialog Box 

3) After making the appropriate selection select OK. The Save As dialog box 
displays prompting you to select the desired location and specify the file 
name to which to save the attribute text file on the hard drive. 

Export > Attributes Topology > Export > Attributes for All Objects Export all object attributes to text 
files. 

1) The Export Attributes for All Objects dialog box displays. 
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Figure 3-124   Export Attributes for All Objects Dialog Box

2) After making the appropriate selection select OK. The Save As dialog box 
displays prompting you to select the desired location and specify the file 
name to which to save the attribute text file on the hard drive. 

Export > Selected
Area to Bitmap

Topology > Export > Selected Area to Bitmap Specify an arbitrary area on the 
workspace and export the contents to an image file. 

1) Drag a rectangle around the area of interest for the screen capture. 

2) In the Model Image Capture Preview window, set desired image options 
and click Save. 

3) In the Select Captured Image Location dialog box, choose a file format, file 
name, and location, and then click Save. 

Export > Visible
Area to Bitmap

Topology > Export > Visible Area to Bitmap Capture the visible area of a subnet 
as a screen shot and save it as a GIF or TIF file.

1) In the Model Image Capture Preview window, set desired image options 
and click Save.

Figure 3-125   Model Image Capture Preview Window

2) In the Select Captured Image Location dialog box, choose a file format, file 
name, and location, and then click Save.

3) Click OK.
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Import Performance
Metrics

Topology > Import Performance Metrics > (option) Import performance metrics 
for devices in your network.

Import Performance
Metrics > From Text

File

Topology > Import Performance Metrics > From Text File Add performance 
metrics information from a text file after the import. This option allows you to 
import operational performance metrics from a .csv file that can be applied over 
an existing network model for further analysis.

Figure 3-126   Import Performance Metrics from Text File Dialog Box 

• Use the Browse button to open a file chooser—Select the file you want to 
import into the current project. 

• Click Import to accept the specified path to the text file, import the file, and 
close the dialog box when finished. 

A summary report is displayed after the import to show the metrics that were 
imported. The import log is an important source of information for 
troubleshooting. If entries are skipped or anything fails during the import from a 
text file, select Topology > Import Performance Metrics > Open Import Log... to 
see an import log dialog box.

Import Performance
Metrics > Open

Import Log

Topology > Import Performance Metrics > Open Import Log Display log file 
entries after importing a performance metrics text file.

Configure Link
Delays

Topology > Configure Link Delays > (option) Configure link delays based on 
measured delay values.
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Configure Link
Delays > From

Measured Delay
Information

Topology > Configure Link Delays > From Measured Delay Information Specify 
link delays based on measured delay values contained in the Performance 
Metrics.

Figure 3-127   Configure Link Delays from Measured Delay Information Dialog 
Box 

• Link delay configuration options—Specify the type of round trip delay to use 
and how multiple delay values are handled for a given node pair. 

— Use the ___ of measured round trip delay values—Specify which delay 
value of the measured information (Maximum, Minimum, Average, or 
95th percentile) is to be used for configuring link delays. 

— Use the ___ if multiple values exist for same node pair—Specify whether 
the Maximum, Minimum, or Average of multiple values are to be used if 
multiple values exist for a given node pair. 

• Apply above selection to—Specify the nodes whose Round Trip Delay 
information will be used for configuring the link delays. 

— All Nodes radio button—Uses the available information from all nodes in 
the network model. 

— Selected Nodes radio button—Uses the available information from the 
nodes you selected in the network model. 

• Overwrite existing link delay values checkbox—Specify if existing link delay 
values should be overwritten with the new calculated delay values based on 
the selections made above. If checked, any existing link delays on links will 
be overwritten by new values. If unchecked, previously set delays will be 
preserved on links.

Note—Links with the delay values set to the default ("Distance Based") will 
always be modified regardless of this checkbox. 
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• Enable logging checkbox—Specify if an output error log is to be created.If 
checked, an output log will be created which contains details of skipped 
"Delay, Jitter and Loss" information, as well as a configuration summary. To 
view the output error log, select Topology > Configure Link Delays > Show 
Output Log. If unchecked, no output log is created. 

• Click OK to configure the link delays based on the selected configuration 
options. 

Configure Link
Delays > Show

Output Log

Topology > Configure Link Delays > Show Output Log Display output log with 
details of skipped "Delay, Jitter and Loss" information as well as a configuration 
summary after configuring link delays. 

Generate IP Cloud
Metrics File > From

Router Metrics
Information...

Topology > Generate IP Cloud Metrics File > From Router Metrics Information
Generates performance metrics for a cloud based on router information. In 
imported networks in which delay and loss metrics have been imported for 
routers, the performance metrics for the cloud nodes can be determined from 
the metrics in the router nodes. A new dialog box opens that allows you to 
specify whether to use the minimum, maximum, average, or 95th percentile of 
the measured round trip delay and of the measured packet loss specified in the 
delay, jitter, and loss metrics of the routers.

The process results in the generation of a performance metrics file for each 
cloud device in the network. Each file, corresponding to a specific cloud node, 
contains performance metrics information accumulated from router nodes 
connected to the cloud node.

Role Assignment >
Assign Roles

Topology > Role Assignment > Assign Roles Sets the role attribute on multiple 
devices and network objects in your current network scenario to organize, 
analyze, and report on sets of objects in the network model.

The main steps to assign roles are as follows:

1) Choose Topology > Role Assignment > Assign Roles to open the dialog 
box.

2) Specify the role names by entering the role names in the Role(s) list.

3) Select devices from the left-pane treeview.

4) Use “Assign To” button to assign one or more roles to one or more devices.

Note—You can assign more than one role to an object by entering a 
comma-separated list of role names.
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Role Assignment >
Scan for Assigned

Roles

Topology > Role Assignment > Scan for Assigned Roles Scans the network for 
existing roles and lets you select or unselect sites with specific roles. The basic 
steps to scan for assigned roles are as follows:

1) Choose Topology > Role Assignment > Scan Network For Roles. After you 
scan the network for existing roles, the available roles display in the options 
to select or unselect sites with specific roles.

2) Choose Topology > Role Assignment > Select Sites With Roles or Unselect 
Sites With Roles.

3) Select the role you want to select or unselect from the menu.

Model Assistant Topology > Model Assistant > (option) Edit model assistant files, apply the data 
to your network, and save the data to reuse later. A model assistant file is an 
ASCII text file that specifies a set of changes to a scenario. You can specify 
multiple changes in one file, then apply the file to make multiple changes in one 
operation. For example, you can create a model assistant file to: 

• Create subnetworks, nodes, and links, 

• Set object attributes, 

• Import node aliases, and 

• Specify object locations. 

Model Assistant >
Edit File

Topology > Model Assistant > Edit File Edit model assistant files.

1) The Edit Model Assistant File dialog box displays. This dialog box contains 
multiple tabbed pages; each page has fields for entering the data you want 
to apply. If you want to edit an existing file, click Load, choose the file to 
load, and click OK. The dialog box updates each tabbed page to reflect the 
data in the loaded file. 

2) Specify the information you want to apply on each page (click the tabs to 
view specific pages). 

a) If you do not want to apply a certain type of data, leave the page empty. 

b) If you want to reset all settings on all pages and reenter your data, click 
Clear. 

c) If you want to save your data to a model assistant file so you can reuse 
it later, click Save. 

3) Click Apply to apply your data to the network, or Close to close the dialog 
box without applying your data. 

Model Assistant >
Apply File

Topology > Model Assistant > Apply File Apply the selected model assistant 
file. 
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Model Assistant >
Open Error Log

Topology > Model Assistant > Open Error Log View errors that occur when the 
model assistant file is applied to your scenario. 

Model Assistant >
Save Current

Topology to File

Topology > Model Assistant > Save Current Topology to File Create a model 
assistant file based on your current topology. 

Create Custom
Device Model

Topology > Create Custom Device Model... Create your own new device 
models, in addition to using the built-in model objects provided by JCSS and 
creating derived models. Create several different types of network components, 
including routers, bridges, hubs, workstations, switches, LANs, and vendor 
devices. For complete instructions, consult the IT Guru documentation set, 
available via Help > Documentation > IT Guru Documentation. 

Rapid Configuration Topology > Rapid Configuration Create network components using the rapid 
configuration feature. A network configuration, or topology, refers to a model's 
set of nodes and links and their arrangement within the network. Rapid 
configuration allows you to build common network topologies quickly and easily. 
You can select the type of network configuration to be built-such as a ring or 
bus-and specify its node models, link models, and arrangement all at once, 
without having to create and specify each network component individually. You 
can also control the number of nodes that will be in the network and the type of 
link that will be used to connect the nodes. 

Seven rapid configuration topologies are available: Bus, Full Mesh, 
Randomized Mesh, Tree, Ring, Unconnected Network, and Star. 

Each type of configuration can be created using the Rapid Configuration 
operation. Through a series of dialog boxes, select the type of configuration to 
be created, specify the number of nodes, and select the node or link models to 
be associated with them. You can also control how the nodes will be arranged 
and their location within the workspace. After the specifications are entered, the 
configuration is constructed in the workspace. 

Delete Unconnected
Nodes

Topology > Delete Unconnected Nodes Delete marked nodes. 

Figure 3-128   Unconnected Node Deletion Dialog Box 
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Deploy Wireless
Network

Topology > Deploy Wireless Network Use the Wireless Deployment Wizard to 
create a wireless network by specifying parameters for technology, topology, 
and mobility. You can use the wizard iteratively to deploy multiple network 
segments into the same project.

Figure 3-129   Wireless Deployment Wizard

Click Continue. The wizard will prompt you through the screens. After defining 
your parameters, you can save them into a file in the last stage of the wizard, 
and reuse them. 
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Open Edge
Connectivity Wizard

Topology > Open Edge Connectivity Wizard Use the Edge Connectivity Wizard 
to create IP connectivity between the enterprise sites in your network model. By 
specifying the WAN interfaces that connect to your Service Provider network, 
you can create Layer-3 IP clouds that connect the sites. You can create as many 
IP clouds that you need to model the IP connectivity, and then save the 
configuration to a Model Assistant (MA) file. The MA file can be applied as part 
of topology import. 

Figure 3-130   Edge Connectivity Wizard

Follow the steps of the wizard to: 

• Create new IP cloud definitions, 

• Manage a set of IP cloud definitions, 

• Use MA files to Save/Load IP cloud definitions, and 

• Apply IP cloud definitions on the current network model. 

Link Operations Topology > Link Operations > (option) Use the sub-menu options to perform 
link consistency checks and define valid links between devices using a 
wizard-like feature. 

Link Operations >
Deploy Link

Topology > Link Operations > Deploy Link Quickly define valid links between 
devices using a wizard-like feature. 

1) Select two devices (through GUI or Network Browser) and then select 
Topology > Link Operations > Deploy Link (or press <Ctrl> + L.) 
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2) If more than one device is present in an OPFAC, the Select Devices dialog 
box displays. Select the desired devices to connect and then click Next. 

Figure 3-131   Select Devices Dialog Box 

If a selected OPFAC has only one device, then the device will be selected 
by default and the Select Devices dialog box will be skipped. If the OPFAC 
doesn't have a device, an error will be flagged. 

This feature will be only applicable to the fixed nodes (only wired ports will 
be considered for selection.) 

3) The best default link available and a list of the other applicable link types 
displays. A series of the most common default bandwidths for the selected 
link type is also provided as well as the first available ports applicable to the 
chosen link as default ports. Use the default values or select the desired 
values, and then click OK. 

Figure 3-132   Select Wired Link Properties Dialog Box 

An inter-OPFAC link or intra-OPFAC link will be created with the 
user-defined attributes between the two devices, depending on whether the 
selected devices are within one OPFAC or different OPFACs. 

Deploying Satellite Links 

Defining satellite links can be performed using a procedure similar to defining 
other links. 

1) Select two OPFACs or devices and then select Topology > Link 
Operations > Deploy Link (or press <Ctrl> + L.) 
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2) If more than one device is present in an OPFAC, the Select Devices dialog 
box displays. Select the desired devices to connect and then click Next. 

Figure 3-133   Sample Select Devices Dialog Box 

If a selected OPFAC has only one device, then the device will be selected 
by default and the Select Devices dialog box will be skipped. If the OPFAC 
doesn't have a device, an error will be flagged. 

3) The Satellite Bent Pipe Link Deployment dialog box displays. 

Figure 3-134   Satellite Bent Pipe Link Deployment Dialog Box—Basic

The Basic tab displays the default Link Name, and allows you to select the 
Home Satellite which provides the available frequencies. 

a) Click the Advanced Tab. The following screen displays. 
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Figure 3-135   Satellite Bent Pipe Link Deployment Dialog Box—Advanced 

Based on the frequencies provided by the chosen Home Satellite, this 
screen allows you to configure the frequencies uplink and downlink (in 
each direction) to establish a satellite link between the two selected 
satellite terminals. 

The fields of this screen are pre-populated for you with the best available 
default link. 

b) Click the Help Diagram tab. The following screen displays a diagram 
which explains the function of this dialog box . 

Figure 3-136   Satellite Bent Pipe Link Deployment dialog box—Help Diagram

c) Click the Help FAQs tab. The following screen displays a scrollable list 
of Frequently Asked Questions and answers regarding satellite link 
deployment. 
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Figure 3-137   Satellite Bent Pipe Link Deployment Dialog Box—Help FAQs 

4) Use the default link values provided in the Satellite Bent Pipe Link 
Deployment dialog box (or select the desired values), and then click OK. 
The newly deployed satellite link displays in the workspace. 

Link Operations >
Verify Links

Topology > Link Operations > Verify Links Perform inter and intra OPFAC link 
consistency checks. Inconsistent links (e.g., links not connected to the right 
ports on the end points of the link) will be marked with a red X in the workspace. 
This option can also be launched using the Verify Link Consistency toolbar 
button. 

Figure 3-138   Inconsistent Links 
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In addition, the results of the link consistency check will be displayed in the 
Cross Classification Check dialog box

Figure 3-139   Cross Classification Check Dialog Box

Link Operations >
Clear Links

Topology > Link Operations > Clear Links Remove red Xs marking inconsistent 
links in the workspace.

Link Operations >
Import Links from

File

Topology > Link Operations > Import Links from File Imports links from 
designated link import file.

Deploy Circuit Topology > Deploy Circuit Follow the steps in the Circuit Wizard to configure 
the desired circuit. All circuit devices (i.e., SCREAM, SHOUTip, CTP, Promina, 
TSSP, and Multiplexers) are deployed using the same procedure. A sample 
generic Circuit Wizard workflow – using Prominas as an example – is provided 
below.

1) Select Topology > Deploy Circuit (or press Ctrl + D) to start the wizard. You 
must select at least two compatible circuit devices or OPFACs that contain 
circuit devices; otherwise, an error will be prompted and the wizard is 
terminated.

2) As prompted, select the appropriate devices in the Choose Circuit Devices 
dialog box, and then click OK. 
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Figure 3-140   Choose Circuit Devices Dialog Box 

The Circuit Deployment Wizard displays. 

Figure 3-141   Circuit Deployment Wizard Ports Tab 

3) On the Ports tab, specify the ports for the selected source and destination 
Promina devices in the scenario. 

4) On the CCSD tab, configure the CCSD codes for the Promina circuit. 
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Figure 3-142   Circuit Deployment Wizard CCSD Tab 

5) On the Attributes tab, configure the circuit's attribute values. 

Figure 3-143   Circuit Deployment Wizard Attributes Tab 

6) Click the OK button to complete the Promina circuit configuration and 
deploy the circuit. 
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Deploy Broadcast
Network

Topology > Deploy Broadcast Network Define broadcast networks by selecting 
units in the workspace, and then selecting Topology > Deploy Broadcast 
Network.

1) Select the source and destination OPFACs or organizations in the 
workspace, and then select Topology > Deploy Broadcast Network (or 
press Ctrl + Shift + B). The Network Attributes dialog box displays.

Figure 3-144   Defining Broadcast Network Radio Attributes

2) Type a name for the broadcast network in the Network Name field. 

3) On the Radio Attributes tab, enter the desired attributes for default 
frequency, channel bandwidth, and data rate. In addition, if the radio 
supports Frequency Hopping, additional attributes for frequency hopping 
spread spectrum (FHSS) will appear which can also be configured. 

4) On the Choose Devices tab, select devices for the corresponding OPFACs 
or organizations. 
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Figure 3-145   Defining Broadcast Network Devices 

5) On the Optimization Attributes tab, enter the desired attributes for possible 
capacities, and target and maximum utilization. 

Figure 3-146   Defining Broadcast Network Optimization Attributes 
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a) Possible Capacities table: Specifies all of the capacities that the 
optimization engine can use when mutating solutions. For example, if 
there are two capacities specified, then the engine will be able to set 
either of them as the suggested capacity for this network. The Capacity 
column is where the capacity is specified. The Status column is used to 
mark the "original" capacity and the "current" capacity (or "Orig/Current" 
if the current capacity is also the original capacity.) 

b) Insert Row button: To add a new capacity, click this button and type the 
new capacity into the Capacity column of the new row. 

c) Delete Row button: To remove a capacity, select a cell in the row and 
click this button. 

d) Target Utilization: Specifies the target utilization to be achieved on this 
network. The default value is to use the global values specified in the 
Capacity Optimization Settings dialog. You can override this just on this 
network by specifying a new value. 

e) Maximum Utilization: Specifies the maximum utilization that is allowed 
on this network. The default maximum utilization is set to use the global 
values specified in the Capacity Optimization Settings dialog. You can 
override this just on this network by specifying a new value.

6) Click OK to create the newly defined broadcast network.

Deploy Relationship Topology > Deploy Relationship Define relationships by selecting units in the 
workspace, and then selecting Topology > Deploy Relationship.

1) Select the OPFACs that you want to associate in the workspace, and then 
select Topology > Deploy Relationship (or press Ctrl + Alt + R). The 
Relationship Attributes dialog box displays. 

Figure 3-147   Creating a Relationship 

2) Select the type of relationship from the Relationship Type drop-down menu.

3) Select the source OPFAC from the Source drop-down menu.

4) Click OK. The relationship between the selected OPFACs is created. 

Configuration
Utilities > UHF

DAMA SATCOM

Topology > Configuration Utilities > UHF DAMA SATCOM Follow the steps in 
the Configuration Wizard to configure the desired UHF DAMA SATCOM utility 
node. You must select at least one NCS device and two terminals in order to 
start the wizard. 
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1) Select Topology > Configuration Utilities > UHF DAMA SATCOM to start 
the wizard. 

Figure 3-148   UHF DAMA SATCOM Wizard: Define CPS Node Attributes (Step 1 
of 3) Dialog Box 

2) Browse and select a service plan file, and browse and select a noise area 
file (or check Create default file to create a default file.) Click Next>> to 
continue. 

Figure 3-149   UHF DAMA SATCOM Wizard: Define Channels (Step 2 of 3) Dialog 
Box

3) Specify the settings for the channel that you want to define, and then click 
Next>> to continue. 
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Figure 3-150   UHF DAMA SATCOM Wizard: Define Services (Step 3 of 3) Dialog 
Box 

4) Specify the settings for the service that you want to define, and then click 
Finish to end and close the wizard. 

Configuration
Utilities >

Cut-through >
Enable

Topology > Configuration Utilities > Cut-through > Enable Cut-through on 
Selected Devices (All Ports) Select the two devices that you want to be 
cut-through enabled, then select this command (or press Ctrl + Alt + E). The 
selected devices will be cut-through enabled on all ports. (Note the message 
that displays in the status bar at the bottom of the Scenario Builder window.)

Figure 3-151   Enable Cut-Through on Selected Devices 
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Configuration
Utilities >

Cut-through >
Disable

Topology > Configuration Utilities > Cut-through > Disable Cut-through on 
Selected Devices (All Ports) Select two cut-through enabled devices that you 
want to be cut-through disabled, then select this command (or press Ctrl + Alt + 
D). The selected devices will be cut-through disabled on all ports. (Note the 
message that displays in the status bar at the bottom of the Scenario Builder 
window.)

Figure 3-152   Disable Cut-Through on Selected Devices 

Set Owner Topology > Set Owner Determine which units are needed for subordinate's 
input (performed by Lead Planner), and then mark them for subordinate input 
by setting ownership information. 

Alternative method to access this option: right-click on a unit and select Edit 
JCSS Attributes, and then click the Set Owner button. 

1) Select units to be marked for subordinate before accessing this option. 

2) After this option is accessed, click on the Last Name drop-down menu to 
select an owner. 

a) An owner can be set on multiple units through one operation by enabling 
the Applying owner information on all selected units option. 

b) If the desired owner is not listed in the drop-down menu, add the desired 
owner to the list by clicking on the New Owner button. 
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Figure 3-153   Set Owner Dialog Box

Once the owner information is applied to the desired units, those units 
will display a yellow icon indicating the owner has been set and those 
units have been marked. Units are unmarked by default; therefore, the 
Lead Planner must remember to set ownership information on the units 
before exporting the subordinate query files to Subordinate Planners. 

Figure 3-154   Owner Information Set on Desired Units 

Remove Owner Topology > Remove Owner Remove ownership from selected units. 

Alternative method to access this option: right-click on the unit, select Edit JCSS 
Attributes, click the Set Owner button, and then enable the Unset Owner 
Information checkbox. 

1) Select units to be unmarked before accessing this option. Once the remove 
owner operation is applied, the yellow icons are removed. 

Terrain Topology > Terrain <options> This menu is available only if a Terrain Modeling 
Module GUI (TMMGUI) license is obtained. Use this feature to import terrain 
data, view the terrain profile and study the effects of the atmosphere on the 
communication. 

JCSS supports the following terrain data formats: 

• DTED Level 0 
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• DTED Level 1 

• 15-minute DEM data 

• 2-arc-second DEM data 

• 1-degree-DEM data 

Terrain > View
Terrain Profile

Topology > Terrain > View Terrain Profile View the terrain profile between two 
points. 

1) In View Profile mode, click on one point and then click on the second point. 
This will display the terrain profile between the two selected points. 

Figure 3-155   Terrain Profile 

Terrain > Set Propagation Model 

The brown area indicates terrain. Using this interface, you can turn on or off the 
Fresnel Zone and also the Earth's curvature (which is represented by the green 
arc). The blue line in the profile can be used to determine whether line-of-sight 
exists between the two points. If the blue line crosses over the terrain or the 
Earth's curvature, there is no line-of-sight. 

Terrain > Set
Propagation Model

Topology > Terrain > Set Propagation Model Set the model used by the 
TMMGUI module for representing the atmospheric conditions. Example 
propagation models include the Free-Space model and the Longley-Rice model 
You can also create user-defined propagation models. 
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Terrain > Edit Topology > Terrain > Edit Parameter Sets Access the tabular interface for 
Parameter Sets making changes to the propagation models. 

Figure 3-156   Edit TMM Propagation Parameter Sets Dialog Box 

1) From the drop-down menu, select the propagation model to modify. 

2) Once the desired changes to the propagation model are made, save it to 
the same model or save it to a new model (sing the Save or Save As 
buttons) and close this table. 

Terrain > Specify
Terrain Data

Directory

Topology > Terrain > Specify Terrain Data Directory Set the directory where 
JCSS will access terrain data. 

Figure 3-157   Terrain Data Directory Preferences Dialog Box 

1) Type in the folder name where the files are stored or use the Browse button 
to browse to that location using the file browser. 

JCSS supports three types of terrain data: DTED, USGS DEM, and 
OpenFlight. The specified folder must contain the files of the specified type. 

Terrain > Rebuild
Terrain Data Catalog

Topology > Terrain > Rebuild Terrain Data Catalog Refresh terrain data before 
import if files are added to the terrain data directory or changes are made to the 
location of the terrain data directory. JCSS does not automatically detect the 
changes. 
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Terrain > Set
Elevation Maps

Topology > Terrain > Set Elevation Maps Set elevation or contour lines on the 
map. If terrain data has already been imported, it can be saved as elevation 
lines and can be reused in future sessions of JCSS. This saves the time taken 
to import the data and create the elevation lines. 

Figure 3-158   Select Elevation Lines Dialog Box 

1) If there are no elevation lines for the area of interest, import terrain data and 
use the new elevation lines. Click the Import button to launch the Import 
Elevation Lines dialog box. 

Figure 3-159   Import Elevation Lines Dialog Box 

2) When importing the data, specify the following information: 

a) Area to Import—Specifies the portion of the map corresponding to which 
one you want to import the terrain information. You have three choices: 
Currently Visible Area, Entire Subnet, or Define Area. 

b) Elevation Lines Name—Identifies a name for the elevation lines being 
imported. By saving the elevation lines, you can avoid going through the 
import process again. 

c) Resolution—Indicates the number of sample points per unit. 

d) Line Spacing—Specifies how far away the elevation lines are spaced 
when imported into the scenario. 

e) Terrain Data Directory—Click this button to select the folder that 
contains the terrain data. This launches the same interface as the 
Terrain > Specify Terrain Data Directory menu option. 
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f) Display Settings: Click this button to control the display preferences. 
This option launches the same interface as the Terrain > Edit Map 
Display Settings option.

3) Click OK.

Terrain > Edit Map
Display Settings

Topology > Terrain > Edit Map Display Settings Specify map display settings, 
such as the colors and thresholds to be used for the elevation lines.

Figure 3-160   Current Elevation Line Display Settings Dialog Box

3DNV Topology > 3DNV > (option) Use the 3DNV options to display 3D network views, 
play 3DNV history, add '3DNV Mapping' attribute to selected nodes, manage 
3DNV entities, show/hide and manage trajectories and pathloss of selected 
nodes in 3D Visualizer, and visualize antenna coverage. 

3D Network Visualizer (3DNV) functionality lets you create three-dimensional 
animations based on topology information, node relationships, performance 
statistics, and terrain data. You can, for example, use 3DNV to visualize network 
characteristics such as node placement, line-of-sight restrictions, transmission 
quality, throughput, delay, and message status information. 

Note—For more information about this feature, please refer to the OPNET IT 
Guru documentation set, available via Help > Documentation > IT Guru 
Documentation.) 

These options are available only to users with 3D Network Visualizer GUI, 
Terrain Modeling, and Wireless product module licenses. 

3DNV > Display 3D
Network View

Topology > 3DNV > Display 3D Network View View 3D animation of a network 
model in the workspace. 
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3DNV > Play 3DNV
History

Topology > 3DNV > Play 3DNV History Choose a 3DNV history file to play. 

Figure 3-161   Choose 3DNV History File Dialog Box 

3DNV > Add '3DNV
Mapping' Attribute
to Selected Nodes

Topology > 3DNV > Add “3DNV Mapping” Attribute to Selected Nodes: Create 
'3DNV Mapping' extended attribute for the selected nodes and subnets. 

Figure 3-162   Sample Attributes Dialog Box with “3DNV Mapping” Attribute 

3DNV > Manage
3DNV Entities

Topology > 3DNV > Manage 3DNV Entities Assign, review, and modify the 
3DNV Mapping attribute, which maps an OPNET node to a 3D model in 3D 
Network Visualizer. Also, enable the optional visualization of a node’s trajectory 
or the pathloss between wireless nodes.

Figure 3-163   Manage 3DNV Entities and Associated Visualizations Dialog Box 

In the Manage 3DNV Entities and Associated Visualizations dialog box, the 
treeview displays the subnets and nodes present in the network model, while 
the table presents associated information for the nodes. 
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The checkboxes next to the subnets in the treeview indicate whether none, 
some or all of the included nodes have an associated 3DNV Mapping attribute. 
(Nodes do not have similar checkboxes because that information is shown in 
the associated table.) 

Which columns are shown in the table depends on what options are selected, 
as controlled by the Show All 3DNV Mapping Attributes in Table, Show 
Trajectory in Table, and Show Pathloss in Table checkboxes. Gray values 
indicate that no associated data is present. 

• 3D View column-Displays the value of the "Animation" field of the 3DNV 
Mapping attribute, indicating whether to show or hide the corresponding 
node in 3D Network Visualizer when the scenario is visualized. When the 
scenario is visualized, toggling this value will cause the corresponding 3D 
model to appear or disappear in 3D Network Visualizer. 

• Entity Type column-Displays the value of the "DIS Entity Type" field of the 
3DNV Mapping attribute. You can modify the node's mapping by clicking on 
a defined cell value, which opens a pop-up menu containing the defined 
symbolic values. When the scenario is visualized and the node is shown, 
changing this value causes the corresponding 3D model to be updated 
appropriately in 3D Network Visualizer. 

• Force ID column-Displays the value of the "DIS Force ID" field of the 3DNV 
Mapping attribute. You can modify the node's mapping by clicking on a 
defined cell value, which opens a pop-up menu containing the defined 
symbolic values. 

• Dead-Reckoning column-Displays the value of the "DIS Dead Reckoning" 
field of the 3DNV Mapping attribute. You can modify the node's mapping by 
clicking on a defined cell value, which opens a pop-up menu containing the 
defined symbolic values. 

• Agg. Mode column-Displays the value of the "Aggregation Mode" field of the 
3DNV Mapping attribute. You can modify the node's mapping by clicking on 
a defined cell value, which opens a pop-up menu containing the defined 
symbolic values. If the aggregation mode is "Aggregate", the Agg. X, Agg. Y, 
and Agg. Z table cells are defined. 

• Agg. X, Agg. Y, and Agg. Z columns-Displays the x, y, and z fields of the 
"Aggregation Info" field of the 3DNV Mapping attribute. These columns are 
defined only for Aggregate objects. 

• 3D Traj. column-Indicates whether the associated trajectory can be or is 
shown in 3D Network Visualizer. Only "shown" nodes with an associated 
3DNV Mapping attribute can also display their trajectories. NONE and 
VECTOR trajectories are not shown in 3D Network Visualizer. 

• Trajectory column-Displays the current value of the "trajectory" attribute of 
the site. Clicking on a defined cell opens a pop-up menu containing a list of 
possible trajectories. 
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• Color column-Displays the current value of the "color" attribute of the site, 
which controls the color of the associated trajectory. Clicking on a defined 
cell opens a color picker dialog box to change the color. 

• Pathloss in 3D column-Indicates whether the associated node with a 
wireless transceiver should be included in the visualization of pathloss 
computations between nodes. Pathloss is shown as a line between every 
pair of possible nodes, with the pathloss value displayed next to the line and 
controlling the color of the line. 

• Set 3DNV Mapping Attribute tab-Contains a set of controls used to assign 
attribute values to a set of selected nodes. If a node doesn't have a 3DNV 
Mapping attribute already, a new extended attribute is automatically added 
with its initial value based on these controls. If a node already has a 3DNV 
Mapping attribute, the attribute fields are updated appropriately based on 
these controls. 

• Trajectories in 3DNV tab-Contains a set of controls used to control the 
visualization of trajectories in 3D Network Visualizer. 

• Pathloss in 3DNV tab-Contains a set of controls used to control the 
visualization of pathloss information in 3D Network Visualizer. 

• Connect to 3D Network Visualizer button—Establishes a connection with 3D 
Network Visualizer (via the 3DNV Communication RTI) so that nodes with an 
associated 3DNV Mapping attribute and a 3D View column setting of ‘Show’ 
are displayed appropriately. The visualization will also include enabled 
trajectories or pathloss information for visualized nodes. After connection 
has been established, this button’s label changes to

• Disconnect from 3D Network Visualizer. Clicking the button severs the 
communication, which removes all visualizations from 3D Network 
Visualizer.

• OK button—Closes the dialog box, keeping all changes made to the various 
attributes and preferences.

• Cancel button—Closes the dialog box, reverting all the changes made to the 
various attributes and preferences to the settings they had before the dialog 
box was opened.

3DNV > Show/Hide
Trajectories of

Selected Nodes in
3D Visualizer

Topology > 3DNV > Show Trajectories of Selected Nodes in 3D Visualizer and 
Topology > 3DNV > Hide Trajectories of Selected Nodes in 3D Visualizer Show 
and/or hide visualization of selected nodes' trajectories in 3D Network 
Visualizer. 

3DNV > Manage 3D
Visualization of

Trajectories

Topology > 3DNV > Manage 3D Visualization of Trajectories Control the 
visualization of trajectories in 3D Network Visualizer. 

• In the Manage 3DNV Entities and Associated Visualizations dialog box, 
select the Show Trajectory in Table checkbox, and the Trajectories in 3DNV 
tab. 
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• Line thickness field-Specifies the thickness of the 3D lines displayed in 3D 
Network Visualizer. This sets the "3dnv.trajectory_thickness" preference. 

Figure 3-164   Manage 3DNV Entities and Associated Visualizations Dialog 
Box—Trajectories in 3DNV Tab

• Line thickness field—Specifies the thickness of the 3D lines displayed in 3D 
Network Visualizer. This sets the “3dnv.trajectory_thickness” preference.

• Sampling distance field—Specifies the sampling distance used to break a 
potentially long trajectory segment into an appropriate number of 3D lines. A 
value of 0 indicates that no sampling is to take place, with one 3D line per 
segment. This sets the "3dnv.trajectory_sampling_distance" preference. 

• Visualize All Trajectories button—Displays all node trajectories in 3D 
Network Visualizer, selecting the checkboxes in appropriate cells of the 3D 
Traj. Column as each trajectory is drawn. A progress bar is displayed during 
the operation. Canceling the progress bar stops the operation with the 
trajectories drawn to that point left selected. 

• Do Not Visualize Any Trajectories button—Hides all node trajectories in 3D 
Network Visualizer, unselecting the checkboxes in appropriate cells of the 
3D Traj. Column as each trajectory is hidden. A progress bar is displayed 
during the operation. Canceling the progress bar stops the operation with the 
trajectories hidden to that point left unselected. 

3DNV > Show/Hide
Pathloss between
Selected Nodes in

3D Visualizer

Topology > 3DNV > Show Pathloss between Selected Nodes in 3D Visualizer and 
Topology > 3DNV > Hide Pathloss between Selected Nodes in 3D Visualize
Show and/or hide visualization of selected nodes' pathloss information in 3D 
Network Visualizer. 

3DNV > Manage 3D
Visualization of

Pathloss

Topology > 3DNV > Manage 3D Visualization of Pathloss Control the 
visualization of pathloss information in 3D Network Visualizer. 

• In the Manage 3DNV Entities and Associated Visualizations dialog box, 
select the Show Pathloss in Table checkbox, and the Pathloss in 3DNV tab. 
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Figure 3-165   Manage 3DNV Entities and Associated Visualizations Dialog 
Box—Pathloss in 3DNV Tab 

• Center frequency field—Specifies the center frequency used for pathloss 
computation. This sets the "3dnv.pathloss_center_frequency" preference. 

• Bandwidth field—Specifies the bandwidth used for pathloss computation. 
This sets the "3dnv.pathloss_bandwidth" preference. 

• Propagation model drop-down menu—Specifies the propagation model used 
for pathloss computation. This modifies the propagation model information in 
the scenario. 

• Parameter set drop-down menu—Specifies the set of propagation 
parameters used for pathloss computation. This modifies the propagation 
model information in the scenario. 

• Visualize All Pathloss Pairs button—Includes all nodes with wireless 
transceivers in the pathloss display, selecting the checkboxes in appropriate 
cells of the Pathloss in 3D column as the pathloss for each node is drawn. A 
progress bar is displayed during the operation. Canceling the progress bar 
stops the operation with the pathloss shown to that point left selected. 

• Do Not Visualize Any Pathloss Pairs button—Removes all nodes with 
wireless transceivers from the pathloss display, unselecting the checkboxes 
in appropriate cells of the Pathloss in 3D column as the pathloss for each 
node is hidden. A progress bar is displayed during the operation. Canceling 
the progress bar stops the operation with the pathloss hidden to that point left 
unselected. 
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3DNV > Visualize
Antenna Coverage

Topology > 3DNV > Visualize Antenna Coverage Configure and visualize 
antenna "gain fields" for the current scenario. 

Figure 3-166   Manage Antenna Coverages Dialog Box 

In the Manage Antenna Coverages dialog box, the Visualizations area includes 
a table showing the list of defined visualizations and buttons to manage that list. 

• Active column-Used to specify that the visualization should be displayed in 
the 3D Network Visualizer if the scenario is currently connected with it. 
Selecting the checkbox while a connection is established results in the 
corresponding 3DNV graphical elements being created. 

• Changes column-When marked, indicates that some of the visualization 
settings have been changed since the last update of the graphical elements. 
This column becomes marked as soon as some control is modified for the 
visualization. It becomes unmarked when the visualization changes are 
applied or undone. 

• Name column-Name of the visualization. Double-click on a name value to 
edit it. 

• Add button-Used to create a new visualization. Clicking this button opens 
another dialog box in which to enter the new visualization's name. 

• Duplicate button-Used to create a new visualization by duplicating the 
currently selected one. All settings are duplicated, except for the 
visualization's name. Clicking the name brings up another dialog box in 
which to enter the new visualization's name. 

• Delete... button-Used to delete the currently selected visualization. Clicking 
it brings up another dialog box to confirm or cancel the deletion. 
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In the Manage Antenna Coverages dialog box, the Configuration area includes 
controls to display and modify the settings of the currently selected visualization.

• Transmitter button—Defines the transmitter module to visualize using an 
antenna field. Clicking on the button opens a dialog box showing a hierarchy 
of all wireless transmitter modules in the scenario. 

• Tabs—Provides access to visualization settings for Antenna FIeld, 
Receivers, Propagation, and Rendering. 

• Apply Changes button—Updates the visualization based on the values in the 
controls. If the visualization is currently displayed in the 3D Network 
Visualizer, the various graphical primitives will be updated or regenerated 
appropriately based on the settings. 

• Undo Changes button—Resets the visualization's settings to the last applied 
values, or (if changes were never applied) to the original settings that existed 
when the dialog box was opened or the visualization created. If the 
visualization is currently displayed in 3D Network Visualizer, the various 
graphical primitives will be updated or regenerated appropriately based on 
the settings. 

Other controls In the Manage Antenna Coverages dialog box include: 

• Apply Changes to All Visualizations button—Same as clicking Apply 
Changes for every visualization that has pending changes. 

• Undo Changes to All Visualizations button—Same as clicking Undo 
Changes for every visualization that has pending changes. 

• Connect to 3D Network Visualizer button—Establishes a connection with 3D 
Network Visualizer (via the 3DNV Communication RTI) so that nodes with an 
associated 3DNV Mapping attribute are displayed appropriately. The 
visualization will also include enabled antenna field visualizations. 

After connection has been established, this button's label changes to 
Disconnect from 3D Network Visualizer. Clicking the button severs the 
communication, which removes all visualizations from 3D Network 
Visualizer. 

• Close button—Closes the dialog box, prompting you to save if any changes 
were made to any visualization's settings.

Define Trajectory Topology > Define Trajectory Create a trajectory defined in segments.

1) Define a trajectory type, how long the unit waits at the starting location 
before it starts moving, and the altitude at which the unit is when it starts its 
trajectory. 

a) Trajectory name—Sets the name of the trajectory. 

b) Trajectory type—The types are Variable interval and Fixed interval. 
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Figure 3-167   Define Trajectory Dialog Box 

c) Initial altitude—This field sets the initial altitude of the trajectory. Choose 
the units of measurement for the altitude with the drop-down menu. 

d) Initial wait time—In a variable-interval trajectory, the initial wait time 
pauses a mobile object for a specified time before it covers the next 
segment. 

e) Initial pitch—Sets the initial pitch of the trajectory. Possible assignments 
are: Autocomputed to assign a value automatically according to the 
trajectory; Unspecified to not assign any value; or 0.0, which you can 
edit to assign an explicit value. 

f) Initial yaw—Sets the initial yaw of the trajectory. Possible assignments 
are: Autocomputed to assign a value automatically according to the 
trajectory; Unspecified to not assign any value; or 0.0, which you can 
edit to assign an explicit value. 

g) Initial roll—Sets the initial roll of the trajectory. Possible assignments 
are: Autocomputed to assign a value automatically according to the 
trajectory; Unspecified to not assign any value; or 0.0, which you can 
edit to assign an explicit value. 

h) Coordinates are relative to object's position—You can specify a 
trajectory that is either relative to an object's initial position or has its own 
absolute initial position. If you define a relative trajectory, all objects that 
are assigned this trajectory will trace out the same path starting at their 
initial positions. If you define an absolute trajectory, all the objects that 
are assigned this trajectory jump to the trajectory's initial position before 
traversing it. Also indicate whether the trajectory's path points are 
absolute or relative to the object's current location. 

2) Click Define Path to enter trajectory definition mode, display the Trajectory 
Status dialog box, and change the cursor into a line tool in the Project 
Editor. This is used to draw a node's mobile trajectory; the path displays in 
red. 
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3) When you define a variable interval trajectory, the Trajectory Segment 
Information dialog box displays after you create a path. This dialog box is 
used to specify trajectory information for each segment. 

Figure 3-168   Trajectory Segment Information Dialog Box 

4) Click Continue to add a segment, and/or click Complete when you are 
finished. 

5) From the Scenario Builder, right-click on the desired unit to open the 
shortcut menu. 

6) Select Edit JCSS Attributes. The OPFAC/Organization Attributes dialog 
box displays. 

7) Select the name of the trajectory from the Trajectory drop-down menu. 

8) Click OK. 
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Figure 3-169   Assigning Trajectory 

The assigned trajectory displays as a light-green arrow. 

Figure 3-170   Assigned Trajectory

Clear Trajectory Topology > Clear Trajectory Assignment Clear the trajectory attribute on all 
Assignment or selected mobile nodes. 

Figure 3-171   Clear Trajectory Assignment Dialog Box 
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Note—For more information about this feature, please refer to the OPNET IT 
Guru documentation set, available via Help > Documentation > IT Guru 
Documentation.) 

Random Mobility Topology > Random Mobility > (option) Configure and/or clear Mobility Profiles, 
and set the trajectory created from Random Mobility on all or selected mobile 
nodes in this network. 

Trajectories and orbits specify deterministic paths for mobile sites. To model 
random movement, you can use the random mobility feature. Random mobility 
lets you define a rectangular region in which a site will move during a simulation. 
You can define this region by specifying x-y coordinates or by using a mobility 
domain (a special kind of wireless domain). During simulation, the site randomly 
selects a destination in the region and moves toward it at a specified or 
randomly chosen speed. Upon reaching its destination, the site pauses a 
configurable length of time before it repeats the process by selecting another 
random destination. 

A mobility configuration object holds random mobility parameters as "profiles", 
making it easy to reuse them. Profiles are applied to specified sites using 
Topology > Random Mobility > Set Mobility Profile. Even if multiple sites in a 
network use the same profile, their movements will be different because the 
destination for each site is chosen randomly and independently. 

Note—For more information about this feature, please refer to the OPNET IT 
Guru documentation set, available via Help > Documentation > IT Guru 
Documentation.) 

Random Mobility >
Set Mobility Profile

Topology > Random Mobility > Set Mobility Profile Select the Mobility Profile to 
configure on the selected mobile nodes in this network.

Figure 3-172   Configure Mobility Profile on Selected Nodes Dialog Box 
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Random Mobility >
Clear Mobility Profile

Topology > Random Mobility > Clear Mobility Profile Clear the mobility profiles 
on all or selected mobile nodes. 

Figure 3-173   Clear Mobility Profiles Dialog Box 

Random Mobility >
Set Trajectory
Created From

Random Mobility

Topology > Random Mobility > Set Trajectory Created From Random Mobility
Assign random trajectories to one of more sites. 

1) Select the mobile sites to which you want to apply random trajectories. To 
apply trajectories to all mobile sites, leave them all unselected. 

2) Choose Topology > Random Mobility > Set Trajectory Created From 
Random Mobility. 

For each selected site (or all sites), JCSS looks for a random trajectory from the 
current scenario and, if found, applies it to the corresponding site. 

Import STK Orbit Topology > Import STK Orbit Imports an STK orbit file (wireless functionality 
only). The general steps are as follows:

1) In any project, choose Topology > Import STK Orbit.

Figure 3-174   Import STK Orbit

2) Choose either Single STK file or All STK files under chosen directory.

3) Select the checkbox “Create a satellite node for each orbit” if you want to 
create individual satellite nodes in the topology. These individual nodes are 
placed in the top subnet workspace for each imported orbit automatically. 
For each satellite node, its name is set to the corresponding imported orbit 
and it displays the imported orbit in top subnet.
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4) Enter the full path name of the desired orbit file, or use the Browse button 
to display and select the file.

5) Click OK.

Shared Risk Groups Topology > Shared Risk Groups > (option) Create shared risk groups, import 
and/or export *.srgi data files for shared risk groups, and visualize which 
network objects are members of a failed risk group. 

A shared risk group defines a failure relationship between two sets of network 
objects, where failures in one set cause failures in the other set. You can use 
risk groups to model risk factors that can cause failures in a production network 
but do not exist as actual objects in the network model. To do this, you can 
create a risk group in which the risk element set is empty and the impacted 
element set contains objects that depend on the "missing" object. 

After creating risk groups, you can view and edit them in the Network Browser. 

Shared Risk Groups
> New

Topology > Shared Risk Groups > New Create a risk group manually. Verify that 
all the network objects you want to specify as risk elements and impacted 
elements are present in the scenario, and then choose Topology > Shared Risk 
Groups > New. 

The Network Browser opens, with the View filter menu set to Shared Risk 
Groups. A new risk group appears in the treeview. 

• To rename a risk group, right-click on the group, choose Edit Attributes, and 
set the "name" attribute. 

• Add the risk elements (if any): 

• Select the nodes, links, and risk groups that you want to include in the risk 
element set. (If you want to select a risk group, you must select it in the 
Network Browser because risk groups are not visible in the project 
workspace.) 

• In the Network Browser treeview, right-click on the risk group and choose 
Add Selected Objects as Risk Elements. 

The selected objects are added under Risk Elements. 

• Add the impacted elements to the group: 

• Select the nodes, links, and risk groups that you want to include in the 
impacted element set. (If you want to select a risk group, you must select it 
in the Network Browser because risk groups are not visible in the project 
workspace.) 

• In the Network Browser treeview, right-click on the risk group and choose 
Add Selected Objects as Impacted Elements. 



3—Scenario Builder

JCSS/Release 10.0 JCSS-3-155

The selected objects are added under Impacted Elements. 

• Specify the failure propagation criterion for the risk group: 

• Right-click on the risk group and choose Edit Attributes. The Attributes dialog 
box for the shared risk group displays. 

• For the "failure propagation criterion" attribute, specify one of the following 
settings: 

— Any Risk Element Failed-All impacted objects are disabled if any member 
of the risk element set is disabled. 

— All Risk Elements Failed-All impacted objects are disabled only if all 
members of the risk element set are disabled. 

• Close the Edit Attributes dialog box. 

Shared Risk Groups
> Import

Topology > Shared Risk Groups > Import Select a Shared Risk Group Import 
File (*.srgi) to import, and then click OK in the Select SRG Import File dialog box.

Figure 3-175   Select SRG Import File Dialog Box

Shared Risk Groups
> Export

Topology > Shared Risk Groups > Export Create a data file for shared risk 
groups by exporting the shared risk groups defined in an existing scenario. 
Choose Topology > Shared Risk Groups > Export. As prompted, specify a file 
name for the saved Shared Risk Group Import File (*.srgi), and then click Save 
in the Save As dialog box. If desired, you can edit the resulting file in a text 
editor. 

Shared Risk Groups
> Visualize

Operational Status

Topology > Shared Risk Groups > Visualize Operational Status > (option)
Choose Topology > Shared Risk Groups > Visualize Operational Status > 
Visualize to display which network objects are members of a failed risk group. 
An icon appears over every network object that is currently failed due to its 
membership in a risk group. To clear the risk-group visualizations, choose 
Topology > Shared Risk Groups > Visualize Operational Status > Clear. 

Note—If any risk-group elements are failed or recovered while status 
visualization is enabled, the visualization status does not refresh automatically; 
you must choose Topology > Shared Risk Groups > Visualize Operational 
Status >Visualize again to update the visualization. 
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Traffic Menu

Traffic Wizard Traffic > Traffic Wizard Launch the Traffic Wizard which provides you with a 
quick and simple way to deploy traffic within JCSS. Select two OPFACs, and 
then the Traffic Wizard walks you through selecting the end devices (and the 
profile to deploy between the client and server devices), and deploying a link 
between them.

Note—The Traffic Wizard will launch only if you have selected two OPFACs 
between which the traffic is to be deployed.

1) Select Traffic > Traffic Wizard (or press <Ctrl> + W) to launch the Traffic 
Wizard. 

Figure 3-176   Traffic Wizard

2) Select a profile to deploy, specify client and server devices, and then click 
OK.

IERs Traffic > IERs > (option) Create, deploy, and edit IERs and their attributes.

IERs > Deploy IERs Traffic > IERs > Deploy IERs... Launches the IER Wizard which allows you to 
easily specify attributes and create IERs between one producer and one 
consumer.

1) Select two devices or OPFACs in the scenario.

2) Choose Traffic > IERs > Deploy IERs.... The Deploy IER: Choose Devices 
dialog box displays.
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Figure 3-177   Deploy IER: Choose Devices Dialog Box 

3) Verify the selection of Producer and Consumer(s) for the IER you want to 
create: 

a) Producer column—When creating new IERs, the producing OPFAC is 
displayed. Only one OPFAC may be selected at a time. Use the 
drop-down menu to select a different producer. 

Note—If the Auto Select option is chosen for either the producer or consumer, 
a specific device will be chosen by the OPFAC's OE module at simulation time.

b) Consumers column—When creating IERs, the consuming OPFAC is 
displayed. Use the drop-down menu to select a different consumer. 

4) Click Next. The IER dialog box displays where a new IER can be created. 

Figure 3-178   IER Dialog Box
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Note—Options presented are based on the properties of the chosen devices. 
The Equipment type is set to the equipment type of the devices. The equipment 
type is also used to limit the available IER type choices. Finally, the classification 
field is limited to classifications supported by the devices

5) Specify attributes for the IER: 

a) Name—Name of the IER. 

b) ID—Identifies an IER in the database. The ID is used to identify the IER 
for reporting and can be set to any arbitrary string value.  By default, it is 
set to "Use demand name" which means that the ID comes from the 
assigned name on the demand object.

c) Type—This is the type of IER - voice, VTC or data. 

d) Equipment—This is the type of equipment that will be used to transmit 
this IER. 

e) Protocol—Defines the underlying Transport Layer protocol that traffic 
(IERs) will use for transmission. Typical transport layer protocols include 
TCP and UDP. 

f) Classification—Specifies the security classification of an IER. The 
security classification of an IER is one criterion that determines the 
system element through which the IER is transmitted. The default 
classification is "Unclassified." 

g) Priority—Determines the number of transmission retries and the wait 
time between successive retries. 

h) Perishability (sec)—Specifies the time in seconds for which the IER is 
alive. If the time taken by the IER to reach the destination from the 
source is greater than the perishability, the IER is recorded as "failed." 

i) Message—This field can be set to any value (usually in a <tag>=<value> 
format).  Custom models can then parse this information and use it 
during the simulation.  Multiple portions of information are separated by 
the ';' character.

j) The following fields are not filtered in the IER properties dialog box; you 
can choose values as desired. The values will be validated when you 
click OK, if the "Validate IER Values" checkbox is selected.

Size—This is the size of the IER. For data IERs, the size is specified in 
bytes. For voice or VTC IERs, the size is specified in number of seconds. 

Interarrival(s)—Represents the time, in seconds, between IER firings. 

Start Time—Identifies the time, in seconds, in which the IER will begin 
firing after a simulation begins. 
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Stop Time—Identifies the time, in seconds, in which the IER will stop 
firing after the simulation begins. 

6) Record Route Interval (sec)—Set the interval at which you wish to record 
IER routes during a simulation: Never (default), All (record all IER firings), 
Once (record only the first firing), or enter an integer in seconds.

7) Application Delay Tracking checkbox—If selected, enables application 
delay tracking. 

8) Export Reports checkbox—If selected, enables exported reports. 

9) Validate IER Values checkbox—If selected, performs a continuous 
validation of IER values. 

10) Click OK to create the specified IER. 

IERs > Deploy IERs
(Advanced)

Traffic > IERs > Deploy IERs (Advanced) Launches the IER Rapid Deployment 
wizard, shown below, which allows you to create IERs for the entire scenario.

1) Choose Traffic > IERs > Deploy IERs (Advanced). The IER Rapid 
Deployment Wizard displays.

Figure 3-179   IER Rapid Deployment Wizard

2) Specify traffic type, equipment type, and classification to be used for the 
IERs to be created. These properties are used to filter the list of possible 
producer and consumer devices. The set of possible values for these 
properties is obtained directly from the IER demand object, and the 
Decision Table entries from the IER Firing Rules table are used to filter the 
Equipment list based on the chosen Traffic Type.
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3) Define the scope of the deployment, choosing from the following options:

— Full Mesh: Creates a mesh of bi-directional IER pairs among all devices 
that support the specified IER Type, Equipment, and Classification.

Note—A mesh is not created for intra-OPFAC IERs.

— To all other devices from a selected device: Creates individual IERs 
between the selected producer and all other devices that support the 
specified IER configuration and are not in the same OPFAC as the 
producer.

— From all other devices to a selected device: Creates individual IERs 
between all devices that support the specified IER configuration and the 
selected consumer, provided that they are not in the same OPFAC as the 
consumer.

— Multi-consumer IER: Creates a single multi-consumer IER between the 
selected producer device and all other devices in the scenario that 
support the specified IER configuration and are not in the same OPFAC 
as the producer.

a) If you choose the Select Other Devices checkbox and click Next, the 
following dialog box appears. The tree is filtered to show only devices 
that support IERs with the specified type, equipment, and classification 
settings. Select as many devices from this tree as desired and click Next. 
Those devices will be used when creating IERs according to the 
deployment scope you chose.

Figure 3-180   IER Wizard: Choose Devices Dialog Box

When you click Next, either on the initial wizard screen or on the Choose 
Devices dialog box, you will go to the IER dialog box shown in Figure 3-178 on 
page JCSS-3-157. Follow the instructions that accompany that figure to 
complete the IER deployment.
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IERs > Edit All Traffic > IERs > Edit All IERs Display all IERs in a scenario in the IERs dialog 
IERs box for viewing and editing. 

Figure 3-181   IERs Dialog Box 

1) Average Data Traffic and Voice traffic fields-Displays the average size or 
duration and total load values for the Data and Voice categories. 

2) IERs list box-Edit attributes of IERs. 

3) Click Delete to delete the selected IER. 

4) Click Refresh Aggregate Loads to update aggregate loads in the view. 

5) Click OK to save your IER edits. 

IERs > Edit IERs for
Selected Objects

Traffic > IERs > Edit IERs for Selected Objects Display and edit a list containing 
all IERs associated with any subnet, node or demand that is selected in the 
workspace or Network Browser 

IERs > Create
Thread

Traffic > IERs > Create Thread Create and edit IER threads beginning with any 
IER in the scenario.

1) Select one of more IERs in the workspace or Network Browser. 

2) Choose Traffic > IERs > Create Thread. The Thread dialog box displays. 
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Figure 3-182   Thread Dialog Box

3) Specify the ID and segments of the thread: 

4) Click Insert to add segments to the thread. If one or more cells are selected 
in the table, clicking Insert adds a default segment in the row above the 
selected highest cell.  If no cells are selected, the segment is added at the 
end of the thread. You can also simply edit a cell in the last row of the table 
to add a segment to the end of the thread. 

5) Click Delete to remove segments from the thread. Delete is active only 
when cells are selected in the table. Clicking Delete removes all rows with 
selected cells. 

6) Click OK to save the thread. 

IERs > Edit All
Threads

Traffic > IERs > Edit All Threads Display and edit a table containing all threads 
in the scenario. 

IERs > Edit Threads
for Selected Objects

Traffic > IERs > Edit Threads for Selected Objects Display and edit a list 
containing all threads associated with any subnet, node or demand that is 
selected in the workspace or Network Browser.

IERs > Import >
Import IER Text File

Traffic > IERs > Import > Import IER Text File In the Import IER Text File dialog 
box, select an IER Text File (*.txt) to import, and then click OK. 

IERs > Import >
Import IER Report

Traffic > IERs > Import > Import IER Report In the Import IER Report dialog box, 
select an IER Report File (*.txt) to import, and then click OK. 
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IERs > Import >
Threads from ACE

Analyst

Traffic > IERs > Import > Threads from ACE Analyst Opens the ACE to 
Threaded IER Conversion Wizard with which you can convert application 
transaction traffic from ACE or ACE Whiteboard files to IER threads in the JCSS 
Scenario Builder.

1) Choose Traffic > IERs > Import > Threads from ACE Analyst. The ACE to 
Threaded IER Conversion Wizard opens.

Figure 3-183   Import Threads from ACE Analyst Wizard

2) Click the Add Application Transaction... button to identify an ACE (atc.m) or 
ACE Whiteboard (aed.m) file to convert. A file chooser window opens. 
Select a file and click Open. The selected file appears under the 
Transaction Traffic column of the table

Figure 3-184   ACE to Threaded IER Conversion: Specify Application 
Transactions
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a) Application Name—Contains unique name <ApplicationN>, in which N 
is a number appended to make the name unique, is created for each 
application.

b) Transaction Traffic—Contains the name of the ACE or ACE Whiteboard 
file you selected.

c) Aggregation—Specifies the aggregation parameter values used while 
converting the traffic into IER threads. Aggregation parameters are 
defined in terms of application turns. An application turn is defined as a 
change in the flow of the application message. For example two 
consecutive application messages from a source to destination and vice 
versa defines a single application turn.

By default, if the selected file is an ACE file, then the corresponding 
Aggregation column value is set to Default. If the selected file is an ACE 
Whiteboard file, the corresponding Aggregation column value is set to 
None. You can change the Aggregation value by clicking in the column 
and selecting Default, None, or Edit... If you choose Edit..., another 
dialog box appears, which lets you specify how aggregation is to be 
handled. When finished, click OK to return to the previous dialog box.

Figure 3-185   Application Turn Aggregation Parameters

Enable Intra-turn Aggregation Only aggregates all the contiguous 
messages that flow from same source to the same destination. Each of 
the contiguous set of messages within an application turn is converted 
into a single IER of size and processing delay equal to the sum of the 
constituent messages.

Enable Inter-turn Aggregation (includes intra-turn) implicitly enables 
and applies intra-turn aggregation to the application messages. The 
resulting intra-turn aggregated application messages are further 
aggregated across multiple contiguous application turns as specified by 
the inter-turn aggregation parameters. You can include an unlimited 
number of turns to aggregate, or you can specify an odd number of turns 
to aggregate.

If you make any edits to the 
aggregation parameters, 
you will be asked whether to 
apply the changes and 
continue or go back to Save 
As a file for later re-use.
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d) Start Time—Specifies the thread start time. This value is set to Default, 
but you can change this value to an integer in seconds. The Default 
value corresponds to the default value of the Generation Parameters > 
Start Time attribute of the IER_demand Traffic Flow model. If you 
specify a value under this column, the value is then set to the Generation 
Parameters > Start Time attribute of the start segment/IER of the IER 
thread.

3) Click Next. The Assign Producers and Consumers to Application Tiers 
dialog box appears. 

Figure 3-186   Assign Producers and Consumers to Application Tiers

4) Assign producers and consumers for each threaded IER. You can add new 
devices or OPFACs in the workspace and return to the Assign Producers 
and Consumers dialog box. If you do so, click the Refresh button to refresh 
the listing.

For each application, the wizard creates one tier group, which you must 
define. If the same application needs to be deployed on a different tier 
group or on the same tier group with different settings, you need to create 
a new tier group by selecting the Create new group option from the Tier 
Group selection drop-down menu. Select a Tier in the left-side pane and 
select a tier in the right-side pane. Use the << or >> button to make the 
connection. 

If you need to create a new tier group for 
application mapping, use the drop-down 
Tier Group menu option, as shown.
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a) Select the “Launch IER Thread Pre-deployment Editor following 
conversion” if you want to visualize the IERs prior to final deployment 
into the workspace. Use the pre-deployment editor to validate the 
conversion for simple application transactions, edit the appropriate IER 
attributes, and/or manually select and aggregate the application 
messages/IERs. 

b) Use the Advanced Options... button to further specify aggregation or IER 
attribute options for a tier group prior to deployment. Click OK when 
finished.

Figure 3-187   Advanced Options for a Tier Group

5) (Optional) Review the IERs in the Pre-Deployment Editor. Make changes 
as necessary.

6) Click Finish to deploy the IERs.

IERs > Export IER
Report

Traffic > IERs > Export IER Report Export all traffic in the scenario (excluding 
threads) to a text file. 

Flows Traffic > Flows > (option) View and edit traffic flows in your network. Threads 
are groups of IERs that are fired in segments. Threads are a conditional 
sequence of IERs that represent complex real world information exchanges.

Flows > Open Flows
Browser

Traffic > Flows > Open Flows Browser Opens the Traffic Center, which allows 
you to view and edit traffic flows in your network.

Flows > Import Traffic > Flows > Import > (option) The Import sub-menu contains operations 
related to importing traffic.

Note—For more information about this feature, please refer to the OPNET IT 
Guru documentation set, available via Help > Documentation > IT Guru 
Documentation.)
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What follows below is a sample workflow for importing Cisco Netflow traffic files; 
workflows are similar for the other data sources listed on the Traffic > Flows > 
Import submenu; however, there may be subtle differences. 

Netflow Import Process 

The traffic import for Netflow traffic files involves a two-step process. The first 
step involves the conversion of the traffic information included in the Netflow 
traffic file into traffic profiles for the appropriate nodes in the network while the 
second step involves converting the imported flow profiles into JCSS-specific 
traffic. 

During the first step, each line in the Netflow traffic files is integrated into a traffic 
profile based on parameters such as the source and destination IP addresses 
and the aggregation scheme. Thus, if there are multiple lines in the file that have 
the same values for source, destination and aggregation scheme, then these 
lines will be integrated into a single traffic profile by the software. In the second 
step, each flow profile is converted into a single IER using the information that 
you provided in the Traffic Import Defaults dialog box. 

The average size for the IER is calculated based on the total number of packets 
and total number of bits of the traffic profile while the inter-arrival time is 
calculated based on the difference between start and stop times and the total 
number of packets. 

The minimum inter-arrival time, displayed in the Traffic Import dialog box, is 
used for those IERs where the calculated inter-arrival time is less than the 
user-specified minimum. In this case, the average size of the IER is increased 
proportionately. For example, if you specified inter-arrival time is 1 sec and the 
calculated inter-arrival time is 0.0002 secs, then the calculated average size is 
multiplied by the ratio of the user-specified minimum and the calculated 
inter-arrival time (1/0.0002) to get the new average size (new avg size = avg 
size x 1/0.0002). 

If the calculated inter-arrival time is greater than the user-specified inter-arrival 
time, the calculated average size is not modified. For the case where the 
user-specified value for the minimum inter-arrival time is greater than the 
difference between the start and stop times, the size is computed based on the 
total number of bits and this IER is sent only once during the simulation. 

1) Collecting Netflow Traffic Data 

The first step in importing traffic data is capturing or creating the Netflow 
traffic data file(s) to be imported. When capturing the Netflow traffic data, 
please ensure that the Netflow data file meets the following requirements: 

a) The data file must use one of the following aggregation schemes: 

RouterAS or RouterPrefix 

CallRecord or DetailCallRecord 
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AsHostMatrix or DetailHostMatrix 

b) The file may use either Format A or Format 2. 

c) The file must be an uncompressed ASCII file. You may need to manually 
uncompress a file and/or convert it from binary to ASCII before you can 
import it. 

d) The file must have a four-digit extension where the extension follows the 
"MMSS" (mins-secs) format. 

e) The header of the file must include the correct format type, i.e. if the file 
is of Format A then the format field in the header must say Format A and 
not Format 2. 

f) The number of records in the file must match the number of records 
specified in the header of the file. 

If the header of the file is incorrect, the Start and End times in the Import 
Traffic Flows dialog box will be set to Jan 1, 1970. 

For additional details, please refer to the Traffic Import section in the MVI 
User's Guide of your Modeler documentation. 

2) Getting Started 

To import traffic from Cisco Netflow traffic files, a project must currently be 
open in the Scenario Builder. Once a project has been loaded, start the 
import process by choosing the Traffic > Flows > Import > From Cisco 
Netflow menu item. Note that this menu item will be disabled (grayed out) 
if no project is open. 

3) Deleting Previously Imported Netflow IERs 

If you already performed a Cisco Netflow traffic import and chose to save 
the IERs created from that import, the software launches the following 
dialog box. This dialog box provides you with the option to delete all those 
IERs that were created as a result of previous Cisco Netflow traffic data 
imports. 

4) Specifying the Traffic Import Defaults 

The Traffic Import dialog box displays. Specify values for the parameters 
required in converting the imported flow profiles into IERs. 
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Figure 3-188   Traffic Import Dialog Box

The minimum inter-arrival time is used for those IERs where the calculated 
inter-arrival time is less than the user-specified inter-arrival time. When this 
occurs, the average size of this IER is increased proportionately. If the 
calculated inter-arrival time is greater than the user-specified inter-arrival 
time, the average size computed from the flow profile is not modified. For 
the case where the user-specified value for minimum inter-arrival time is 
greater than the difference between the start and stop times, the size is 
computed based on the total number of bits and this IER is sent only once 
during simulation. 

5) Choosing the Netflow File 

After selecting the OK button in the Traffic Import dialog box, the Traffic 
Flows Import dialog box will be launched. Click the + signs for all the 
subdirectories that appear under the Netflow directory. Click the 
10.0.0.1.0000 traffic file that is included in the ASHostMatrix directory. 

The directory that appears in the Traffic Flows Import dialog box is 
determined by the traffic_archive_dir preference that may be set via the 
Preferences dialog box. By default, this preference is set to the 
…\User_Data\Traffic_Data directory on your machine. 

6) Add and/or remove directories and/or servers from the Traffic archive 
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Figure 3-189   Traffic Flows Import Dialog Box 

7) Specifying the Netflow Traffic Import Parameters 

The Archive information corresponds to each traffic archive file and 
provides identifying information about the file: 

a) Host - Specifies the IP address of the probe. 

b) Media - The type of NetMetrix probe (Ethernet, FDDI, etc.) used to 
collect network traffic. 

c) Device - The name of the NetMetrix probe. 

d) Start - The start time of the traffic capture period. 

e) End - The end time of the traffic capture period.

f) Interval - The amount of time between traffic collections. 

The remaining sections include the following options that control the traffic 
import: 

a) From - Indicates the start time of the period of traffic to import. 

b) To - Indicates the end time of the period of traffic to import. 

c) Data Source Time Zone - Indicates the time zone. 

d) Multiple archive alignment - Indicates whether JCSS aligns or 
concatenates multiple archives from a single traffic server. This menu 
has three options: 
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Align Start of Each Archive - Each archive is aligned so that all traffic 
starts simultaneously (at simulation time = 0) and runs concurrently. This 
option is useful for archives from separate network probes that started 
simultaneously. 

Align Archives Based on Time Stamps - The traffic is aligned based on 
the time stamps in each archive to replicate its real-world behavior. This 
option is useful for archives (from separate probes) that have 
overlapping time frames but did not start simultaneously. 

Concatenate Archives - The archives are aligned by start time so that 
traffic runs consecutively: the traffic for each subsequent archive follows 
the traffic in the preceding archive. This option is most useful if you made 
successive runs from a single network probe. 

e) When duplicate data from different sources exists use the - Indicates 
what merging mode to use when (1) you are importing from multiple 
traffic files, or, (2) you choose to retain (not overwrite) the current traffic 
data in your scenario. In both these cases the merge mode resolves any 
conflicting data in multiple traffic sources. Merging is useful when you 
have nodes on different segments, and probes on each segment as well. 
When nodes send traffic to one another, the probe on each segment will 
record the traffic, so that multiple values for the same traffic will be stored 
in the archive file. During import, you can set the Archive Merging Mode 
option either to Maximum, Addition, or Minimum. Setting the merge 
mode to Maximum selects the maximum of the two traffic values during 
import (this setting is most commonly used), while setting Minimum 
selects the smaller of the two traffic values. Choosing Addition adds the 
two traffic values. 

f) Traffic Preprocessor - This menu lets you import traffic archives that use 
ASCII formats unsupported by JCSS. You can create preprocessor 
scripts (either shell scripts or executable files) that convert a traffic file to 
a format that JCSS can import. By selecting an archive and then 
choosing a preprocessing script in this menu, you can automatically 
convert the archive to Flexible CSV (.tr2) format prior to the import. Note 
that you cannot assign a script to multiple archives-you must assign a 
script to each archive individually. The initial setting for all archives is 
None. This tells JCSS to import the files "as is," and is the correct setting 
for CSV, NetMetrix and Sniffer files. 

g) Import threshold - Specifies the import threshold in average octets per 
second. 

h) Aggregation options - Allows you to specify the method by which to 
aggregate traffic. 

Select the Import button to proceed with the traffic import process. 
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8) Unrecognized Traffic 

If OPNET could not map all the imported traffic to specific nodes in the 
network/scenario, the Unrecognized Traffic Assistant dialog box displays. 
You may then manually specify sources and/or destinations for any 
unrecognized traffic. 

Figure 3-190   Unrecognized Traffic Assistant Dialog Box 

For the cases where the exact source and destination nodes for the 
unrecognized traffic are unknown, you may assign certain nodes in your 
network to be edge devices. Specifying edge devices in your network will 
route this unrecognized traffic randomly between the edge devices in your 
network. 

After you finish mapping some/all of your unrecognized traffic, select the 
Close button in the Unrecognized Traffic Assistant dialog box. The 
Remaining Unrecognized Sources dialog box displays, prompting you for 
confirmation to proceed with the traffic import. 

Figure 3-191   Remaining Unrecognized Sources Dialog Box

Selecting Yes in this dialog box launches the Reimport Traffic dialog box, 
giving you the option of re-importing all the traffic in this network
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Figure 3-192   Reimport Traffic Dialog Box

If you click the Yes button, the Import Flows dialog box will be displayed again 
and this time choosing the Import button will include all of your recognized traffic 
as well as any unrecognized traffic that was mapped using the Unrecognized 
Traffic Assistant. Clicking the No button will not include any unrecognized traffic 
that was mapped during the import.

9) Examining the IERs

After the traffic import is complete, a message indicating the number of 
IERs created from this traffic import displays in the message buffer at the 
bottom right corner of the Scenario Builder.

The IERs created from this import are populated as background IERs on 
the source node and therefore may be viewed using the View Traffic dialog 
box. The View Traffic dialog box is accessible both from the Define 
Infrastructures treeview as well as from the right-click menu option of an 
OPFAC.

IERs created from a Cisco Netflow traffic import are tagged with DMD_CNF 
in their IER ID.

10) Visualizing the IERs

To view these IERs in your workspace, zoom in so that your units are visible 
and select the Traffic > Show Aggregate Traffic option.

Flows > Import >
Open Import Log

Traffic > Flows > Import > Open Import Log Opens the traffic flow import log, 
which contains error and diagnostic information generated during previous 
imports.

Flows > Import >
Clear Import Log

Traffic > Flows > Import > Clear Import Log Clears the link load import log.
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Flows > Export > To
Spreadsheet

Traffic > Flows > Export > To Spreadsheet Exports traffic flows to an ASCII file 
that can be viewed as a spreadsheet in Microsoft Excel. 

Figure 3-193   Export Traffic Flows Dialog Box

These options allow you to set parameters for the exported traffic: 

• Specify calendar time checkbox and drop-down menu: Sets the start time of 
the traffic that the file spans. The time steps reference this date and time in 
the file. The default is determined by the earliest time set in all existing traffic 
pairs, network base time, or current time. To specify a date and time other 
than the default, select Choose date/time from the Specify calendar time 
drop-down menu. The Set Date/Time... dialog box appears. Select a date 
and time and click OK. 

• Traffic Duration field: Sets the total time the traffic file spans. It is determined 
by the length of the conversation pair traffic in the scenario. 

• Time Step field: Sets the bucket size of the exported traffic. 

• Traffic Units drop-down menu: Lists the units of the exported traffic. This is 
specified in bits/sec, Kbits/sec, Mbits/sec, or Gbits/sec. 

• Export traffic only for selected nodes check box: When selected, only traffic 
for selected nodes in the scenario is considered for export. When unselected 
traffic for all nodes is considered for export. This option is useful when you 
want to view and edit traffic for a few objects. 

• Export node pairs that have no traffic flows check box: When selected, the 
entire matrix of node pairs is exported, including node pairs that have no 
traffic flows. When unselected, only node pairs that have traffic flows 
between them are exported. 

• Display file in spreadsheet program check box: When checked, the exported 
traffic file displays automatically in the program specified by the 
spreadsheet_prog preference (environment attribute). 
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• Export node names check box: Exports full hierarchical node names with the 
traffic data. If unchecked, node names are only exported if IP address 
information is missing. Including the node names with the export data affects 
the import of the data. The import engine attempts to match the traffic flow to 
its endpoints based on node name first, if available. If that lookup fails, then 
the endpoint IP addresses are used for matching. 

• Export button: Accepts the current export settings, exports to a spreadsheet 
program, and closes the dialog box. 

Flows > Export > To
TR2

Traffic > Flows > Export > To TR2 Exports traffic flows to a TR2 (*.tr2) text file. 

Flows > Merge
Traffic Flows

Traffic > Flows > Merge Traffic Flows Combine selected traffic flows that have 
common endpoints only or common endpoints and specific characteristics. This 
operation is useful when you have multiple flows between the same 
node/destination and you want to reduce the number of flow objects in the 
scenario. 

Figure 3-194   Merge Traffic Flows Dialog Box 

1) Choose one of the two radio buttons (and select the matching 
characteristics for the second radio button) to combine traffic flows with 
common end points based on the selection. 

2) Click OK to merge the selected traffic flows based on the criteria set by this 
dialog box. 

Flows > Create
Flows

Traffic > Flows > Create Flows Create IP traffic flows, which represent 
background traffic, between all or selected nodes in the network. The traffic 
flows can be a full mesh between all or selected nodes, or can be from one node 
to the remaining selected nodes (or all nodes in the case of no selection). In the 
latter case, you can specify the direction of the traffic. 

This feature filters out all IP nodes in the network and provides a list of eligible 
nodes for which you can configure the flows. The traffic can also be specified in 
bits/packets. 
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Figure 3-195   Create IP Unicast Traffic Flows Dialog Box 

in order to prevent duplication of traffic during simulation. It is recommended 
that a duplicate scenario be created prior to using this feature if you want to keep 
the application and profile configurations for later use.  The following dialog box 
displays to input the required flow generation parameters. 
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Device /Link Loads >
Import

Traffic > Device/Link Loads > Import > (option) The Import sub-menu contains 
operations related to importing background traffic loads on devices and links; 
consult the IT Guru documentation set, available via Help > Documentation > IT 
Guru Documentation, for further details. The following options are available 
from the sub-menu:

Device /Link Loads >
Open Import Log

Traffic > Device/Link Loads > Open Import Log Opens the traffic flow import log, 
which contains error and diagnostic information generated during previous 
imports.

Device /Link Loads >
Clear Import Log

Traffic > Device/Link Loads > Clear Import Log Clears the link load import log.

Convert Traffic >
Applications to

Flows

Traffic > Convert Traffic > Applications to Flows Automatically convert standard 
OPNET application and profile configuration parameters into IP flow objects. 
This process turns the discreet application traffic into background flows for use 
in simulation or traffic visualization. After creating the flows, the application and 
profile configuration objects are cleared of all traffic information in order to 

Table 3-4 Device Link Loads > Import Sub-Menu Items

Menu Item Description Reference

From CA eHealth Imports the background traffic load in a 
device or link from CA eHealth. (XDI 
module only)

XDI User’s Guide: Importing 
Device/Link Loads

From MRTG Imports the background traffic load on a 
device or link from MRTG traffic file. 
(XDI module only)

XDI User’s Guide: Creating MRTG 
Link-Load Data

From InfoVista Imports the background traffic load on a 
link from InfoVista reports. (XDI module 
only

XDI User’s Guide:Creating InfoVista 
Link-Load Data

From HP OpenView Performance 
Insight

Imports the background traffic load on a 
link from HP Openview Performance 
Insight reports. (XDI module only)

XDI User’s Guide:Creating HP 
Openview Link-Load Data

From Text Files Imports the background traffic load on a 
device or link from ASCII (.gbu) traffic 
files.

XDI User’s Guide: Importing 
Device/Link Loads
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prevent duplication of traffic during simulation. It is recommended that a 
duplicate scenario be created prior to using this feature if you want to keep the 
application and profile configurations for later use. The following dialog box 
displays to input the required flow generation parameters.

Figure 3-196   Convert Applications to Flows Dialog Box

As shown above, the required parameters include:

• Start-Time (Hours, Minutes, Seconds): The start-time of the flow objects. 
This will effectively act to truncate all flow traffic recorded prior to the value 
provided. The flow’s bps and pps values during this time will be set to 0.0. 
The input values must be integers.

• Duration (Length, Units): The duration of the simulated calculation window. 
This method corresponds to the Capacity Planning Optimization feature. The 
input value must be an integer. Flows will be aggregated for any 
source/destination pair. Thus, any number of applications that contribute to 
traffic between a given client and server will be aggregated into two flows 
with one for each direction of travel.

Generate Traffic Web
Report

Traffic > Generate Traffic Web Report Launch the most recent Traffic web report 
which details all of the different types of traffic contained in the scenario.

Import Node Aliases
> From Text File

Traffic > Import Node Aliases > From Text File... Select a file from which to 
import node aliases into a scenario.

Export Node Aliases
> To Text File

Traffic > Export Node Aliases > To Text File... Export node aliases from a 
scenario to a text file. Edit the aliases using a spreadsheet program like Excel, 
and then import the aliases back into a scenario.



3—Scenario Builder

JCSS/Release 10.0 JCSS-3-179

Protocols Menu 

The Protocols menu contains operations related to the various protocols 
supported in the standard and specialized model libraries. The protocols are not 
documented in this manual; please refer to the OPNET documentation listed for 
each menu option below (consult the IT Guru documentation set, available via 
Help > Documentation > IT Guru Documentation): 

Table 3-5   Protocols Menu Items

Menu Item Description Reference

Applications Adds ACE application 
models to the existing 
network and configures 
application traffic.

Model User Guide

Servers Manages server models Model User Guide

Mainframes Manages mainframe models Model User Guide

TCP Configures TCP Model User Guide

IP Configures IP addresses, 
dynamic routing protocols, 
type of service 
characteristics for 
conversation pair traffic, 
autonomous system 
numbers on routers, and 
ping traffic.

Model User Guide

Link16 Configures/assigns Time 
Slot Blocks (TSBs) on 
terminals in the network.

Model User Guide

IPv6 Configures IPv6 addresses, 
routing protocols, interface 
status, and runs readiness 
assessment and migration 
planner.

Model User Guide

BGP Configures BGP start time, 
autonomous system 
numbers, and route 
redistribution from other 
protocols into BGP.

Model User Guide

EIGRP Configures EIGRP start time 
and route redistribution from 
other protocols into EIGRP.

Model User Guide

IGRP Configures IGRP start time 
and route redistribution from 
other protocols into IGRP.

Model User Guide
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IS-IS Configures interface metrics, 
interface circuit types, 
system types, metric styles, 
and SPF calculation 
parameters.

Model User Guide

OSPF Configures interface cost, 
OSPF start time, areas, and 
route redistribution.

Model User Guide

RIP Configures RIP start time 
and route redistribution from 
other protocols into RIP.

Model User Guide

MPLS Configure MPLS Model User Guide

LDP Enables/disables LDP 
protocol status on 
all/selected routers.

MPLS Model User Guide

RSVP Enables/disables RSVP 
protocol status across 
connected interfaces on 
all/selected links.

Model User Guide

ATM Configures oversubscription 
on a per-service class basis 
for all or selected nodes in 
the network.

Model User Guide

Frame Relay Configures PVCs between 
nodes in the network

Model User Guide

Ethernet Configures Ethernet Model User Guide

FDDI Configures FDDI Model User Guide

VLAN Configures virtual LANs 
(VLANs) for selected nodes 
and links.

Model User Guide

STP Applies STP visualization to 
the current scenario.

VLAN Model User Guide

MANET Configures MANET DSR Model User Guide

Table 3-5   Protocols Menu Items (Continued)

Menu Item Description Reference
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Capacity Planning Menu 

Evaluate Capacity Planning > Evaluate or click the Evaluate Current Network toolbar 
button: Evaluate the scenario in its current state during the specified time 
interval or intervals. This is different from running an optimization in that it 
evaluates the scenario with the current capacities for links and networks. It does 
not mutate the capacities of the links and networks. It routes the traffic through 
the links and broadcast networks, and provides a summary of the scenario's 
current condition. 

1) After choosing the Evaluate menu item or clicking the Evaluate Current 
Network toolbar button, the Evaluation Settings dialog box displays. 

Figure 3-197   Evaluation Settings Dialog Box 

The Evaluation Settings dialog box allows you to set the number of time 
steps, length of each time step, and the start time. For example, if you know 
that your peak usage occurs from 9 A.M. to noon, you could evaluate that 
time period by setting number of time steps to 3, length of time step to 1 
hour, and start time to 9 hours 0 minutes 0 seconds. 

You can set the following parameters for the evaluation: 

a) Number of Time Steps: A Capacity Planning Evaluation can be done for 
multiple time steps by setting this value to an integer greater than one.  
Reports will be created for the evaluation at each time step as well as 
reports reflecting results over the entire time of evaluation. Must be an 
integer greater than zero. 

SIP Allows visualization of SIP 
signaling routes after 
running Discrete Event 
Simulation

Model User Guide

UMTS Configures UMTS Model User Guide

Wireless LAN Configures wireless LAN Model User Guide

ZigBee™ Configures ZigBee™ Model User Guide

Table 3-5   Protocols Menu Items (Continued)

Menu Item Description Reference
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b) Length and Units of Time Steps: The length and units of the time steps 
used in the evaluation. The value selected must be an integer greater 
than zero. Units can be seconds, minutes, hours, days or weeks. 

c) Start Time: The start time used for the evaluation in hours, minutes and 
seconds. All values must be integers greater than or equal to 0. 

d) Advanced Parameters: Opens a dialog box for more parameters for the 
evaluation and reporting of the evaluation. 

e) Click the Apply button to save any changes you made to the settings. 

2) If you click the Advanced Parameters button to access advanced 
evaluation settings, the Evaluation Settings Advanced dialog box displays. 

Figure 3-198   Evaluation Settings Advanced Dialog Box 

You can set the following advanced parameters for the evaluation: 

a) Naming Convention: The names of all the devices and links that are in 
the report will use the naming convention selected here. 

b) Include Web Reports: If this option is selected, the link and circuit traffic 
reports are also selected. Unchecking this will disable the options for the 
individual reports. 

c) Include Individual Link Traffic Reports: If this option is selected, 
individual reports will be included in the web report for each link in the 
scenario.  The reports will include all the traffic going directly over the link 
as well as any circuits that are going over the link.  The reports will take 
longer to generate if this option is selected. 

d) Include Individual Circuit Traffic Reports: If this option is selected, 
individual reports will be included in the web report for each routable 
circuit.  The reports will include all the traffic using the circuit.  The 
reports may take longer to generate if this option is selected. 
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e) Enable IP Load Balancing: If this checkbox is selected, IP load balancing 
will be done during the evaluation so that traffic will use multiple equal 
hop length paths. 

f) Number of Balanced Routes to Report: If IP load balancing is selected, 
then the number of balanced routes to report can be selected. The entry 
must be an integer greater than 0.  This number of route reports will be 
reported in the web reports 

g) Allow ATM SVCs to be Setup: If this checkbox is selected, ATM SVCs 
will be setup during the evaluation when applicable. 

h) Click the OK button to save any changes you made to the settings. 

3) Once everything is set, click the Run button in the Evaluation Settings 
dialog box to start the evaluation. 

The evaluation engine evaluates the specified number of time steps using 
only the traffic, circuits, devices, and links active at each time step. For 
traffic that is active during only a portion of the time step, the load will be 
prorated according to the fraction of the time step the traffic is active. 
Circuits, devices, and links will be considered active only if they are active 
at the end of the time period. 

4) Once the evaluation is complete, the evaluation web reports launch 
automatically. 

The web reports include the following reports for the overall evaluation: 
Executive Summary, Overall Peak Results, and Overall Average Results. 
Additionally there are a group of reports which are generated for each time 
step: Traffic Report, Link Utilization Report, Residual Bandwidth Report, 
Circuit Switch Link Report, Transmission Link Report, Data Link Report, 
ATM & CellXpress TVC Report, Frame Relay Report, TSSP Circuit Report, 
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and Multiplexer Circuit Report. There are also Route Reports for each 
routed circuit and traffic IER, and Unroutable Reports for each unroutable 
circuit and traffic IER. Each Individual Link also has a group of tables that 
show the circuit and traffic IERs which flow over it specifically. 

If a load object (IER, IP Flow, Promina circuit, etc.) is unroutable, the 
Unroutable Report will list reasons why the load could not be routed.  The 
following table lists all possible failure messages and their associated 
suggestions.: 

Table 3-6   Route Failure Messages and Suggestions 

Message Suggestion

There was no path at the Promina layer. Make sure all of the necessary links between 
Promina devices have been added to the 
scenario. Also, check for lower-level 
CellXpress circuit failures that could prevent 
Promina devices from communicating.

There was no path at the ATM layer. Make sure all of the necessary links between 
ATM devices have been added to the 
scenario.

There was no path at the Frame Relay 
layer.

Make sure all of the necessary links between 
Frame Relay devices have been added to the 
scenario.

There was no path at the Voice layer Make sure all of the necessary links between 
Voice devices have been added to the 
scenario. Also, check for lower-level Promina 
circuit failures that could prevent Voice 
devices from communicating.

There was no path at the IP layer. Make sure all of the necessary links between 
routers have been added to the scenario. 
Also, check for lower-level circuit failures that 
could prevent IP routers from communicating.

An end device that can support this IER 
could not be located in the producer or 
consumer OPFAC.

Make sure the source and destination 
OPFACs both contain a non-failed end device 
that supports the IERs traffic type.

There was a mismatch in the number of 
layer 3 encryptors and decryptors in this 
route.

Make sure each layer 3 encryptor (NES, 
IP_ATM_TACLANE, etc.) has a 
corresponding decryptor.
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Capacity
Optimization

Capacity Planning > Capacity Optimization > (option) Run an optimization for 
capacity. Given a network and the traffic, the optimization process provides 
suggestions for optimal link and network capacities. If a link is over-utilized, 
optimization will suggest an alternate capacity that will support the IERs and 
keep the cost of the link down to the required minimum. If a link is under-utilized, 
optimization will decrease the capacity for that link. Capacity optimization 
options are discussed in the sections below.

Application profiles are converted to IERs when a user evaluates or optimizes a 
scenario for the first time. Once the profiles have been converted to IERs, they 
are retained as IERs. The conversion process is not initiated again unless you 
add more application profiles.

Capacity
Optimization > Start

Optimization

Capacity Planning > Capacity Optimization > Start Optimization Specify 
parameters that control how optimal solutions for the scenario are computed.

1) Select Start Optimization or click the Start Capacity Optimization toolbar 
button: The Capacity Optimization Settings dialog box displays.

Selected path for Promina circuit is invalid. Make sure all necessary links between 
Prominas in the Selected Path have been 
added to the scenario. Also, check for 
lower-level CellXpress circuit failures that 
could prevent Promina devices from 
communicating.

Selected path for Promina circuit does not 
have sufficient bandwidth.

Increase the capacity of the links between 
Prominas in the selected path, or add 
additional links between the Prominas.

<xxx> circuit does not have enough 
bandwidth.

Increase the reserved bandwidth of the 
circuit.

<link_name> does not have enough 
bandwidth.

Increase the capacity of the link or add an 
additional link between the endpoints.

Table 3-6   Route Failure Messages and Suggestions (Continued)

Message Suggestion
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Figure 3-199   Capacity Optimization Settings Dialog Box 

These options let you set optimization parameters: 

a) Time Settings: Allows you to specify the start time and the duration for 
the optimization process. Only traffic that is active during the specified 
time frame is considered while optimizing. 

b) Voice and Data Target Utilization: Specifies the average percentage 
utilization we are trying to achieve on the voice and data portions of the 
trunks. 

c) Maximum Utilization: Specifies the maximum percentage utilization we 
are trying to achieve on the voice and data portions of the trunks. 

d) Link Goals, Traffic Load, and Performance Weights: 

Link Goals: This value allows you to optimize for different criteria. If you 
want to minimize the capacity, move the slider to the left (towards 
Capacity). This will produce a final solution in which the capacity is 
reduced. If the target utilization is more important to you, move the slider 
to the right (towards Utilization). This will produce a final solution in 
which the link utilization values are closer to the target. 

Traffic Load: This value allows you to control the load caused by the 
traffic on the network. If you set this value to 1, the engine uses the mean 
values from the distribution. As you increase this value, the engine uses 
values from the tail of the distribution. If the distribution type is 
"Constant," this parameter does not make a difference. 

Performance - This value allows you to specify how fast or how accurate 
you want the optimization solution to be. If you set this slider at 1, the 
engine converges on a solution quickly at the cost of accuracy. If you set 
this slider at 10, the engine tries more configurations and the solution 
may be better, but it will take longer. 

2) Click the Advanced Parameters button on the Capacity Optimization 
Settings dialog box. The Advanced Parameters dialog box displays. 
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Figure 3-200   Advanced Parameters Dialog Box 

Configure advanced parameters, if needed, or use the default values: 

a) Random Seed: This is the seed value used by the random number 
generators in the optimization engine. 

b) Unroutable Demand Penalty: This is the penalty that will be added to the 
optimization cost for each IER that is unroutable in this configuration. 

c) Number of Solutions to Store: The optimization engine stores the 
configurations corresponding to the 'n' best solutions and you can switch 
back and forth between these solutions. This value specifies the number 
of such solutions to store. 

d) Penalize Underutilization: The utilization cost depends on the difference 
between actual link utilization and target utilization, regardless of 
whether link utilization is over or under target utilization. 

e) Allow ATM SVCs to be Setup: By not allowing ATM SVCs to be setup, 
you are forcing the Scenario Builder to always look for PVCs between 
gateway ATM devices. In this case, the route taken by the IER in the 
Scenario Builder will be the same as that in the simulation. 

f) Enable IP Load Balancing: Allows you to disable or enable IP load 
balancing to be done during the evaluation so that traffic will use multiple 
equal hop length paths.

g) Per Hop Cost: This is a fixed cost that is computed for each load based 
on the number of device-to-device hops in the route. If there are multiple 
solutions that have the same objective cost, adding this cost will ensure 
that the solution in which the loads have the shortest path is chosen as 
the best solution.

3) Click Run to begin the optimization.

JCSS computes the routes for the traffic and then starts the optimization. 
After the optimization completes, a dialog box displays a summary of the 
optimization process:

a) Original Average Values - Displays the values before the optimization 
process was started.
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b) Final Average Values - Displays the values at the end of the 
optimization.

c) Summary Table - Displays a list of links and broadcast networks for 
which the optimization engine suggested changes. Click on a row in this 
table to display the Attributes dialog box for that link or network. This 
Attribute dialog box shows the original values and the current values 
suggested by the engine. You can accept the changes suggested by the 
engine or selectively reject the changes for some links while retaining 
the changes for the others by setting the Status field to “Reject.”

Capacity
Optimization > Save

Optimization As

Capacity Planning > Capacity Optimization > Save Optimization As Save the 
results of an optimization as part of the scenario, so that it is available for future 
comparisons. 

During an optimization, JCSS might suggest changes to the link and network 
bandwidths or to the inter-arrival times of the IERs. If you save the project after 
an optimization, these values become the actual values and you will not be able 
the previous values. 

To prevent losing the original values accidentally, you will be prompted by a 
dialog to save the scenario under a different name. If you choose this option, a 
copy of the scenario is made under the current project and the values in the 
original scenario are left unchanged. 

1) Enter a name for the optimization and click OK. The name is used to identify 
the optimization in the Manage Results interface. 

Figure 3-201   Save Optimization As Dialog Box 
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Capacity
Optimization >

Manage
Optimization

Results

Capacity Planning > Capacity Optimization > Manage Optimization Results
Access the Manage Capacity Optimization Results to delete optimization results 
from the scenario's state, compare optimizations, and make one of the 
optimization solutions the current solution. 

Figure 3-202   Manage Capacity Optimization Results Dialog Box 

Select the row number(s) for the optimizations to compare, delete, or install as 
current solution, and then click the corresponding button. 

Capacity
Optimization >

Examine Top
Solutions

Capacity Planning > Capacity Optimization > Examine Top Solutions Examine 
top solutions returned by the optimization. At the end of optimization, the engine 
returns the best solution that it found so far. Sometimes the best solution might 
have suggestions that you do not agree with. In such cases, review a few of the 
top solutions and use the one that you think is the best. You can specify the 
number of top solutions that the engine must store. At the end of optimization, 
you can review the top solutions and pick the one that suits your needs. 

You can specify the number of solutions to store using the Advanced 
Optimization Parameters.

1) The top most solution is highlighted in yellow. If you prefer a different 
solution, you can click on the drop-down menu at the top of the dialog box 
and change the currently visible solution.
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Figure 3-203   Top Solutions Summary Dialog Box

Capacity
Optimization >

Restore Original
Capacities

Capacity Planning > Capacity Optimization > Restore Original Capacities
Restore the scenario’s original capacities after an optimization is run.

Reports Capacity Planning > Reports > (option) Open the listed reports.

Reports > View Web
Report

Capacity Planning > Reports > View Web Report Launch the most recent 
Capacity Planner web report for this scenario.

Reports > Settings Capacity Planning > Reports > Settings Web report settings are used in the web 
reports produced after a Capacity Planning Evaluation or Optimization. 

Figure 3-204   Web Report Settings Dialog Box

These options let you set report parameters: 

• Naming Convention: The names of all the devices and links that are in the 
report will use the naming convention selected here. 

• Include Web Reports: If this option is selected, the link and circuit traffic 
reports are also selected. Unchecking this will disable the options for the 
individual reports. 
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• Include Individual Link Traffic Reports: If this option is selected, individual 
reports will be included in the web report for each link in the scenario. The 
reports will include all the traffic going directly over the link as well as any 
circuits that are going over the link.  The reports will take longer to generate 
if this option is selected. 

• Include Individual Circuit Traffic Reports: If this option is selected, individual 
reports will be included in the web report for each routable circuit. The reports 
will include all the traffic using the circuit.  The reports may take longer to 
generate if this option is selected. 

• Number of Balanced Routes to Report: If IP load balancing is selected, then 
the number of balanced routes to report can be selected.  The entry must be 
an integer greater than 0.  This number of route reports will be reported in the 
web reports. 

NetDoctor 

NetDoctor is a powerful rules-based engine that proactively identifies incorrect 
device configurations, including policy violations and inefficiencies. NetDoctor 
exposes hidden problems that can be difficult to discover due to the sheer 
volume of configuration information distributed throughout the network. 

NetDoctor rules are normally run against model attributes, which are set from 
device configurations that you can import from a production network. Also, 
some NetDoctor rules use simulation data to identify inconsistencies in the 
operation or performance of the network. 

You can run all of the NetDoctor rules on a JCSS network, except for the ones 
that have JCSS devices in them, usually on the networks that are created from 
Device Configuration Import (DCI). For the networks with JCSS devices in them, 
you can run only rules that are devised for individual devices or a device group. 

Note—A separate NetDoctor license is required in order to run NetDoctor in 
JCSS. A JCSS license does not include a NetDoctor license. 
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The table below outlines the main menu options under NetDoctor: 

Please refer to the NetDoctor chapter under the IT Guru product documentation 
for details on using NetDoctor. 

NetMapper 

NetMapper provides up-to-date Microsoft Office Visio network diagrams "on 
demand." These diagrams extend beyond simple topology to feature detailed 
logical views of the network including: Layer 2-3, VPNs, OSPF, VLANs, etc. 
Also, Microsoft Office Visio diagrams allow you to print in various sizes including 
posters. 

Note—A separate NetMapper license is required in order to run NetMapper in 
JCSS. A JCSS license does not include a NetMapper license. 

Table 3-7   NetDoctor Menu Items 

Menu Item Description

Configure/Run NetDoctor... Configure, save, and run NetDoctor report 
templates.

Run NetDoctor... Run NetDoctor using an existing report 
template.

Auto-Generate Report Template... Create a NetDoctor Report Template.

View Recent NetDoctor Reports... Choose a recently run NetDoctor report and 
open it in the appropriate viewer.

Configure/Run Trending Configure and generate NetDoctor Trending 
reports. Note: NetDoctor trending is 
project-specific. You cannot trend NetDoctor 
data using scenarios from more than one 
project.

Open NetDoctor Log Display the NetDoctor Log file contents.

Suppress Messages Choose not to display NetDoctor messages.

Rule Development... Create new or edit existing NetDoctor rules.

Options Configure NetDoctor operation and report 
generation settings.
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The table below outlines the main menu options under NetMapper: 

 

Please refer to the IT NetMapper chapter under the IT Guru product 
documentation for details on using NetMapper. 

DES (Discrete Event Simulation) Menu 

Configuration OPFAC 

Every time a new scenario is created (or an older scenario is converted), a 
Configuration OPFAC will automatically be placed in the top-level subnet. 
Simulations cannot be run if this object is not present in the scenario, therefore, 
the Configuration OPFAC cannot be deleted or duplicated. The Configuration 
OPFAC is an actual OPFAC, and can be accessed via the treeview or the 
workspace (the default location for the OPFAC is 60, -150). The Configuration 
OPFAC contains (at least) these four utility nodes: Failure/Recovery, Wireless 
Failure/Recovery, IER Firing Rules Node, and QoS. 

Failure/Recovery Node 

JCSS failure/recovery functionality allows you to specify a time interval or period 
of time for which devices of an OPFAC are inoperable. You can also specifying 
failure and recovery times for organizations, links, individual devices, and 
OPFACs. This feature simulates equipment failures or loss of forces. 
Failure/recovery times are specified on the individual objects listed above, 
however, once specified, the failure/recovery times for all objects in the scenario 
reside on the Failure/Recovery node. This node can be deleted. 

1) From the Scenario Builder, right-click on an organization, link, individual 
device, or OPFAC to open the shortcut menu. 

2) On the shortcut menu, select Edit JCSS Attributes. The Attributes dialog 
box displays. 

Table 3-8 NetMapper Menu Items

Menu Item Description

Generate NetMapper Diagram... Launches the Generate NetMapper Diagram 
dialog box that allows you to select a 
template from which to generate a new 
diagram, or generate a diagram based on a 
previously-generated diagram.

View Recent NetMapper Diagram... Get information about generated diagrams, 
open them in Visio, and delete any old, 
unwanted diagrams

Publish Recent NetMapper Diagram... Select a generated diagram to publish.

Open NetMapper Log Opens the Log Viewer to view both 
text-based and event-based logs.
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3) Click the Failure/Recovery button at the bottom of the dialog box. The 
Failure/Recovery Times dialog box displays. 

Figure 3-205   Failure/Recovery Times Dialog Box 

4) Click Insert. A failure/recovery time with default values displays in row 1. 
Edit the Device, Time, and Status fields as needed. Repeat as needed to 
create all failure/recovery times for the selected object. 

Figure 3-206   Inserting a Fail Time 

5) Click OK to close the Failure/Recovery Times dialog box, and then click OK 
again to close the Attributes dialog box. Repeat steps 1-5 to create 
failure/recovery times for other scenario objects. 

6) To view all failure/recovery times for the scenario, right-click on the 
Failure/Recovery node in the Configuration OPFAC and select Edit 
Attributes. 

7) Next, click in the Value cell of the Link Failure/Recovery Specification 
attribute and select (…) to view link failure/recovery times, or click the Value 
cell of the Node Failure/Recovery Specification attribute and select (…) to 
view node failure/recovery times. 
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Figure 3-207   Failure/Recovery Node Attributes

Wireless Failure/Recovery Node 

The Wireless Failure/Recovery node works in the same manner as the 
Failure/Recovery node explained above, except it is only used for wireless 
networks (i.e., broadcast networks). This node can be deleted. 

IER Firing Rules Node 

The IER Firing Rules node must exist to run a simulation; therefore, it cannot be 
deleted. Before a simulation is executed, certain parameters that influence the 
behavior of the simulation can be configured from this node. These parameters, 
which specify the behavior of traffic during simulation, are configured through 
the Priority Table, Decision Table, and System Element Table. These tables are 
accessible via the IER Firing Rules node shortcut menu by selecting Edit 
Attributes. 

Figure 3-208   Accessing the Decision Table and Priority Table
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This table can be used to specify how the simulation deals with failed IER 
transmissions due to busy sending and receiving devices. For each precedence 
type, you can specify the number of retries and the wait time between retries. 

Figure 3-209   Priority Table 

From this table we can see that if a Flash IER cannot be fired at the specified 
time, the simulation will wait for 5 seconds and try to send it again. For Flash, 
the simulation will try a maximum of 12 times before failing the IERs. 

Decision Table and System Element Table When creating IERs, you specify the 
producing and consuming OPFACs. You do not have to specify the device 
within the OPFAC that produces or consumes the traffic, but the simulation 
needs to know the device within the OPFAC that handles the traffic. 
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This device selection process can be left to the simulation with the help of the 
Decision Table and the System Element (SE) Table. These tables have a series 
of entries tying the type of traffic, the classification, and the equipment type to 
be used for that traffic to the actual device within an OPFAC. 

Figure 3-210   Decision Table and System Element Table 

When it is time for the simulation to send traffic, it looks for a matching entry in 
the Decision Table. If an entry is found, it looks in the SE table corresponding to 
that entry for a matching equipment type. Using the equipment type and 
classification obtained from these two tables, the simulation looks for a device 
within the producer and consumer OPFACs that can produce and consume the 
traffic. 

The Priority Table and Decision Table can also be configured in the 
Configuration OPFAC utility. 

Quality of Service (QoS) Node 

The QoS node is used to define custom QoS schemes and apply 
quality-of-service constraints to your network. This node can be deleted. 

Before a simulation is executed, certain parameters that influence the behavior 
of the simulation can be configured. 
Choose Individual
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Statistics DES > Choose Individual Statistics... Choose statistics on devices, 
inter-OPFAC, and intra-OPFAC links to be collected during simulation.

1) Select the object in the workspace for which the statistics will be collected 
(includes all devices, the OE, inter-OPFAC, and intra-OPFAC links).

2) Select DES > Choose Individual Statistics or select Choose Individual 
Statistics from the shortcut menu. The Choose Results dialog box displays.

3) Select statistics to be collected during a simulation by clicking the 
checkboxes next to the desired statistics.

Figure 3-211   Choose Results Dialog Box 

4) Right-click on the individual statistic to make changes to the collection 
mode or draw style.
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Figure 3-212   Change Collection Mode or Draw Style

Choose Statistics DES > Choose Statistics (Advanced) In the Probe Model window, choose 
(Advanced) advanced statistics on devices, inter-OPFAC, and intra-OPFAC 
links to be collected during simulation. 

Figure 3-213   Probe Model Window 
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Record Packet Flow
2D Animation for

Subnet and Record
Node Movement 2D

Animation for
Subnet

DES > Record Packet Flow 2D Animation for Subnet and DES > Record Node 
Movement 2D Animation for Subnet Turn on or off the collection of animation 
data from the subnetwork. This data allows you to view the packet flow and (with 
the Wireless Module) node movement that occurs during a simulation. 

Expert Service
Prediction > Define

Service Level
Agreement

DES > Expert Service Prediction > Define Service Level Agreement: Defines the 
thresholds for a service level agreement (SLA.)

Figure 3-214   Define SLA Dialog Box

• Show Compliance drop-down menu/fields: Displays a statistic's compliance 
with an SLA. An SLA can include thresholds for one or more statistics. To 
view a statistic's compliance, select it in the Statistic Browser. You must set 
each statistic's threshold individually; if you select multiple statistics and set 
a threshold, the threshold applies only to the last statistic you selected. 

• Bucket Duration field/drop-down menu: Sets the duration for buckets for the 
simulation run. If a statistic has a bucket-capture mode set to time average, 
sum/time, or count, the SLA measures compliance for the entire simulation 
run. For all other statistics, it divides the total simulation run into buckets (set 
by the Bucket Duration field) and measures compliance for each bucket. 

• Service Level Agreement drop-down menu: Allows edits to existing service 
level agreements. 

• Import All Statistics button: Lists statistics for all models listed in the mod_dirs 
directory. 

• Clear button: Deselects all statistics, and resets the statistics tree. 
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• Save button: Opens the Save As dialog box, which allows you to save the 
thresholds defined for the scenario. 

• Close button: Opens the Confirm dialog box, which prompts you to save your 
changes before closing. 

Configure/Run
Discrete Event

Simulation

DES > Configure/Run Discrete Event Simulation or click the Configure/Run 
Discrete Simulation button: Set the values of simulation attributes and control 
how a discrete event simulation (DES) runs in the current (or specified) 
scenario. The Configure/Run DES dialog box displays in simple mode. This 
dialog box has a set of commonly used dialog box controls, and two tabbed 
windows to configure DES inputs (Global attributes) and outputs (Reports.)

1) Set the duration of the simulation in the Duration field. The units are 
specified by the pull-down menu next to this field. This sets the duration 
simulation preference.

2) Set the number of values collected for each statistic in the Values per 
statistic field. This sets the num_collect_values simulation preference.

Figure 3-215   Configure/Run DES Dialog Box

3) Set the simulation attributes in the Global attributes window to the desired 
values. The Attribute table displays all simulation attributes declared by 
models involved in the scenario to be simulated and the values assigned to 
each attribute. Click on a question mark icon to display information about 
the corresponding attribute. Click on an Attribute Value to change it.

For details on the attributes that can be configured on the Global attributes 
page, refer to the OPNET Editors Reference Manual (consult the IT Guru 
documentation set, available via Help > Documentation > IT Guru 
Documentation). 
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4) Click the Reports tab to select Statistics and Service Level Agreement 
(SLA) reports for the simulation to collect. Reports are predefined sets of 
statistic probes. 

• Record the following date and time in results label-Displays the date and time 
associated with the network model, if any. 

• Generate web report for simulation results checkbox-When selected, 
simulation results are included in a report viewed from a web browser. 

• Minimum number of decimal places for statistics in output reports 

• Number of entries displayed in 'Top N' reports counter—Sets the value of 'N'.

• Statistics reports pane—Specifies the statistics reports to generate at the 
end of the simulation. Each selected value is added to the reports simulation 
preference.

• Define Statistics Report button—Opens a dialog box used to define new 
statistics reports.

• SLAs pane—Specifies the SLA reports to generate at the end of the 
simulation. Each selected value is added to the sla_reports simulation 
preference.

• Define SLA Report button—Opens a dialog box used to define new SLA 
reports.

5) Click the Detailed button if you want to open the Configure/Run DES dialog 
box in “detailed” mode. Detailed mode lets you configure all of the 
parameters of DES, some of which are not available in the simple mode. 
This dialog box contains a treeview of information categories for configuring 
different aspects of the simulation.

6) Click Cancel to close the dialog box without saving any changed settings, 
or click Apply to save the current settings and keep the dialog box open, or 
click Run to save the current settings, close the dialog box, and run the 
simulation immediately. The simulation runs for set duration, displaying 
frequent progress updates in the viewing window until completion.

Run Discrete Event
Simulation

DES > Run Discrete Event Simulation Run a simulation of the current scenario. 
The dialog box that appears displays the status of the simulation as it runs and 
allows you to pause or stop the simulation, if desired.

1) Choose DES > Configure/Run Discrete Event Simulation to open the 
Simulation Set dialog box. 

2) If desired, set the simulation attributes.

3) Click the Run toolbar button. The Simulation Execution dialog box opens.
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Figure 3-216   Simulation Execution Dialog Box

JCSS displays a series of messages in this dialog box. These messages 
show the progress of the simulation, beginning with the initialization stages 
and continuing with run-time statistics. The following statistics are 
displayed at each update:

• Time: Current simulation time.

• Events: Total number of events processed. An event usually signifies the 
arrival of a packet or an interrupt at a module, triggering some kind of 
response within the module.

• Speed: Average – Simulation Sequence graph displays the average number 
of simulation events per second of real time (measured since the beginning 
of the simulation).

• Speed: Current – Simulation Sequence graph displays the instantaneous 
number of simulation events per second (measured using real time over the 
last update interval).

• Time: Elapsed – Real running time of the simulation.

The following buttons stop, pause, and resume the simulation:
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• Pause / Resume button—Pauses / Resumes the current simulation. You can 
save the output generated by the simulation up to this point when pausing 
the simulation.

• Stop button—Stops the current simulation. You can save the output 
generated by the simulation up to this point. (This acts as if op_sim_end() 
was invoked by model code.)

The following panels display:

• Simulation Speed panel—Displays a graph of the current and average event 
speed for the simulation.

• Memory Usage panel—Displays a graph of the OPNET-managed memory 
usage of the simulation.

4) When the simulation is finished, click Close.

If fatal errors are present in the scenario when a simulation is run, the simulation 
process is aborted. A pop-up dialog box instructs you to access the Scenario 
Conversion Log file, which details errors that correspond to incorrect scenario 
elements requiring adjustment prior to a successful simulation. The log file, 
which resides on the on the same level as the nt.m file, can be opened using 
any text editor. When the simulation is complete, a file named <project 
name>-<phase name>.ov is saved in the same location as the nt.m file. This file 
will be used for results analysis.

Restart Discrete
Event Simulation

DES > Restart Discrete Event Simulation Restart a simulation of the current 
scenario.

Open DES Log DES > Open DES Log Display the log of errors and significant simulation events 
maintained by JCSS during discrete event simulation. The DES log is written to 
a tab-delimited ASCII file. Because there may be many events in a DES log, a 
log browser is provided so that you can view only those events of interest to you.

Figure 3-217   DES Log Viewer
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1) Click the module tabs to move between modules for which logs are 
available. The Miscellaneous tab gives you access to session and error 
logs. 

2) Use the treeview provided in the Logs pane to select from the available logs 
associated with the selected module. 

3) For text-based logs, the Selected Log pane displays a single pane with 
simple text descriptions of events. For event-based logs, it displays two 
panes. The first pane displays sections of the log. Select the section(s) that 
you want displayed. The second pane displays the log data, one event per 
row. 

• Click and drag the vertical lines in the header row to resize columns. 

• Click on an entry in the Message column to open an edit pad containing the 
full text of the message. 

4) Check (or uncheck) the Display logs for current scenario only checkbox to 
specify whether the treeview (in the Logs pane) should list all logs or only 
those for the current scenario. 

5) Click the Open Advanced Viewer button to open an advanced log viewer 
that provides additional capabilities using a menu bar. The additional 
capabilities include: changing which column is used to color-code a log 
entry, changing which columns are visible or filterable, saving the current 
viewer settings, and exporting the log information to a file. 

6) Click the Close button to close the Log Viewer dialog box. 

Results DES > Results > (option) Select one of the listed options to view simulation 
results in various formats. 



3—Scenario Builder

JCSS/Release 10.0 JCSS-3-206

Results > View
Results

DES > Results > View Results Launch a graphical interface, the Results Results 
Browser, that allows the planner to browse a list of MOPs loaded from an output 
vector file and create graph panels to display the MOPs. 

Figure 3-218   View Results 

The list of MOPs is categorized and displayed in a tree on the left of the 
interface. Global statistics are calculated from all objects in the simulation. 
Object statistics are calculated from individual objects, which are primarily links 
and OPFACs. One or more statistics may be selected from multiple categories 
at any time. 

Configuration options may be set in the drop-down lists immediately above the 
lists and below the graph preview. These options control how multiple MOPs or 
a single MOP from multiple scenarios are combined in a graph panel, and allow 
the planner to apply filters to the raw MOP data. 

If more than one output vector file has been loaded, the upper-left list allows the 
planner to configure the graph panel to contain graphs of the selected MOP from 
the most recently loaded file (Current Scenario), from all files (All Scenarios), or 
from individually selected files (Select Scenarios). If All Scenarios or Selected 
Scenarios is chosen, only one MOP may be selected. 
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If multiple MOPs are selected, or a single MOP is being graphed from multiple 
files, the lower-right lists specify how the graphs will be combined on the graph 
panel. The Stacked Statistics option causes the panel to contain a separate 
graph for each MOP or file. The Overlaid Statistics option causes the panel to 
contain one graph on which all MOPs are plotted, using colors to distinguish the 
plots. The Individual Statistic option ensures that only one MOP can be selected 
at any time. 

Once the graph has been configured, the planner may create an independent 
graph panel containing the MOP(s) by clicking on the Show button. The graph 
panel will have the same appearance as the preview, but will exist as an 
independent dialog and provide editing features that can further configure the 
graph. Any number of graph panels may be created by repeatedly selecting 
statistics, setting options, and clicking on Show. 

Figure 3-219   MOP Graph Panel 

MOP graphs should be interpreted in the same manner as a standard line 
graph. The graph heading displays the name of the MOP; the X axis always 
represents simulation time; and the Y axis represents various units of 
measurement, depending on the MOP selected. 
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Figure 3-220   Speed of Service MOP 

The table below lists MOPs and their descriptions: 

Table 3-9 MOP Descriptions

MOP Description

IERs sent count A cumulative count of IERs sent.

Number of blocks for each IER sent The number of times each IER was blocked.

Perishability for the rcvd IERs A cumulative count of IERs received where the 
delay (IER_Rcvd IER_Start) is greater than the 
IER_Perish time.

Speed of service (in sec.) for the rcvd IERs The delay (IER_Rcvd IER_Start) computed for 
each received IER.

Forward Data Throughput (in bits/sec.) The throughput of the point-to-point link in the 
forward direction.

Reverse Data Throughput (in bits/sec.) The throughput of the point-to-point link in the 
reverse direction.

Forward Link Utilization (percent) The utilization of the point-to-point link in the 
forward direction.

Reverse Link Utilization (percent) The utilization of the point-to-point link in the 
reverse direction.

Broadcast Network Utilization The broadcast network utilization during the 
simulation. A value of ‘1’ indicates that the 
network was utilized, and ‘0’ indicates that it 
was not utilized.

Connection latency (in sec.) The latency (IER_Sent IER_Start) in 
establishing a connection.



3—Scenario Builder

JCSS/Release 10.0 JCSS-3-209

Grade of service The percentage of IERs received within the 
IER_Perish time.

Message completion rate The ratio of the number of IERs of type ‘data’ 
received to the number of those sent.

Message error rate The ratio of the number of IERs of type ‘data’ 
that failed to the number which were sent.

Call completion rate The ratio of the number of IERs of type ‘voice’ 
received to the number of those sent.

Blocking probability The ratio of the number of IERs that were 
blocked at least once to the number which 
were sent.

End-to-end delay (in sec.) The delay (IER_Rcvd IER_Sent) computed for 
each received IER.

Channel Utilization (percent) The percentage of channels on this link that 
are used.

Voice Throughput (in bits/sec.) The number of voice calls that go through this 
link.

Table 3-9 MOP Descriptions

MOP Description
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MOP graphs allow user interaction. For example, examine statistics by placing 
the cursor over a segment of the trace to display a tool tip regarding graph 
coordinates, or zoom in on any segment of the trace by drawing a small box 
around the segment with the cursor. Right-clicking on an MOP graph opens a 
shortcut menu that allows manipulation of graph properties and other 
capabilities such as modifying the look and style of the graph, exporting the 
graph data to a spreadsheet, and creating a graph template. 

Figure 3-221   MOP Shortcut Menu 

Results > Compare
Results

DES > Results > Compare Results Launches the Results Browser containing 
DES reports.

Results > Find Top
Statistics

DES > Results > Find Top Statistics Launch a graphical interface that allows the 
planner to browse a list of MOPs loaded from an output vector file and create 
reports listing the objects that have the highest or lowest values for that MOP. 
Average, maximum, minimum, and standard deviation values may be evaluated 
for each MOP.
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The primary interface is a list of available MOPs that can be evaluated.

Figure 3-222   Select Statistic for Top Results 

1) Select a statistic and click the Find Top Results button to launch a report 
interface. Several report interfaces may be opened concurrently by 
selecting different MOPs and launching the interface for each in turn. 

Figure 3-223   Top Results Report Interface 
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The report interface lists all objects that have recorded the selected statistic and 
displays the minimum, average, maximum, and standard deviation values 
calculated from each object's MOP data. Initially, the list is sorted in decreasing 
average values, but the planner may dynamically resort the list in increasing or 
decreasing order for each column by clicking on that column's header. 

Both graph and text reports may be created from the report interface. The 
content of each report is controlled using the fields on the left of the report 
interface. The maximum number of objects included in the report is set in the 
Report on top N statistics field. Further constraints may be placed on the report 
by setting a boundary on allowed values for one of the four calculated columns. 
For example, the report can be constrained to include only objects for which the 
Average value is greater than (>) a specific value (1.0). 

1) Create a graph panel containing the full MOP graph for all objects matching 
the constraints by clicking on the Graph button. The graphs for each object 
may be stacked or overlaid on the panel, and filters may be applied to the 
graphs, as specified in the two drop-down lists beside the Graph button. 

2) Create a text report based on the constraints by clicking on the Text Report 
button. The text report will be displayed in a text-edit interface and may be 
saved from that interface. 

The Find Object button is not operational, since the Scenario Builder does not 
contain a scenario model in which to find the objects named in the list.

Results > View
Application Delay

Tracking

DES > Results > View Application Delay Tracking Select an application delay 
tracking file and use the Application Segment Tracking Viewer to display its 
data.
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For example, you can track how each IER moves through the network. 

Figure 3-224   Choose an Application Delay Tracking File 

IER data displays in the Application Segment Tracking Viewer. 

Figure 3-225   Application Segment Tracking Viewer 

Results > View DES
Reports

DES > Results > View DES Reports Displays output tables generated during a 
discrete event simulation. 
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Results > Generate
Web Report

DES > Results > Generate Web Report... Generates a Web report that contains 
one or more of the reports available in the Results Viewer. 

1) From the Select Tables for Web Report dialog box, choose the results you 
want to include in the Web report. 

2) Select the Include Network Diagram checkbox if you want the web report to 
include a graphic of the network topology. 

3) Click Generate. 

4) Select a directory for the HTML files and click OK. 

5) The web report is created and opens in the default Web browser. 

Results > Launch
Last Web Report

DES > Results > Launch Last Web Report Opens most recently generated Web 
report in the HTML browser. 

Results > Import DES > Results > Import... Load a previously created .ov file. Select the file to 
load and then click OK; the data is loaded into the current project and is 
available for analysis. When multiple files are loaded, each file will be a distinct 
scenario. The name of the scenario will match the name of the output vector file. 
Multiple scenarios may be active in the Scenario Builder concurrently, so that 
their MOPs may be graphed and compared. 

Play 2D Animation DES > Play 2D Animation View collected animations. Toolbar buttons display to 
control operations for playing animation sequences, pausing animation, and 
speeding animation up or slowing it down. You can also load animation history 
files, view "real-time" animation (simultaneously with an executing simulation), 
and use a variety of operations to control how animation data displays. The 
largest area of the display-the animation viewing area-is where you can load 
and view animations. Animation displays in windows called viewers. A viewer is 
a rectangular region with an internal coordinate system. Viewer windows can be 
manipulated using the standard GUI operations for moving, resizing, scrolling, 
and circulating editor windows. 

The following toolbar buttons control animation operations: 

• Play: Activates any animation flow that has been established. 

• Pause: Pauses an animation indefinitely, until another operation reactivates 
it. 

• Restart: Restarts a paused or stopped animation flow from its beginning. 

• Terminate: Stops an animation flow. After it is stopped, an animation can be 
restarted only using the Restart Animation flow operation. 

• Slow Down Animation: Slows down the animation sequence in increments. 

• Speed Up Animation: Speeds up the animation sequence in increments. 
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Panels DES > Panels Display a list of all open panels and select one to make active. 

Panel Operations DES > Panel Operations > (option) Select one of the operations listed below to 
control panel display. 

• Arrange Panels: 

— Show All: This operation draws any analysis panels previously hidden. 

— Hide All: This operation hides all analysis panels that have been drawn. 

— Distribute: This operation arranges open panels along a grid but (unlike 
tile) does not redraw them to a uniform size. 

— Cascade: This operation arranges open panels in an overlapping pattern 
that ensures the title bar of each panel is visible. Panels are not redrawn 
to a uniform size, unlike the tile operation. 

— Tile: This operation redraws open panels to a uniform size and arranges 
them in a grid. 

• Panel Annotations: 

— Make All Panels Into Annotations: Creates annotation objects from all 
open analysis panels. 

— Delete All Panel Annotations: Deletes all analysis panel annotations in 
the network. 

• Panel Templates: 

— Create From All Panels: Makes all analysis panels in the current scenario 
into templates. 

— Load With Latest Results: Applies current statistics to all templates in the 
scenario. 

• Export Panels: 

— To BMP: Creates BMP images of all graphs currently available in the 
Scenario Builder. Select a directory in which to place the new image files. 
One image file is then created for each graph. 

— To TIFF: Creates TIFF images of all graphs currently available in the 
Scenario Builder. Select a directory in which to place the new image files. 
One image file is then created for each graph. 

— To PowerPoint: Creates a PowerPoint document containing images of all 
graphs currently available in the Scenario Builder. Select a directory and 
provide a name for the new PowerPoint file. 

• Reload Data Into All Panels: Reloads data into all panels. 

• Delete All Panels: Deletes all analysis panels in the current scenario. 
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Windows Menu

Previous Editor Windows > Previous Editor Make the previously displayed editor the current 
editor.

Circulate Editors Windows > Circulate Editors One at a time, make each open editor the current 
editor.

Hide This Editor Windows > Hide This Editor Hide the current editor. If another editor is open, 
that editor is made the current editor.

Hide Other Editors Windows > Hide Other Editors Hide all open editor windows except the current 
one.

Show All Editors Windows > Show All Editors Re-display any hidden editors.

Configure Toolbar Windows > Configure Toolbar Customize the main toolbar by adding and 
deleting desired buttons, selecting button icons and names, and moving button 
order.

To add a toolbar button, select an available operation from the left pane and

then click the Add>> button. Use the Move Up or Move Down buttons to position 
the button in the desired toolbar location. In the Title field, enter a button title. 
Next, click the Choose button and select the desired icon from the palette that 
displays. Click OK.

To remove a toolbar button, select a button in the right pane and then click 
<<Remove.

Use the Move Up or Move Down buttons to reposition a button in the toolbar.
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Use the Add Separator>> button to add a divider between button icons.

Figure 3-226   Configure Toolbar Dialog Box

Show Toolbar Windows > Show Toolbar Show or hide the main toolbar.

Float Toolbar Windows > Float Toolbar Allow the main toolbar to be dragged and dropped 
anywhere in the viewing area.

Figure 3-227   Floating Toolbar

Note—The Configure Toolbar, Show Toolbar, and Float Toolbar options are 
also accessible on a shortcut menu, which is available by right-clicking on the 
toolbar. 

System Windows > System Moves the System Editor window forward. 

Help Menu 

This menu is identical to the System Editor Help menu. See the Help Menu 
section in chapter 2 of this manual. 
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4 Icon Database

The Icon Database allows you to create new icons for OPFACs and 
organizations displayed within the Scenario Builder. 

Accessing the Icon Database 

Access the Icon Database using the File > New Other or File > Open Other 
commands in the System Editor. The Icon Database is used to create new icon 
palettes (databases) that can be a collection of new customized icons and icons 
that are already present. The Image Editor that is a part of the Icon Database is 
used to create / modify the icons. The individual icons are organized into icon 
database files, with the suffix .icons. Many icon databases are included as part 
of JCSS; you can also create your own icon databases. 

Figure 4-1   Icon Database 
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You may wish to modify icon databases; you may also wish to modify individual 
icons. Use the Icon Database window to modify the icon database. Use the 
Image Editor window to modify individual icons (double-click an icon in the Icon 
Database to launch the Image Editor.) You cannot create a single icon file, but 
you can create an icon database file that contains a single icon.. 

Figure 4-2   Image Editor

You cannot save an individual icon while in the Image Editor. To write the data 
related to an individual icon to disk, close the Image Editor and choose the Save 
operation in the Icon Database to save the entire database. 

The icon databases included with JCSS are stored in various locations. Icons 
specific to JCSS are stored in: 

JCSS/Scenario_Builder/16.0.A/netwars/icons. 

COTS icons are stored in: 

JCSS/Scenario_Builder/16.0.A/models/vendor_models 

Other icon databases are in the appropriate model directory or in the sys 
directory. When you create an icon database, it is stored in your default directory 
(the first directory listed in your mod_dirs preference, typically op_models). 

File Menu 

New File > New Creates a new icon database. This will open a blank database to 
which new icons can be added and the database can be customized. 
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Open File > Open Opens an existing icon database. Once the database is opened, 
new icons can be added, existing icons can be deleted or modified using the 
image editor. 

Close File > Close Closes the currently open icon database. 

Save File > Save Retain changes to an icon database. 

Save As File > Save As Save the current database under a different name. Specify a 
name and click OK; the icon database is stored in <User_Data>\SB_Data. 

Manage Model Files File > Manage Model Files > (option) This submenu lists options which allow 
Files you to delete model files, add a model directory, or refresh model 
directories. 

Exit File > Exit Closes all windows and exits JCSS. 

Edit Menu 

Cut Icon Edit > Cut Icon Cut the selected icon to the clipboard. 

Copy Icon Edit > Copy Icon Copy the selected icon to the clipboard. Paste Icon Edit > 
Paste Icon: Paste the selected icon from the clipboard. 

New Icon Edit > New Icon Create and add a new icon to an existing or new database. 
Click in the workspace to create a new icon with missing name as the name, and 
a default image for the icon. 

Delete Icon Edit > Delete Icon Delete an icon from the icon database. 

Preferences Edit > Preferences Display and edit JCSS preference settings. 

Help Menu 

This menu is similar to the System Editor Help menu. See the Help Menu 
section in System Editor on page JCSS-2-1. 



App A—Time Varying Infrastructure

JCSS/Release 10.0 JCSS-A-1

App A Time Varying Infrastructure

You can define start and stop times for the infrastructure during a simulation run, 
which includes relationships. IERs will only be allowed to pass if they fall within 
the active time window of the infrastructure. 

Relationships 

The Relationship Attribute dialog box includes a button to specify start and stop 
times. 

Figure A-1   Relationship Attribute Dialog Box 

Clicking on the Specify Start/Stop Time button allows you to specify different 
start and stop times for a relationship. Start and stop times must be entered 
consecutively START/STOP, START/STOP, etc., as shown below. 

Figure A-2   Specify Start/Stop Time Dialog Box 

IERs imported from a text file that are tied to an explicit relationship will have the 
start and stop times assigned to the relationship applied to them. 
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User-created IERs can also have a relationship associated with them. You can 
set this relationship from a list of all relationship types attached to the producer 
OPFAC. Start and stop times assigned to the relationship will be applied to the 
IER. 

Imported IERs with implicit relationships are not tied to a relationship, so you 
have to manually specify the start and stop times for these IERs when 
viewing/editing traffic. 
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App B System Administration

Types of Administrators 

System Administrators 

System Administrators are determined and managed by local policies. They 
alone have the access to install and remove software from computers. They are 
members of the Administrators group, based on the user ID and password 
submitted to the operating system authentication management. 

Local Administrator User Profile 

• Every installation of JCSS has a Local Administrator user profile. You can 
login using this profile to make changes to the pre-configured section of the 
object library. 

• JCSS stores the login information for the five (5) most recently used 
accounts. The Local Administrator profile is always available and is in 
addition to the five (5) most recent users. 

• This special account does not have any security implications. Just as with 
any JCSS user profile, the Local Administrator account is not protected by a 
password. 

• In addition to selecting a user profile when starting JCSS, the current user 
profile can be changed from the Edit > Change User menu item of the main 
JCSS window. 
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App C Operations and Maintenance Procedures

Object Library

JCSS does not enforce access restrictions on the Organization and OPFAC 
Library. Users should follow the policies and procedures of their organization 
when creating or modifying library contents. OPFAC and Organization Library

The OPFAC and organization library are divided into two parts:

• Custom Library

• Pre-configured Library

Custom Library

The custom library contains OPFACs and organizations that were created or 
modified by the user. All users have privileges to edit the contents of the custom 
library. You can make copies of the standard templates, store them in the 
custom library and then make changes to them. OPFACs and organizations in 
the custom library are called custom templates.

Pre-Configured Library

The pre-configured library contains doctrinal OPFACs and organizations. 
OPFACs and organizations in the pre-configured library are called= 
pre-configured templates.

Only the local administrator has privileges to modify the contents of the 
pre-configured library, such as creating new or editing existing OPFACs and 
organizations, creating new folders, etc. All other users are prevented from 
making changes to the pre-configured library and their corresponding object 
palettes.

Even though editing privileges on the pre-configured library is limited to only the 
local administrator, any user can use its contents when building scenarios. A 
scenario can contain a combination of pre-configured and custom templates. It 
is also possible to have sub-folders within the above set of folders. Use of 
sub-folders allows you to further categorize the organizations and OPFACs 
within a service folder.
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The figure below shows an example of a library treeview with the pre-configured 
folders and custom folders created by the user.

Figure C-1   Library Treeview with Custom and Pre-Configured Folders

OPFAC and Organization Palettes

In addition to the above treeview interface, users can also use objects from the 
OPFAC and organization palettes to build the scenario. To build a scenario, 
users can drag-and-drop OPFACs and organizations from the palettes on to the 
workspace.

There are four main folders to hold the custom and configured OPFACs and 
organization. They are:

• Custom OPFACs

• Custom Organizations

• Pre-configured OPFACs

• Pre-configured Organizations

Regardless of the sub-folder it is in, every OPFAC or organization will belong to 
one of the above four palettes.
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Editing the Contents of the Library

You can edit the contents of the organization and OPFAC library. You can edit 
template attributes, rename templates, save them under a different name, 
delete them from the library, and undo or redo template units. Right-click menu 
options are provided for performing these operations.

If you login using the local administrator profile, you can perform the above 
operations on the pre-configured and custom sections of the library. If you login 
as a regular user, you can change the OPFACs or organizations in the custom 
section, but not the pre-configured section.

Procedure C-1   Edit Template OPFAC/Organization Attributes

1 Right-click on a template OPFAC/organization in the library treeview and choose 
Edit JCSS Attributes. The OPFAC/organization Attributes dialog box displays.

2 Make changes as needed to the available attributes, and then click OK. The 
attributes for the selected OPFAC/organization are changed.

End of Procedure C-1

Procedure C-2   Rename Template OPFAC/Organization

1 Right-click on a template OPFAC/organization in the library treeview and choose 
Rename Template.

2 Type a new name for the selected OPFAC/organization in the dialog box that 
displays, and change the folder to which the OPFAC/organization belongs. You 
can also create a new folder to store this OPFAC/organization. The selected 
OPFAC/organization will be renamed, and if you changed the folder, the files will 
be moved to the new location on disk. The treeview is also automatically updated.

End of Procedure C-2

Procedure C-3   Save Template OPFAC/Organization As

1 Right-click on a template OPFAC/organization in the library treeview and choose 
Save As.
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2 Type a new name for the selected OPFAC/organization in the Save As dialog box, 
and change the folder to which the OPFAC/organization belongs. You can also 
create a new folder to store this OPFAC/organization. A copy of the selected 
OPFAC/organization will be made, and if you changed the folder, the files will be 
moved to the new location on disk. The treeview is also automatically updated.

End of Procedure C-3

Procedure C-4   Delete Template OPFAC/Organization

1 Right-click on a template OPFAC/organization in the library treeview and choose 
Delete Template.

2 Confirm the deletion as prompted to delete the selected OPFAC/organization from 
the library. The selected OPFAC/organization will be removed from its current 
location on disk. The treeview is also automatically updated.

End of Procedure C-4

Procedure C-5   Undo/Redo Template Units

1 Right-click on a template OPFAC/organization in the library treeview and choose 
Undo or Redo.

2 Confirm the operation as prompted. The treeview is also automatically updated.

End of Procedure C-5

OPNET License Server Management

Standalone Mode

The OPNET application licenses reside on the application computer. The 
licenses are not available to any other system.

Floating Mode (local)

The OPNET application licenses reside on the application computer, but the 
licenses are available to the local network as well as the host machine. The 
license server must run as a network service.
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The OPNET License Server shuts down each time a user logs off or shuts down 
the machine. Users can also shut down the OPNET License Server through the 
License Manager, available from the JCSS main menu.

Floating Mode (external)

The OPNET application licenses reside on another computer, so this machine 
must compete for licenses with other computers on the local network. 

License Server Files and Directories

C:\OPNET_license

This folder cannot be moved or renamed. It will contain license files for 
Standalone and Floating (local) licensing modes. The folder and all its files must 
be writable by Authenticated Users, or those users will be unable to acquire a 
lock on a license to use the application. licensing.ef

The location of this file is:

• JCSS\Scenario_Builder\16.0.A\sys\configs\ global_prefs\licensing.ef

The format of the licensing.ef file is:

• license_server_standalone : true | false

• license_server : /LICENSE_SERVER/

• license_port : /LICENSE_PORT/

where:

• /LICENSE_SERVER/ is the local hostname

• /LICENSE_PORT/ is the desired port for the server

• license_server_standalone may be either true or false

env_db16.0

The env_db16.0 file contains option settings for JCSS and OPNET commercial 
modules. Among these options are license server settings. The env_db16.0 file 
can be edited manually or through the Edit > Advanced menu item. The 
env_db16.0 file license settings should be consistent with the settings in the 
licensing.ef file. The absence of license server settings in the env_db16.0 file 
means that the licensing.ef values take precedence.

The env_db16.0 file is located in the following location: 
JCSS\Scenario_Builder\op_admin\env_db16.0.
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Manually Configuring License Settings

Normally, configuration of license settings should be performed through the 
JCSS user interface. Manually changing configuration files should be used only 
as a last resort.

/hostname/ represents the hostname of the localhost system. To determine 
the hostname of a system, open a DOS console and run the hostname 
command.

/port/ represents the desired port, one of port_a, port_b, or port_c.

Procedure C-6   Configure Localhost Floating Licensing

1 Make sure that all JCSS windows are closed. This includes any JCSS editors as 
well as the OPNET License Manager.

2 The file named licensing.ef is located in 
JCSS\Scenario_Builder\16.0.A\sys\configs\global_prefs. Modify it as follows:

2.1 Set license_server_standalone to FALSE

2.2 Set license_server to /hostname/

2.3 Set license_port to /port/

3 Modify the env_db16.0 file located in JCSS\Scenario_Builder\op_admin\ as 
follows:

3.1 Set license_server_standalone to FALSE

3.2 Set license_server to /hostname/

3.3 Set license_port to /port/

End of Procedure C-6

Procedure C-7   Change from Localhost to External Floating Licensing

1 Using the License Manager, make sure that the localhost license server is shut 
down.

2 Close all JCSS applications.

3 The file named licensing.ef is located in 
JCSS\Scenario_Builder\16.0.A\sys\configs\global_prefs. Modify it as follows:

3.1 Set license_server_standalone to FALSE

3.2 Set license_server to /hostname/
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3.3 Set license_port to /port/

4 Modify the env_db16.0 file located in JCSS\Scenario_Builder\op_admin\ as 
follows:

4.1 Set license_server_standalone to FALSE

4.2 Set license_server to /hostname/

4.3 Set license_port to /port/

End of Procedure C-7

Procedure C-8   Change from Localhost to Standalone Licensing

1 Using the License Manager, make sure that the localhost license server is 
shutdown.

2 Close all JCSS applications.

3 The file named licensing.ef is located in 
JCSS\Scenario_Builder\16.0.A\sys\configs\global_prefs. Modify it as follows:

3.1 Set license_server_standalone to TRUE

3.2 Set license_server to /hostname/

3.3 Set license_port to /port/

4 Modify the env_db16.0 file located in JCSS\Scenario_Builder\op_admin\ as 
follows:

4.1 Set license_server_standalone to TRUE

4.2 Set license_server to /hostname/

4.3 Set license_port to /port/

End of Procedure C-8

License Management and Product Modules

JCSS comes with a built-in license that allows you to run the program. A special 
“simulation runtime license” is required in order to run simulations. Additional 
licenses are required for ACE and NetDoctor modules.
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If the module licenses are installed on a single license server rather than on 
individual machines, various machines can share licenses, which may reduce 
the total number of licenses required. Simulation runtime licenses, ACE 
licenses, and NetDoctor licenses must be purchased from OPNET 
(http://www.opnet.com/products).

To install module licenses, start by running JCSS (go to Start > Programs > 
JCSS > JCSS v10.0). From the System Editor main menu, select License > 
License Management.

Current instructions for loading and configuring OPNET License permits are 
available from the OPNET Support web site (http://www.opnet.com/support).

Log Files

The various log files assist in troubleshooting or tracking user activity. Users 
should examine the relevant log files before consulting JCSS Technical 
Support, and may be asked to include log files in submissions.

Note—All log files grow over time and can potentially become a constraint on 
system resources. Administrators should periodically check the sizes of the log 
files and prune the logs as needed.

nw_odbc_log

• Located in JCSS\User_Data

• Runtime log that records unusual events associated with extracting IER 
information, service provided by MSDE (Microsoft SQL Server Desktop 
Engine).

err_log

• Located in JCSS\Scenario_Builder\op_admin

• OPNET and JCSS application warnings, recoverable errors, errors, and 
program abort messages, with stack traces for context, are stored in this file.



App C—Operations and Maintenance Procedures

JCSS/Release 10.0 JCSS-C-9

Archiving and Backup Procedures

Project Packaging

Each project has a single .prj file in the project directory under 
JCSS\User_Data\Projects. The project folder and the .prj file have the same 
name as the project itself. A JCSS project may make use of other library files. 
Library files may be used by any number of projects. The only way to know 
which library files are included in a project is to examine the contents of the 
project.

Scenario Files

Each project consists of one or more scenarios. Each scenario is a subfolder 
under the main project folder. The scenario consists of a file with the extension 
‘.nt.m’ and possibly an XML file with the same base name.

Traffic Files

Demand Files

A demand file for each scenario, if one exists, would be located in the 
JCSS\User_Data\Projects\<Project>\<Scenario> directory. Its name would be 
the Project Name followed by the Scenario Name connected with a plus ('+') and 
with an extension of '.dm'.

IER Text Files

All IER Text files are available for use by every scenario. IER Text files are 
located in the JCSS\User_Data\IER_Text_Files directory and have an 
extension of '.txt'.

Organization Files

Organizations are represented by '.nt.m' files located in the 
JCSS\User_Data\Organizations directory. The project may include any, all, or 
none of the template organizations.

OPFAC Files

OPFACs consist of ‘.nd.m’ and ‘.nt.m’ files. The names of the various files that 
relate to a specific OPFAC have similar base names, though not identical. 

All .nd.m file names contain the prefix “opfac_”. 

OPFAC .nd.m and nt.m files

The OPFACs used by a project/scenario may reside in any folder under the 
JCSS\User_Data\OPFACs folder. The ‘nt.m’ file includes all the OPFAC specific 
information while the ‘.nd.m’ file is only necessary for an OPFAC t o appear in a 
palette.
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Trajectories

Trajectory files, ending in '.trj', may be applied to any organization or OPFAC in 
its JCSS attributes. Trajectory files may be stored in any directory included in 
the system's mod_dirs environment attribute. Many trajectory files are stored in 
the JCSS\User_Data\SB_Data directory, although they may be in other 
directories also.
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App D Error Recovery Guidelines

Automatic Backup of Project Files 

Project files are backed up automatically at a predetermined interval (the default 
setting is 15 minutes.) Users may modify the backup interval by selecting Edit > 
Preferences and changing the "backup_interval" preference. The backed up 
files have '-backup<index>' appended to the filename. You can load these 
backup files into the Scenario Builder. 

Note—Setting the "backup_interval" preference to 0 turns the backup off. 



JCSS Technical Reference Index

JCSS/Release 10.0 JCSS-IX-i

Index

Numerics 
3D network view 

display, JCSS-3-141 
3DNV, JCSS-3-141 

add '3DNV Mapping' attribute to selected nodes, 
JCSS-3-142 

display 3D network view, JCSS-3-141 
manage 3D visualization of pathloss, JCSS-3-145 
manage 3D visualization of trajectories, JCSS-3-144 
manage 3DNV entities, JCSS-3-142 
play 3DNV history, JCSS-3-142 
show/hide pathloss between selected nodes in 3D 

visualizer, JCSS-3-145 
show/hide trajectories of selected nodes in 3D visualizer, 

JCSS-3-144 
visualize antenna coverage, JCSS-3-147 

3DNV entities 
manage, JCSS-3-142 

3DNV history 
file chooser, JCSS-3-142 
play, JCSS-3-142 

3DNV Mapping attribute 
add to selected nodes, JCSS-3-142 

A 
accessing the decision table and priority table, JCSS-3-195 
accessing the icon database, JCSS-4-1 
accessing the scenario builder, JCSS-3-1 
ACE to threaded IER conversion - specify application 

transactions, JCSS-3-163 
acronyms 

JCSS, JCSS-2-25 
add background image, JCSS-3-41 
add model directory, JCSS-2-6 
adding a background image, JCSS-3-41 
adding a MIF map, JCSS-3-40 
adding an image map, JCSS-3-40 
adding objects to a scenario, JCSS-3-102 
administrator 

local 
user profile, JCSS-B-1 

administrators 
system, JCSS-B-1 
types of, JCSS-B-1 

advanced options for a tier group, JCSS-3-166 
advanced parameters dialog box, JCSS-3-187 
advanced preferences, JCSS-2-13 
aggregation parameters 

application turn, JCSS-3-164 
alert dialog box when exporting response, JCSS-3-80 
annotation palette, JCSS-3-105 

annotations, JCSS-3-60 
antenna coverage 

visualize, in 3DNV, JCSS-3-147 
application delay tracking 

file chooser, JCSS-3-213 
application segment tracking viewer, JCSS-3-213 
application tiers 

assign producers and consumers to, JCSS-3-165 
application turn aggregation parameters, JCSS-3-164 
applications 

convert to flows, JCSS-3-178 
archiving and backup procedures, JCSS-C-9 
assign producers and consumers to application tiers, 

JCSS-3-165 
assigned trajectory, JCSS-3-151 
assigning trajectory, JCSS-3-151 
attributes 

circuit deployment wizard tab, JCSS-3-130 
Automatic Backup of Project Files, JCSS-D-1 
automatic icon scaling, JCSS-3-47 

B 
background 

add CADRG/CIB raster catalog directories, JCSS-3-42 
add MIF map, JCSS-3-40 
add MrSID image, JCSS-3-42 
map edit mode, JCSS-3-42 
set border map, JCSS-3-39 
show MIF log, JCSS-3-41 

background add image, JCSS-3-41 
background add image map, JCSS-3-40 
background image 

adding, JCSS-3-41 
briefings dialog box, JCSS-3-9 
broadcast netowrk 

defining 
radio attributes, JCSS-3-131 

broadcast network 
deploy, JCSS-3-131 

broadcast network devices 
defining, JCSS-3-132 

optimization attributes, JCSS-3-132 
browse for workflow 

task assistant, JCSS-2-21 

C 
CADRG/CIB raster catalog directories 

background 
add, JCSS-3-42 

capacity optimization, JCSS-3-185 
examine top solutions, JCSS-3-189 



JCSS Technical Reference D

JCSS/Release 10.0 JCSS-IX-ii

manage optimization results, JCSS-3-189 
restore original capacities, JCSS-3-190 
save optimization as, JCSS-3-188 
start optimization, JCSS-3-185 

capacity optimization settings dialog box, JCSS-3-186 
capacity planning 

capacity optimization, JCSS-3-185 
examine top solutions, JCSS-3-189 
manage optimization results, JCSS-3-189 
restore original capacities, JCSS-3-190 
save optimization as, JCSS-3-188 
start optimization, JCSS-3-185 

evaluate, JCSS-3-181 
reports, JCSS-3-190 

settings, JCSS-3-190 
view web report, JCSS-3-190 

capacity planning menu, JCSS-3-181 
CCSD 

circuit deployment wizard tab, JCSS-3-130 
CCSD summary report, JCSS-3-83 
change collection mode or draw style, JCSS-3-199 
change user, JCSS-2-7 

edit, JCSS-2-7 
changes made to original scenario, JCSS-3-75 
changing user, JCSS-2-7 
choose 3DNV history file dialog box, JCSS-3-142 
choose an application delay tracking file, JCSS-3-213 
choose circuit devices dialog box, JCSS-3-129 
choose device model map, JCSS-2-9 
choose results dialog box, JCSS-3-198 
choose source and target model name lists dialog box, 

JCSS-3-23 
choose statistics, JCSS-3-199 
choose transaction method dialog box, JCSS-2-16 
circuit 

deploy, JCSS-3-128 
circuit deployment wizard attributes tab, JCSS-3-130 
circuit deployment wizard CCSD tab, JCSS-3-130 
circuit deployment wizard ports tab, JCSS-3-129 
circuit devices 

chooser, JCSS-3-129 
circuits, JCSS-3-60 
circulate editors, JCSS-2-18, JCSS-3-216 
clear error log, JCSS-2-25 
clear import log 

flows, JCSS-3-173 
clear message log, JCSS-2-26 
clear mobility profiles dialog box, JCSS-3-153 
clear session log, JCSS-2-26 
clear session log., JCSS-2-26 
clear trajectory, JCSS-3-151 
clear trajectory assignment dialog box, JCSS-3-151 
close 

icon database, JCSS-4-3 
close file, JCSS-3-8 

closing a project, JCSS-3-8 
collection mode 

change, JCSS-3-199 
color by link usage, JCSS-3-63 
communications plan task 

devlop, JCSS-2-20 
completing a task, JCSS-2-23 
configuration OPFAC, JCSS-3-193 
configuration utilities 

cut-through 
disable, JCSS-3-136 
enable, JCSS-3-135 

UHF DAMA SATCOM, JCSS-3-133 
configure link delays, JCSS-3-117 

from measured delay information, JCSS-3-118 
show output log, JCSS-3-119 

configure link delays from measured delay information dialog 
box, JCSS-3-118 

configure mobility profile on selected nodes dialog box, 
JCSS-3-152 

configure palette dialog box, JCSS-3-103 
configure toolbar, JCSS-3-216 
configure toolbar dialog box, JCSS-3-217 
configure/run DES dialog box, JCSS-3-201 
configure/run discrete event simulation, JCSS-3-201 
configure/run network differences dialog box, JCSS-3-82 
configuring custom palettes, JCSS-3-103 
convert applications to flows, JCSS-3-178 
copy, JCSS-3-13 
copy icon, JCSS-4-3 
create custom device model, JCSS-3-121 
create IP unicast traffic flows, JCSS-3-176 
creating a new login profile, JCSS-2-2 
creating a new model map, JCSS-3-23 
creating a new project, JCSS-2-3, JCSS-3-2 
creating a new scenario, JCSS-3-64 
creating a relationship, JCSS-3-133 
cross classification check, JCSS-3-128 
custom device model 

create, JCSS-3-121 
custom library, JCSS-C-1 
cut icon, JCSS-4-3 
cut-through 

disabled on selected devices, JCSS-3-136 
enable on selected devices, JCSS-3-135 

D 
DCI, JCSS-3-105 
DCI dialog box, JCSS-3-106 
DCI end station models 

compared to JCSS, JCSS-3-108 
decision table 

accessing, JCSS-3-195 
define object/attribute difference report, JCSS-3-91 
define SLA dialog box, JCSS-3-200 
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define trajectory, JCSS-3-148 
define trajectory dialog box, JCSS-3-149 
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group selection/action 
action filter, JCSS-3-16 
selection filter, JCSS-3-15 
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close, JCSS-3-8, JCSS-4-3 
exit, JCSS-3-12, JCSS-4-3 
exit JCSS, JCSS-2-6 
generate scenario briefing, JCSS-3-8 
import packaged project.., JCSS-2-5 
manage model files, JCSS-2-5, JCSS-3-10, JCSS-4-3 

add model directory, JCSS-2-6, JCSS-3-10 
create project file archive, JCSS-3-10 
delete model files, JCSS-2-6, JCSS-3-10 
expand project file archive, JCSS-2-6, JCSS-3-10 
refresh model directories, JCSS-2-6, JCSS-3-10 

new, JCSS-4-2 
new other..., JCSS-2-5 
new project, JCSS-3-2 
new project..., JCSS-2-3 
open, JCSS-4-3 
open other.., JCSS-2-5 
open project, JCSS-3-6 
open project.., JCSS-2-4 
open subordinate query, JCSS-3-7 
open subordinate query..., JCSS-2-4 
package project files, JCSS-3-11 
print graphs, JCSS-3-10 
recent projects, JCSS-2-6, JCSS-3-11 
save, JCSS-4-3 
save as, JCSS-4-3 
save project, JCSS-3-7 
save project as 

, JCSS-3-7 
file menu, JCSS-2-3, JCSS-3-2, JCSS-4-2 
files 

demand, JCSS-C-9 
OPFAC, JCSS-C-9 
organization, JCSS-C-9 
scenario, JCSS-C-9 
traffic, JCSS-C-9 

filter, JCSS-3-52 
devices, JCSS-3-53 
hide locked units, JCSS-3-54 
infrastructure, JCSS-3-53 
restore full view, JCSS-3-54 
selected objects, JCSS-3-52 

filter map dialog box, JCSS-3-52 
filter OPFACs and devices dialog box, JCSS-3-53 
filtering selected objects, JCSS-3-52 
find node/link, JCSS-3-14 
find node/link dialog box, JCSS-3-15 
finding a node/link, JCSS-3-14 
float toolbar, JCSS-3-217 
floating toolbar, JCSS-3-217 
flows, JCSS-3-166 

create flows, JCSS-3-175 
export 

to spreadsheet, JCSS-3-174 

to TR2, JCSS-3-175 
import, JCSS-3-166 

clear import log, JCSS-3-173 
open import log, JCSS-3-173 

merge traffic flows, JCSS-3-175 
open flows browser, JCSS-3-166 

free-text questions report, JCSS-3-84 
free-text questions stored as object attributes, JCSS-3-84 
functional profile dialog box, JCSS-2-10, JCSS-3-26 
functional profiles, JCSS-2-10 

preferences, JCSS-2-10 

G 
generate DoDAF Visio reports dialog box, JCSS-3-72 
generate network inventory summary, JCSS-3-97 
generate object/attribute difference report dialog box, 

JCSS-3-89 
generate scenario bitmap, JCSS-3-99 
generate scenario briefing, JCSS-3-8 
generate scenario web report dialog box, JCSS-3-98 
generate traffic web report, JCSS-3-178 
generate user-defined report diaog box, JCSS-3-68 
generating a scenario briefing, JCSS-3-8 
geographical coordinates 

edit, JCSS-2-10 
preferences, JCSS-2-10 

geographical coordinates dialog box, JCSS-2-10, JCSS-3-27 
geographical coordinattes 

setting, JCSS-2-10 
go to parent organization, JCSS-3-37 
group action dialog box, JCSS-3-17 
group selection/action 

action filter, JCSS-3-16 
selection filter, JCSS-3-15 

H 
help 

about JCSS, JCSS-2-26 
documentation, JCSS-2-24 

IT Guru documentation, JCSS-2-25 
JCSS acronyms, JCSS-2-25 
JCSS models user’s guides, JCSS-2-25 
software release bulletin (SRB), JCSS-2-24 
technical reference manual, JCSS-2-24 
user’s manual, JCSS-2-24 

error log, JCSS-2-25 
clear.., JCSS-2-25 
open, JCSS-2-25 

message log, JCSS-2-26 
clear, JCSS-2-26 
open, JCSS-2-26 

session log, JCSS-2-26 
clear.., JCSS-2-26 
open, JCSS-2-26 

show all logs..., JCSS-2-25 
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task assistant, JCSS-2-18 
web - JCSS Home Page, JCSS-2-26 
web - JCSS Support Center, JCSS-2-26 

help menu, JCSS-2-18, JCSS-3-217, JCSS-4-3 
hide other editors, JCSS-2-18, JCSS-3-216 
hide this editor, JCSS-2-18, JCSS-3-216 

I 
icon database, JCSS-4-1 

accessing, JCSS-4-1 
icon scaling 

automatic, JCSS-3-47 
icons 

copy, JCSS-4-3 
cut, JCSS-4-3 
delete, JCSS-4-3 

IER 
deploy 

choose devices, JCSS-3-157 
IER dialog box, JCSS-3-157 
IER firing rules node, JCSS-3-195 

decision table and system element table, JCSS-3-197 
IER rapid deployment wizard, JCSS-3-159 
IER text files, JCSS-C-9 
IER wizard 

choose devices dialog box, JCSS-3-160 
IERs, JCSS-3-156 

color by aggregate load, JCSS-3-59 
create thread, JCSS-3-161 
deploy, JCSS-3-156 
deploy IERs (advanced), JCSS-3-159 
edit all, JCSS-3-161 
edit all threads, JCSS-3-162 
edit for selected objects, JCSS-3-161 
edit threads for selected objects, JCSS-3-162 
export IER report, JCSS-3-166 
hide aggregate load coloring, JCSS-3-59 
hide all, JCSS-3-59 
import 

threads from ACE Analyst, JCSS-3-163 
import IER text file, JCSS-3-162 
import IER report, JCSS-3-162 
set color thresholds, JCSS-3-59 
show all, JCSS-3-59 
show only selected, JCSS-3-59 

IERs dialog box, JCSS-3-161 
image editor, JCSS-4-2 
image map 

add to background, JCSS-3-40 
adding, JCSS-3-40 

import, JCSS-3-105 
circuits, JCSS-3-112 
from configlets, JCSS-3-112 
from device configurations, JCSS-3-105 
from VNE Server, JCSS-3-109 

link specification, JCSS-3-112 
import device configurations dialog box, JCSS-3-106 
import elevation lines dialog box, JCSS-3-140 
import flows, JCSS-3-166 
import from VNE Server dialog box, JCSS-3-109 
import node aliases 

from text file, JCSS-3-178 
import package options, JCSS-3-11 
import packaged project, JCSS-2-5 
import packaged project..., JCSS-2-5 
import performance metrics 

from text file, JCSS-3-117 
open import log, JCSS-3-117 
performance metrics 

import, JCSS-3-117 
import performance metrics from text file dialog box, 

JCSS-3-117 
import scenario, JCSS-3-73 

from JCSS/NETWARS, JCSS-3-76 
from OPNET Modeler, JCSS-3-76 
from XML, JCSS-3-77 
subordinate response, JCSS-3-73 
TNAPS to XML, JCSS-3-77 

import threads 
from ACE Analyst wizard, JCSS-3-163 

importing a background image, JCSS-3-41 
importing an image map, JCSS-3-40 
importing MIF data, JCSS-3-40 
inconsistent links, JCSS-3-127 
initial topology dialog box, JCSS-3-3 
inserting a fail time, JCSS-3-194 
introduction, JCSS-1-1 
IP address summary report 

report 
IPaddress summary, JCSS-3-85 

IPunicast traffic flows 
create, JCSS-3-176 

IT Guru Documentation, JCSS-2-25 
IT Guru documentation, JCSS-2-25 

J 
JCSS 

about, JCSS-2-26 
exit, JCSS-2-6 

JCSS acronyms, JCSS-2-25 
JCSS end station models 

compared to DCI, JCSS-3-108 
JCSS Home Page, JCSS-2-26 
JCSS models user’s guides, JCSS-2-25 
JCSS Support Center, JCSS-2-26 

L 
layout, JCSS-3-47 

automatic label placement, JCSS-3-47 
geographic positioning, JCSS-3-51 
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lay out nodes (balanced), JCSS-3-50 
lay out nodes (circular), JCSS-3-51 
lay out nodes (core centric), JCSS-3-50 
lay out nodes (hierarchical), JCSS-3-51 
lay out nodes (simple), JCSS-3-50 
lay out nodes interactively, JCSS-3-48 
move selected nodes to geographic positions, JCSS-3-51 
move selected nodes to non-geographic positions, 

JCSS-3-51 
scale node icons interactively, JCSS-3-47 

layout > lay out nodes (schematic), JCSS-3-51 
layout network objects dialog box, JCSS-3-48 
library 

custom, JCSS-C-1 
editing the contents of, JCSS-C-3 
treeview with custom and pre-configured folders, JCSS-C-2 

library treeview, JCSS-3-104 
license 

attributes, JCSS-2-15 
files, JCSS-2-15 
license management, JCSS-2-14 
management, JCSS-2-14 
product modules, JCSS-2-17 
terminology, JCSS-2-14 

license attributes, JCSS-2-15 
license files, JCSS-2-15 
license management, JCSS-2-14 

and product modules, JCSS-C-7 
license manager 

starting, JCSS-2-15 
license manager requested server dialog box, JCSS-2-16 
license menu, JCSS-2-14 
license server 

files and directories, JCSS-C-5 
license,adding a, JCSS-2-16 
licensing 

change from localhost to external floating, JCSS-C-6 
change from localhost to standalone, JCSS-C-7 
configure localhost floating, JCSS-C-6 
floating Mmde (local), JCSS-C-4 
floating mode (external), JCSS-C-5 
license server 

files and directories, JCSS-C-5 
license server management, JCSS-C-4 
license settings 

manually configuring, JCSS-C-6 
link datarate visualization dialog box, JCSS-3-61 
link defaults dialog box, JCSS-3-20 
link delays 

configure, JCSS-3-117 
from measured delay, JCSS-3-118 
from measured delays 

dialog box, JCSS-3-118 
show output log, JCSS-3-119 

link operations, JCSS-3-123 

clear links, JCSS-3-128 
deploy link, JCSS-3-123 

Link Operations > Import Links from File, JCSS-3-128 
Link Operations > Verify Links, JCSS-3-127 
Link Technology Visualization Dialog Box, JCSS-3-62 
link usage 

color by, JCSS-3-63 
Link Visualization Settings Dialog Box, JCSS-3-62 
Links, JCSS-3-58 
Links Summary Report, JCSS-3-85 
Live Object/Attribute Difference, JCSS-3-92 
Live Object/Attribute Difference > Compare to Network, 

JCSS-3-95 
Live Object/Attribute Difference > Compare to Scenario, 

JCSS-3-96 
Live Object/Attribute Difference > GlobalPreferences, 

JCSS-3-94 
Live Object/Attribute Difference > Reconcile Selected Object 

Differences, JCSS-3-95 
Live Object/Attribute Difference > Select Objects Only in This 

Network, JCSS-3-95 
Live Object/Attribute Difference > Select Objects With 

Differences, JCSS-3-95 
Live Object/Attribute Difference > Specify Behavior, 

JCSS-3-93 
Live Object/Attribute Difference > Stop Comparing, 

JCSS-3-94 
Live Object/Attribute Difference > Track Changes From Last, 

JCSS-3-95 
Live Object/Attribute Difference > Track Changes From Now, 

JCSS-3-95 
Live Object/Attribute Difference > Track Changes From 

Object Defaults, JCSS-3-95 
Live User-Defined Report Tables Dialog Box, JCSS-3-67, 

JCSS-3-87 
livrary 

pre-configured, JCSS-C-1 
Load Object Selection Set, JCSS-3-17 
local administrator user profile, JCSS-B-1 
log files, JCSS-C-8 
log viewer, JCSS-2-25 
Logical View Selection Dialog Box, JCSS-3-30 
login information, JCSS-2-7 

, JCSS-2-7 
login profile 

creating new, JCSS-2-2 
logs 

show all, JCSS-2-25 
LOS Connectivity, JCSS-3-56 
LOS Legend, JCSS-3-58 
LOS Range, JCSS-3-57 
LOS Settings, JCSS-3-55 

M 
manage 3DNV entities, JCSS-3-142 
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Manage 3DNV Entities and Associated Visualizations Dialog 
Box, JCSS-3-142 

Manage 3DNV Entities and Associated Visualizations Dialog 
Box—Pathloss in 3DNV Tab, JCSS-3-146 

Manage 3DNV Entities and Associated Visualizations Dialog 
Box—Trajectories in 3DNV Tab, JCSS-3-145 

Manage Antenna Coverages Dialog Box, JCSS-3-147 
Manage Capacity Optimization Results Dialog Box, 

JCSS-3-189 
Manage Model Files, JCSS-3-10 
manage model files, JCSS-2-5, JCSS-4-3 

add model directory, JCSS-2-6 
delete, JCSS-2-6 
delete model files, JCSS-2-6 
expand project file archive, JCSS-2-6 
refresh model directories, JCSS-2-6 

Manage Model Files > Add Model Directory, JCSS-3-10 
Manage Model Files > Create Project File Archive, JCSS-3-10 
Manage Model Files > Delete Model Files, JCSS-3-10 
Manage Model Files > Expand Project File Archive, 

JCSS-3-10 
Manage Model Files > Refresh Model Directories, JCSS-3-10 
Manage Scenarios, JCSS-3-65 
Manage Scenarios Dialog Box, JCSS-3-65 
manage visualization 

3D 
trajectories, JCSS-3-144 

manually configuring license settings, JCSS-C-6 
Mapped Devices, JCSS-3-25 
maps 

filtering, JCSS-3-52 
merge traffic flows, JCSS-3-175 
Merge Traffic Flows Dialog Box, JCSS-3-175 
message log, JCSS-2-26 

clear, JCSS-2-26 
open, JCSS-2-26 

MIF Import Log Dialog Box, JCSS-3-41 
MIF log 

show, JCSS-3-41 
MIF map 

add to background, JCSS-3-40 
adding, JCSS-3-40 

milestones 
show, JCSS-2-24 

mobility profile 
configure 

on selected nodes, JCSS-3-152 
mobility profiles 

clear, JCSS-3-153 
mode 

standalone, JCSS-C-4 
Model Assistant, JCSS-3-120 
Model Assistant > Apply File, JCSS-3-120 
Model Assistant > Edit File, JCSS-3-120 
Model Assistant > Open Error Log, JCSS-3-121 
Model Assistant > Save Current Topology to File, JCSS-3-121 

Model Completeness Analysis, JCSS-3-96 
Model Completeness Analysis > Configure/Run, JCSS-3-96 
Model Completeness Analysis > Generate Report, JCSS-3-96 
Model Image Capture Preview Dialog Box, JCSS-3-99 
Model Image Capture Preview Window, JCSS-3-116 
model map 

create a new, JCSS-3-23 
model name lists dialog box 

choose source and target, JCSS-2-9 
Model Scenarios > Model Completeness Analysis > 

Configure/Run, JCSS-3-96 
MOP Descriptions, JCSS-3-208 
MOP Graph Panel, JCSS-3-207 
MOP Shortcut Menu, JCSS-3-210 
MrSID image 

add to background, JCSS-3-42 

N 
NetDoctor, JCSS-3-191 
NetDoctor Menu Items, JCSS-3-192 
Netflow Import Process, JCSS-3-167 
NetMapper, JCSS-3-192 
NetMapper Menu Items, JCSS-3-193 
Network Browser, JCSS-3-31 
Network Browser with Showcase Window and Right-Click 

Menu, JCSS-3-32 
Network Defaults Dialog Box, JCSS-3-20 
Network Difference Report, JCSS-3-82 
Network Difference Report > Generate Report, JCSS-3-82 
Network Difference Report > Launch Last Web Report, 

JCSS-3-82 
Network Difference Report > Open Network Difference Log, 

JCSS-3-83 
network inventory summary 

generate, JCSS-3-97 
Network Inventory Summary Dialog Box, JCSS-3-97 
Network Showcase Window, JCSS-3-35 
Network Views, JCSS-3-54 
Network Views > Connectivity, JCSS-3-54 
Network Views > Operational, JCSS-3-55 
Network Views > OPFAC Systems, JCSS-3-55 
Network Views > Planning, JCSS-3-54 
Network Views > Planning and Connectivity, JCSS-3-54 
new, JCSS-4-2 
new device model map, JCSS-2-9 
new icon, JCSS-4-3 
new other, JCSS-2-5 
new other dialog box, JCSS-2-5 
new profile dialog box, JCSS-2-2 
New Project, JCSS-3-2 
new project, JCSS-2-3 
New Scenario, JCSS-3-64 
Next Scenario, JCSS-3-66 
node aliases 

import from text file, JCSS-3-178 
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Node Map Editor Dialog Box, JCSS-3-108 
node/link 

finding, JCSS-3-14 
nw_odbc_log, JCSS-C-8 

O 
object attributes 

free-text questions stored as, JCSS-3-84 
object library, JCSS-C-1 
Object Palette by Icon View, JCSS-3-101 
Object Palette by Treeview, JCSS-3-101 
object palettes 

displaying, JCSS-3-101 
object selection set 

save, JCSS-3-17 
Object/Attribute Difference Report, JCSS-3-89 
object/attribute difference report 

generate, JCSS-3-89 
Object/Attribute Difference Report > Define Report, 

JCSS-3-90 
Object/Attribute Difference Report > Generate Report, 

JCSS-3-89 
Object/Attribute Difference Report > Launch Last Web Report, 

JCSS-3-92 
Object/Attribute Difference Report > View Last Report, 

JCSS-3-92 
Object/Attribute Difference Tree Dialog Box, JCSS-3-92 
Object/Attribute Scenarios > Object/Attribute Difference 

Report > Define Report, JCSS-3-90 
open, JCSS-4-3 
Open a Node Model, JCSS-3-32 
Open Annotation Palette, JCSS-3-104 
Open DES Log, JCSS-3-204 
open device model map., JCSS-2-9 
Open Edge Connectivity Wizard, JCSS-3-123 
open error log, JCSS-2-25 
open flows browser, JCSS-3-166 
open import log 

flows, JCSS-3-173 
Open Library Treeview, JCSS-3-104 
open message log, JCSS-2-26 
Open Network Showcase Window, JCSS-3-35 
Open Node Editor Message Dialog Box, JCSS-3-33 
Open Object Palette, JCSS-3-100 
open other, JCSS-2-5 
Open Project, JCSS-3-6 
open project, JCSS-2-4 
open session log, JCSS-2-26 
Open Subordinate Query, JCSS-3-7 
open subordinate query, JCSS-2-4 
Opened Subordinate Query, JCSS-3-8 
Opening a Node Model in OPNET Modeler, JCSS-3-33 
Opening a Project in Scenario Builder, JCSS-3-6 to JCSS-3-7 
Opening a Subordinate Query, JCSS-3-7 
opening existing project, JCSS-2-4 

operations and maintenance procedures, JCSS-C-1 
OPFAC .nd.m and nt.m files, JCSS-C-9 
OPFAC and organization palettes, JCSS-C-2 
OPFAC Distances > Remove OPFAC Distances, JCSS-3-58 
OPFAC Distances > View OPFAC Distances, JCSS-3-58 
OPFAC files, JCSS-C-9 
OPFACs and devices 

filtering, JCSS-3-53 
OPNET license server management, JCSS-C-4 
organization files, JCSS-C-9 
Outstanding Query in a Scenario, JCSS-3-80 
Owner Information Set on Desired Units, JCSS-3-137 
Owner List Dialog Box, JCSS-3-27 
owner list dialog box, JCSS-2-11 
owners list 

edit, JCSS-2-11 
preferences, JCSS-2-11 

P 
Package Project Files, JCSS-3-11 
palette 

dynamic listings mode, JCSS-3-103 
palettes 

configuring custom, JCSS-3-103 
Panel Operations, JCSS-3-215 
Panels, JCSS-3-215 
parent organization 

go to, JCSS-3-37 
Paste, JCSS-3-14 
pathloss 

between selected nodes 
show/hide, in 3DNV visualizer, JCSS-3-145 

pathloss visualization 
3D 

manage, JCSS-3-145 
Paths, JCSS-3-60 
Perform Auto-Mapping, JCSS-3-109 
performance metrics 

import 
from text file, JCSS-3-117 

dialog box, JCSS-3-117 
import log, JCSS-3-117 

Play 2D Animation, JCSS-3-214 
play 3DNV history, JCSS-3-142 
ports 

circuit deployment wizard tab, JCSS-3-129 
pre-configured library, JCSS-C-1 
preferences, JCSS-2-8, JCSS-4-3 

advanced, JCSS-2-13 
device model map 

choose..., JCSS-2-9 
new..., JCSS-2-9 
open.., JCSS-2-9 

edit, JCSS-2-8 
env_db15.0, JCSS-C-5 
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functional profiles, JCSS-2-10 
geographical coordinates, JCSS-2-10 
owners list, JCSS-2-11 
security classifications, JCSS-2-11 
traffic flow thresholds, JCSS-2-12 

Preferences > Advanced, JCSS-3-29 
Preferences > Device Model Map > Choose, JCSS-3-25 
Preferences > Device Model Map > New, JCSS-3-23 
Preferences > Device Model Map > Open, JCSS-3-25 
Preferences > Functional Profiles, JCSS-3-26 
Preferences > Geographical Coordinates, JCSS-3-27 
Preferences > Owners List, JCSS-3-27 
Preferences > Security Classifications, JCSS-3-27 
Preferences > Traffic Flow Thresholds, JCSS-3-29 
Preferences Editor Dialog Box, JCSS-3-29 
Previous Editor, JCSS-3-216 
previous editor, JCSS-2-17 
Previous Scenario, JCSS-3-66 
Print Graphs, JCSS-3-10 
Print Preview Dialog Box, JCSS-3-9 
Priority Table, JCSS-3-196 
priority table 

accessing, JCSS-3-195 
Probe Model Window, JCSS-3-199 
procedures 

operations and maintenance, JCSS-C-1 
producers and consumers 

assign to 
application tiers, JCSS-3-165 

product modules, JCSS-2-17 
and license management, JCSS-C-7 

project 
closing, JCSS-3-8 
creating a new, JCSS-2-3, JCSS-3-2 
defaults 

default requirements matrix, JCSS-3-21 
save, JCSS-3-7 
save as, JCSS-3-7 

Project Defaults > Distance Between OPFACs, JCSS-3-22 
Project Defaults > Network, JCSS-3-20 
Project Defaults > Requirements Matrix, JCSS-3-21 
Project Defaults > Link, JCSS-3-20 
project file chooser, JCSS-2-4 
project packaging, JCSS-C-9 
Protocols Menu, JCSS-3-179 
Protocols Menu Items , JCSS-3-179 

Q 
Quality of Service (QoS) Node, JCSS-3-197 

R 
Random Mobility, JCSS-3-152 
Random Mobility > Clear Mobility Profile, JCSS-3-153 
Random Mobility > Set Mobility Profile, JCSS-3-152 

Random Mobility > Set Trajectory Created From Random 
Mobility, JCSS-3-153 

Rapid Configuration, JCSS-3-121 
Recent Projects, JCSS-3-11 
recent projects, JCSS-2-6 
Record Packet Flow 2D Animation for Subnet and Record 

Node Movement 2D Animation for Subnet, JCSS-3-200 
Redo, JCSS-3-12 
refresh model directories, JCSS-2-6 
Refresh Workspace, JCSS-3-47 
Reimport Traffic Dialog Box, JCSS-3-173 
relationship 

creating, JCSS-3-133 
deploy 

deploy relationship, JCSS-3-133 
relationship attribute 

specifying, JCSS-A-1 
relationship attributes 

specify start/stop time, JCSS-A-1 
relationships, JCSS-A-1 

relationship attribute 
specifying, JCSS-A-1 

relationship attributes 
specify start/stop tim, JCSS-A-1 

Remaining Unrecognized Sources Dialog Box, JCSS-3-172 
Remove Owner, JCSS-3-137 
rename template OPFAC/Organization, JCSS-C-3 
report 

capacity planning, JCSS-3-190 
settings, JCSS-3-190 
view web, JCSS-3-190 

CCSD summary, JCSS-3-83 
DES 

generate web, JCSS-3-214 
launch last web, JCSS-3-214 
view, JCSS-3-213 

free-text questions, JCSS-3-84 
object/attribute difference 

generate, JCSS-3-89 
scenario web 

displaying in browser, JCSS-3-98 
traffic web 

generate, JCSS-3-178 
Reports, JCSS-3-83, JCSS-3-190 
reports 

object/attribute difference 
define, JCSS-3-91 

Reports > CCSD Summary, JCSS-3-83 
Reports > Free-Text Questions, JCSS-3-84 
Reports > Generate Report from Template..., JCSS-3-87 
Reports > IP Addresses, JCSS-3-85 
Reports > Links, JCSS-3-85 
Reports > Requirements, JCSS-3-85 
Reports > Settings, JCSS-3-190 
Reports > SLD Summary, JCSS-3-86 
Reports > User-Defined Reports, JCSS-3-86 
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Reports > User-Defined Reports > Open Live Report Table..., 
JCSS-3-87 

Reports > View Web Report, JCSS-3-190 
Requirements Summary Report, JCSS-3-86 
Response File Information Dialog Box, JCSS-3-74 
Restart Discrete Event Simulation, JCSS-3-204 
Restore Saved Unit View, JCSS-3-55 
Results, JCSS-3-205 
results 

chooser, JCSS-3-198 
Results > Compare Results, JCSS-3-210 
Results > Find Top Statistics, JCSS-3-210 
Results > Generate Web Report, JCSS-3-214 
Results > Import, JCSS-3-214 
Results > Launch Last Web Report, JCSS-3-214 
Results > View Application Delay Tracking, JCSS-3-212 
Results > View DES Reports, JCSS-3-213 
Results > View Results, JCSS-3-206 
Route Failure Messages and Suggestions , JCSS-3-184 
Run Discrete Event Simulation, JCSS-3-202 
Run Model Completeness Analysis Dialog Box, JCSS-3-96 

S 
Sample Attributes Dialog Box with “3DNV Mapping” Attribute, 

JCSS-3-142 
sample preferences editor, JCSS-2-13 
Sample Select Devices Dialog Box, JCSS-3-125 
Satellite Bent Pipe Link Deployment Dialog Box—Advanced, 

JCSS-3-126 
Satellite Bent Pipe Link Deployment Dialog Box—Basic, 

JCSS-3-125 
Satellite Bent Pipe Link Deployment dialog box—Help 

Diagram, JCSS-3-126 
Satellite Bent Pipe Link Deployment Dialog Box—Help FAQs, 

JCSS-3-127 
satellite links 

deploying, JCSS-3-124 
save, JCSS-4-3 
save as, JCSS-4-3 
Save Current Unit View, JCSS-3-55 
Save Object Selection Set, JCSS-3-17 
Save Optimization As Dialog Box, JCSS-3-188 
Save Project/ Save Project As, JCSS-3-7 
save template OPFAC/Organization as, JCSS-C-3 
Scale All Icons Dialog Box, JCSS-3-47 
Scaling Node Icons Interactively, JCSS-3-47 
scenario 

adding objects to, JCSS-3-102 
changes made to original, JCSS-3-75 
creating a new, JCSS-3-64 
duplicating, JCSS-3-65 

scenario bitmap 
generate, JCSS-3-99 

scenario briefing 
generate, JCSS-3-8 
generating, JCSS-3-8 

Scenario Builder, JCSS-3-1 
scenario builder, JCSS-1-1 

accessing, JCSS-3-1 
Scenario Documentation Dialog Box, JCSS-3-69 
scenario files, JCSS-C-9 
scenario web report 

displaying in web browser, JCSS-3-98 
Scenarios > DoDAF Integration (option), JCSS-3-69 
Scenarios > Duplicate Scenario, JCSS-3-65 
Scenarios > Export Scenario > (option) 

, JCSS-3-78 
Scenarios > Export Scenario > Subordinate Query, 

JCSS-3-78 
Scenarios > Export Scenario > Subordinate Response, 

JCSS-3-80 
Scenarios > Export Scenario > To JNMS, JCSS-3-82 
Scenarios > Export Scenario > To Visio, JCSS-3-82 
Scenarios > Export Scenario > To XML, JCSS-3-81 
Scenarios > Generate Network Inventory Summary 

Launch a Network Inventory Summary report., JCSS-3-97 
Scenarios > Generate Scenario Bitmap, JCSS-3-99 
Scenarios > Import Scenario > (option), JCSS-3-73 
Scenarios > Import Scenario > From JCSS/NETWARS, 

JCSS-3-76 
Scenarios > Import Scenario > From OPNET Modeler, 

JCSS-3-76 
Scenarios > Import Scenario > From XML, JCSS-3-77 
Scenarios > Import Scenario > Subordinate Response, 

JCSS-3-73 
Scenarios > Import Scenario > TNAPS to XML, JCSS-3-77 
Scenarios > Live Object/Attribute Difference > Compare to 

Network 
, JCSS-3-95 

Scenarios > Live Object/Attribute Difference > Compare to 
Scenario 
, JCSS-3-96 

Scenarios > Live Object/Attribute Difference > Global 
Preferences > (options) 
, JCSS-3-94 

Scenarios > Live Object/Attribute Difference > Reconcile 
Selected Object Differences, JCSS-3-95 

Scenarios > Live Object/Attribute Difference > Select Objects 
Only In This Network, JCSS-3-95 

Scenarios > Live Object/Attribute Difference > Select Objects 
With Differences, JCSS-3-95 

Scenarios > Live Object/Attribute Difference > Specify 
Behavior, JCSS-3-93 

Scenarios > Live Object/Attribute Difference > Stop 
Comparing, JCSS-3-94 

Scenarios > Live Object/Attribute Difference > Track Changes 
From Last Save 
, JCSS-3-95 

Scenarios > Live Object/Attribute Difference > Track Changes 
From Now 
, JCSS-3-95 

Scenarios > Live Object/Attribute Difference > Track Changes 
From Object Defaults, JCSS-3-95 
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Scenarios > Live Object/Attribute Difference> (option), 
JCSS-3-92 

Scenarios > Manage Scenarios, JCSS-3-65 
Scenarios > Model Completeness Analysis > (option), 

JCSS-3-96 
Scenarios > Model Completeness Analysis > Generate 

Report, JCSS-3-96 
Scenarios > Network Difference Report > (option), JCSS-3-82 
Scenarios > Network Difference Report > Generate Report, 

JCSS-3-82 
Scenarios > Network Difference Report > Launch Last Web 

Report, JCSS-3-82 
Scenarios > Network Difference Report > Open Network 

Difference Log 
, JCSS-3-83 

Scenarios > New Scenario or press ++, JCSS-3-64 
Scenarios > Next Scenario, JCSS-3-66 
Scenarios > Object/Attribute Difference Report > (option), 

JCSS-3-89 
Scenarios > Object/Attribute Difference Report > Generate 

Report, JCSS-3-89 
Scenarios > Object/Attribute Difference Report > Launch Last 

Web Report, JCSS-3-92 
Scenarios > Object/Attribute Difference Report > View Last 

Report, JCSS-3-92 
Scenarios > Previous Scenario, JCSS-3-66 
Scenarios > Reports > (option), JCSS-3-83 
Scenarios > Reports > CCSD Summary, JCSS-3-83 
Scenarios > Reports > Free-Text Questions, JCSS-3-84 
Scenarios > Reports > IP Addresses, JCSS-3-85 
Scenarios > Reports > Links, JCSS-3-85 
Scenarios > Reports > Requirements, JCSS-3-85 
Scenarios > Reports > SLD Summary, JCSS-3-86 
Scenarios > Reports> User-Defined Reports > (option), 

JCSS-3-86 
Scenarios > Reports> User-Defined Reports > Generate 

Report from Template..., JCSS-3-87 
Scenarios > Reports> User-Defined Reports > Open Live 

Report Table..., JCSS-3-87 
Scenarios > Set Classification, JCSS-3-67 
Scenarios > Set Scenario Documentation, JCSS-3-69 
Scenarios > Switch To Scenario, JCSS-3-67 
Scenarios > User-Defined Reports > (option), JCSS-3-67 
Scenarios > User-Defined Reports > Generate Report from 

Template, JCSS-3-68 
Scenarios > User-Defined Reports > Open Live Report Table, 

JCSS-3-67 
Scenarios Menu, JCSS-3-64 
Scenarios > DoDAF Integration > DoDAF Editor..., 

JCSS-3-70 
Scenarios > DoDAF Integration > Generate Visio Reports..., 

JCSS-3-71 
Security Classifications, JCSS-3-28 
security classifications 

edit, JCSS-2-11 
preferences, JCSS-2-11 

security classifications dialog box, JCSS-2-11 

Select All, JCSS-3-14 
Select Devices Dialog Box, JCSS-3-124 
Select Elevation Lines Dialog Box, JCSS-3-140 
Select Equipment Types Dialog Box, JCSS-3-3 
Select Included Entries Dialog Box, JCSS-3-104 
Select Output Table Files to View Dialog Box, JCSS-3-100 
Select SRG Import File Dialog Box, JCSS-3-155 
Select Statistic for Top Results, JCSS-3-211 
select user dialog box, JCSS-2-7 
Select Wired Link Properties Dialog Box, JCSS-3-124 
Selecting a Border Map, JCSS-3-39 
Selection Filter Dialog Box, JCSS-3-16 
session log, JCSS-2-26 

clear.., JCSS-2-26 
open, JCSS-2-26 

Set Area of Interest, JCSS-3-36 
Set Area of Interest Dialog Box, JCSS-3-36 
Set Area of Operations Dialog Box, JCSS-3-5 
Set Classification, JCSS-3-67 
Set Owner, JCSS-3-136 
Set Owner Dialog Box, JCSS-3-137 
Set Scenario Documentation, JCSS-3-69 
Set View for Network, JCSS-3-64 
Set View for Subnet, JCSS-3-64 
Setting Background View Properties, JCSS-3-37 
Setting Border Map, JCSS-3-39 
setting geographical coordinates, JCSS-2-10 
Shared Risk Groups, JCSS-3-154 
Shared Risk Groups > Export, JCSS-3-155 
Shared Risk Groups > Import, JCSS-3-155 
Shared Risk Groups > New, JCSS-3-154 
Shared Risk Groups > Visualize Operational Status, 

JCSS-3-155 
Show All Editors, JCSS-3-216 
show all editors, JCSS-2-18 
show all logs, JCSS-2-25 
Show Logical Views, JCSS-3-30 
Show LOS > Clear LOS Ranges, JCSS-3-58 
Show LOS > Display LOS Legend, JCSS-3-58 
show milestones, JCSS-2-24 
Show Network Browser, JCSS-3-31 
Show Network Showcase, JCSS-3-34 
Show Network Showcase in Scenario Builder, JCSS-3-34 
Show Network Topology, JCSS-3-34 
Show Time Controller, JCSS-3-35 
Show Toolbar, JCSS-3-217 
sign-in dialog box, JCSS-2-1 
Simulation Execution Dialog Box, JCSS-3-203 
SLA 

define, JCSS-3-200 
SLD Summary Report, JCSS-3-86 
software release bulletin (SRB), JCSS-2-24 
source and target model name lists 

file chooser, JCSS-3-23 
Source Model List Browser, JCSS-3-23 
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specify application transactions 
in ACE to threaded IER conversion, JCSS-3-163 

Specify Live Object/Attribute Difference Behavior Dialog Box, 
JCSS-3-93 

Specifying the Requirements Matrix Defaults File, JCSS-3-22 
Speed of Service MOP, JCSS-3-208 
SRB, JCSS-2-24 
standalone mode, JCSS-C-4 
starting license manager, JCSS-2-15 
Statistics, JCSS-3-198 
statistics 

choose, JCSS-3-199 
Switch Between Scenarios, JCSS-3-67 
Switch To Scenario, JCSS-3-67 
System, JCSS-3-217 
system administration, JCSS-B-1 
system editor, JCSS-1-1, JCSS-2-1 

accessing, JCSS-2-1 
system editor's edit menu, JCSS-2-7 
system editor's file menu, JCSS-2-3 
system editor's help menu, JCSS-2-18 
system editor's license menu, JCSS-2-14 
system editor’s windows menu, JCSS-2-17 

T 
task 

communications plan 
develop, JCSS-2-20 

completing a, JCSS-2-23 
task assistant, JCSS-2-18 

browse for workflow, JCSS-2-21 
task assistant browse for workflow, JCSS-2-21 
task assistant dialog box, JCSS-2-19 
task tracking, JCSS-2-21 
task tracking dialog box, JCSS-2-22 
technical reference manual, JCSS-2-24 
template 

OPFAC/Organization 
delete, JCSS-C-4 
rename, JCSS-C-3 
save as, JCSS-C-3 

OPFAC/Organization attributes 
edit, JCSS-C-3 

units 
undo/redo, JCSS-C-4 

Terrain, JCSS-3-137 
terrain 

edit line display settings 
current elevation line display settings, JCSS-3-141 

Terrain > Edit, JCSS-3-139 
Terrain > Edit Map Display Settings, JCSS-3-141 
Terrain > Rebuild Terrain Data Catalog, JCSS-3-139 
Terrain > Set Elevation Maps, JCSS-3-140 
Terrain > Set Propagation Model, JCSS-3-138 
Terrain > Specify Terrain Data Directory, JCSS-3-139 

Terrain > View Terrain Profile, JCSS-3-138 
Terrain Data Directory Preferences Dialog Box, JCSS-3-139 
Terrain Effects Shading, JCSS-3-58 
Terrain Profile, JCSS-3-138 
text files 

IER, JCSS-C-9 
Thread Dialog Box, JCSS-3-162 
threads 

import from ACE Analyst, JCSS-3-163 
Time Controller Dialog Box, JCSS-3-35 
Time Controller Settings Dialog Box, JCSS-3-36 
time varying infrastructure, JCSS-A-1 
TNAPS to NETWARS Converter Dialog Box, JCSS-3-78 
toolbar 

float, JCSS-3-217 
Top Level Unit Dialog Box, JCSS-3-6 
Top Results Report Interface, JCSS-3-211 
Top Solutions Summary Dialog Box, JCSS-3-190 
topology 

delete unconnected nodes, JCSS-3-121 
Topology > 3DNV > (option), JCSS-3-141 
Topology > 3DNV > Add “3DNV Mapping” Attribute to 

Selected Nodes 
, JCSS-3-142 

Topology > 3DNV > Display 3D Network View, JCSS-3-141 
Topology > 3DNV > Manage 3D Visualization of Pathloss, 

JCSS-3-145 
Topology > 3DNV > Manage 3D Visualization of Trajectories, 

JCSS-3-144 
Topology > 3DNV > Manage 3DNV Entities, JCSS-3-142 
Topology > 3DNV > Play 3DNV History, JCSS-3-142 
Topology > 3DNV > Show Pathloss between Selected Nodes 

in 3D Visualizer and Topology > 3DNV > Hide Pathloss 
between Selected Nodes in 3D Visualize, JCSS-3-145 

Topology > 3DNV > Show Trajectories of Selected Nodes in 
3D Visualizer and Topology > 3DNV > Hide Trajectories of 
Selected Nodes in 3D, JCSS-3-144 

Topology > 3DNV > Visualize Antenna Coverage, 
JCSS-3-147 

Topology > Clear Trajectory Assignment, JCSS-3-151 
Topology > Configuration Utilities > Cut-through > Disable 

Cut-through on Selected Devices (All Ports), JCSS-3-136 
Topology > Configuration Utilities > Cut-through > Enable 

Cut-through on Selected Devices (All Ports), JCSS-3-135 
Topology > Configuration Utilities > UHF DAMA SATCOM, 

JCSS-3-133 
Topology > Configure Link Delays > (option), JCSS-3-117 
Topology > Configure Link Delays > From Measured Delay 

Information, JCSS-3-118 
Topology > Configure Link Delays > Show Output Log, 

JCSS-3-119 
Topology > Create Custom Device Model..., JCSS-3-121 
Topology > Define Trajectory, JCSS-3-148 
Topology > Delete Unconnected Nodes, JCSS-3-121 
Topology > Deploy Broadcast Network, JCSS-3-131 
Topology > Deploy Circuit, JCSS-3-128 
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Topology > Deploy Relationship, JCSS-3-133 
Topology > Deploy Wireless Network, JCSS-3-122 
Topology > Export > (option), JCSS-3-112 
Topology > Export > Attributes for All Objects, JCSS-3-115 
Topology > Export > Attributes For Selected Objects, 

JCSS-3-115 
Topology > Export > Selected Area to Bitmap, JCSS-3-116 
Topology > Export > Subnet Hierarchy to VNE Server as 

Groups > (option) 
, JCSS-3-114 

Topology > Export > Subnet Hierarchy to VNE Server as 
Groups > Entire Network, JCSS-3-115 

Topology > Export > Subnet Hierarchy to VNE Server as 
Groups > Selected Subnets, JCSS-3-115 

Topology > Export > To Network Whiteboard, JCSS-3-114 
Topology > Export > To Spreadsheet, JCSS-3-113 
Topology > Export > To Visio, JCSS-3-113 
Topology > Export > Visible Area to Bitmap, JCSS-3-116 
Topology > Import > (option), JCSS-3-105 
Topology > Import > From Configlets, JCSS-3-112 
Topology > Import > From Device Configurations, 

JCSS-3-105 
Topology > Import > From VNE Server, JCSS-3-109 
Topology > Import > Link Specification, JCSS-3-112 
Topology > Import Performance Metrics > (option), 

JCSS-3-117 
Topology > Import Performance Metrics > From Text File, 

JCSS-3-117 
Topology > Import Performance Metrics > Open Import Log, 

JCSS-3-117 
Topology > Link Operations > (option), JCSS-3-123 
Topology > Link Operations > Clear Links, JCSS-3-128 
Topology > Link Operations > Deploy Link, JCSS-3-123 
Topology > Link Operations > Import Links from File, 

JCSS-3-128 
Topology > Link Operations > Verify Links, JCSS-3-127 
Topology > Model Assistant > (option), JCSS-3-120 
Topology > Model Assistant > Apply File, JCSS-3-120 
Topology > Model Assistant > Edit File, JCSS-3-120 
Topology > Model Assistant > Open Error Log, JCSS-3-121 
Topology > Model Assistant > Save Current Topology to File, 

JCSS-3-121 
Topology > Open Annotation Palette, JCSS-3-104 
Topology > Open Edge Connectivity Wizard, JCSS-3-123 
Topology > Open Library Treeview, JCSS-3-104 
Topology > Open Object Palette, JCSS-3-100 
Topology > Random Mobility > (option), JCSS-3-152 
Topology > Random Mobility > Clear Mobility Profile, 

JCSS-3-153 
Topology > Random Mobility > Set Mobility Profile, 

JCSS-3-152 
Topology > Random Mobility > Set Trajectory Created From 

Random Mobility, JCSS-3-153 
Topology > Rapid Configuration, JCSS-3-121 
Topology > Remove Owner, JCSS-3-137 
Topology > Set Owner, JCSS-3-136 

Topology > Shared Risk Groups > (option), JCSS-3-154 
Topology > Shared Risk Groups > Export, JCSS-3-155 
Topology > Shared Risk Groups > Import, JCSS-3-155 
Topology > Shared Risk Groups > New, JCSS-3-154 
Topology > Shared Risk Groups > Visualize Operational 

Status > (option), JCSS-3-155 
Topology > Terrain, JCSS-3-137 
Topology > Terrain > Edit Map Display Settings, JCSS-3-141 
Topology > Terrain > Edit Parameter Sets, JCSS-3-139 
Topology > Terrain > Rebuild Terrain Data Catalog, 

JCSS-3-139 
Topology > Terrain > Set Elevation Maps, JCSS-3-140 
Topology > Terrain > Set Propagation Model, JCSS-3-138 
Topology > Terrain > Specify Terrain Data Directory, 

JCSS-3-139 
Topology > Terrain > View Terrain Profile, JCSS-3-138 
Topology Menu, JCSS-3-100 
Topology > Export > Circuits, JCSS-3-113 
Topology > Import > Circuits, JCSS-3-112 
traffic 

convert 
applications to flows, JCSS-3-177 

Traffic > Convert Traffic > Applications to Flows, JCSS-3-177 
Traffic > Device/Link Loads > Clear Import Log, JCSS-3-177 
Traffic > Device/Link Loads > Import > (option), JCSS-3-177 
Traffic > Device/Link Loads > Open Import Log, JCSS-3-177 
Traffic > Export Node Aliases > To Text File..., JCSS-3-178 
Traffic > Flows > (option), JCSS-3-166 
Traffic > Flows > Create Flows, JCSS-3-175 
Traffic > Flows > Export > To Spreadsheet, JCSS-3-174 
Traffic > Flows > Export > To TR2, JCSS-3-175 
Traffic > Flows > Import > (option), JCSS-3-166 
Traffic > Flows > Import > Clear Import Log, JCSS-3-173 
Traffic > Flows > Import > Open Import Log, JCSS-3-173 
Traffic > Flows > Merge Traffic Flows, JCSS-3-175 
Traffic > Flows > Open Flows Browser, JCSS-3-166 
Traffic > Generate Traffic Web Report, JCSS-3-178 
Traffic > IERs > (option), JCSS-3-156 
Traffic > IERs > Create Thread, JCSS-3-161 
Traffic > IERs > Deploy IERs..., JCSS-3-156 
Traffic > IERs > Edit All IERs, JCSS-3-161 
Traffic > IERs > Edit All Threads, JCSS-3-162 
Traffic > IERs > Edit IERs for Selected Objects, JCSS-3-161 
Traffic > IERs > Edit Threads for Selected Objects, 

JCSS-3-162 
Traffic > IERs > Export IER Report, JCSS-3-166 
Traffic > IERs > Import > Import IER Report, JCSS-3-162 
Traffic > IERs > Import > Import IER Text File, JCSS-3-162 
Traffic > Import Node Aliases > From Text File..., JCSS-3-178 
Traffic > Traffic Wizard, JCSS-3-156 
traffic files, JCSS-C-9 
traffic flow thresholds, JCSS-2-12 

preferences, JCSS-2-12 
Traffic Flow Thresholds Dialog Box, JCSS-3-59 
traffic flow thresholds dialog box, JCSS-2-12 
traffic flows 
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IPunicast 
create, JCSS-3-176 

Traffic Flows Import Dialog Box, JCSS-3-170 
Traffic Import Dialog Box, JCSS-3-169 
Traffic Menu, JCSS-3-156 
traffic web report 

generate, JCSS-3-178 
Traffic Wizard, JCSS-3-156 
Traffic > IERs > Deploy IERs (Advanced), JCSS-3-159 
Traffic > IERs > Import > Threads from ACE Analyst, 

JCSS-3-163 
trajectories, JCSS-C-10 

of selected nodes 
show/hide, in 3D visualizer, JCSS-3-144 

trajectory 
define, JCSS-3-148 

Trajectory Segment Information Dialog Box, JCSS-3-150 
transaction method 

choose, JCSS-2-16 

U 
UHF DAMA SATCOM Wizard 

Define Channels (Step 2 of 3) Dialog Box, JCSS-3-134 
Define CPS Node Attributes (Step 1 of 3) Dialog Box, 

JCSS-3-134 
Define Services (Step 3 of 3) Dialog Box, JCSS-3-135 

Unconnected Node Deletion Dialog Box, JCSS-3-121 
Undo, JCSS-3-12 
undo/redo template units, JCSS-C-4 
Unowned Units Dialog Box, JCSS-3-79 
Unrecognized Traffic Assistant Dialog Box, JCSS-3-172 
user 

change, JCSS-2-7 
changing, JCSS-2-7 

user level, JCSS-2-8 
advanced, JCSS-2-8 
beginner, JCSS-2-8 
intermediate, JCSS-2-8 

user profile 
local administrator, JCSS-B-1 

user’s manual, JCSS-2-24 
user-defined report 

generating, JCSS-3-68 
User-Defined Reports, JCSS-3-67 
User-Defined Reports > Generate Report from Template, 

JCSS-3-68 
User-Defined Reports > Open Live Report Table, JCSS-3-67 
Using a Selection Filter, JCSS-3-15 
Using Dynamic Listing Option for Object Palettes, 

JCSS-3-103 
Using Group Actions, JCSS-3-16 
using task tracking, JCSS-2-21 

V 
view 

demands, JCSS-3-58 
View > Annotations > (option), JCSS-3-60 
View > Background > Add CADRG/CIB Raster Catalog 

Directories..., JCSS-3-42 
View > Background > Add Image, JCSS-3-41 
View > Background > Add Image Map, JCSS-3-40 
View > Background > Add MIF Map, JCSS-3-40 
View > Background > Add MrSID Image..., JCSS-3-42 
View > Background > Map Edit Mode, JCSS-3-42 
View > Background > Set Border Map, JCSS-3-39 
View > Background > Set Properties, JCSS-3-37 
View > Background > Show MIF Log, JCSS-3-41 
View > Circuits > (option), JCSS-3-60 
View > Demands > (option) 

, JCSS-3-58 
View > Edit Display Preferences, JCSS-3-43 
View > Filter > (option), JCSS-3-52 
View > Filter > Devices, JCSS-3-53 
View > Filter > Hide Locked Units, JCSS-3-54 
View > Filter > Infrastructure, JCSS-3-53 
View > Filter > Restore Full View, JCSS-3-54 
View > Filter > Selected Objects, JCSS-3-52 
View > Go to Parent Organization or click the Go to Parent 

Organization toolbar button, JCSS-3-37 
View > IERs > (option) 

, JCSS-3-58 
View > IERs > Color by Aggregate Load, JCSS-3-59 
View > IERs > Hide Aggregate Load Coloring, JCSS-3-59 
View > IERs > Hide All, JCSS-3-59 
View > IERs > Set IER Color Thresholds, JCSS-3-59 
View > IERs > Show All, JCSS-3-59 
View > IERs > Show Only Selected, JCSS-3-59 
View > Layout > (option), JCSS-3-47 
View > Layout > Geographic Positioning, JCSS-3-51 
View > Layout > Lay Out Nodes Interactively..., JCSS-3-48 
View > Layout > Move Selected Nodes to Geographic 

Positions, JCSS-3-51 
View > Layout > Move Selected Nodes to Non-Geographic 

Positions, JCSS-3-51 
View > Layout > Scale Node Icons Interactively, JCSS-3-47 
View > Layout> Automatic Icon Scaling, JCSS-3-47 
View > Layout> Automatic Label Placement, JCSS-3-47 
View > Layout> Lay Out Nodes (Balanced), JCSS-3-50 
View > Layout> Lay Out Nodes (Circular), JCSS-3-51 
View > Layout> Lay Out Nodes (Core Centric)..., JCSS-3-50 
View > Layout> Lay Out Nodes (Hierarchical), JCSS-3-51 
View > Layout> Lay Out Nodes (Schematic)..., JCSS-3-51 
View > Layout> Lay Out Nodes (Simple), JCSS-3-50 
View > Links > (option), JCSS-3-58 
View > Network Views > (option), JCSS-3-54 
View > Network Views > Connectivity, JCSS-3-54 
View > Network Views > Operational, JCSS-3-55 
View > Network Views > OPFAC Systems, JCSS-3-55 
View > Network Views > Planning, JCSS-3-54 
View > Network Views > Planning and Connectivity, 

JCSS-3-54 
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View > Network Views > Connectivity, JCSS-3-54 
View > Open Network Showcase Window, JCSS-3-35 
View > OPFAC Distances > Remove OPFAC Distances, 

JCSS-3-58 
View > OPFAC Distances > View OPFAC Distances, 

JCSS-3-58 
View > Paths > (option), JCSS-3-60 
View > Refresh Workspace, JCSS-3-47 
View > Restore Saved Unit View, JCSS-3-55 
View > Save Current Unit View, JCSS-3-55 
View > Set Area of Interest, JCSS-3-36 
View > Set View for Network > (option), JCSS-3-64 
View > Set View for Subnet > (option), JCSS-3-64 
View > Show Logical Views..., JCSS-3-30 
View > Show LOS > Clear LOS Ranges, JCSS-3-58 
View > Show LOS > Display LOS Legend, JCSS-3-58 
View > Show LOS > LOS Settings, JCSS-3-55 
View > Show Network Browser, JCSS-3-31 
View > Show Network Showcase, JCSS-3-34 
View > Show Network Topology, JCSS-3-34 
View > Show Time Controller, JCSS-3-35 
View > Visualize Link Usage > (option), JCSS-3-62 
View > Visualize Link Usage > Clear Visualization, JCSS-3-63 
View > Visualize Link Usage > Color by Link Usage, 

JCSS-3-63 
View > Visualize Link Usage > Reset Utilization Value Label 

Positions 
, JCSS-3-64 

View > Visualize Link Usage > Settings, JCSS-3-62 
View > Visualize Link Usage > Show Legend, JCSS-3-63 
View > Visualize Network Configuration > (option), JCSS-3-61 
View > Visualize Protocol Configuration > (option), JCSS-3-60 
View > Wireless Domains > (option), JCSS-3-60 
View > Zoom > To All, JCSS-3-52 
View > Zoom > To Rectangle, JCSS-3-51 
View > Zoom > To Selection, JCSS-3-52 
View > Zoom > Unzoom, JCSS-3-52 
View Associated Output Tables, JCSS-3-100 
View Associated Scenarios > View Associated Output Tables, 

JCSS-3-100 
View Infrastructure Dialog Box, JCSS-3-53 
View Menu, JCSS-3-30 
View Results, JCSS-3-206 
visualization of trajectories 

3D 
manage, JCSS-3-144 

Visualize Link Usage, JCSS-3-62 

Visualize Link Usage > Clear Visualization, JCSS-3-63 
Visualize Link Usage > Color by Link Usage, JCSS-3-63 
Visualize Link Usage > Reset Utilization Value Label 
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