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Identification

Document Identification

Document Title: JCSS User’s Manual
Version: 10.0 Final

Software Identification

Product Name: JCSS
Product Release: 10.0

Documentation Conventions

This documentation uses specific formatting and typographic conventions to
present the following types of information:

* Objects, examples, and system 1/0O
* Object hierarchies
e Computer commands

¢ Lists and procedures

Objects, Examples, and System I/O
e Directory paths and file names are in standard Courier typeface:
C:\JCSS\User_ Data\Projects

* Function names in body text are in italics:

op_dist outcome ()

e The names of functions of interest in example code are in bolded Courier
typeface:

/* determine the object ID of packet’s creation module */
src_mod objid = op _pk creation mod get (pkptr);

* Variables are enclosed in angle brackets (< >):
<JCSS path>\Scenario Builder\op admin\err log

Object Hierarchies

Menu hierarchies are indicated by right angle brackets (>); for example:
Edit > Preferences > Advanced
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Computer Commands

These conventions apply to Windows systems and navigation methods that use
the standard graphical-user-interface (GUI) terminology such as click, drag, and
dialog box.

* Key combinations appear in the form “press <button>+x”; this means press
the <button> and x keys at the same time to do the operation.

* The mouse operations left-click (or click) and right-click indicate that you
should press the left mouse button or right mouse button, respectively.

Lists and Procedures

Information is often itemized in bulleted (unordered) or numbered (ordered)
lists:

* In bulleted lists, the sequence of items is not important.
* In numbered lists, the sequence of items is important.
Procedures are contained within procedure headings and footings that indicate

the start and end of the procedure. Each step of a procedure is numbered to
indicate the sequence in which you should do the steps.
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Document Revision History

Table FM-1 Document Revision History

Release Date

Product Version

Chapter

Description of Change

April 2010

10.0 Final

All

¢ Updated references from 9.0 to 10.0
* Updated references from 15.0 to 16.0

» Changed from Draft to Final version

¢ Added note about support deprecation for
Traffic Assistant

» Updated Circuit Deployment Wizard
screenshots

¢ Updated Protocols menu items

¢ Updated screenshots to include FHSS
Modeling in “Defining Broadcast Networks”

* Updated Circuit Deployment Wizard
screenshots

e Updated Protocols menu items
* Updated Figure 3-31

» Added information about ier_configs file in
relation to default IER properties

* Revised Priority definition

¢ Added information about Export Reports
checkbox functionality

* Added note about requirements for running a
simulation

March 2010

10.0 Draft

All

Converted PDF files of JCSS User Manual and
JCSS Technical Reference into Adobe
FrameMaker 7.0. and applied commercial
OPNET product documentation style template to
improve quality and update manual. Reformatted
text as needed to fit new format and style.
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Table FM-1 Document Revision History (Continued)

Release Date Product Version Chapter Description of Change
4 * Revised “Creating IERs” section to include
dialog box changes and new Record Routes
feature

* Added “Creating Threads from ACE Analyst”
* Revised Integrating DoDAF Views

¢ Updated Procedure 4-21: Create IERs from
DoDAF Editor

» Added Procedure 4-22: Create and Deploy
Standard Applications from the DoDAF Editor

» Added Procedure 4-23: Creating Threads from
DoDAF Editor

» Added section “Generating DoDAF Visio
Reports”

¢ Added descriptions of new DoDAF views
available for Visio output

6 » Updated “Running a Simulation” to include
Record IER Route feature

* Revised Procedure 6-5 for clarity
* Added “Viewing Recorded IER Routes”

Glossary * Added note and revised documentation
references for Process Registry

March 2009 9.0 Final 1 * Updated JCSS System Architecture figure.

2 * Added a disclosure that the Task Assistant is
no longer maintained and some of the steps
may no longer be valid.

¢ Removed View > Zoom > To Window.

3 * Added Protocols > IPv4 submenu.
* Added Netmapper section
* Added Importing from VNE Server section.

4 e Updated IERs section.
¢ Updated Threads section.
* Added Integrating DoDAF section.

8 * Added JCSS@disa.mil as a PMO Contact
Address.
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Table FM-1 Document Revision History (Continued)

Release Date

Product Version

Chapter

Description of Change

January 30, 2009

9.0 Draft

Front matter

* Updated JCSS Logo and text to reflect name

change from Joint

All

e Communications Simulation System to Joint
Communication Simulation System.

* Updated document footers and applicable
figures to reflect new JCSS version 9.0.

* Changed applicable figures to reflect update
from env_db14.5 to env_db15.0, and file path

names from 14.5.A to 15.0.A.

» Updated New Project Wizard steps in Creating

a New Project section.

* Updated Creating IERs and Creating Threads

sections

August 1, 2008

8.0 Final

* Updated Figure 2-1 to remove IER Database

menu from System Editor.

» Updated Figure 3-17, Select Wired Link

Properties dialog box.

* Removed reference to IER Database.

¢ Added note to Procedure 7-1, step 1.

¢ Added note that statistics can be exported to

Excel.

July 11, 2008

8.0 Draft

All

» Updated figures to reflect product name

change to JCSS from NETWARS.

* Removed “Answering Mission Analysis

Questions” section.

* Removed Specify Equipment Lists step from

New Project Wizard.

¢ Updated procedure for TSSP/Multiplexer

circuit deployment.

November 30, 2007

7.0 Final

All

* Began introduction of product name change to

JCSS from NETWARS.

» Updated figure 2-26 Logical View Selection
dialog box, and removed refs to Frame Relay,

VTC, etc., in this section.

¢ Added note that Modeler will not launch from

JCSS without a Modeler license.
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Table FM-1 Document Revision History (Continued)

Release Date

Product Version Chapter

Description of Change

October 31, 2007

2007 2
Final

¢ Added sentence to Procedure 2-17 that
Network Layer Filters shown are only those
which apply to the deployed network.

* Removed “Scenario Treeview” references from
document, and updated procedures for
deploying satellite links and defining broadcast
networks.

¢ Added “Save As Link Type” section.

» Updated procedures for creating threads and
creating relationships.

JCSS/Release 10.0

JCSS-FM-ix



—Document Revision History

Table FM-1 Document Revision History (Continued)

Release Date Product Version Chapter

Description of Change

October 17, 2007 2007 2
Draft

» Updated figures and text to reflect change to
NETWARS v2007.

¢ Updated figure 2-11 list of pre-configured
organizations.

* Changed Scenarios > Reports > Mission
Analysis Questions to Scenarios > Reports >
Mission Analysis.

* Added reference to CADRG/CIB Raster
Catalog Directories and MrSID images to
“Adding Background Images” section.

» Updated figure 2-26 with new Logical View
options.

Updated figures with new options/lists:

* 3-3 Organization Attributes dialog box

* 3-4 OPFAC Attributes dialog box

* 3-5 Edit Objects Using Template dialog box

¢ 3-25 TSSP Group Config (Circuit Deployment)
dialog box

» 3-38 Satellite Link Attributes dialog box
¢ 3-43 and 3-44 changed ‘Phase’ to ‘Scenario’
¢ 3-48 LOS Settings dialog box

* Added “Opening Node Models in Modeler’
section.

¢ Updated “Defining Broadcast Networks”
section to include new wizard.

¢ Added procedure to “Add Broadcast Networks
via the Right-Click Menu.”

» Updated “Configuring Utility Nodes” section to
reflect new Circuit Deployment Wizard.

¢ Added Protocols > Link 16 and Protocols >
IPv6 submenus.

¢ Added View > Visualize Protocol Configuration
> |P Address Types.

¢ Added Protocols > Link 16 and Protocols >
IPv6 submenus.

¢ Added View > Visualize Protocol Configuration
> |P Address Types.

¢ Added note to “Create a Thread” procedure re:
right-click “View Threads” option.

» Added note to “Create a Relationship”
procedure re: right-click “Deploy Relationship”
option.
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Table FM-1 Document Revision History (Continued)

Release Date Product Version Chapter Description of Change

6 » Added figure 6-2 Probe Model window.

» Updated figure 6-3 list of Attributes in
Configure/Run DES dialog box

7 ¢ Updated figure 7-1 Results Browser.

December 6, 2006 6.2 Final 3 * Revised ref to “the three OPFACs” in Step 4 of
Procedure 3-25 to read “the two OPFACs that
contain the endpoint earth terminals and the
OPFAC that contains the home satellite.”

¢ Updated Figure 3-33, Satellite Bent Pipe Link
Deployment.

4 * Removed Defining Application Profiles section
(refer instead to Traffic Wizard in chapter 4.)

* Moved Creating Relationships section to after
Creating IERs and Creating Threads sections
(Relationships are no longer needed for IERs.)

5 * Updated figure 5-1 and accompanying text to
reflect changes to Specifying Alternate Link
Capacities procedure. Moved section to after
Optimizing a Network section.

* Expanded descriptions of dialog box options in
Evaluating a Network section.\

6 * Updated figure 6-6 and accompanying text to
reflect new Log Viewer feature.

November 3, 2006 6.2 Final 1 * Updated Task Assistant figures 1-1, 1-2, and
1-3.
2 ¢ Updated Mission Analysis Questions figure
2-19.

* Changed Map > Set Area of Interest to View >
Set Area of Interest, and Map > Background >
(options) to View > Background > (options).

» Updated Logical View Selection figure 2-26
(removed Type of View drop-down list, and
Re-use/Re-create options.)

3 * Updated Adding Units via the Library Treeview
figure 3-2.

» Updated figures 3-18 and 3-22 to reflect new
toolbar buttons.

* Updated Satellite Bent Pipe Link Deployment
dialog box figure 3-20.

¢ Changed Terrain > View Terrain Profile to
Topology > Terrain > View Terrain Profile.

* Changed Map > LOS Settings to View > Show
LOS > LOS Settings.
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Table FM-1 Document Revision History (Continued)

Release Date

Product Version Chapter

Description of Change

4 .

Added Ctrl+W shortcut keys to Traffic Wizard
section

October 20, 2006

6.2 Draft

—_
L]

Removed references to separate IER Editor
(functionality now accessible via System
Editor’s IER Database menu.)

N
.

Updated System Editor and Sign-in figures to
reflect version 6.2.

Updated Create a New Project to reflect use of
File > New Project command in System Editor.

Added Zoom to Window and Zoom to All
procedures.

Changed View > Network Views > Logical to
View > Show Logical Views, and updated
Logical View Selection dialog box.

w
.

Updated all Object Palette figures.

Updated Create a Device Model procedure to
reflect new Create Custom Device dialog box
and procedure.

Updated references to Scenario menu to
reflect name change to Scenarios menu.

Updated Protocols menu items table.

N
L]

Updated Traffic Wizard dialog box.

(o]
.

Updated Choose Results dialog box.

Updated Perform a Network Simulation
procedure to reflect simple and detailed modes
and new dialog boxes.

~
L]

Updated Results Browser and graph shortcut
menu figures.

Removed DES > Results > Compare Results.

Glossary

Removed references to the Scenario
Conversion Module.

March 30, 2006

6.1 Final 3

Added references to Help Diagram and Help
FAQs tabs on Satellite Bent Pipe Link
Deployment dialog box.

Added shortcut keys to TSSP circuit
configuration, and added multiplexer circuit
configuration.

* Removed references to Multiplexer utility node.

» Updated text to reflect name change from “Icon
Editor” to “Icon Database”.

March 3, 2006 6.1 Draft 1
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Table FM-1 Document Revision History (Continued)

Release Date

Product Version

Chapter

Description of Change

2

* Updated System Editor and Sign-in figures to
reflect version 6.1.

¢ Updated Procedure 3-18, “Deploy a Satellite
Link”, to reflect new tabbed design of dialog
boxes.

4

* Removed “Converting Flows to IERs” section.

November 14, 2005

5.2 Final

Front material

* Changed refs in Documentation Conventions
section to be NETWARS-specific rather than
OPNET-specific (i.e, changed
<opnet_user_home>\... ref to <NETWARS
path>\Scenario_Builder\...)

Updated Logical View Selection figure.

* Added ‘Editing Attributes for Many Objects’
section.

* Added Object Palette Tree view to ‘Adding a
Device to an OPFAC’section.

* Added ‘Deploy a Satellite Link’ procedure.

e Updated NETWARS Standard Models object
palette figure.

¢ Removed Convert Link Loads to Flows
procedure.

* Removed Advanced Traffic Wizard procedure.

» Updated Traffic Wizard figure.

October 14, 2005

5.2 Draft

All

¢ Updated document footers and applicable
screenshots to reflect new NETWARS version
number.

* Added (optional) Server Characterization and
Mainframe Characterization options to System
Editor (File > Open Editor.)
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Table FM-1 Document Revision History (Continued)

Release Date Product Version Chapter Description of Change

2 * Added ‘Selecting the User Level’ section.

» Added New Project Wizard to ‘Creating a New
Project’ section.

¢ Added detail to ‘Answering Mission Analysis
Questions’ section.

* Updated ‘Setting the Area of Interest’ section
(changed from ‘Setting Area of Operation’.)

* Removed JMTK Data Maps and updated
procedures in ‘Adding Background Images’
section.

* Changed ‘Zooming In/Out’ to
‘Zooming/Unzooming’, and updated
procedures.

¢ Updated and added detail to ‘Viewing
Scenarios’ section.

3 * Revised ‘Add Units via the Treeview’ section to
reflect use of the Library Treeview.

¢ Added ‘Add Units via the Scenario Treeview’
section.

¢ Renamed Topology > Device Creator as
Topology > Create Custom Device Model.

* Removed ‘Redeploying Links’ section.
* Removed ‘Remove a Scenario’ section.
* Added ‘Manage Scenarios’ section.

¢ Added Protocols > LDP, Protocols > RSVP,
Protocols > VLAN, and Protocols > STP.

¢ Removed Protocols > MPLS and Protocols >
DPT.

* Added detail to ‘Enabling Line-of-Sight (LOS)
Connectivity and Range’ section.

4 * Revised ‘Creating Relationships’ and ‘Creating
Threads’ sections to reflect use of the Scenario
Treeview.

» Updated Figure 4-2 (Relationship Attributes
dialog box) to reflect addition of Specify
Start/Stop Time button.

* Removed ‘Creating Demands’ and ‘Converting
Applications into Demands’ sections.

* Renamed Scenario > Convert Applications to
Flows to Traffic > Convert Traffic >
Applications to Flows.

¢ Added ‘Converting Link Loads into Flows’ and
‘Converting Flows into IERs sections.

¢ Added Traffic Wizard section
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Table FM-1 Document Revision History (Continued)

Release Date Product Version Chapter Description of Change

April 1, 2005 5.1 Final Cover * Changed release date to April 1, 2005, and
removed OPNET contact info from
Identification section

March 21, 2005 5.1 Final Added ACE to ACE Whiteboard section.

—
L]

2 » Added Procedure 2-13, Zoom to Selection.

Updated Figure 2-8 to reflect new button
placement

Added SLD info to ‘Deploying Links’ section,
and added steps for editing SLDs to Procedure
3-14.

In ‘Defining Additional Scenarios’ section,
replaced ‘Copy a Scenario’ procedure with
‘Create a New Scenario’ and ‘Duplicate a
Scenario’. Also added ‘Remove a Scenario’
procedure.

w
.

Changed Terrain > LOS Settings to Map >
LOS Settings in Procedure 3-35.

Updated Figure 4-6 to reflect removal of time
step info, and Figures 4-3 and 4-4 to reflect
new button placement.

N
L[]

5 * Updated Figures 5-2 and 5-7 to reflect new
button placement.

February 21, 2005 5.1 Final No changes

February 7, 2005 5.1 Draft All Ported existing Word document (NETWARS v
4.2) into Adobe FrameMaker 7.1, and applied
commercial OPNET product documentation
style template to improve quality and update
manual. Reformatted text as needed to fit new
format and style.

Content changes:

¢ Updated applicable screenshots to reflect new
NETWARS version number.

* Added reference to ACE in chapter 1.

* Noted that annotations are now saved as part
of a template OPFAC/organization, and are
also deployed with the template.

* Removed Alternate Link Cost field from
Capacity Optimization Settings Advanced
Parameters dialog box.
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1—Introduction

1 Introduction

JCSS Overview

The JCSS User Manual is a guide that covers basic aspects of JCSS operation
and use. It contains figures that provide visual examples of the JCSS interfaces,
step-by-step procedures, and descriptions of other important JCSS features
and concepts.

Organization of the chapter topics is based on a JCSS workflow for creating a
communications plan. By following the chapter topics in sequence, you will be
able to do the following:

* Gain a high level-conceptual understanding of what the JCSS software is
and what features it can deliver that are of use to the goals of military
planners

* Acquire a set of rudimentary skills that enable military planners to create or
modify JCSS scenarios, run simulations, and analyze the results

Note—This manual contains frequent references to the JCSS Technical
Reference Manual, which explains JCSS features, concepts, and
methodologies in greater detail.

Military planners are challenged by several problems when considering
communications needs for theater operations. You must be able to visualize
and describe the networks for which you are responsible. Where are the main
communications nodes for the military units? Where are the main
communications pipes linking these units? What interoperable communications
devices are the units employing? Given the general message load demands of
an impending major military operation, you need to anticipate where bottlenecks
are likely to develop in the communications network infrastructure. Faced with
the certainty that during the conduct of an operation, time critical messages
must flow rapidly from one military unit to another, you must be able to anticipate
whether all will arrive on time as not to jeopardize mission completion.

JCSS is a tool that helps you to solve these kinds of problems. It does this by
letting you construct a computer representation of the communications network
infrastructure coordinated to a map and letting you use the computer to simulate
the operational dynamics of message (or traffic) flow through this structure,
depending upon the scheduled loads you choose to input.
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JCSS is designed to be used in two phases:
* Phase One—Building network topology and setting traffic scenarios, and

* Phase Two—Analyzing network performance using Capacity Planning for
analytical analyses or/and using Simulation Domain for detailed analyses.

The framework for initiating a JCSS analysis is based on building a scenario. A
scenario consists of one or more OPerational FACilities (OPFAC) and their
associated communications equipment placed at specific geographic
coordinates, a specific simulation start and end time, the operating parameters
of the communications equipment, the movement (potentially dynamically
determined) of these elements over time, and the associated communications
traffic (e.g., Information Exchange Requirements or IERs). OPFACs are the
basic building blocks of a JCSS scenario. OPFACs are user-defined groupings
of communication equipment that can move together like the communications
assets of a tank or a plane. OPFACs can be grouped into organizations, to
provide military hierarchical relationships and context.

Traffic, or the conveyance of messages through the communications
infrastructure, is used during simulation and optimization. You define the traffic
flow for a given operational scenario, and the JCSS simulation runs it through
the constructed communications infrastructure. You then examine the output for
unacceptable delays of critical messages.

To assist you with the sequence of tasks, three workflows are presented below,
and are also presented as wizards in the JCSS software. These workflows are
in order of increasing complexity and precision, depending upon the time
available for the work:

1) The shortterm, high level Crisis Action Planner, which comprises a network
of nodes and links and loads it with traffic

2) The Operational Planner, which specifies actual communications devices
located in OPFACs and is used in support of an OPLAN (Operations Plan)

3) The Analyst, which specifies detailed IERs and makes use of detailed
Measures of Performance (MOPs), such as Speed of Service, from the
simulation results.

Sample Workflows

Crisis Action Planner's Workflow

Sample workflows are provided via the JCSS Task Assistant.

Note—The Task Assistant feature is no longer maintained, and some of the
following information may no longer be valid. This section is provided only for
reference purposes.
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The Crisis Action Planner's workflow, shown below, helps a Crisis Action
Planner to develop, evaluate, and optimize a network to produce a
communications plan. This workflow provides new or novice users with a
checklist of sequenced tasks needed to perform this task following specific
JCSS procedures.

Figure 1-1 Crisis Action Planner's Workflow
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Wworkflow Explanation
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M| Optirnize Network for Capaciby LIJ _FI
Annatation
=
.
K0 ¥ =i
Help... | Export I [~ Show Milestones Cloze |

Operational Planner's Workflow

Sample workflows are provided via the JCSS Task Assistant. The Operational
Planner's workflow, shown below, helps an Operational Planner to develop a
communications plan in a semi-collaborative Joint Planner Environment. This
workflow provides new or novice users with a checklist of sequenced tasks
needed to perform this task following specific JCSS procedures.

Figure 1-2 Operational Planner's Workflow

#]3CSs - Task Assistant = =l
ok flavy E xplanation
Develop Communications Plan ! This workflow shows the Operational ;l
{M| Create a New Project planner how to develop
M Define the Missi communications plan in a
T Efine e_ |s_3|on zemi-collaborative Joint Planner
M| Add Organizations and OPFACs Environment. The Develop
M| Define Planning Links Communications Plan warkflow
#-M| Define Connectivity Links utilizes the Scenaria Builder editor a5
W Verify Link Cansistency _the PNy LiSEr |n_terfac:e. Adc_llhonal
S . . ) information regarding the functionaliy
B Review Requirements Matris of the Scenario Builder editor can be
10 Define Additional Scenarias or T found in the JC5S Users Manual. To
0| Export Queries to Subordinates wiew the JCSS Users Manual, select
FQ| Import Subordinate Response Fil Help > Documentation -> User
= ) ) o . b anial.
#-0| Define Device Application Profile _I
= . . -
F-0| Usze Capacity Planning Features
B Simulate the Network Plan LIJ _'I
-0 Open Scenaro Conversion Log Annotation
-0 Open Simulation Log ;l
-1 Save and Close Plan
F-M Analyze Results
.
< | _>l_I [
Help.. | Export | [~ Show Milestones Close |

JCSS/Release 10.0

JCSS-1-3



1—Introduction

Analyst's Workflow

Sample workflows are provided via the JCSS Task Assistant. The Analyst's
workflow, shown below, helps an Analyst to develop and analyze a
communications network. This workflow provides new or novice users with a
checklist of sequenced tasks needed to perform this task following specific
JCSS procedures.

Figure 1-3 Analyst's Workflow
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JCSS Interfaces

System Editor

The capabilities of the JCSS software are organized into multiple editors:
System Editor, Scenario Builder, Icon Database, (Optional) ACE and ACE
Whiteboard, (Optional) Server Characterization, and (Optional) Mainframe
Characterization. A description of each editor is provided below.

The System Editor acts as an entry point to the remaining editors. It allows you
to access user and profile information as well as the task assistant interface.

Scenario Builder

Ilcon Database

The Scenario Builder allows you to build template OPFACs and organizations,
define infrastructure and Information Exchange Requirements (IERs) between
OPFACs and organizations, specify movement and geographical context for
OPFACs and organizations, and run discrete-event simulations for their
developed scenarios. You can open and work with multiple projects
simultaneously, and easily cut, copy, and paste supported objects
(Organizations, OPFACs, devices, links, etc.) between them.

Additionally, the Scenario Builder provides you with the option of deploying a
communications infrastructure using a top-down approach. More specifically,
the Lead Planner sets up the planning view and sends the initial scenario to the
Subordinate Planners. The Subordinate Planners modify their portion of the
initial plan and then send it back to the Lead Planner who integrates them into
a complete plan.

The Scenario Builder allows you to optimize link and broadcast network
capacities as well as traffic load. The optimization of the link and broadcast
network capacities is implemented by changing the size of links and broadcast
networks while the optimization of the traffic load is implemented by changing
the load caused by the IERs.

This editor also allows you to view results of the simulation. After the simulation
is complete, the Simulation Domain creates text files that capture the results of
the simulation. JCSS reads these files and displays the results graphically as
Measures of Performance (MOPs). The MOPs focus on the ability of selected
communication equipment to send and receive information (e.g., file transfers,
situation awareness updates, e-mail messages, etc.)

The Icon Database allows you to create new icons for OPFACs and
organizations displayed within the Scenario Builder.

JCSS/Release 10.0
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(Optional) ACE and ACE Whiteboard

The Application Characterization Environment (ACE) and the ACE Whiteboard,
which require a separate license, allow you to perform network performance
analysis and troubleshooting. Use ACE to analyze traces obtained from a live
network. However, if you want to simulate the behavior of an application that
does not exist yet, use the ACE Whiteboard to create a model of the application
and then run analyses on it. To learn more about ACE and the ACE Whiteboard,
refer to the ACE User Guide.

(Optional) Server Characterization

The Server Characterization Editor (SCE) is an optional module that allows you
to import server performance information for analysis of the processes and
applications, and characterization into workloads used as the basis for
simulation modeling. To learn more about the SCE, refer to the IT Guru User
Guide.

(Optional) Mainframe Characterization

The Mainframe Characterization Editor (MCE) is an optional module that allows
you to import measured performance data, and analyze it to create workloads
suitable for the mainframe models.To learn more about the MCE, refer to the
MCE tutorials.

JCSS/Release 10.0
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System Architecture

Figure 1-4 JCSS System Architecture
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JCSS is launched via the System Editor, which is considered a supporting
interface.

In JCSS, organizations and OPFACS are built and modified inside the Scenario
Builder, the primary interface.

The Simulation Domain allows the Scenario Builder to provide its output to a
COTS Simulation Engine (e.g., OPNET Modeler) in a file structure expected by
the Simulation Engine.

After a simulation is run, the results are viewed in the form of graphs called
Measures of Performance (MOPSs). Scenarios can also be further analyzed and
then optimized for network performance.

Graphical presentations of JCSS objects, such as device models and military
units, can assume various forms via the Icon Database. This editor is a
supporting interface.
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2 Getting Started

Launching JCSS

Launch JCSS to access the desktop software application as described in the
following procedure.

Procedure 2-1 Launch JCSS

1 Select Start > Programs > JCSS > JCSS v10.0.
= The System Editor and the Sign In dialog box automatically display.

Figure 2-1 System Editor

i—]JESS 2010 Portions copyrighted by OPNET Technologies, Inc
File Edit License ‘wWindows Help

Fortions protected by U5, Patents §,273,963; and B,820,042.

|backing up file "C:%CS 545 cenario_Builderop_adminteny_db16.0" ... done

Figure 2-2 Sign In Dialog Box

—#]1CSs sign In 1]

Profile:
ELocal Administratar ﬂ

Signin | Esit | Help |

You are accessing a U.S. Government (USE) information system (IS) that ]
is provided for USG-authorized use only, -

By using this IS (which includes any device attached to this 1S), you
consent 1o the following conditions: =l

<] i
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End of Procedure 2-1

Signing In and Creating a New User Profile

Create a new user profile, which will allow you to sign into JCSS under your own
account, using the following procedure. Note that only one user at a time can be

signed in.

Procedure 2-2 Create a User Profile

1 Click the New button on the Sign In dialog box to create a new user profile.

= The New Profile window displays.

Figure 2-3 Adding a New User Profile

“#{New Profile =101x]
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Fhaore |2EI4.?58.3454

Tactical Prone | 383,549 9808

SheetAddress [22072 willis Street ]
Quantico, WA 22134
W Use Task Asziztant at Statup
* = Reguired Field oK | Lancel |

2 Enter required information and any optional information. Click OK.

= The Sign In dialog box displays again with the new username in the Profile field.

3 Click Sign In to sign in. (Returning users can select their previously created profile

name from the Profile drop-down menu and then click Sign In).

End of Procedure 2-2
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Selecting the User Level

Switch between JCSS interfaces (simple to complex) by selecting one of the
available User Level options, as described in the following procedure. JCSS
menus change to reflect the selected User Level. Higher User Levels display
more menu items and menu headers. You can switch between User Levels at
any time, so that all menu items can be available if you so choose. Switching
the User Level affects all open editors.

Procedure 2-3 Select the User Level

1 Select one of the user levels, as follows:

1.1 (Option 1) From the System Editor, select Edit > User Level > Beginner to
access a simplified JCSS interface. The Beginner interface hides access to
many of the functionalities of the system without removing the capabilities
themselves. This results in an interface that is reduced in complexity, and is
easier to navigate for beginner JCSS users.

1.2 (Option 2) Select Edit > User Level > Intermediate, if you want to access a
JCSS interface that exposes more functionalities of the system than the
Beginner level, but less than the Advanced level. This results in an interface
that is reduced in complexity, and is easier to navigate for intermediate users.

1.3 (Option 3) Select Edit > User Level > Advanced, if you want to access the
full-featured JCSS interface. The Advanced interface exposes all of the
functionalities of the system. This results in an interface that is more complex,
and best utilized by more experienced JCSS users.

End of Procedure 2-3

Using the Task Assistant

Note—The Task Assistant feature is no longer maintained, and some of the
following steps may no longer be valid. This section is provided only for
reference purposes.

The Task Assistant is a tool that guides you through the steps necessary to plan,
analyze, and simulate a communications data/voice network. It presents
workflows that provide new or novice users with a checklist of sequenced tasks
needed to perform certain JCSS procedures.

The Task Assistant workflows are located in a unique window that can be
moved or minimized on the screen. The checklist of tasks displays in the
Workflow pane on the left side of the Task Assistant; a corresponding detailed
explanation displays in the Explanation pane on the right along with a pane for
entering user annotations. The contents of the Explanation pane provide
step-by-step instructions for completing the associated task.

JCSS/Release 10.0
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Not all of the tasks in the workflow are required. Milestone tasks are marked with
a red "M" and can be optional or required, required tasks are marked on the left
with a green "R", and optional tasks are marked with a blue "O". After you
complete a task, double-click it to check it off. More help is available through the
Help button on the bottom left of the Task Assistant workflow window.

Some tasks, marked with a plus (+) sign to the left, are made up of multiple
sub-tasks. Clicking on the plus sign expands the task to show all of the
sub-tasks in that task.

Procedure 2-4 Open a Workflow Using the Task Assistant

1 From the System Editor, select Help > Task Assistant to launch the Task Assistant.
Keep in mind that from the Scenario Builder you can click the Open Task Assistant
button.

Figure 2-4 Task Selection

1SS - Task Selection =101 x|
Workflows Explanation
JCSS Introduction d The Task Assistant has several workfloves ;I

that are designed to quide the user twough
the steps necessary to plan, analyze, and
simulate a communications data/voice
network. The Task Assistant workflows are
a sequence of user instructions that define
the steps requined to accomplish fundamental
L8 DevelopCo ications Plan JC35 tasks. The Task Assistant workflows
i - are contained n 2 unigue window that can
—® Create Response to Communicatio be moved or minimized on the screen. The
= Analpst Task Assistant Workflow windows contain a
& Analyze Communications Performar checklist of associsted steps on the left side,
JMMS User with instructions and user annotation on the

Tas ant Descrption
Task Aszzistant User Types
Crizis Action Plannes

{ % HRapid Scenano Bulding and Analy
=~ Operational Planner

-

—& Develop Communications Plan with

— & Perform Capacity Planning Analysis

& Perform Configuration Management
O Recent Workflows

=2 Browse for Workflow...

Kl E LlJ
Help... | [~ Shows At Startup

right side. Mot all of the steps in the workflow
are required, g0 & green "R for requared or
blue "0 fior optional will guide the wser
through each step of a warkflow.
Additionally, tazks defined as milestone tazks
are marked with a red "M". Both reguired
and optional basks can be designated a2
milestone tasks. A uzer can define a specific
tazk az a milestone tazk by right-chcking on a
task and selecting Taszk Tracking Info from

Start Warkflow | Cloze

=

2 Select the Develop Communications Plan workflow from the Workflows pane.

= A description of this workflow displays in the Explanation pane.

also initiates the workflow).

3 Clickthe Open Workflow button (double-clicking on Develop Communications Plan

w This launches the Scenario Builder and the selected workflow in the Task

Assistant.

4 Follow the sequential tasks in the Workflows pane until completion.
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Figure 2-5 Following Sequential Tasks in the Workflows Panel
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End of Procedure 2-4

Creating a New Project

The first step in the planning process is to create a new project in the Scenario
Builder. Projects are files that contain scenarios (time phases or courses of
action). A scenario or groupings of related scenarios can be saved under one
project.

You can simply name and launch a generic project, or use the New Project
Wizard to set equipment types, area of operations, and top-level units and
locations to use in the new project.

Procedure 2-5 Create a New Project

1 From the System Editor, select File > New Project to open the Create Project
Project dialog box, or click the Create a New Project button.
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Figure 2-6 Creating a New Project

i—]treate Project ﬂ

To create a new project, you must ;l Project Mame: rl
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first zcenano. The classification zetting
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Note—The names for both the project and the scenario cannot contain any spaces
or special characters. In addition, the scenario name cannot be the same as any
existing OPFAC; it must be unique.

Select a classification level for the project in the Create Project dialog box.

Click OK.

If Launch New Project Wizard is not checked, then JCSS creates a generic project
using the names you have designated. You can skip the remaining steps in this
procedure.

OR

If Launch New Project Wizard is checked, then JCSS displays a sequence of dialog
boxes that enable you to make selections specific to your new project.

If you selected to launch the New Project Wizard, then the Initial Topology dialog
box displays.

Figure 2-7 Initial Topology Dialog Box

i] New Project Wizard: Initial Topology

| )

fau can start with an empty ;I Iritial Topology
network and create your

Create emply scenario

netwark or import directy from b

other data source. Irmpoart from JCSS/METwWARS

Impart from OPMET Modeler

Import from Device Configurations

Import from WME Server

Import from =L ==
LI Impart from JCS5 Templates et

<< Back | Gt |

5 Choose to create an empty scenario or import from one of the various data

sources, and then click Next.
5.1 If you choose Create empty scenario, a blank scenario is created.

= The Select Equipment Types dialog box displays.
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5.2

Figure 2-8 Select Equipment Types Dialog Box

r-i]New Project Wizard: Select Equipment Ty ll
Select the tppes of ;I Equipment Type | Included ;I
equipment you will uze in =
your project. #om | no

ADMY_Animationg o
The equipment types table ACE no
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palettes. The devices within ca.te_. ucent o
each of the included palettes applications na
will be concatenated into a Ascend na
zingle new palette for this
project. The new palette will LI afm J R na ;I

This table lists all existing device palettes. The devices within each of the
included palettes will be concatenated into a single new palette for this project.
The new palette will be named <project_name>-<phase_name> and will be
the default palette. Note that you will still be able to use devices in other
palettes.

Click Finish to create the new project using the settings you have chosen.
Scenario Builder displays your new project in the workspace, and displays the
project name and active scenario name in the title bar.

¢ If you choose Import from JCSS/NETWARS, a file chooser dialog box
displays. Select the appropriate nt.m file.

* If you choose Import from OPNET Modeler, a file chooser dialog box
displays. Select the appropriate nt.m file.

¢ If you choose Import from Device Configurations, the Import Device
Configurations dialog box displays.

Figure 2-9 Import Device Configurations Dialog Box
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Specify the location of the device configuration files and how these files
should be integrated into the existing topology (if it already exists), and then
click Import.

If you choose Import from VNE Server, the process begins. Import from
VNE Server is a COTS feature which allows you to create a network model
based on information imported from VNE Server. You can import both
topology and traffic information using imported VNE Server data.

Enter your VNE Server hostname in the Import from VNE Server dialog
box, and then click OK.

A second Import from VNE Server dialog box displays. Specify the import
mode you want to use, based on the following table, and then click Import.

Table 2-1 VNE Server Import Modes

Import Mode

Usage

Description

Create/Replace network
using the most recent
VNE Server data

Use when starting a new
scenario or when you want
to erase all existing
information in the current
model to replace with
VNE Server data.

If checked, the current

VNE Server data is used to
create a network model.
“Create” appears if you are in
a new scenario; “Replace”
appears if you are in an
existing scenario.

Incrementally update
network using the most
recent VNE Server data

Use when you want to
update the current model
with any changes that have
occurred in VNE Server
since the last import.

If checked, VNE Server
updates the current network
model with all recorded
changes in VNE Server since
the original import.

Replace network using an
existing archive’

Use when you want to
replace the current model
with information contained
in a VNE Server archive
file.

If checked, a network model is
created using the archived
network specified in the
drop-down menu. This menu
is populated based on
available archives from

VNE Server.

1. This option does not allow you to import collected configuration files.

* If you choose Import from XML, a file chooser dialog box displays. Select
the appropriate xml file.

5.3 If you choose Import from JCSS Templates, the Set Area of Operations dialog

box displays.
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Figure 2-10 Set Area of Operations Dialog Box
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Note—The Set Area of Operations dialog box provides the coordinates where the
template Organizations/OPFACs will reside inside the scenario. The Area of the
View and Center of the View are updated depending on the selected View. The
Top-Level Units and Location utilize this information to provide base coordinates
for any imported Organizations/OPFACs.

¢ Choose the border map that you want to see in the Project Editor from the
Map drop-down list, and specify the area of view and center of view. The
view settings determine the initial zoom level of the project. You will still be
able to place units outside that area if needed.

¢ Click Preview to display the chosen view area in the workspace.

5.4 Click Next to continue to the next setting, or Finish to create the new project
using the settings you have chosen, along with other setting defaults.

= |f you clicked Next, then the Top Level Unit dialog box displays.

Figure 2-11 Top Level Unit Dialog Box
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5.5 Choose a project template from the Project Template drop-down list with
which to fill in the units table, or select the number of units from the Number
of Top Level Units field drop-down list.

5.6 For each top-level unit in the table, type the name of the unit in the Name
column, and select whether the unit is an organization or an OPFAC in the
Type column.
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5.7 Click Next to continue to the next setting, or Finish to create the new project
using the settings you have chosen, along with other setting defaults.

6 At the end of the import, the Select Equipment Types dialog box displays. Select
the types of equipment that you will use in your project, and then click Finish.

= The new project is created using the settings you have chosen. Scenario Builder
displays your new project in the workspace, and displays the project name and
active scenario name in the title bar.

End of Procedure 2-5

Setting Scenario Classification

Now that the project is created, you can specify initial scenario information such
as the scenario classification, as described in the following procedure. This
information applies to the entire scenario. Providing initial scenario information
is optional in JCSS; if the information is not provided, default values will be used.
The default scenario classification is Unclassified.

Procedure 2-6 Set Scenario Classification

1 Select Scenarios > Set Classification to open the Set Scenario Classification dialog
box.

2 Select the desired classification from the Scenario Classification drop-down menu.

3 Click OK.

= The scenario classification displays in the upper-left and lower-right corners of
the Scenario Builder.

Figure 2-12 Setting the Scenario Classification
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End of Procedure 2-6
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Setting the Area of Interest

The area of interest gives geographical context to the scenario. Use the
following procedure to set the area of interest.

Procedure 2-7 Set the Area of Interest

1 Select View > Set Area of Interest from the Scenario Builder.

= The Set Area of Interest dialog box displays.

Figure 2-13 Setting the Area of Interest
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Cancel

The geographic focus can be specified by entering values for the Area of the View
and the Center of the View. These attributes determine the location and size of the
displayed view of the map. For example, if the center of view is (0,0) and the area
of view is (width = 100, height = 50), then the portion of the map that would be
displayed will be from (50W, 25N) to (50E, 25S).

The geographic focus also determines the relative range at which OPFACs (and
their devices) are located from each other. This is of significance when exchanging
IERs/traffic during a simulation. While TSC-85 radios and wire links have no range
limitations, TRC-170 radios and tactical broadcast networks only work within a
limited range of each other. For example, if two TRC-170 radios are more than 150
miles apart, then all packets transmitted between them will be dropped, resulting
in failed IERs.

Select desired options for displaying grid.

Click OK.

= The settings reflect in the Scenario Builder.

End of Procedure 2-7

Adding Background Images

You can provide further geographical context to a scenario through the use of
various maps and images. JCSS recognizes several different types of maps,
including: border maps, image maps, Maplnfo (MIF) maps, CADRG/CIB Raster
Catalog Directories, and MrSID images.
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Border Maps

Border maps use stylized lines to define political and geographical areas. JCSS
comes with a library of border maps that represent a geographic area described
by latitude and longitude. Add a border map using the following procedure.

Procedure 2-8 Add a Border Map

1 Select View > Background > Set Border Map from the Scenario Builder. The
Choose Border Map dialog box displays.

2 Choose a border map from the drop-down menu. Note that the border map listis a
finite list and may not be modified.

Figure 2-14 Selecting a Border Map
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3 If the desired map is not in the list, select the world map and zoom in to the desired
location.

End of Procedure 2-8

Image Maps

Image maps are TIFF or GEOTIFF files that provide additional geographical
information on a border map, such as a satellite or aerial image. Add an image
map using the following procedure.

Procedure 2-9 Add an Image Map

1 Select View > Background > Add Image Map from the Scenario Builder to open the
Add Map dialog box, shown below.
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Figure 2-15 Add Map Dialog Box
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2 Choose an option of importing an existing map or specifying the file path to an
image map located on the hard drive; select desired map.

3 Click OK.

End of Procedure 2-9

MIF Maps

MIF maps are files that provide additional geographical information on a border
map, such as roadways, waterways, regions, and counties. Several MIF maps
come standard with JCSS. Add a MIF map using the following procedure.

Procedure 2-10 Add a MIF Map

1 Toimporta MIF map, select View > Background > Add MIF Map from the Scenario
Builder to open the MIF menu.

Figure 2-16 MIF Menu
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2 Select the desired MIF map from the menu.
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3 Click Close.
= The MIF map automatically imports.

Note—When image maps are imported, the maps can be deleted, resized, or
dragged and dropped to a different location while in Map Edit mode. To enter/exit
Map Edit mode, select View > Background > Map Edit Mode.

End of Procedure 2-10

Zooming/Unzooming

Get a close-up view of a JCSS object or area in the workspace or restore the
workspace view to the previous zoom level. Use the following procedure to
zoom to rectangle.

Procedure 2-11 Zoom to Rectangle

1 Togetaclose-up view of the object in question in the workspace, first select View >
Zoom > To Rectangle, or press <Ctrl>+<I>, or use the Zoom In option from the
shortcut menu, or click the Zoom In toolbar button.

2 Drag the cursor to define a rectangular shaped region to be magnified.

= The defined area magnifies in the workspace.

Figure 2-17 Zooming In
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3 Apply this option multiple times to obtain an ever-closer view.

End of Procedure 2-11

Use the following procedure to zoom to selection.

Procedure 2-12 Zoom To Selection

1 Drag the cursor to define a rectangular shaped region to be magnified.
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2 Select View > Zoom > To Selection, or press <Ctrl>+<Shift>+<Z>.

= The defined area magnifies in the workspace.

End of Procedure 2-12

Use the following procedure to zoom out.

Procedure 2-13 Zooming Out

1 To restore the workspace view to the previous zoom level, select View > Zoom >
Unzoom, or press <Ctrl>+<U>, or use the Zoom Out option from the shortcut
menu, or click the Zoom Out toolbar button

Figure 2-18 Zooming Out
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End of Procedure 2-13

Use the following procedure to zoom to all active areas in the workspace.

Procedure 2-14 Zoom To All

1 Select View > Zoom > To All, or press <Ctrl>+<Alt>+<Z>.

= The active areas in the workspace are magnified so they show in the window.

End of Procedure 2-14
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Viewing Scenarios

JCSS offers a number of different views of a scenario, accessible by selecting
a view option from View > Network Views > (option), choosing from one of the
following options:

Planning—This view is useful for someone working in a collaborative
planning environment. Using this view, the planner can display only the
planning portions of the scenario and hide all others. Organizations,
OPFACs, and planning links are all part of the planning view. Devices and
connectivity links are hidden in this view.

Connectivity—If a planner is not interested in the planning links and just
wants to view the connectivity links in the network, he or she can choose this
view option. Planning links and OPFACs without any devices are hidden in
this view.

Planning and Connectivity—The planner can use this view option to return to
the default view, which includes the planning and connectivity elements in
the scenario.

Operational—Selecting this view option switches from a Systems or Logical
View back to the default view of the scenario, the same view that loads when
you first open the scenario in Scenario Builder.

OPFAC Systems—Selecting this view option switches from the current view,
the Operational View or some other type of Systems View, to the OPFAC
Systems View. The OPFAC Systems View expands the contents of the
organizations, collapses the contents of the OPFACs, and redraws the links
to connect to their respective devices.

You can also choose View > Show Logical Views..., which displays similar
objects in an abstract manner, without geographical context. Selecting this view
option launches the Logical View Selection dialog box that you may use to
specify settings for filtering the logical views.

Each of these views offers the user a different perspective of the network.

Procedure 2-15 Selecting Settings for the Logical View of a Scenario

1 Select View > Show Logical Views....

= The Logical View Selection dialog box displays.
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Figure 2-19 Logical View Selection Dialog Box
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Select a Network Layer Filter with which to filter your logical view. This filtering
parameter enables you to hide all devices except for those of a particular layer of
the network. [Note that this doesn't necessarily mean OSI network layer, but
instead, it means the various devices that use a particular protocol.] Network Layer
Filters shown are only those which apply to the deployed network.

Select a Security Classification Filter with which to filter your logical view. This
treeview enables you to filter elements of the network based on their security
classifications. Any custom classifications added in the Operational view will be
available here as well for filtering.

Specify the Duration and Start Time parameters to get the Capacity Planner graphs
that are used for filtering for various layers.

Check the Consider Link Capacities checkbox if you want to use this parameter to
get the Capacity Planner graphs. A link capacity considered filter will result in the
Capacity Planner creating a graph that may not show complete physical
connectivity of the devices due to link load. A link capacity ignored filter will result
in a graph that shows complete physical connectivity of the devices regardless of
link load.

Click Create View to create and load the type of view that you specified if you are
not already in this view.

= The filter specifications are applied to the logical view model.

Click Save Settings to save the settings instead of creating a logical view network
with the specified settings at this time.
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8 Click Cancel to close the Logical View Selection dialog box without making any
changes to the model.

End of Procedure 2-15
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3 Topology Building

Adding Units (Organizations and OPFACSs)

To develop a JCSS scenario, add organizations and OPFACs that represent a
communications plan. Build it from scratch by adding an empty unit from the
shortcut menu or the Organization and OPFACs Library Treeview (via
drag-and-drop), or select a pre-configured unit complete with specific attributes
and devices.

Organizations are groupings of sub-organizations and OPFACs that can
represent military organizations or a physical location.

Operational Facilities (OPFACs) are the fundamental building blocks of JCSS.
They are collections of communications devices that are assigned to military
units, which are used to construct Organizations. Use the following procedure
to add units to the scenario.

Procedure 3-1 Add Units via the Library Treeview

1 Select Topology > Open Library Treeview to display the Organizations and
OPFACs Library Treeview.

Figure 3-1 Adding Units via the Library Treeview
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2 Select the unit you want to add in the treeview, and drag-and-drop it to the desired
location on the Scenario Builder workspace.

End of Procedure 3-1
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Modifying Units

Procedure 3-2 Add Units via the Shortcut Menu
1 Right-click in the workspace to open the shortcut menu.
2 Select Create New Organization or Create New OPFAC.

End of Procedure 3-2

Units have attributes that define functionality, behavior, and physical
characteristics.

Organization Attributes

* Organization Name—This field uniquely identifies an instance of an
Organization.

* Organization Type—This attribute specifies the type of the Organization.

* Type Name—This attribute specifies the type name. This attribute does not
affect the simulation at this time and maybe ignored or left blank.

* Echelon Size—This attribute specifies the echelon size. This attribute does
not affect the simulation at this time and maybe ignored or left blank.

* Tasks—This attribute specifies the tasks for this organization. This attribute
does not affect the simulation at this time and maybe ignored or left blank.

* Trajectory—Specify the trajectory for the organization from a selection menu
that displays all the saved trajectories (Scenario Builder Editor Feature).

* Dissociate Subordinate Organization and OPFAC Movement—Check this
option to separate the subordinate organization from the movement of the
OPFAC.

e Start Time(s), Stop Time(s)—These are start and stop time(s) for the
simulation (Scenario Builder Editor Feature).

* Altitude, Alt. Units, Altitude set by terrain—These attributes specify the
location of the Organization (Scenario Builder Editor Feature).

* Icon Name—Click the Edit Icon button to select an icon for the organization;
the name displays in the Icon Name field.

* Documentation—Access a free-form text box to enter organization purpose
and topology notes to be stored with the scenario for documentation
purposes.
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Set Owner—Mark organizations for subordinate input by setting ownership
information.

JNMS Attributes—Set JNMS attributes for export to Network Engineer.

Failure/Recovery—Specify a time interval or period of time for which the
organization is inoperable.

OPFAC Attributes

OPFAC Name—This field uniquely identifies an instance of an OPFAC.

OPFAC Functional Profile—Click the Edit button to select a profile for the
OPFAC; the name displays in the OPFAC Functional Profile field.

OPFAC Type—This is the name of the OPFAC model stored on disk. If you
modify this, Infrastructure Re-assignment dialog boxes may be launched.

Trajectory—Specify the trajectory for the OPFAC from a selection menu that
displays all the saved trajectories (Scenario Builder Editor Feature).

Start Time(s), Stop Time(s)—These are start and stop time(s) for the
simulation (Scenario Builder Editor Feature)

Altitude, Alt. Units, Altitude set by terrain—These attributes specify the
location of the OPFAC (Scenario Builder Editor Feature).

Icon Name—Click the Edit Icon button to select an icon for the organization;
the name displays in the Icon Name field.

Devices—This is a table that provides a list of all devices contained in an
OPFAC.

JNMS Attributes—Set JNMS attributes for export to Network Engineer.

Failure/Recovery—Specify a time interval or period of time for which the
OPFAC is inoperable.

Set Owner—Mark OPFACs for subordinate input by setting ownership
information.

Use the following procedure to edit unit attributes.

Procedure 3-3 Edit Unit Attributes

1 To edit unit attributes, right-click on the unit to open the shortcut menu.

2 Select Edit JCSS Attributes to open the corresponding Organization Attributes or

OPFAC Attributes dialog box.
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Figure 3-2 Organization Attributes
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Figure 3-3 OPFAC Attributes
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3 Edit attributes as needed and then click OK.

End of Procedure 3-3
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Editing Attributes for Many Objects

You might need to set values for the same attributes on several objects in a
network model. JCSS provides several alternate methods for quickly changing
attributes on many objects, one of which is using the Edit Objects Using
Template command on the Edit menu.

JCSS allows you to edit attributes for multiple objects in one window, using an
attribute table similar to a User Defined Report. You can create your own
attribute templates (as described in Procedure 3-6) to generate tables of
specific attribute values for one or more objects in a network. An attribute
template specifies the following information about an attribute table:

* Table category and name—Every attribute table belongs to a category, such
as "IP" or "Application", and has a name that identifies it.

* Obiject types to include—A table can include all network objects, a specific
type of network object, or objects selected by custom criteria that you specify.

* Attributes to include—Each row of an attribute template specifies the title and
contents of a column that will appear in the attribute table.

Use the following procedure to edit attributes for many objects at once.

Procedure 3-4 Edit Attributes For Many Objects Using a Template
1 Select Edit > Edit Objects Using Template.
= The Edit Objects Using Template dialog box displays.

Figure 3-4 Edit Objects Using Template Dialog Box
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2 Select an attribute template in the Select table to include in user report list box from
which to generate an editable table of attribute values.
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To select an entire category of tables, click on the top-level category entries. To
select an individual table, expand the top-level category subtree and click on the
table entry. Selected tables and categories show a green checkmark. Categories
with some but not all of its tables selected will display a green dot instead.

Note—If you want to define a custom template, click Close, define a template as
described in Procedure 2-3, then begin this procedure again.

3 Select the Include only selected objects checkbox if you want to collect table data
only for objects that are currently selected in the network.

4 Select the Ignore views checkbox if you want to collect table data even for objects
that are not in the current view or views of the network.

5 Select the Send reports to the Report Server (host) checkbox if you want to send
reports to the Report Server. This option is active only when a Report Server
license is available.

5.1 Specify a name for the report in the Report Server text field.

6 Click Generate to generate the table data for all of the selected tables.

= The corresponding dialog box displays.

Figure 3-5 Table of Generated Attributes
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7 Edit the attributes as needed. There are two editing modes:

7.1 Standard Mode-Click on any attribute value and edit it as you would in the
Attributes dialog box.

7.2 Copy and Paste Mode-Copy an attribute value and paste it to one or more
similar attributes. This mode disables the standard methods for changing
attribute values (edit fields, pull-down lists, and so on).

¢ Select the Copy and Paste Mode checkbox.
e Select an attribute value and press <Ctrl>+<C>.

* Select the attribute value or a range of contiguous values and press
<CtrI>+<V>.

JCSS/Release 10.0 JCSS-3-6



3—Topology Building

You can paste only into the same attribute column from which you copied.
8 When you are finished editing attribute values, click OK to make the changes.

End of Procedure 3-4

Use the following procedure to define or edit an attribute template.

Procedure 3-5 Define or Edit an Attribute Template
1 Select Edit > Edit Attribute Template.
= The Edit Attribute Template dialog box displays.

Figure 3-6 Edit Attribute Template Dialog Box
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Each table row corresponds to an attribute column in tables generated from this
template. At first, the only column defined is for an object name.

2 Choose whether to define a new template or edit an existing one:

2.1 To define a new template, leave the category and template names set to
"unnamed". (You will specify these names when you save the template.)

2.2 Toeditan existing template, select its category and name from the drop-down
menus.

3 Choose what object types to include in the table:

3.1 Select an object type from the Include drop-down menus.

4 Choose what attributes to include in table columns:
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4.1 To add a new undefined column, click New.

4.2 To add a new column based on an existing one, select the desired attribute
row and click Duplicate.

4.3 To edit a column definition, select a row and click Edit. (Alternatively, you can
double-click the Column Value field.).

= A dialog box for specifying the contents and format of the table column
opens.

4.4 To delete a column, select its row and click Delete.

4.5 To add a drilldown, select a row and click Add Drilldown. A drilldown is a child
table that you open by following a link in the parent table. Drilldowns are useful
when you want to show a set of related attributes in a separate window. For
example, you might want to create a drilldown table for IP port attributes on a
router.

This operation creates a drilldown table definition, which is initially equivalent
to the current table definition. To edit the drilldown table, select the row and
click Edit.

5 Move attributes around as needed to modify the appearance of tables generated
from the template:

5.1 To change the sequence of attributes, select an attribute row and click Move
Up or Move Down (thus moving the resulting table column left or right,
respectively).

5.2 To see what the generated table will look like, click Preview. A dialog box
displays a preview of the table to be generated using the current template.

Figure 3-7 Preview of Table to be Generated from Template
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6 Click Save As in the Edit Attribute Template dialog box.

6.1 If you are defining a new template, enter names for the category and table.
The category can be one of the existing categories or a new one.

6.2 If you are editing a template, you can either keep the original category and
table names (to replace the original template) or change the table name (to
create a new version of the original).
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The template is saved with the extension .urep.xml. New templates are saved
in your default model directory; edited templates are saved in the same
directory as the original template.

7 Click Cancel to close the dialog box.

End of Procedure 3-5

Creating Template Organizations and OPFACs

Reusable templates of organizations and OPFACs created in JCSS can be
saved to object palettes. This provides a quick and easy way to add duplicate
organizations and OPFACs to a workspace without having to configure them
from scratch. All devices, links, and attributes (including annotations) of a
template organization or OPFAC are captured.

A change to a template will not replicate that change to instantiated
organizations or OPFACs throughout the topology. Use the following procedure
to create a template OPFAC or organization.

Procedure 3-6 Create a Template OPFAC or Organization
1 Right-click on a unit to open the shortcut menu.
2 Select Create Template OPFAC or Create Template Organization.
3 (OPFACs Only) In the dialog box that displays, enter a cost for the OPFAC devices
(if known) in the Cost field, and enter a description of the OPFAC in the Description

field.

4 Click OK.
= The Save OPFAC/Organization dialog box displays.

5 Specify a folder/object palette in which to save the template. Click Open.

6 Click Save.

= The template is saved and is available on the specified object palette.
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Figure 3-8 Template Organizations and OPFACs Saved to Object Palettes
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End of Procedure 3-6

Drilling Down into Units

"Drilling down" is a term that describes accessing the contents of organizations
and OPFACs. For example, organizations may contain sub-organizations and
OPFACSs, while OPFACs contain devices.

Procedure 3-7 Drill Down into a Unit
1 Double-click on a unit icon to drill into/view its contents.

Figure 3-9 Drilling Down into Units
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End of Procedure 3-7

Adding Devices to OPFACs

Place devices inside OPFACs. Devices are pieces of communications
equipment that represent specific models. Examples include routers,
computers, phones, and satellites. We suggest using the
JCSS_Standard_Models palette to build OPFACs, because the palette includes
all of the updated device models and link models for connecting the devices.
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OPFACs are automatically created for single devices that are added to the
workspace or an organization (i.e., not placed directly in an OPFAC). The
OPFAC will have the same icon as the device, and both the OPFAC and device
right-click menu options will be made available.

JCSS provides a variety of different object palettes containing nodes, devices,
links, and paths (circuits.) All of these objects are easily added to a workspace
using drag-and-drop or point-and-click techniques.

Procedure 3-8 Add a Device to an OPFAC

1 1 Click the Open Object Palette button, or select Topology > Open Object Palette.

= The object palettes display in either a Tree view style or an Icon view style,
depending upon how your environment preferences are set.

Figure 3-10 Obiject Palette by Tree View
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Note—The view style in which the object palettes display changes based on the
value specified for the network_palette.style environment preference. You may set
the object palette view style preference via Edit > Preferences > Advanced.

2 In the Object Palette Tree view, click the Open Palette In Icon View icon button
(upper left corner) to replace this dialog box with the Object Palette Icon view that
displays only a single palette file at a time.
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Figure 3-11 Adding Devices to an OPFAC via Object Palette
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The palette file initially displayed will be either the default palette of the scenario or,
if the tree selection is within a particular palette file tree element, the palette that
contains the current tree selection.

3 Select the JCSS Standard Models object palette or other palette.

4 Left-click the desired device in the object palette.

5 Drag-and-drop device from the object palette to the workspace.

6 Right-click to exit Device Creation mode.

Note—Consult the JCSS Technical Reference Manual for instructions on
configuring custom object palettes.

End of Procedure 3-8

Cutting, Copying, and Pasting Objects

Cut, copy, or paste selected supported objects on the workspace to or from the
Windows clipboard. Supported objects include the following:

Organizations

OPFACs

Devices

Links (External and Internal links)

Satellite links
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¢ Broadcast Networks

* OPNET demand objects

Objects which are not supported include radio links, relationships,
IERs/demands, and Configuration OPFACs. If unsupported objects are
attached to a supported object and the supported object is cut, then the
unsupported objects are also removed from the workspace but not maintained
on the clipboard.

When copying, cutting, or pasting an Organization and/or OPFAC, all supported
children are also copied, cut, or pasted.

When undoing cut, copy, or paste operations, some actions may prevent
certain, or all, prior actions from being undone (for example, saving a project
file). Immediately following a save to disk, there will be no undoable actions.
There is no limit on the number of actions that can be undone; however, the
actions can only be undone in the reverse order in which they were performed.

When redoing undone cut, copy, or paste operations, the actions can only be
redone in the reverse order in which they were undone, which means that the
last undone action will be the first one to be redone.

Any action (editing operation which includes add, delete, move, modify)
performed after performing Undo will clear the Redo feature, and the undone
operation cannot be redone.

Use the following procedures to cut, copy, or paste an object.

Procedure 3-9 Cut or Copy an Object
1 Select the object on your workspace that you want to cut or copy.

2 Select Edit > Cut (or press the Ctrl+X short-cut keys after the object has been
selected) to remove the selected supported object to the Windows clipboard,

Or

Select Edit > Copy (or press the Ctrl+C short-cut keys after the object has been
selected) to copy the selected supported object to the Windows clipboard.

End of Procedure 3-9
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Procedure 3-10 Paste an Object

1 Select Edit > Paste (or press the Ctrl+V short-cut keys after the objects have been
selected) to copy the object back from the clipboard into the workspace.

End of Procedure 3-10

Use the following procedures to undo or redo an edit operation.

Procedure 3-11 Undo Editing Operations

1 Select Edit > Undo (or press the Ctrl+Z short-cut keys) to undo the previous editing
operation. Only the following actions can be undone:

¢ Adding a unit (includes OPFAC and organization), device, or association
(includes intra OPFAC link, inter OPFAC link, satellite link, broadcast network,
relationship and circuit) from the palette or library.

e Moving a unit, device, association, or any group of these objects in the
workspace.

¢ Deleting a unit, device, association, or any group of these objects in the
workspace or using Scenario Builder treeview.

¢ Modifying attributes on devices; all attribute changes made while the Edit
Attributes dialog box is open will be considered a single action.

End of Procedure 3-11

Procedure 3-12 Redo Editing Operations
1 Select Edit > Redo (or press the Ctrl+Y short-cut keys) to redo the last undone
operation. The actions can only be redone in the reverse order in which they were
undone, which means that the last undone action will be the first one to be redone.

End of Procedure 3-12
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Creating Custom Models with Device Creator

In addition to using the built-in model objects provided by JCSS and creating
derived models, you can create your own new device models using the Device
Creator. Device Creator allows you to create several different types of network
components, including routers, bridges, hubs, workstations, switches, LANSs,
and vendor devices. Models created with Device Creator have the following
characteristics:

* They can be easily configured for specialized needs and then integrated into
a network model.

* They support inheritance, so that changes to the original (parent) model can
automatically affect all models derived from it.

Procedure 3-13 Create a Device Model

1 Choose Topology > Create Custom Device Model.

= The Create Custom Device dialog box displays. This dialog box presents a
treeview of the different device categories.

Figure 3-12 Selecting a Device Category for a New Device Model
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2 Select the desired device category in the upper window.

= A corresponding list of parameters will immediately display in the lower window.

3 Set each parameter's value appropriately in the lower window.
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4 Select the model list from the Destination palette drop-down list in which you want
the new device model to reside.

5 After you have specified all the required parameters for the desired model and
selected a model list, click the Create As button to create the model. A dialog box
displays prompting you to name your new device model.

6 Name your new device model. Once you have done so, your new device model
displays in the model list you specified.

End of Procedure 3-13

Opening Node Models in Modeler

If you have an OPNET Modeler license, you can easily open node models in
Modeler via JCSS.

Note—For derived models, you must open the parent instead.

Procedure 3-14 Open a Node Model in Modeler

1 Double-click on a node model.

= The Open Node Editor message dialog displays.

Figure 3-13 Open Node Editor Message Dialog

—+|0pen Node Editor |

Double clicking on a device will open the node
model for editing. If vou would like to modify this
behavior, please look at the ‘modeler_ipc' preferences

[~ Do not display this message again

Cancel

2 Click OK.
= OPNET Modeler launches and displays the node model.

Note—Modeler will not launch if you do not have a license for it.
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Figure 3-14 Opening a Node Model in OPNET Modeler
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3 Consult the documentation for OPNET Modeler for instructions on using Modeler
with node models.

End of Procedure 3-14

Connecting Device Models

Connect communications devices. There are many different kinds of links in
JCSS available from a variety of object palettes. Most links are available on the
JCSS_Standard_Models or JCSS_Links palettes.

Internal Connectivity Links

Internal Connectivity Links connect devices to other devices within the same
OPFAC and define actual physical links that show the specific type of
connectivity; they are drawn as black solid lines.

Use the following procedure to link devices from the object palette.

Procedure 3-15 Link Devices via Object Palette

1 From the object palette drop-down menu, select the desired link palette.
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Figure 3-15 Adding Links to OPFAC Devices via Object Palette
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2 Select desired link icon.

3 Left-click endpoint 1 (device) to identify it as the source, and then left-click on
endpoint 2 (device) to identify it as the destination.

4 Right-click to exit Device Creation mode.

End of Procedure 3-15

Deploying Links

Quickly define valid links between devices using a wizard-like feature, instead
of creating links using an object palette.

Procedure 3-16 Deploy a Link

1 Select two devices (in the workspace or the Network Browser), and then select
Topology > Link Operations > Deploy Link.

2 If more than one device is present in an OPFAC, the Select Devices dialog box
displays. Select the desired devices to connect and then click Next.
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Figure 3-16 Select Devices Dialog Box

iﬁ—]Select Devices ﬂ
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If a selected OPFAC has only one device, then the device is selected by default
and the Select Devices dialog box is skipped. If the OPFAC doesn't have a device,
an error is flagged.

This feature is only applicable to the fixed nodes (only wired ports will be
considered for selection).

= The best default link available and a list of the other applicable link types
displays.

Figure 3-17 Select Wired Link Properties Dialog Box

~+|Select Wired Link Properties =10l x]
Select Port Group: | ) |
Select Link: | PPP_DS0 x|
ciscodS00SrcPort [ 6.0 [~
computer. Dest Port | p_te 0_0 =1
Bandwidth | 10000.00 | Kbps

= A series of the most common default bandwidths for the selected link type is also
provided as well as the first available ports applicable to the chosen link as
default ports.

Use the default values or select the desired values from the drop-down lists in the
Select Wired Link Properties dialog box.

When you create a satellite, external, or radio link, instead of providing long link

names like SIPRNET_Router-GCCS_COP, JCSS supports the use of a System

Link Designator (SLD) name. SLDs follow an eight-character alphanumeric code
to identify the transmission systems that they connect.

If you want to specify the SLD codes that will make up the SLD Name for this link,
click Next.

= The Edit SLD Name dialog box displays.
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Figure 3-18 Edit SLD Name Dialog Box

~#|Edit 5LD Name =101l
SLD Codes:
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System Mumber: IUQ
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4.1 To specify the SLD Name, choose a System/Link Type, From User, and To
User from the drop-down lists and then enter a System Number and Number
of Channels Per System. The full SLD Name will then be generated
automatically based on what you have entered.

4.2 Click OK to complete the SLD creation, or click Cancel to cancel the process.

= The Select Link dialog box re-displays.

5 Click Finish.

= An inter-OPFAC link or internal link will be created with the user-defined
attributes between the two devices, depending on whether the selected devices
are within one OPFAC or different OPFACs.

End of Procedure 3-16

Deploying Satellite Links

JCSS supports two types of satellite links: bentpipe and broadcast links.

To create a bentpipe satellite link, the scenario must contain two earth terminals
that are the endpoints of the satellite link and a home satellite through which the

earth terminals communicate.

To create a generic broadcast satellite (GBS) link, the scenario must contain an
earth terminal to act as one endpoint of the satellite link and a satellite to act as

the other endpoint.

Procedure 3-17 Deploy a Satellite Link

1 Select two OPFACs or devices and then select Topology > Link Operations >

Deploy Link (or press <Ctrl> + L.)

JCSS/Release 10.0

JCSS-3-20



3—Topology Building

Figure 3-19 Selecting Satellites for Link Deployment
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2 If more than one device is present in an OPFAC, the Select Devices dialog box
displays. Select the desired devices to connect and then click Next.

Figure 3-20 Select Devices Dialog Box

i—]SEIect Devices x|

Site1.S1c Device | satterm_nodal =

Site2 Dest Device | sat_term_basic Rd|

LCancel |

If a selected OPFAC has only one device, then the device will be selected by
default and the Select Devices dialog box will be skipped. If the OPFAC doesn't
have a device, an error will be flagged.

= The Satellite Bent Pipe Link Deployment dialog box displays.
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Figure 3-21 Satellite Bent Pipe Link Deployment Dialog Box—Basic
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The Basic tab displays the default Link Name, and allows you to select the
Home Satellite which provides the available frequencies. The Help Diagram tab
displays a diagram which explains the function of this dialog box. The Help
FAQs tab lists helpful answers to frequently asked questions.

3 If you click the Advanced Tab, the following screen displays.

Figure 3-22 Satellite Bent Pipe Link Deployment Dialog Box—Advanced
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Based on the frequencies provided by the chosen Home Satellite, this screen
allows you to configure the frequencies uplink and downlink (in each direction) to
establish a satellite link between the two selected satellite terminals.

= The fields of this screen are pre-populated for you with the best available default
link.

4 If you are creating a GBS link, the Satellite Link Attributes dialog box displays
(instead of the Satellite Bent Pipe Link Deployment dialog box shown previously in
this procedure.)
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Figure 3-23 Defining Satellite Link Attributes (GBS)
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5 Use the default values or select the desired values, and then click OK.

= The newly deployed satellite link displays in the workspace.

Figure 3-24 Deploying Satellite Links
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After you have deployed a satellite link, you can create a TSSP circuit by selecting
exactly two objects (devices or OPFACs) and configuring the circuit via the Circuit
Deployment wizard.
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6 Select Topology > Deploy Circuit to start the wizard.

Note—The process for configuring multiplexer circuits is the same as the process
for configuring TSSP circuits. You can create a multiplexer circuit by selecting
exactly two devices and configuring the circuit via the Circuit Deployment wizard.

End of Procedure 3-17

Deploying Circuits

Import Circuits

Export Circuits

You can import circuit information from or export to a tab-delimited text file.

Import circuit information from a tab-delimited text file. Depending on the
information contained in the file, the import process may do one of the following:

1)
2)

4)

Reject rows containing invalid values
Add new circuits not already contained in the scenario
Delete circuits from the scenario not found in the file

Modify circuits in the scenario based on the information in the imported file

Select Topology > Import > Circuits. A file chooser dialog box appears.

Select the tab-delimited file you want to import. An Import Circuit Report

dialog box which provides a summary of the validated entries appears. If
any lines in the imported file had errors, a dialog box listing the errors will
appear first.

Modify the Action field to change lines for additions, deletions, or
modifications. Circuit entries that failed validation will not appear in the
report.

Click OK to import the entries.

Export information about all circuits in the scenario to a tab-delimited file by
choosing Topology > Export > Circuits. JCSS examines all devices in the
scenario that have circuits defined and writes the circuit information to a text file
in the project directory with the following naming convention:
<project>-<scenario>-circuits.txt.
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Each section of the text file starts with a circuit_type field, followed by a field
listing the name of the circuit type. The sections of the file are sorted by circuit
type.

Verifying Device Connectivity

Verify that devices are connected properly.

Procedure 3-18 Verify a Link
1 Select Topology > Link Operations > Verify Links, or click the Verify Link

Consistency button. Inconsistent links (e.g., links not connected to the right ports
on the end points of the link) will be marked with a red X in the workspace.

Figure 3-25 Inconsistent Links

-

node_1 node_2

In addition, the results of the link consistency check will be displayed in the
Scenario Link Consistency dialog box.

Figure 3-26 Link Errors and Failure Reasons Display
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2 The Scenario Link Consistency dialog box lists the link errors and failure reason.
Troubleshooting solutions are provided, where possible in the text of the failure
reason.

Note—In most cases, one or more of the link's attributes may be the source of the
failure. In the Attributes dialog box, carefully review the attributes. Pay particular
attention to the model, port assignments, and data rate.

End of Procedure 3-18

Save as Link Type

You can save inter-OPFAC links to a new link, using the following procedure.
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Procedure 3-19 Save As Link Type

1 Right-click on a link in the workspace, and select Save As Link Type.

= The status bar at the bottom left corner of the Scenario Builder window displays
the following message, "New Link type '<selected link name>' saved."

End of Procedure 3-19

Defining Planning Links

Set placeholders for the connectivity links that will be created based on the
subscriber requirements. These links can have organizations or OPFACs as
terminating points and show the anticipated bandwidth. Planning links are
drawn as green dashed lines. Planning links cannot be used for discrete event
simulation and capacity planning analyses. Use the following procedure to
deploy planning links from the object palette.

Procedure 3-20 Add Planning Links via Object Palette
1 From the object palette drop-down menu, select the JCSS_Links palette.
2 Select the Planning Link icon.

3 Left-click endpoint 1 (OPFAC, organization) to identify it as the source, and then
left-click on endpoint 2 (OPFAC, organization) to identify it as the destination.

Figure 3-27 Planning Links Drawn as Green Dashed Lines
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End of Procedure 3-20
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Defining External Connectivity Links

Connect OPFAC devices to devices in other OPFACs. These links define actual
physical links that show the specific type of connectivity. Organizations are not
valid terminating points for connectivity links. External links are drawn as green
solid lines and show the actual bandwidth.

Table 3-1 Planning Links vs. Connectivity Links

Planning Link Connectivity Link

High-level link Actual physical link

Shows general connectivity Shows the specific type of connectivity
Shows anticipated bandwidth Shows actual bandwidth

Can connect organizations and OPFACs Can only connect OPFACs

Drawn as dashed green line Drawn as solid green line

Use the following procedure to add external connectivity links from the object
palette.

Procedure 3-21 Add External Connectivity Links via Object Palette

1 From the object palette drop-down menu, select the JCSS_Standard_Models, or
JCSS_Links palette.

2 Select the desired link icon (10BaseT, T3, wire point-to-point, etc.).

3 Left-click endpoint 1 (OPFAC) to identify it as the source, and then left-click on
endpoint 2 (OPFAC) to identify it as the destination.

Figure 3-28 External Links Drawn as Green Solid Lines
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End of Procedure 3-21
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Defining Broadcast Networks

Connect radio system devices that are tuned to the same frequency and/or
belong to the same frequency hop group. Only OPFACSs can be included as
members of a broadcast network. Broadcast networks are drawn as a broadcast
network object with members connected by blue links.

Use the following procedure to add broadcast networks from the object palette.

Procedure 3-22 Add Broadcast Networks via Object Palette

1 From the object palette drop-down menu, select JCSS_Links palette.

Figure 3-29 Broadcast Network Object Palette Icons
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2 Click the nw_bcast_network icon and drop it to the desired location.
3 Click the nw_bcast_network_attachment.

4 Left-click on an OPFAC to be added, and then left-click the nw_bcast_network icon
on the workspace to add the member to the network.

Figure 3-30 Broadcast Network
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End of Procedure 3-22

Use the following procedure to deploy broadcast networks from the Topology
menu.

Procedure 3-23 Deploy Broadcast Networks via the Topology Menu
1 Select the source and destination OPFACs or organizations in the workspace.

2 Select Topology > Deploy Broadcast Network (or press Ctrl + Shift + B).
= The Network Attributes dialog box displays.

Figure 3-31 Defining Broadcast Network Radio Attributes
|

Metwark, Mame: I

Mode of Operation: Isincgars LI
Classification: I Unclazsified LI
Start Time: [5TART Stop Time: |END

Fadio Attributes | Choose Devicesl Optimization .&ttributesl

Attribute Dezcription | Range |Va|ue | Uit ;I
Default Frequeticy 30-490 30 tMHz
Channel B andwidth 25 kHz

[Data Rate 16000 bps

Powser 025-5 025 Wiattz
FH5S Modeling Dizabled

FFHSS Model Ahshract

|—FHSS Low Frequency 30-90 30 kHz
|—FHSS High Frequency 30- 90 a0 tHz
|—FHSS Channel Spacing 10 KHz

- FHSS Hop Set Size 20

|—FHSS Hop Seguence Generation Random

|- FHSS Hop Duration 10.0 Secs

[ ]

— Corcel |

3 Type a name for the broadcast network in the Network Name field.

4 On the Radio Attributes tab, enter the desired attributes for default frequency,
channel bandwidth, and data rate. In addition, if the radio supports Frequency

Hopping, additional attributes for frequency hopping spread spectrum (FHSS) will
appear which can also be configured.

5 On the Choose Devices tab, select devices for the corresponding OPFACs or
organizations.
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Figure 3-32 Defining Broadcast Network Devices
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6 On the Optimization Attributes tab, enter the desired attributes for possible
capacities, and target and maximum utilization.
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Figure 3-33 Defining Broadcast Network Optimization Attributes
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6.1 Possible Capacities table: Specifies all of the capacities that the optimization
engine can use when mutating solutions. For example, if there are two
capacities specified, then the engine will be able to set either of them as the
suggested capacity for this network. The Capacity column is where the
capacity is specified. The Status column is used to mark the "original" capacity
and the "current" capacity (or "Orig/Current" if the current capacity is also the
original capacity.)

6.2 Insert Row button—To add a new capacity, click this button and type the new
capacity into the Capacity column of the new row.

6.3 Delete Row button—To remove a capacity, select a cell in the row and click
this button.

6.4 Target Utilization—Specifies the target utilization to be achieved on this
network. The default value is to use the global values specified in the Capacity
Optimization Settings dialog. You can override this just on this network by
specifying a new value.

6.5 Maximum Utilization—Specifies the maximum utilization that is allowed on
this network. The default maximum utilization is set to use the global values
specified in the Capacity Optimization Settings dialog. You can override this
just on this network by specifying a new value.

7 Click OK to create the newly defined broadcast network.

End of Procedure 3-23
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Verifying Link Consistency

Verify that links are connected consistently. This feature is identical to Device
Connectivity covered in the Verifying Device Connectivity section in this manual.
Clicking the Verify Link Consistency button prompts JCSS to simultaneously
check all links (external, internal, etc.) in the scenario.

Configuring Utility Nodes
Utility nodes contain information/attributes pertaining to multiple nodes in the

scenario. They provide a convenient way of configuring information that is
conceptually shared.

The Circuit Deployment Wizard provides step-by-step guidance for configuring
Promina utility nodes. Use the following procedure to configure Promina
devices.

Procedure 3-24 Configure Promina Devices

1 Select Topology > Deploy Circuit to start the wizard. You must select at least two
compatible circuit devices or OPFACs that contain circuit devices; otherwise, an
error will be prompted and the wizard is terminated.

= The Circuit Deployment Wizard dialog box displays.

Figure 3-34 Circuit Deployment Wizard Ports Tab
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Note—Click the Help button for information on the current dialog box; click the
Cancel button at any time to terminate the wizard.
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devices in the scenario.

Figure 3-35 Circuit Deployment Wizard CCSD Tab
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Figure 3-36 Circuit Deployment Wizard Attributes Tab
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The following attributes can be set for the Promina circuit:

e Call priority—Specify the range and value for call priority.

2 Onthe Ports tab, specify the ports for the selected source and destination Promina

3 Onthe CCSD tab, configure the CCSD codes for the Promina circuit.

* Preempt priority—Specify the range and value for preempt priority.

JCSS/Release 10.0

JCSS-3-33



3—Topology Building

e Terrestrial routing—Do not care leaves the attribute set to the default value
¢ Encryption routing—Do not care leaves the attribute set to the default value
¢ Fiber routing—Do not care leaves the attribute set to the default value.

e Call type—A permanent call will be set up at the beginning of simulation and
never torn down; a demand call will be set up whenever demanded by the
connected end devices and torn down if inactive.

¢ Direction—The direction of the circuit; some ports can only receive and some
only send. Dual represents a full duplex circuit.

5 Click the OK button to complete the Promina circuit configuration and deploy the
circuit.

End of Procedure 3-24

Reviewing the Requirements Matrix

Answer a series of questions designed to help identify the requirements for a
particular organization or OPFAC. Each new organization and OPFAC added to
the project contains these default questions. The questions, which can be
modified or deleted, are divided into five functional areas:

* Voice Services

* Data Services

e VTC Services

* Message Services

¢ Joint Digital Network

The collaborative planning features of JCSS allow lead planners to designate
portions of the planning process/topology building to subordinate planners. To
assist the subordinate planner in completing the assigned tasks, the lead
planner should provide background information on the scenario using the
requirements matrix.

A filter in the upper-right corner of the requirements matrix controls the type of
requirements that display-either approved or requested.

Approved Requirements:

* Filled by the upper-level planners
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* Requirements specified on organizations and OPFACs

* Values are not aggregated

Requested Requirements:
* Filled by the subordinate planners
* Requirements specified on organizations, OPFACs, and devices

* Values are aggregated from the lower up

Procedure 3-25 Provide Requirements Matrix Information

1 Right-click on the desired unit to open the shortcut menu, and then select Open
Requirements Matrix.

= The Requirements Matrix dialog displays.

Figure 3-37 Answering Requirements Matrix Questions
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2 Select either Approved or Requested in the Filter drop-down list in the upper-right
of the Requirements Matrix to control the type of requirements that display.

3 Click the buttons below the table to view questions for each functional area.

4 Answer questions by clicking in the Answer cell and entering text in the dialog box
that displays.

5 Click Close when complete.

End of Procedure 3-25

Defining Additional Scenarios

When a project is created, there is only one scenario (a “baseline” scenario) in
the project. You may want to define additional scenarios to use to define specific
points in time in the project, such as pre-deployment, deployment, and
execution. JCSS allows you to define additional scenarios by either creating a
new blank scenario or creating an exact duplicate of an existing scenario under
a new name.
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You can switch easily from one scenario to another by selecting from a menu of
available scenarios in the project.

A convenient way to manage all of the scenarios in a project is via the Manage
Scenarios dialog box. Using this feature, you can view each scenario in the
project and its status. Buttons and drop-down menus enable you to do the
following:

¢ Add new scenarios

Duplicate scenarios

* Delete scenarios

* Run a simulation

e Change the simulation duration
* Delete results

¢ Reorder scenarios in the list

Use the following procedure to create a new scenario.

Procedure 3-26 Create a New Scenario
1 Select Scenarios > New Scenario, or press <Ctrl>+<Shift>+<N>.

2 Enter a name for the scenario in the New Scenario Name field, and then click OK.

Figure 3-38 Creating a New Scenario
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w The new scenario is blank and contains no data. The Scenario Builder indicates
in the title bar the current open scenario.

End of Procedure 3-26

Use the following procedure to duplicate a scenario.

Procedure 3-27 Duplicate a Scenario
1 Select Scenarios > Duplicate Scenario, or press <Ctrl>+<Shift>+<D>.

2 Enter a name for the scenario in the Duplicate Scenario Name field, and then click
OK.
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Figure 3-39 Duplicating a Scenario
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= The new scenario is an exact copy of the current scenario, which can serve as
the baseline scenario. The Scenario Builder indicates the current open scenario
in the title bar.

End of Procedure 3-27

Use the following procedure to switch between scenarios.

Procedure 3-28 Switch Between Scenarios

1 Select Scenarios > Switch To Scenario.

= A menu displays the current scenarios in the project. A black bullet indicates the
current scenario open in the Scenario Builder.

2 Select the name of the scenario that you want to display.

End of Procedure 3-28

Use the following procedure to manage scenarios.

Procedure 3-29 Manage Scenarios

1 Select Scenarios > Manage Scenarios.

= The Manage Scenarios dialog box displays.

Figure 3-40 Manage Scenarios Dialog Box
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2 Click in each table cell to edit its contents. Brackets indicate a change to the
scenario is requested, and will be applied when you click OK. The column functions
are as follows:

e #—Changes the order of the scenarios in the table.
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8

e Scenario Name—Lists the name of each scenario.

e Saved—Shows if a scenario is saved or unsaved. Clicking within a cell also lets
you delete a scenario.

¢ Results—Shows the state of the results of each scenario simulation.
"Uncollected" means that a probe file exists, but you have not run a simulation.
"Out of date" means that the set of chosen results, simulation configuration, or
network model has changed since the results file was created.

¢ Sim Duration—Specifies the length of time to run the simulation. Use it with the
Time Units column.

¢ Time Units—Specifies the time units that apply to the simulation exam: seconds,
minutes, hours, days, or weeks. Used with the Sim Duration column.

If you want to save the project under a new name, type the name in the Project
Name field. This is similar to the File > Save Project As... feature.

If you want to delete a scenario from the project, select it in the list and then click
Delete.

If you want to delete results from a scenario, select it in the list and then click
Discard Results.

If you want to run a simulation and collect the specified statistics for a scenario,
select it in the list and then click Collect Results.

Click OK to close the Manage Scenarios dialog box, and run any simulations that
are waiting.

Click Cancel to close the Manage Scenarios dialog box without making changes.

End of Procedure 3-29

JCSS/Release 10.0

JCSS-3-38



3—Topology Building

Configuring Protocols

The Protocols menu contains operations related to the various protocols
supported in the standard and specialized model libraries. The protocols are not
documented in this manual; please refer to the OPNET documentation listed for
each menu option below (consult the IT Guru user guide, available via Help >
Documentation > IT Guru Documentation):

Table 3-2 Protocols Menu ltems

Menu ltem

Description

Reference

Applications

Adds ACE application
models to the existing
network and configures
application traffic.

Model User Guide

Servers

Manages server models

Model User Guide

Mainframes

Manages mainframe models

Model User Guide

TCP

Configures TCP

Model User Guide

IP

Configures IP addresses,
dynamic routing protocols,
type of service
characteristics for
conversation pair traffic,
autonomous system
numbers on routers, and
ping traffic.

Model User Guide

Link16

Configures/assigns Time
Slot Blocks (TSBs) on
terminals in the network.

Model User Guide

IPv6

Configures IPv6 addresses,
routing protocols, interface
status, and runs readiness
assessment and migration
planner.

Model User Guide

BGP

Configures BGP start time,
autonomous system
numbers, and route
redistribution from other
protocols into BGP.

Model User Guide

EIGRP

Configures EIGRP start time
and route redistribution from
other protocols into EIGRP.

Model User Guide

IGRP

Configures IGRP start time
and route redistribution from
other protocols into IGRP.

Model User Guide
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Table 3-2 Protocols Menu Items (Continued)

Menu ltem

Description

Reference

IS-1S

Configures interface metrics,
interface circuit types,
system types, metric styles,
and SPF calculation
parameters.

Model User Guide

OSPF

Configures interface cost,
OSPF start time, areas, and
route redistribution.

Model User Guide

RIP

Configures RIP start time
and route redistribution from
other protocols into RIP.

Model User Guide

MPLS

Configure MPLS

Model User Guide

LDP

Enables/disables LDP
protocol status on
all/selected routers.

MPLS Model User Guide

RSVP

Enables/disables RSVP
protocol status across
connected interfaces on
all/selected links.

Model User Guide

ATM

Configures oversubscription
on a per-setrvice class basis
for all or selected nodes in
the network.

Model User Guide

Frame Relay

Configures PVCs between
nodes in the network

Model User Guide

Ethernet

Configures Ethernet

Model User Guide

FDDI

Configures FDDI

Model User Guide

VLAN

Configures virtual LANs
(VLANS) for selected nodes
and links.

Model User Guide

STP

Applies STP visualization to
the current scenario.

VLAN Model User Guide

MANET

Configures MANET

DSR Model User Guide
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Table 3-2 Protocols Menu Items (Continued)

Menu Item Description Reference

SIP

Allows visualization of SIP Model User Guide
signaling routes after
running Discrete Event

Simulation
UMTS Configures UMTS Model User Guide
Wireless LAN Configures wireless LAN Model User Guide
ZigBee™ Configures ZigBee™ Model User Guide

Visualizing Protocol Configuration

To determine which routing protocols are running on your network, run the
routing protocol visualization feature, as described in the following procedure.

Procedure 3-30 Run a Routing Protocol Visualization

1

Select View > Visualize Protocol Configuration > (option).

Control the display of protocol configuration using the following options:

¢ |P Interface Status—Shows whether the connected interface is active or

shutdown. A green up arrow indicates that interface is active whereas a red down
arrow indicates that the interface is shutdown.

IP Routing Domains—Shows the routing protocols that are configured on the
router interfaces.

IP Address Types—Shows the IP address types on the network by color, along
with a legend to explain the color-coding.

IP QoS Configuration—Shows the IP QoS configuration on the links.

IP Security Configuration—Shows the packet filtering security configured on the
links.

IP Tunnel Configuration—Shows the router tunneling configured on the links.

BGP Peers—Shows the BGP peering (neighbor) relationships in the network.
EBGP confederation peers are shown in dark green, EBGP peers are shown in
blue, all other colors indicate IBGP peers. You can view the tool tip of each
peering visualization for more information about the peers. For networks using
route reflection, the visualization also indicates if a router is a reflector or a client.

OSPF Area Configuration—Shows the OSPF areas configured on the router
interfaces.

IPv4 Interface Metrics—Displays metric legend for IGP, OSPF, ISIS, IGRP,
EIGRP, and MPLS TE.

ATM Routing Domains—Shows which ATM routing protocols that are configured
on the switch ports.
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¢ VLAN Configuration—Shows the VLANSs configured in the network.
¢ HAIPE Versions—Shows the HAIPE devices configured in the network.

¢ Clear Visualization—Removes all protocol configuration visualizations from the
workspace.

Figure 3-41 Viewing IP QoS Configuration on Links
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End of Procedure 3-30

Viewing a Terrain Profile

The JCSS license includes a license for the Terrain Modeling Module GUI
(TMMGUI). The terrain profile feature is always available in JCSS if the Terrain
Data is available.

Use this feature to visualize the physics of a radio link by displaying a
cross-section of the path between a transmitter and receiver, as well as an
optional plot of signal strength variations along that path.

JCSS supports the following terrain data formats:

DTED Level O

DTED Level 1
15-minute DEM data
2-arc-second DEM data

1-degree-DEM data

Use the following procedure to view a terrain profile.

Procedure 3-31 View a Terrain Profile

1 Select Topology > Terrain > View Terrain Profile.
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2 In the workspace, click on the location of the transmitter, and then click on the
location of the receiver.

= The View Terrain Profile dialog box opens, showing the terrain profile for the
specified path.

Figure 3-42 Viewing a Terrain Profile
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3 Customize the signal path to match your situation by changing any of the
parameters and clicking the Recompute button.

4 Control what is shown in the profile by selecting or deselecting any of the
checkboxes to the right of the profile. From the drop-down menus, select the
propagation model and parameter set to use for the path loss calculations.

5 Click the Add to Graph button to generate the signal strength plot.

6 To see any messages generated by the path loss calculations, click the Signal
Strength Diagnostics button.

7 To add additional plots to the graph, change the configuration as desired (for
example, different frequency, propagation model, or parameter set), and click the

Add to Graph button.

End of Procedure 3-31
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Enabling Line-of-Sight (LOS) Connectivity and Range

You can indicate whether a particular radio transmitter could communicate
successfully with a radio receiver at a given location. This option requires terrain
data; it computes LOS connectivity between multiple OPFACs and LOS range
for selected OPFACs. Use the following procedure to enable LOS connectivity
and range.

Procedure 3-32 Enable LOS Connectivity and Range
1 Select View > Show LOS > LOS Settings.
= The LOS Settings dialog box displays.

Figure 3-43 Enabling LOS Connectivity and Range
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Measured in meters, the value in the LOS Range Radius field specifies the size of
the circle that may appear around an organization or OPFAC. It is a nominal range,
and this single setting affects all LOS Visualization in the editor. For reference,
10,000 meters is the typical transmission limit when terrain elevation data is not
available. Transmitters assisted by elevation could transmit many times this
distance.

The value in the LOS Terrain Shading Density field specifies the number of
samples to check within the LOS Range Radius for determining LOS Terrain
Effects Shading. More samples give a more accurate representation, but can also
slow display as more information must be considered to update Terrain Effects
Shading.

2 Select the Enable LOS Connectivity checkbox, if you want to allow the editor to
display LOS Connectivity links when selected for organizations or OPFACs. This
options is enabled by default.

LOS Connectivity is a thick, dashed, double-headed arrow. The color of the arrow
indicates whether the two objects could communicate. Connectivity is bi-directional
and independent of specific device characteristics. Connectivity is based on signal
loss between the transmitter and receiver positions as determined by the
Longley-Rice signal propagation model.
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LOS Connectivity exists between OPFACs. Organizations that contain OPFACs
may display LOS Connectivity links when they are collapsed. Enabling LOS
Connectivity on an organization enables LOS Connectivity on all subordinate
organizations and OPFACs. An organization that contains no subordinate
OPFACs will not display any LOS Connectivity links (it would not be able to join a
broadcast network or connect via point-to-point links either).

LOS Connectivity works through broadcast networks and point-to-point
transmission links to determine all of the OPFACs to which a selected Organization
or OPFAC could possibly communicate and designates the state of that
communication link. LOS Connectivity links are attributes of their end points. The
existence of LOS Connectivity links indicates that one or both of the objects at an
end of the link has LOS Connectivity enabled. LOS Connectivity links disappear
when neither end point has LOS Connectivity enabled, in either the top-level
organization or any subordinate organization or OPFAC. LOS Connectivity link
coloration is automatically updated when either end point moves for any reason,
including mouse dragging, attribute changes, or animation, to reflect the LOS
closure state at the new location.

Select the Enable Scenario LOS Range checkbox, if you want to allow the editor
to display LOS Range circles and Terrain Effects Shading for selected
organizations or OPFACs. This option is enabled by default.

LOS Range is a circle of a fixed radius placed around the organization or OPFAC
in question. The circle represents a ground distance and is used as a reference for
the distance from a particular object. There is a single setting for the range that
pertains to all LOS Ranges displayed in the entire scenario. The LOS Range is a
nominal indicator, having no direct connection to a particular device's transmission
range. The LOS Range does indicate the limit of the area within which locations
may be sampled for determining LOS Terrain Shading.

Any organization or OPFAC may display an LOS Range without regard for the type
of device contained within or even if an OPFAC or device is contained. The LOS
range simply indicates a distance.

Select the Enable LOS Terrain Shading checkbox if you want to allow the editor to
display Terrain Effects Shading if LOS Range is also enabled. This option is
disabled by default.

= Terrain Effects Shading indicates portions of the area around an organization or
OPFAC where a radio receiver could not receive a hypothetical transmission
from the object.

Since the LOS Range defines the limit of the area where LOS Terrain Shading is
tested, LOS Range must be enabled to view LOS Terrain Shading. Disabling LOS
Range on an object also disables LOS Terrain Shading.

Like LOS Range, LOS Terrain Shading does not indicate anything about the
specific OPFACs or devices contained within the designated object. It simply
indicates that if the object contained a radio transmitter, that radio transmitter would
or would not be able to communicate with a generic radio device at a particular
location.

LOS Terrain Shading works by testing for LOS closure at a predetermined number
of sample locations evenly spaced throughout the circle formed by the LOS Range.
You can select the number of samples to take.
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LOS Terrain Shading updates when the selected object moves for any reason,
whether by mouse dragging, attribute change, or animation.

5 Click OK to accept the settings in the LOS Settings dialog box.

End of Procedure 3-32

Displaying Line-of-Sight (LOS) Connectivity

Indicate whether the two objects could communicate. Connectivity is
bi-directional and independent of specific device characteristics. Connectivity is
based on signal loss between the transmitter and receiver positions as
determined by the Longley-Rice signal propagation model. Use the following
procedure to display LOS connectivity.

Procedure 3-33 Display LOS Connectivity

1 Select OPFAC(s) of interest in the workspace. To use this feature, a broadcast
network must connect the OPFACs.

2 Right-click to open the shortcut menu, and then select Enable LOS Connectivity.

= [nvalid connections are indicated by red links, clear connections are indicated by
green links.

Figure 3-44 Displaying LOS Connectivity
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End of Procedure 3-33
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Displaying Line-of-Sight (LOS) Range

Indicate LOS range, a circle of fixed radius placed around the organization or

OPFAC in question. The circle represents a ground distance and is used as a
reference for the distance from a particular object. Use the following procedure
to display the LOS range.

Procedure 3-34 Display LOS Range
1 Select unit(s) of interest in workspace.

2 Right-click to open the shortcut menu, and then select Enable Object LOS Range.

= | OS Range displays as a circle around the unit.

Figure 3-45 Displaying LOS Range
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End of Procedure 3-34

Displaying Terrain Effects Shading

Use the following procedure to indicate portions of an area around a unit where
a radio receiver could not receive a hypothetical transmission from the object.

Procedure 3-35 Display Terrain Effect Shading
1 Make sure Enable LOS Terrain Shading is selected in the LOS Settings dialog box.
2 After enabling LOS Range for an object, right-click to open the shortcut menu.

3 Select Display Terrain Effects.
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Figure 3-46 Displaying Terrain Effects Shading

End of Procedure 3-35

Importing from VNE Server

JCSS lets you create a network model based on information imported from VNE
Server. Use the following procedure to create a network topology using data
imported from VNE Server.

Procedure 3-36 Import from VNE Server
1 Choose Topology > Import > From VNE Server.
= The Import from VNE Server dialog box displays.

Figure 3-47 Import from VNE Server Dialog Box
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2 Specify the name of the VNE Server from which you want to import, and then click
OK.

= A second Import from VNE Server dialog box displays.

3 Inthe VNE Server Name field, specify the hostname or IP address and port for the
VNE Server.

3.1 If you are running import on the same machine as the VNE Server, use
"localhost" as the server name. If the VNE Server is in the same domain in
which you are running import, enter the hostname without domain extension
or enter the IP address of the VNE Server. If the VNE Server is in a different
domain, enter the server name as hostname.domain (i.e.,
vneserver.opnet.com), or enter the IP address of the VNE Server.
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3.2

The default port number is 900. If you are importing from a VNE Server
installed on Linux, change the port number to 3001. If you are importing from
VNE Server on any port other than 900, enter the server name as
hostname:port (or hosthame.domain:port) or IP address and port (i.e.,
ip_address:port).

Specify the import mode you want to use:

4.1

4.2

4.3

Create network using VNE Server data—Use when starting a new scenario or
when you want to erase all existing information in the current model to replace
with VNE Server data. If selected, the current VNE Server data is used to
create a network model. "Create" appears if you are in a new scenario;
"Replace" appears if you are in an existing scenario.

Incrementally update network using the most recent VNE Server data—Use
when you want to update the current model with any changes that have
occurred in VNE Server since the last import. If selected, VNE Server updates
the current network model with all recorded changes in VNE Server since the
original import.

Create network using an existing archive—Use when you want to replace the
current model with information contained in a VNE Server archive file. If
selected, a network model is created using the archived network specified in
the drop-down menu. This menu is populated based on available archives
from VNE Server.

On the Options tab, specify the import options as follows:

5.1

5.2

5.3

5.4

5.5

6.1

6.2

Include collected configuration files—When selected, this checkbox gathers
the configuration files of the devices to be imported along with all other import
data. When this option is used, you can right-click on any imported node for
which a configuration file exists and select View Device Configuration Source
Data.

Append operational data—When you include collected configuration files, you
can also choose to append the operational data. This lets you append
operational data to the configuration file collected by VNE Server in the import.
The operational data can include CDP data and other data that can be used
in a subsequent import using Device Configuration Import.

Generate import log—Creates a log of actions during the import. You can
access the log through the object or workspace pop-up menus after the
import.

Generate Model Completeness Report—Runs a Model Completeness Report
on the imported model based on the last template you used. If you have never
generated a Model Completeness Report, the default template is used.

Use the following model assistant file(s)—When the checkbox is selected, you
can choose model assistant files that specify certain import-related
information (i.e., data rates, connectivity).

6 On the Topology tab, specify topology-related import options as follows:

Group nodes into subnets (based on VNE Server groups)—Uses the VNE
Server groups to create node grouping, in subnets, in the imported model.

Create tunnel based connections—Infers logical tunnel clouds based on
tunnel end-point information when there is no physical path inferred
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6.3 Create nodes to represent external ASes—Creates dummy objects to
represent missing external BGP (EBGP) neighbors.

6.4 Create nodes to represent edge LANs—Creates LAN objects for active router
interfaces that are not connected. By connecting these interfaces to LAN
objects, no active router interfaces are left unconnected after the import.

6.5 Filters—Specify the amount of data to include in the import.

On the Traffic tab, traffic that is available from the VNE Server is displayed, such
as link loads or flows. Specify traffic-related import options as follows:

7.1 Include?—Click on the value in this column to enable or disable the inclusion
of the available traffic data.

7.2 Traffic type—Displays the available traffic type you can configure in this row.

7.3 Traffic information—Displays the available traffic information gathered from
the VNE Server.

7.4 Modify?—Click on "Edit..." in this field to open the Rollup Configuration dialog
box. Customize the way in which you want to rollup the available information,
depending on what exists in VNE Server.

On the Metrics tab, performance metrics, CPU utilization, and RAM utilization data
for the following device types are available and can be configured when the data is
collected on the VNE Server:

¢ Acme Packet Net-Net 4000 Session Border Controllers (SBC)
¢ Cisco devices using IOS and IOS XR

9 Click Import.

End of Procedure 3-36
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4 Traffic Specification

Creating IERs

You can specify the conveyance of messages/data through your
communications system. IERs are Information Exchange Requirements. Create
an IER either by deploying a demand from the Object Palette or by using the
IER Wizard.

When you deploy demands from the Object Palette, the demands must be
deployed between nodes (devices), not subnets (OPFACs), and may be
attached either to equipment devices or to an OE node. The demands may then
be edited via the IERs dialog box. The IERs dialog box displays immediately
after a demand is deployed from either the Object Palette or the IER Wizard.
The IERs dialog box allows you to specify all attributes except those related to
threads.

The IER Wizard, described in Procedure 4-2 on page JCSS-4-2, enhances the
deployment of individual IER demands. You can create a demand between sites
by selecting exactly two nodes or OPFACs in the workspace or in the Network
Browser. The IER Wizard also allows you to specify which node is the producer
of the IER. Only one node may be the producer and one other node will be made
the consumer. Use this wizard is to deploy single IERs quickly between two
nodes. In most cases, this will be your main IER wizard.

Use the IER Rapid Deployment Wizard, described in Procedure 4-3 on

page JCSS-4-4, to create multiple IERs in a full-mesh, one-to-many, or
many-to-one deployment, or to create individual multiple-consumer IERs. For
the one-to-many, many-to-one, and full mesh options, individuals IERs are
created. For multiple-consumer IERSs, a single entity is created. Even though a
multiple-consumer IER is conceptually a single entity, it is represented by
multiple demands.

The IER Wizard allows you to specify which OPFAC is the producer or
consumer based on the deployment method (i.e., one-to-many, many-to-one,
etc.) In addition, when you edit the attributes of one demand of a
multiple-consumer IER, the changes are applied to all demands of that IER.

Use the following procedure to deploy IERs from the object palette.

Procedure 4-1 Deploy IERs using the Object Palette

1 Choose Topology > Object Palette.
= The Object Palette displays.
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Figure 4-1 IERs in the Object Palette
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2 Drag an IER demand from the Object Palette to the workspace.

3 Click a source node and a destination node for the IER you want to create.

= The |IER dialog box displays.

4 Edit the demand via the IERs dialog box. Specify all attributes except those related
to threads.

End of Procedure 4-1

Use the following procedure to deploy an IER between one producer and one
consumer using the IER wizard.

Procedure 4-2 Deploy IERs using the IER Wizard
1 Choose two devices or OPFACs in the workspace.

2 Choose Traffic > IERs > Deploy IER....

= The Deploy IER Choose Devices dialog box displays.

Figure 4-2 Deploy IER: Choose Devices Dialog Box

iﬁ-]Deplur IER: Choose Devices

Producer Device IJFLEC_D.t’-‘«T.t’-\ [Auto Select) :I

Conzumer Device IJFSDEC_D.&T.& [Auto Select) ;I

Hext Lancel |
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3 Verify the selection of the OPFAC or device for the IER you want to create:

* Producer Device—When creating IERs, the producing OPFAC or device is
selected in this drop-down menu. Only one OPFAC or device may be selected at
a time.

e Consumer Device—When creating IERSs, the consuming OPFAC or device is
selected in this drop-down menu. Only one OPFAC or device may be selected at
a time.

4 Click Next.
= The |ER dialog box displays.

Figure 4-3 |ER Dialog Box

H]IER [_[O]
Name [DE -> DE 1
o [USERT14 =]
Type TS =]
Equipment I Computer” LI
Pratocol I TCF =l
Classification IUI"IC|EI$SifiEd j
Priority [ROUTINE |
Perishabilty (sec] | 15
tessage INDt Configured j
— Generation Parameters

Size [zec or bytes) |constant[1 a00)

Interarmival [zec) exponential(E0]

Start Time 100

Stop Time EMND
— Reporting Dptions

Record Floute Interval [sec) |Never j

[~ &pplication Delay Tracking

[~ Export Reports
[v alidate IER ' alues Ok I LCancel |

Note—The "ier_configs" file, which is located in the
<JCSS Installation Directory>\Scenario_Builder\16.0.A\netwars\rules directory, is
used to provide the IER Properties defaults for the IER wizard. You can modify this
file appropriately to provide different default values.

5 Specify attributes for the IER:

¢ Name—Name of the IER.

¢ ID—Identifies an IER in the database. IDs for IERs that are user-specified start
with the prefix USER, as not to conflict with IER IDs in the database. Background
IERSs start with the prefix BKGD.

e Type—This is the type of IER: voice, VTC, or data.

¢ Equipment—This is the type of equipment that will be used to transmit this IER.
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¢ Protocol—Defines the underlying transport layer protocol that traffic (IERs) will
use for transmission. Typical transport layer protocols include TCP and UDP.

 Classification—Specifies the security classification of an IER. The security
classification of an IER is one criterion that determines the system element
through which the IER is transmitted. The default classification is "Unclassified."

¢ Priority—Determines the precedence that an IER receives in the network.
Network devices may give resources differently to higher priority IERs during
actual traffic routing. Priority also determines the number of transmission retries
and the wait time between successive retries when firing the IERs.

¢ Perishability (sec)—Specifies the time in seconds for which the IER is alive. If the
time taken by the IER to reach the destination from the source is greater than the
perishability, the IER is recorded as "failed."

¢ Message—This field can be set to any value (usually in a <tag>=<value> format).
Custom models can then parse this information and use it during the simulation.
Multiple portions of information are separated by the ';' character.

e Size—This is the size of the IER. For data IERs, the size is specified in bytes. For
voice or VTC IERs, the size is specified in number of seconds.

e Interarrival(s)—Represents the time, in seconds, between IER firings.

e Start Time—Identifies the time, in seconds, in which the IER will begin firing after
a simulation begins.

¢ Stop Time—Identifies the time, in seconds, in which the IER will stop firing after
the simulation begins.

¢ Record Route Interval (sec)—Set the interval at which you wish to record IER
routes during a simulation: Never (default), All (record all IER firings), Once
(record only the first firing), or enter an integer in seconds.

¢ Application Delay Tracking—If this checkbox is selected, enables application
delay tracking.

¢ Export Reports—If this checkbox is selected, the IER OT Reports will be
collected during the simulation so that you can view them after the simulation is
completed. To view IER OT Reports, use the Results Browser located in the
"DES > Results > View Results..." menu.

¢ Validate IER Values—If this checkbox is selected, performs a continuous
validation of IER values

6 Click OK to create the specified IER.

End of Procedure 4-2

Use the following procedure to deploy IERs between multiple end-points.

Procedure 4-3 Deploy IERs (Advanced)

1 Choose Traffic > IERs > Deploy IERs (Advanced).
= The IER Rapid Deployment Wizard appeatrs.
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Figure 4-4 IER Rapid Deployment Wizard

ﬁIER Rapid Deployment Wizard H=] E3
— IER Froperites
Type [paTa [
E quipment I Computer ;l
Clazsification IUnCIassified j

— Device Selection

% Full mesh among all devices

"~ To all ather devices from I MAGTF_DATA [duta Select] =l

™ From all other devices to IMAGTF_DATA [&uta Select] LI

" Mulbi-canzumer IER from IMAGTF_DATA [&uto Select] =l

[ Select ather devices Mext I Cancel |

2 Specify traffic type, equipment type, and classification to be used for the
IERSs to be created.

These properties are used to filter the list of possible producer and consumer
devices. The set of possible values for these properties is obtained directly from
the IER demand object, and the Decision Table entries are used to filter the
Equipment list based on the chosen Traffic Type.

3 Define the scope of the deployment, choosing from the following options:

¢ Full Mesh: Creates a mesh of bi-directional IER pairs among all devices that
support the specified IER Type, Equipment, and Classification.

Note—A mesh is not created for intra-OPFAC IERs.

e To all other devices from a selected device: Creates individual IERs between the
selected producer and all other devices that support the specified IER
configuration and are not in the same OPFAC as the producer.

¢ From all other devices to a selected device: Creates individual IERs between all
devices that support the specified IER configuration and the selected consumer,
provided that they are not in the same OPFAC as the consumer.

¢ Multi-consumer IER: Creates a single multi-consumer IER between the selected
producer device and all other devices in the scenario that support the specified
IER configuration and are not in the same OPFAC as the producer.

3.1 Ifyou choose the Select Other Devices checkbox and click Next, the following
dialog box appears. The tree is filtered to show only devices that support IERs
with the specified type, equipment, and classification settings. Select as many
devices from this tree as desired and click Next. Those devices will be used
when creating IERs according to the deployment scope you chose.
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Figure 4-5 IER Wizard: Choose Devices Dialog Box

i—]IER Wizard: Choose Devices

Devices:

—-D Mwi_Top ;I
+|:| JFMCC_DATA
+D JFLCC_DATA
+D JRACC_DATA
+D JFSOCC_DATA
+D CFH_DATA 3
#{] CFH_DATS 2

" o

Back | Hest | Cancel |

4 When you click Next, either on the initial wizard screen or on the Choose Devices
dialog box, you will go to the IER dialog box shown in step 5 of Procedure 4-2 on
page JCSS-4-2. Follow the instructions that accompany that figure to complete the
IER deployment.

5 Click OK to complete the IER deployment.

End of Procedure 4-3

Use the following procedure to record routes for IERs.

Procedure 4-4 Record IER Routes

1 Right-click on an IER in the workspace.

= The |ER dialog box appears.
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Figure 4-6 IER Dialog Box

Her Pl
Mame |OE > DE1

D ILISEFH 14 =]
Type | DaTa =]
Equipment | Computer ]
Pratocal | TCP =]
Classfication | Unclassified =]
Prioiity | ROUTINE =

Perishabilty (s=c) |15

Mezzage IN ot Configured

Le

— Generation Parameters

Size [zec or bytes) corstant{1000] . ) .
Interarrival [sec) exponentisll5) Set IER route recording using this

Start Time 100 drop-down menu.
Stop Time END

— Reporting Options
Record Route Interval [sec) INBVBI j

[~ Application Delay Tracking
[~ Expoart Beparts

[ Walidate IER Values ok | Cancel |

2 Using the Record Route Interval (sec) drop-down menu, choose Never, Once, or
All, or enter a numeric value by typing it into the box. For example, you can enter
“600” if you want to record IER routes for every 10 minutes of simulation time. By
default this value is set to “Never”, meaning that route recording is disabled. You
must set a value for route recording to be enabled.

3 Click OK to accept changes in this dialog box.

End of Procedure 4-4

Use the following procedure to display and edit all IERs in a scenario.

Procedure 4-5 Edit IERs

1 Choose Traffic > IERs > Edit All IERs.
= The |IERs dialog box displays.
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Figure 4-7 IERs Dialog Box
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Note—To display a list containing all IERs associated with any subnet, node or
demand that is selected in the workspace or Network Browser, choose Traffic >
IERs > Edit IERs for Selected Objects.

¢ Average Data Traffic and Voice Traffic—These fields display the average size or
duration and total load values for the Data and Voice categories

¢ |[ERs—This list box allows you to edit attributes of IERs
2 Click Delete to delete a selected IER.
3 Click Refresh Aggregate Loads to update aggregate loads in the view.
4 Click OK to save your IER edits.

End of Procedure 4-5

Use the following procedure to import an IER text file.

Procedure 4-6 Import an IER Text File

1 Choose Traffic > IERs > Import IER Text File.
= The Import IER Text File dialog box displays.

2 Select an IER Text File (*.txt) to import, and then click OK.

End of Procedure 4-6
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Use the following procedure to view IERs in the workspace.

Procedure 4-7 View IERs

1 Choose View > IERs > Show All to show all IERs in the view, or choose View >
IERs > Show Only Selected to show selected IERs in the view.

Note—To hide all IERs from the view, choose View > IERs > Hide All.

End of Procedure 4-7

Use the following procedure to color IERs by aggregate load.

Procedure 4-8 Color IERs by Aggregate Load

1 Choose View > IERs > Color by Aggregate Load to color IERs in the view by
aggregate load.

Note—To hide aggregate load coloring, choose View > IERs > Hide Aggregate
Load Coloring.

End of Procedure 4-8

Use the following procedure to set IER color thresholds.

Procedure 4-9 Set IER Color Thresholds

1 Choose View > IERs > Set IER Color Thresholds to set IER color thresholds.
= The Traffic Flow Thresholds dialog box displays.

Figure 4-8 Traffic Flow Thresholds Dialog Box

—+|Traffic Flow Thresholds x|
Traffic Load Color
Minimun; |lj
Threshold 1: |2 e -
Threshold 2: |4 Iiﬁ[een e
Threzhold 3: Imi — j
[Oange =]
Threshold 4: |5D Doree
Threshold &: 500 " -
Help... | Cancel |
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2 Set IER color thresholds, and then click OK.

End of Procedure 4-9

Use the following procedure to export an IER report to a text file.

Procedure 4-10 Export an IER Report

1 Toexportall IERs in the scenario (excluding threads) to a text file, choose Traffic >
IERs > Export IER Report.

= The Create IER Report dialog box displays.

Figure 4-9 Create IER Report Dialog Box

2| x]

Save h:l:‘lNDha :_] + @ cf B

_IResults
" 15CM
] Subordinate_Queries

File name: 1J TF_Org_Company.nt.m Save |
Save a3 type: [Defaull Files [* k) ;’ Cancel |

2 Select a location and enter a name for the file, and then click Save.

End of Procedure 4-10

Use the following procedure to import an IER report from a file.

Procedure 4-11 Import an IER Report

1 To import an IER Report, choose Traffic > IERs > Import IER Report.
= The Import IER Report dialog box displays.

2 Select an IER Report File (*.txt) to import, and then click OK.

During import, you are provided with a detailed comparison of the report contents
versus the scenario contents. You may review and reject individual differences,
such as a value change in an |IER attribute.

End of Procedure 4-11
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Creating Threads

Threads are groups of IERs that are fired in segments. For example, an OPFAC
can fire an IER to their platoon leader OPFAC, which in turn can fire an IER to
the company commander OPFAC. Threads can be configured to fire traffic only
when certain conditions are met. Use the following procedure to create a thread
manually.

Procedure 4-12 Create a Thread
1 Select one of more IERs in the workspace or Network Browser.

2 Right-click an IER and select Edit Thread, or choose Traffic > IERs > Create
Thread.

= The Thread dialog box displays.

Figure 4-10 Thread Dialog Box

ﬂ Thread @@@

1D | Relay Alert
Segments
[IER D Condition 1Ds Condition o]
Radio Alert Maone WAIT FOR ALL COMDITIONS
Call Securky Radio Alert WAIT FOR ALL CONDITIONS
Page Dfficers Call Security WAIT FOR ALL CONDITIONS
Insert Delete
oK Cancel |

3 Specify the ID, and segments of the thread in the Segments table:

3.1 Click Insert to add segments to the thread. If one or more cells are selected in
the table, clicking Insert adds a default segment in the row above the selected
highest cell. If no cells are selected, the segment is added at the end of the
thread. You can also simply edit a cell in the last row of the table to add a
segment to the end of the thread.

3.2 Click Delete to remove segments from the thread. Delete is active only when
cells are selected in the table. Clicking Delete removes all rows with selected
cells.

4 Click OK to save the thread.

End of Procedure 4-12
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Use the following procedure to create a thread manually from existing IERs
using “Edit Thread.”

Procedure 4-13 Create a Thread from Existing IERs via "Edit Thread"

Note—This example workflow assumes that you have created all of the IERs that
will be part of the thread and that none of those IERs contain values in any thread
attributes.

1 Right-click an IER and select Edit Thread.

= The Thread dialog box displays. The Segments table is initialized with one row.
The IER ID cell of the first segment contains the chosen IER. The Condition IDs
cell contains None.

2 Click Insert or select a value in the second row of the table to create a new
segment.

= The IER ID cell of the new segment lists all of the IERs that may be triggered by
the segment before it and all of the IERs that may be "start" segments for the
thread.

= The Condition IDs cell of the new segment lists the IER of the first segment and
the value None, which is valid only for "start" segments.

3 Insert another segment at the end of the table, as in the previous step.
= The IER ID cell has the same behavior.

= The Condition IDs cell lists the IERs of all segments above the new segment that
could trigger it, and None.

4 Continue inserting segments until the thread is complete.

End of Procedure 4-13

Use the following procedure to create a thread manually from existing IERs
using “Create Thread.”

Procedure 4-14 Create a Thread from Existing IERs via "Create Thread"

Note—This example workflow assumes that you have created all of the IERs that
will be part of the thread and that none of those IERs contain values in any thread
attributes.

1 Select one or more IERs in the workspace or Network Browser.

2 Choose Traffic > IERs > Create Thread.

= The Thread dialog box displays. The Segments table is initialized with one row.
The IER ID cell of the first segment list all selected IERs and one is arbitrarily
chosen as the initial value. The Condition IDs cell contains None.

3 Choose a different IER for the first segment, if desired.
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4 Continue with step 2 of the Edit Thread workflow.

Alternately, you may begin without selecting IERs in the workspace.

5 Choose Traffic > IERs > Create Thread.

= The Thread dialog box displays. The Segments table is initialized with one row.
The IER ID cell of the first segment is blank. The Condition IDs cell contains
None.

6 Choose the special value Select an IER in the IER ID cell of the first segment.
= A child dialog launches and instructs you to select an IER in the workspace.
6.1 Selectan IER.

6.2 Click the Continue button on the child dialog.
= The selected IER is set in the IER ID cell of the first segment.

6.3 Choose a different IER for the first segment, if desired.
7 Continue with step 2 of the Edit Thread workflow.

End of Procedure 4-14

Use the following procedure to create a thread manually without using existing
IERs.

Procedure 4-15 Create a Thread without Existing IERs

Note—This example workflow assumes that you have not created any IERs that
will be part of the thread. Other IERs may exist in the scenario, but will not be used
in this workflow.

1 Choose Traffic > IERs > Create Thread.

= The Thread dialog box displays. The Segments table is initialized with one row.
The IER ID cell of the first segment is blank. The Condition IDs cell contains
None.

2 Choose the special value “Create an IER” in the IER ID cell of the first segment.

= A child dialog launches and instructs you to select one or more subnets and/or
nodes in the workspace.

2.1 Select one or more subnets and/or nodes in the workspace.
2.2 Click the Continue button on the child dialog.

w The IER Wizard launches to create an IER. The new IER is set in the IER
ID cell of the first segment.

3 Insert a new segment at the end of the table.

= The IER ID cell of the new segment is blank. The Condition IDs cell behaves as
in the Edit Thread workflow.
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4 Repeat step 2 for the new segment.
5 Continue inserting segments and creating IERs until the thread is complete.

End of Procedure 4-15

Use the following procedure to edit threads.

Procedure 4-16 Edit Threads

1 To display a table containing all of the threads in a scenario, choose Traffic >
IERs > Edit All Threads.

= The Threads dialog box displays.

2 Todisplay a list containing all threads associated with any subnet, node or demand
that is selected in the workspace or Network Browser, choose Traffic > IERs >
Edit Threads for Selected Objects.

End of Procedure 4-16

Creating Threads from ACE Analyst

You can import captured application traffic in ACE files and specified application
traffic in ACE Whiteboard into threaded IERs through the ACE to Threaded
IERs wizard. Each file imported will be converted into a single threaded IER per
a specified tier group. The wizard has an aggregation feature that intelligently
groups some application messages into a single IER, thereby improving
performance.

You can specify the aggregation parameters which define the intelligence
during aggregation for each file. You can further specify the aggregation
parameters for each ACE/ACE Whiteboard file and tier group combination. Use
the following procedure to deploy threads from ACE.

Procedure 4-17 Creating Threads from ACE Analyst

1 Choose Traffic > IERs > Import > Threads from ACE Analyst.
= The ACE to Threaded IER Conversion Wizard opens.
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Figure 4-11 Import Threads from ACE Analyst Wizard
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Tewt s I LCancel

2 Add an ACE or ACE Whiteboard file.

2.1 Click the Add Application Transaction... button to identify an ACE (atc.m) or
ACE Whiteboard (aed.m) file to convert.

w A file chooser window opens.
2.2 Select a file and click Open.

= The selected file appears under the Transaction Traffic column of the table

Figure 4-12 ACE to Threaded IER Conversion: Specify Application
Transactions

ﬁAEE to Threaded IER Conversion: Specify Application Transactions
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Application? high_bandwidth_HT TP atc.m Default Default

Chooge the ACEAACE \White Board
application transaction traffic you want to
deploy as IERs.

1 i Llll MOTE: Each transaction should be
assaciated with unique application name.

Tierz included in selected application transaction:

Oracle Client | |vou will assign this raffic to specific
Cracle Server nodes in the nest window,

Mest » I LCancel |

¢ Application Name—Contains unique name <ApplicationN>, in which Nis a
number appended to make the name unique, is created for each
application.

¢ Transaction Traffic—Contains the name of the ACE or ACE Whiteboard file
you selected.
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¢ Aggregation—Specifies the aggregation parameter values used while
converting the traffic into IER threads. Aggregation parameters are defined
in terms of application turns. An application turn is defined as a change in
the flow of the application message. For example two consecutive
application messages from a source to destination and vice versa defines
a single application turn.

By default, if the selected file is an ACE file, then the corresponding
Aggregation column value is set to Default. If the selected file is an ACE
Whiteboard file, the corresponding Aggregation column value is set to
None. You can change the Aggregation value by clicking in the column and
selecting Default, None, or Edit... If you choose Edit..., another dialog box
appears, which lets you specify how aggregation is to be handled. When
finished, click OK to return to the previous dialog box.

Figure 4-13 Application Turn Aggregation Parameters

Application Turn Aggregation Parameters : None %] If you make any edits to the

[~ Enable Intra-turn Aggregation Only aggregation parameters,

[ Enable Inter-turm &ggregation [Includes [ntra-tum) you will be asked whether to
apply the changes and

b axirnurn Mumber of Cantinuous Application Turnz ko Agagregate: :
- continue or go back to Save
t* [Unfimited

¢ ls= Speciied I— As a file for later re-use.

[Accepts Odd Mumber of Application Turns Orly]

Save Az | oK | Cancel I

Enable Intra-turn Aggregation Only aggregates all the contiguous
messages that flow from same source to the same destination. Each of the
contiguous set of messages within an application turn is converted into a
single IER of size and processing delay equal to the sum of the constituent
messages.

Enable Inter-turn Aggregation (includes intra-turn) implicitly enables
and applies intra-turn aggregation to the application messages. The
resulting intra-turn aggregated application messages are further
aggregated across multiple contiguous application turns as specified by the
inter-turn aggregation parameters. You can include an unlimited number of
turns to aggregate, or you can specify an odd number of turns to aggregate.

e Start Time—Specifies the thread start time. This value is set to Default, but
you can change this value to an integer in seconds. The Default value
corresponds to the default value of the Generation Parameters > Start
Time attribute of the IER_demand Traffic Flow model. If you specify a value
under this column, the value is then set to the Generation Parameters >
Start Time attribute of the start segment/IER of the IER thread.

3 Click Next.

= The Assign Producers and Consumers to Application Tiers dialog box appears.
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Figure 4-14 Assign Producers and Consumers to Application Tiers
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4 Assign producers and consumers for each threaded IER. You can add new devices
or OPFACs in the workspace and return to the Assign Producers and Consumers
dialog box. If you do so, click the Refresh button to refresh the listing.

For each application, the wizard creates one tier group, which you must define. A
Tier Group is the collection of devices to which the ACE or ACE Whiteboard file will
be mapped. If the application needs to be deployed across multiple collections of
the devices, then you should use the "Create new group" option from the Tier
Group selection drop-down menu. Select a Tier in the left-side pane and select a
tier in the right-side pane. Use the << or >> button to make the connection.

4.1 Select the “Launch IER Thread Pre-deployment Editor following conversion”
if you want to visualize the IERs prior to final deployment into the workspace.
Use the pre-deployment editor to validate the conversion for simple
application transactions, edit the appropriate IER attributes, and/or manually
select and aggregate the application messages/IERs.

4.2 Use the Advanced Options... button to further specify aggregation or IER
attribute options for a tier group prior to deployment. Click OK when finished.
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Figure 4-15 Advanced Options for a Tier Group
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5 (Optional) Review the IERs in the Pre-Deployment Editor. Make changes as
necessary.

Figure 4-16 Pre-Deployment Editor
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D] Display 1D Seament Type| Producer| Consumer] Start Time (sec]| Depends On (ID] [Depends On [Display ID] | Protocol] Size| Interarival (sec)] Type| Equipment] Classification] Priority] Per_~ |

i o

Agaregate Selected
0-1 2-100 101-500 T 501-1000 T 1001-1459 »=1460
Unda Agaregation

I <Back | Finish Cancel

6 Click Finish to deploy the IERs.

End of Procedure 4-17
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Creating Relationships

Define the association or connection between two or more OPFACs.
Relationships can be used to visualize command structure and to facilitate
traffic flow for JCSS' capacity planning features. Use the following procedure to
create a relationship.

Procedure 4-18 Create a Relationship
1 Select the OPFACs that you want to associate in the workspace.

2 Select Topology > Deploy Relationship.

= The Relationship Attributes dialog box displays.

Figure 4-17 Creating a Relationship

i.—IRelatiunship Attributes |
S [ CFH_DATA_2 |
Specity Start/Stop Time | ok | Cancel |

3 Select the type of relationship from the Relationship Type drop-down menu.
4 Select the source OPFAC from the Source drop-down menu.

5 Click OK.

= The relationship between the selected OPFACs is created.

End of Procedure 4-18

Converting Applications into Flows

Automatically convert standard OPNET application and profile configuration
parameters into IP flow objects. This process turns the discrete application
traffic into background flows for use in simulation or traffic visualization. After
creating the flows, the application and profile configuration objects are cleared
of all traffic information to prevent duplication of traffic during simulation. It is
recommended that a duplicate scenario be created prior to using this feature if
you want to keep the application and profile configurations for later use.
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Use the following procedure to convert applications into flows.

Procedure 4-19 Convert Applications into Flows

1 Select Traffic > Convert Traffic > Applications to Flows.

= The Convert Applications to Flows dialog box displays.

Figure 4-18 Converting Applications into Flows

:I Convert Applications to Flo =10] x|

Flow Time Settings

StatTime: | 0 Houfs)| 0 Mins) | 0 Secls)

Duration: | 1 IHour(s) :]

LCancel |

2 Enter flow generation parameters as needed, and then click OK.

2.1 Enter the start time of the flow objects in the Start-Time (Hours, Minutes,
Seconds) fields. This will effectively act to truncate all flow traffic recorded
prior to the value provided. The flow's bps and pps values during this time will
be set to 0.0. The input values must be integers.

2.2 Enter the duration of the simulated calculation window in the Duration
(Length, Units) field. This method corresponds to the Capacity Planning
Optimization feature. The input value must be an integer.

Flows will be aggregated for any source/destination pair. Thus, any number of
applications that contribute to traffic between a given client and server will be
aggregated into two flows with one for each direction of travel.

End of Procedure 4-19

Deploying Traffic Using the Traffic Wizard

Deploying traffic between a single client-server pair within JCSS can be
performed easily via the Traffic Wizard. Select two OPFACs, and then the
Traffic Wizard walks you through selecting the end devices (and the profile to
deploy between the client and server devices), and deploying a link between
them.

Use the following procedure to deploy traffic with the Traffic Wizard.

Procedure 4-20 Deploy Traffic using the Traffic Wizard

1 Select Traffic > Traffic Wizard (or press <Ctrl> + W) to launch the Traffic Wizard.
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Figure 4-19 Traffic Wizard

ﬁSimple Traffic Wizard il

Profile or ACE File

Mame: FFTP download over WAN. ate.m Hhd

Dezcnption of the traffic option currently being displaved in the
menu

— Devices
Cliert: I Nw_Top.CFH_DATA_3 computer d|
Server | Nw_Top.CFH_DATA_2 computer d|

0K | Cancel |

= The Traffic Wizard will launch only if you have selected two OPFACs between
which the traffic is to be deployed.

2 Select a profile to deploy, specify client and server devices, and then click OK.

End of Procedure 4-20

Integrating DoDAF Views

JCSS enables you to integrate select Department of Defense Architecture
Framework (DoDAF) views:

OV-3 Operational Information Exchange Matrix—Information exchanged
between nodes and the relevant attributes of that exchange such as media,
quality, quantity, and the level of interoperability required.

SV-6 Systems/Services Data Exchange Matrix—Specifies the
characteristics of the system data exchanged between systems. This
product focuses on automated information exchanges (from OV-3) that are
implemented in systems. Non-automated information exchanges, such as
verbal orders, are captured in the OV products only.

You can import the traffic (IERs) defined by either of the two views and use it in
simulations. You can also modify the IERs and export the new traffic as OV-3
and SV-6 views. The following procedures describe how to:

Create and deploy IERs (see Procedure 4-21)

Create and deploy standard applications (i.e., FTP, Email, etc.) (see
Procedure 4-22)

Create and deploy threads (see Procedure 4-23)
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Procedure 4-21 Create IERs from DoDAF Editor

1 Create a network model in JCSS that represents the topology (not the traffic) of the
network to be modeled. The model should contain all the devices and OPFACs that
will be used by the OV-3 and SV-6 views. This information should be manually
created based on OV-3 and SV-6 views in DODAF. OPFACs or end devices that
are not found in the scenario are created at the end of this workflow.

Note—You can still manually create any IERs which would not be imported from
DoDAF documents.

2 Select Scenarios > DoDAF Integration > DoDAF Editor....

= The DoDAF editor dialog box opens.

Figure 4-20 DoDAF Editor Dialog Box
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4
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3 Select the SV-6 radio button in the View Mode.

4 Click the Import button.

= The DoDAF Import Format dialog box opens.

Figure 4-21 DoDAF Import Format Dialog Box

i—]DuDAF Import Format !E

— File Format
s TextFile

™ Metastorm Provizsion

" Telelogic System rchitect

— Wiew Format
O3
¥ SWE

Impart.... I Cancel I

5 Select the file format of the file you want to import, and select SV-6 as the View
Format. Click Import. A file chooser window appears. Select the SV-6 file you want
to import and click Open.

= The |IERs are imported and appear in the DoDAF Editor dialog box.
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Figure 4-22 DoDAF Editor

Status | System | Data Exchange ID | Sending System Name and...| Sending Syst..| i Feceiving System Hame and ID | Feceiving S_l,lst...‘
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Mo Cha.. TED USERT17 MAGTF_DATA, computer ru_ppp_whatrt JFMCC_DATA computer rws_ppp_twkstn
Mo Cha.. TED USER103 JFMCC_DATAQE og MAGTF_DATAQE <]
Mo Cha.. TED USER112 JFMCC_DATAQE oe CFH_DaTA_2.0E oe
Mo Cha.. TED USER115 JFMCC_DATAOQE oe JFACC_DATAOE oe
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4

Yiew Mode —

’7 Cov3 Impait.... | Export... I Insert Row | Duplicate Howl Delete Row | Walidate |
[OR=1

Note—If no model type is specified in Sending/Receiving Op Node Activity Name and ID,
and end devices must be automatically created, a model type will be used that
corresponds to the traffic type of the IER. See step 7 for more information about automatic
device or OPFAC creation from this dialog box.

6 Verify existing or specify new end system device names in the Sending System

Name and ID or Receiving System Name and ID fields; device names are specified
in the hierarchical opfac_name.device_name format. You can insert new IERs by
using the Insert Row or Duplicate Row button, or you can remove an IER by using
the Delete Row button.

Note—You can specify multiple consumers for an IER by entering full hierarchical
names for each consumer in a comma-separated fashion in the Receiving System
Name and ID field. If you specify multiple consumers, you must also specify the
corresponding OPNET domain-specific model type for each consumer in a
comma-separated fashion in the Receiving System Function Name and ID field.

When finished editing, click OK to deploy the IERs and create any new devices and
OPFACs in the scenario.

= The DoDAF Editor Summary window appears, providing a summary of changes
made to the scenario.
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Figure 4-23 DoDAF Editor Summary Dialog Box

iﬁ-]DuDAF Editor Summary

Summary of Changes:

OPF&Cs/Devices Created
Total Opfacs Created:D
Total Devices Created:0

IER. Summary

Total IERs Created:0
Total IERs Modified:D
Total IERs Deleted: 2
Total IERs Ignored:0

Profiles Summary

Total Profiles Created:0
Total Profiles Modified:0
Total Profiles Deleted:0
Total Profiles Ignored:D

End of Procedure 4-21

Use the following procedure to create or modify standard applications in the
scenario.

Procedure 4-22 Create and Deploy Standard Applications from the DoDAF Editor

1 Create a network model in JCSS that represents the topology (not the traffic) of the
network to be modeled. The model should contain all the devices and OPFACs that
will be used by the OV-3 and SV-6 views. This information should be manually
created based on OV-3 and SV-6 views in DODAF. OPFACs or end devices that
are not found in the scenario are created at the end of this workflow.

Note—You can still manually create any IERs which would not be imported from
DoDAF documents.

2 Select Scenarios > DoDAF Integration > DoDAF Editor....
= The DoDAF editor dialog box opens.
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Figure 4-24 DoDAF Editor Dialog Box
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3 Select the SV-6 radio button in the View Mode.

4 Click the Import button.
= The DoDAF Import Format dialog box opens.

Figure 4-25 DoDAF Import Format Dialog Box
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5 Select the file format of the file you want to import, and select SV-6 as the View
Format. Click Import. A file chooser window appears. Select the SV-6 file you want
to import and click Open.

= The |IERs are imported and appear in the DoDAF Editor dialog box.

Figure 4-26 DoDAF Editor
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6 Setthe Media Type field, as desired.
e |f you want to deploy IERs, select TCP or UDP in the drop-down menu.

¢ |f you want to deploy standard applications, select the application from the
drop-down menu.

7 For a standard application, set the Size field to specify the size of the application.
Click OK.

Figure 4-27 Setting Application Size
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8 Fora standard application, set the Periodicity field to specify the repeatability of the
application. Click OK.

Figure 4-28 Setting Application Repeatability
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9 Click OK.

= JCSS creates one application definition and one profile definition for each. JCSS
also assigns the profile to the source and destination devices as specified in the
DoDAF Editor.

End of Procedure 4-22
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Use the following procedure to create and deploy threaded IERs.

Procedure 4-23 Create Threads Using DoDAF Editor

1 Create a network model in JCSS that represents the topology (not the traffic) of the
network to be modeled. The model should contain all the devices and OPFACs that
will be used by the OV-3 and SV-6 views. This information should be manually
created based on OV-3 and SV-6 views in DODAF. OPFACs or end devices that
are not found in the scenario are created at the end of this workflow.

Note—You can still manually create any IERs which would not be imported from
DoDAF documents.

2 Select Scenarios > DoDAF Integration > DoDAF Editor....

= The DoDAF editor dialog box opens.

Figure 4-29 DoDAF Editor Dialog Box
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3 Select the OV-3 or SV-6radio button in the View Mode.

4 Click the Import button.

= The DoDAF Import Format dialog box opens.

Figure 4-30 DoDAF Import Format Dialog Box
i—]DuDAF Import Fo.. !E[ E

— Filz Farmat ————————
(v Text File
= Metastarm Pravision

" Telelogic System Architect

— Wiew Format
v OW-3
5V

Impart... Cancel
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5 Select the file format of the file you want to import, and select OV-3 or SV-6 as the
View Format. Click Import. A file chooser window appears. Select the file you want
to import and click Open.

= The IERs are imported and appear in the DoDAF Editor dialog box.

6 Set the parameters for the thread in the DoDAF Editor.

6.1 Use the Needline field to specify the thread to which to add the IER. In the
example shown below, three IERs are assigned to Thread1.

Figure 4-31 Import Dialog Box for Creating Threads

| DoDAF Editor
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4
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6.2 Set the thread source and destination OPFACs and Devices using the
Sending Op Node/System Name and ID or Receiving Op Node/System Name
and ID columns.

In the example shown, the thread is sending an IER with an ID of
"USER_src"inter" to the "inter" OPFAC from the "src" OPFAC. On reception
of this IER at “inter” OPFAC, the “inter” OPFAC will then send one IER with ID
“USER_inter_dest1” to the “dest1” OPFAC and another IER with ID
“USER_inter_dest2” to the “dest2” OPFAC.

6.3 Set the Triggering Events. The Triggering Events specify the IER(s) which
should be received before firing the given IER for that row.

6.4 Set the Transaction Type. The Transaction Type specifies whether the
defined IER (in the row) should have to wait for all or only one of the Triggering
Events.

7 Click OK when finished editing threads.

= The threads are deployed in the scenario. An example of deployed threads is
shown.
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Figure 4-32 Example Imported Scenario for Creating Threads

End of Procedure 4-23

Generating DoDAF Visio Reports

You can create a Visio drawing that represents traffic (IER) flow in the scenario
using the Scenarios > DoDAF Integration > Generate Visio Reports... menu
option. Four views are supported:

OV-6¢c—The OV-6¢ view provides a time-ordered examination of the
information exchanges between participating operational nodes as a result
of a particular scenario.

SV-10c—The SV-10c view provides a time-ordered examination of the
system data elements exchanged between participating systems (external
and internal), system functions, or human roles as a result of a particular
scenario.

OV-2—The OV-2 view graphically depicts the operational nodes (or
organizations) with needlines between those nodes that indicate a need to
exchange information. The graphic includes internal operational nodes
(internal to the architecture) as well as external nodes.

SV-2—The SV-2 view depicts pertinent information about communications
systems, communications links, and communications networks. SV-2
documents the kinds of communications media that support the systems and
implements their interfaces as described in SV-1. Thus, SV-2 shows the
communications details of SV-1 interfaces that automate aspects of the
needlines represented in OV-2.
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The following procedure describes the workflow for generating reports.

Procedure 4-24 Generating Visio Reports

1 Choose Scenarios > DoDAF Integration > Generate Visio Reports....

= The Generate Visio Reports dialog box opens.

Figure 4-33 Generate Visio Reports Dialog Box

i—]ﬁenerate DoDAF Yisio Reports

Select View: IUV'2 j

Diagramn Title: IDV-2

Diagram Mame: |Z:'\.J C55%Uzer_Data\Projects\UserGuide_CP_Scenanc'UserGuide_CP_Scenaro-UserGuide CP_Scenario 0V-2 wds

Paqe Size: IEi 34 wddin j Orientation: ||an'2|SCBIJE j

Description: [ Thig will generate OY-2 specific view of the scenario in a visio report, =]
Any OPFAC which has any thread configured will be displayed in the report,

&ll IERs belonging to one thread between a pair of OPFACs will be abstractedby a needline.
Use Edit Options button to customize this report.

Edit Options | Bun Cancel |

2 Select the desired view: OV-2, SV-2, OV-6C, or SV-10C.

3 (Optional) Change the default Diagram Title, if desired.

4 (Optional) Change the default Diagram Name and location, if desired.
5 (Optional) Change the default Page Size output, if desired.

6 (Optional) Change the default page Orientation, if desired.

7 (Optional) Click the Edit Options button.
= The DoDAF Diagram Options dialog box appears.
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Figure 4-34 DoDAF Diagram Options Dialog Box

i—]DuDAF Diagram Options

General |DV-2|

Diagram infarmation:

Metwork: |UzerGuide CP_Scenario-UserGuide CP_Scenario

EIS |1D:55:3?.DDD bar 03 2010
Author: IJESS
Connpary: IJESS

oK I Cancel

e Change settings on the General tab.
e Change the Date of the report, if desired.
¢ Change the Author and Company that will appear in the diagram, if desired.

7.1 Click the view tab (i.e., OV2). Set the view-specific options for the diagram, if
desired. Each view will have its own view-specific properties that you can
specify.

Figure 4-35 DoDAF Diagram Options View Tab—OV2 View

“£|DoDAF Diagram Options M=l B3
General| D\r"-2|
OPFAC lcons |Jse Scenario Builder lcons
MHeedling Line Thickness 1
OPFAC Maming OPFAC Mame Only
Select Meedline Mare
Generate IER Table Tes
oK LCancel

7.2 Click OK to apply changes.
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8 Click Run to generate the Visio diagram.

Figure 4-36 Sample OV2 Visio Diagram

T D O ew Gt fpesw Bah Jwe Sndw o0 o @
ST FECERE. A R R AT I R Y | .
P .Im-liulEl e e =- 2
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— DoDAF OV-2 View ;I

]

IE]
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| v
I e
4 | = Meadine ¢ =

| |

EUDEI'HIMHIMM! = Higeling A Oiperational !-i;ﬂnc
e el — heading [
- Neadine E ﬁ
Operational Node E

i v v s o o
e 113 —

O —r— B wazem

End of Procedure 4-24
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5 Capacity Planning

Evaluating a Network

This section describes how to evaluate a scenario in its current state during a
specified time interval or intervals. This is different from running an optimization
in that it evaluates the scenario with the current capacities for links and
networks. It does not mutate the capacities of the links and networks, rather it
routes the demands through the links and broadcast networks and provides a
summary of the scenario's current condition.

The Evaluation Settings dialog box lets you set the number of time steps, length
of each time step, and the start time. For example, if you know that your peak
usage occurs from 9 A.M. to noon, you could evaluate that time period by setting
number of time steps to 3, the length of the time step to 1 hour, and the start
time to 9 hours 0 minutes 0 seconds.

Procedure 5-1 Perform a Network Evaluation
1 Select Capacity Planning > Evaluate, or click the Evaluate Current Network button.

2 Set parameters as needed for the evaluation.

Figure 5-1 Setting Evaluation Parameters

:Z_j]EvaI uation Settings = 10| x|
Time
Murmber of Time Steps: | 1|
Length of Time Step: I 1 I Hour(s) hd |

Start Tirne: I 0 Hours) | 0 Min(s) | 0 Sec(s)

Advanced Parameters... |

Help | Run I Apply 3 Cancel |

2.1 Number of Time Steps. A Capacity Planning Evaluation can be done for
multiple time steps by setting this value to an integer greater than one.
Reports will be created for the evaluation at each time step as well as reports
reflecting results over the entire time of evaluation. Must be an integer greater
than zero.

2.2 Length and Units of Time Steps. The length and units of the time steps used
in the evaluation. The value selected must be an integer greater than zero.
Units can be seconds, minutes, hours, days, or weeks.

2.3 Start Time. The start time used for the evaluation in hours, minutes, and
seconds. All values must be integers greater than or equal to zero.

3 (Optional) To provide finer control of the evaluation process, click the Advanced
Parameters button.
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Figure 5-2 Setting Advanced Evaluation Parameters

-+|Evaluation Settings Adva =10] x|

Select Naming Convention Preferred for Repots
" device

(+ opfac.device

" oiganization oplac, device

" Full Name

[+ Include ‘#'eb Reports
v Include Individual Link Traffic Reports
v Include Individual Circuit Traffic Beports

[~ Enable IP Load Balancing
I 4 Mumber of Balanced Routes to Report

[ Allow ATM 5VCs to be Setup

Help |

Cancel |

Edit advanced parameters as needed, and then click OK. Descriptions of the
parameters are listed below:

Naming Convention. The names of all the devices and links that are in the
report will use the naming convention selected here.

Include Web Reports. If this option is selected, the link and circuit traffic reports
are also selected. Unchecking this will disable the options for the individual
reports.

Include Individual Link Traffic Reports. If this option is selected, individual
reports will be included in the web report for each link in the scenario. The reports
will include all the traffic going directly over the link as well as any circuits that are
going over the link. The reports will take longer to generate if this option is
selected.

Include Individual Circuit Traffic Reports. If this option is selected, individual
reports will be included in the web report for each routable circuit. The reports will
include all the traffic using the circuit. The reports may take longer to generate if
this option is selected.

Enable IP Load Balancing. If this checkbox is selected, IP load balancing will
be done during the evaluation so that traffic will use multiple equal hop length
paths.

Number of Balanced Routes to Report. If IP load balancing is selected, then
the number of balanced routes to report can be selected. The entry must be an
integer greater than zero. This number of route reports will be reported in the
web reports

Allow ATM SVCs to be Setup. If this checkbox is selected, ATM SVCs will be
set up during the evaluation when applicable.
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4 After specifying the evaluation parameters, click the Run button in the Evaluation
Settings dialog box to start the evaluation.

w After the evaluation is complete, the evaluation web reports launch
automatically.

End of Procedure 5-1

Optimizing a Network

Given a network and its demands, the optimization process provides
suggestions for optimal link and network capacities. If a link is overutilized,
optimization will suggest an alternate capacity that will support the demands
and keep the cost of the link down to the required minimum. If a link is
underutilized, optimization will decrease the capacity for that link.

Before a capacity optimization is run, as described in the following procedure,
you must specify parameters that control how optimal solutions for the scenario
are computed. Use the optimization parameters to search for an optimal
solution with the smallest objective value cost. The Simulated Annealing Engine
will try different configurations, increasing or decreasing the size of the links and
networks, computing an objective cost for each.

Procedure 5-2 Perform a Network Capacity Optimization

1 Click the Start Capacity Optimization button, or select Capacity Planning >
Capacity Optimization > Start Optimization.

= The Capacity Optimization Settings dialog box displays.

Figure 5-3 Setting Optimization Parameters

—#|Capacity Optimization Settings =101 x|
Time Settings — Weights
Start Time: Link Goals: B
| O Houfs)| 0 Mifis)| 0 Secls) Capacity —— |——— Utiization
Duaration:
[ | Hours) | Traffic Load: 7
Target Utiization Maimum Ltiization Average m—— }— M aimum
i 20 4 Voice: |SU -4
e Performance: 7
Data IT % Data: |gg % Speed J— Accuracy
Help | Advanced Eaametersl Bun Apply | LCancel

2 Specify the start time and the duration for the optimization process.
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3 Specify Voice and Data Target and Maximum Utilizations.

4 Specify weights for Link Goals, Traffic Load, and Performance by setting the

corresponding slider bar.

(Optional) To provide finer control of the optimization process, click the Advanced
Parameters button.

Figure 5-4 Setting Advanced Optimization Parameters
—+]Advanced Parameters =10] x|

Random Seed 128

Unroutable Demand Penalty I—"UUD

Number of Sohtions to Store |—3

Penalize Underutilization Yes -]
Allows ATM 5%Cs to be Setup Mo =
Enable IF Load Balancing Mo Ll
Fer Hop Cost 5.00

Hep |

5.1 Edit advanced parameters as needed, and then click OK.

Note—Consult the JCSS Technical Reference Manual for descriptions of all
optimization settings and advanced optimization settings.

After specifying the optimization parameters, click the Run button in the Capacity
Optimization Settings dialog box to start the optimization.

= JCSS computes the routes for the demands and then starts the optimization.

End of Procedure 5-2

Specifying Alternate Link Capacities

Suggest alternate link capacities that might improve the ability of the network
architecture to support the mission plan. These settings are used to feed the
optimization engine with an avenue of recourse; if capacity is exhausted in one
link, available capacity alternatives are suggested during the optimization
process.

Procedure 5-3 Specify Alternate Link Capacities
1 Right-click on a link, and choose Edit JCSS Attributes.
2 From the Link Attributes dialog box, click the Optimization Attributes button.

3 Specify possible alternate capacities for the link.
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Figure 5-5 Specifying Alternate Link Capacities
—+#|MAGTF-¥oice_LinkD =10] x|

Possible Capacities (Kbps)

— Target Utiization ——— — Mawimum Utilization

Voice [Use Glol:-alll = Vaice IUse Global j %
Data IUse GlobaI:J & Data IUse Global :J 4

Capacity | Mum Chann... | Channel Size | Status ;I
128.00 2 £4.00

2586.00 2 E4.00 Ornig/Cumrent

512.00 2 E4.00

Insert Row | Delete Row |

Help | oK I Cancel |

3.1

3.2

3.3

3.4

3.5

Possible Capacities table: Use to specify all of the capacities that the
optimization engine can use when mutating solutions. For example, if there
are two capacities specified, then the engine will be able to set either of them
as the suggested capacity for this link.

The first column in the table is the total capacity (voice capacity plus data
capacity), the second is the number of voice channels, and the third is the
voice channel size. Note that total capacity must be greater than or equal to
the number of voice channels times the voice channel size. Anything left over
is the capacity that is available for data. Any of these parameters can be
modified by clicking on the appropriate cell and typing in a new value.

The fourth column in the table is status. This column is used to mark the
"original" capacity and the "current" capacity (or "orig/current” if the current
capacity is also the original capacity).

To add a new capacity, click Insert Row and then type the values into the cells
of the new row.

Select a cell in the row to remove, and then click Delete Row to remove the
capacity.

Target Utilization fields: Use to specify the voice and data target utilization to
be achieved on this link. The default value is to use the global values specified
in the Capacity Optimization Settings dialog box. You can override this just on
this link by specifying a new value.

Maximum Utilization fields: Use to specify the voice and data maximum
utilization that is allowed on this link. When you run the optimization with an
emphasis on minimizing capacity (Link Goals slider < 4) or getting the
utilization close to the target (Link Goals slider > 7), a new capacity is
considered only if it will keep the link utilization under the specified maximum
utilization.
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The default maximum utilization is set to use the global values specified in the
Capacity Optimization Settings dialog box. You can override this just on this
link by specifying a new value.

3.6 Click OK.

End of Procedure 5-3

Displaying Web Reports

Display web reports after a Capacity Planning Evaluation or Optimization. Web
reports include the following reports for the overall evaluation: Executive
Summary, Overall Peak Results, and Overall Average Results.

Additionally there are a group of reports which are generated for each time step:
Traffic Report, Link Utilization Report, Link Subscription Report, Promina Circuit
Report, CellXpress & ATM Circuit Report, Frame Relay Circuit Report, and an
FCC-100 Circuit Report.

There are also Route Reports for each routed circuit and traffic demand, and
Unroutable Reports for each unroutable circuit and traffic demand. Each
Individual Link also has a group of tables that show the circuit and traffic
demands which flow over it specifically.

Procedure 5-4 Display Web Reports

1 To open a report, select the desired option from the Capacity Planning > Reports
menu.

2 To change settings used in the web reports, select Capacity Planning > Reports>
Settings.

Figure 5-6 Changing Web Report Settings

ﬂ\'ﬂeb Report Settings = |EI[1]
Select Naming Convention Preferred for Web Reports
™~ device

+ opfac.device
(" organization.opfac.device
" Full Mame

v Include Web Reports
v Include Individual Link Traffic Reports
v Include Individual Circuit Traffic Reports

’ 4 Number of Balanced Routes to Report

Help ] Cancel ]
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3 Edit web report settings as needed.

3.1 Naming Convention. The names of all the devices and links that are in the
report will use the naming convention selected here.

3.2 Include Web Reports. If this option is selected, the link and circuit traffic
reports are also selected. Unchecking this will disable the options for the
individual reports.

3.3 Include Individual Link Traffic Reports. If this option is selected, individual
reports will be included in the web report for each link in the scenario. The
reports will include all the traffic going directly over the link as well as any
circuits that are going over the link. The reports will take longer to generate if
this option is selected.

3.4 Include Individual Circuit Traffic Reports. If this option is selected,
individual reports will be included in the web report for each routable circuit.
The reports will include all the traffic using the circuit. The reports may take
longer to generate if this option is selected.

3.5 Number of Balanced Routes to Report. If IP load balancing is selected, then
the number of balanced routes to report can be selected. The entry must be
an integer greater than zero. This number of route reports will be reported in
the web reports

3.6 Click OK.

End of Procedure 5-4

Saving Optimization Settings

Save the results of multiple optimization runs and the effects of changing certain
parameters on the optimization; saved optimization runs can be compared.

Procedure 5-5 Save Optimization Settings

1 When the optimization is complete, save the results of the optimization by selecting
Capacity Planning > Capacity Optimization > Save Optimization As.

2 Enter a name for the optimization run in the Save Optimization As dialog box, and
then click OK.

Figure 5-7 Saving Optimization Settings
iﬁ.—ISa\re Optimization =10 x|

Save Ophimization As: “

oK I Cancel !
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End of Procedure 5-5

Managing Optimization Results

You can compare saved optimization results as follows:

e Compare Parameters

e Compare Bandwidths

Both types of comparison are described in the following procedure.

Procedure 5-6 Compare Optimization Results

1 Select Capacity Planning > Capacity Optimization > Manage Optimization Results.

= The Manage Capacity Optimization Results dialog box displays.

Figure 5-8 Managing Optimization Results

—+]Manage Capacity Optimization Results =101 ]
Ro__.| Optirization Narme | Hop Count |.é.vetage Utliz.... | Capacity [kbps) Ll
1 LG10 316 1093 12,604 419.22
2 LGt 316 1093 12,604,035.22
3 LGS 316 10.39 12,600,669.22
Enter the ndices of rows to compare [E.g.: 1.4.5) I‘I_Z‘I
Compare Parameters | Compare Bandwidths I
Delete Besults I Delete Al Results | Install as Current |
Help | Close |

2 Select the row numbers for the optimizations to compare, and click either Compare
Parameters or Compare Bandwidths to compare the optimizations.
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Compare Parameters

Figure 5-9 Comparing Parameters

Paramatar

[ ata Target Utilization [72]
Waice Traget Ltilization [%]
[ ata b asirmum Utilization [%)
Waice Maximurm Utilzation (%)
Optimization Start Hour
Optimization Start Mirute

O ptimization Start S econd

O ptimization Curstion [sec)
Link Gaoals

Traffe: Load

Optimization Preference
Fandom Mumber Seed
Penalize Underutilization
Allow ATM Y Cs
Unroutable Demand Penaly
Erable IP Load Balansing
Murber of Balanced Foutes
Per Hop Cost

|

ﬂ Compare Bandwidths

LG

Figure 5-10 Comparing Bandwidths

=10l x|

Bandwadth values are in kbps

Association Name LG10 (Before] | LG10 [After) | LG1 [Before] | LG [After) &)
MNw_Top+El_Paso <> Colorado_Spri.. 512.00 463200 512.00 4,632.00
Mw_Top+San_Diego_Promina <-> C... 2,048.00 256.00 2,048.00 256.00
MNw_Top+El_Paso <-» San_Diego_P... 2,048 00 25600 2,048.00 256,00
Mws_Top+zat_link_20 100.00 204800 100.00 204800
MNw_Top+network_3 16.00 10.00 16.00 i0.00
Mws_Top+network_2 16.00 1000 16.00 10.00
Mw_Top+sat_link_2 100,00 2,048.00 100.00 2.048.00
Mws_Top+dtlanta Prominag <> Mash._. 1.024.00 25600 1.024.00 Z56.00
Nw_Top+indianapolis_Promina <-> ... 1,024.00 256.00 1.024.00 256.00
Mws_Top+Miami_step_sat <-> Atlanta... 1,024.00 25600 1.024.00 25E.00
MNwi_Top+Pittsburgh_Promina <-» Atl.. 1.024.00 256.00 1.024.00 256.00
Mw_Top+Fittsburgh_Promina <-» Ind... 2,048.00 256.00 2,048.00 256,00
Nwi_Top/Baghdad+TIER_D «-> Bag... 594,432.00 49,536.00 594.432.00 49,536.00
Mw_Top/Baghdad+TIER_O <> AT... 1,544.00 0,00 1.544.00 £0,00
Nw_Top/Baghdad+ATM Net <-> FR... 1,544.00 £0.00 1.544.00 60.00
Cizco 7513 <-» Promina 44 736.00 1.544.00 44 736.00 1.544.00
Promina <-> tsc-94 256.00 4,632.00 256.00 4,632.00 &
] o
Cloze

End of Procedure 5-6
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Examining Top Solutions

Review top solutions and use the one you think is best.

Procedure 5-7 Examine Top Solutions

1 Specify the number of solutions the engine must keep track of in the Advanced
Parameters of the Configuration Settings dialog box before the optimization is run.

2 When the optimization is complete, select Capacity Planning >
Capacity Optimization > Examine Top Solutions.

3 Use the “Currently visible solution” drop-down menu to view a desired solution.

Figure 5-11 Examining Top Solutions

ﬂTup Solutions Summary

=10] x|
Currertly visible sobstion | 1 vI
Salution summaries ’
|ﬂ EAverage Hop Cal 3 age Capacity | Average Utilization Difference  Unroutable Demands ;i
1 h22 1493353 49 2773 ]
2 522 1326953 .49 2614 0
[ 22 1457488.37 26.46 0

Highlighted row comesponds to cumently visible solution

Help... |

End of Procedure 5-7
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6 Simulation Execution

Choosing Device and Link Statistics

Choose statistics on devices, external links, and internal links to be collected
during simulation.

Procedure 6-1 Specify Statistics for Collection During Simulation

1 Select the object in the workspace for which the statistics will be collected.

2 Select DES > Choose Individual Statistics or select Choose Individual Statistics
from the shortcut menu.

3 Select statistics to be collected during a simulation by clicking the checkboxes next
to the desired statistics.

4 Right-click on the individual statistic, and select Change Collection Mode, as
needed. The all values mode will collect all of the data points in a simulation for a
particular statistic. In the bucket mode, a representative data point (e.g., max value,
etc.) will be collected to represent all the other data points in that bucket.
Figure 6-1 Choosing Device Statistics
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Mekile IP
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QSFF
O5SPF Advarcad Uszing Ilart walue LI
OSFF MANET =
a | PI 0K I Lancel
5 Click OK.

End of Procedure 6-1
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Procedure 6-2 Specify Advanced Statistics for Collection During Simulation
1 Select the object in the workspace for which the statistics will be collected.
2 Select DES > Choose Statistics (Advanced). The Probe Model window displays
advanced statistics on devices, inter-OPFAC, and intra-OPFAC links to be

collected during simulation.

Figure 6-2 Choosing Advanced Device Statistics

-+]Probe Modek UserGuide_CP_Scenario-UserGuide CP Sg =10| x|
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I+I-E Automatic Animation Frobes
B Stalishic Arimation Piobss

+ Lugtarn ®ammaton Hrobes
Live Statictic Probes

4]

o e

End of Procedure 6-2
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Running a Simulation

You can evaluate the network performance of your scenario by using
simulations. Simulations model communications behavior of the network and
provide detail down to the packet and protocol level. You can choose to use a
"simple" configuration mode or a "detailed" configuration mode. The simple
mode presents fewer controls to configure, thereby simplifying the configuration
and execution of a discrete event simulation (DES).

Note—To run DES with JCSS, you must have both an OPNET Modeler or IT
Guru license, as well as a Simulation Runtime License.

Procedure 6-3 Running a Simulation

1 Select DES > Configure/Run Discrete Event Simulation, or click on the
Configure/Run Discrete Event Simulation toolbar icon.

Figure 6-3 Setting Simulation Parameters—Simple Mode
=10l x|

—|Configure,/Run DES: U;erD.ide_EP_Stel:::

Curatiory |1 | hiarlz) xl

Walues per stalistic: | 100

Global aftibutes IH:pﬂtsI

[ Tavibute [l I |
= Applications
FEIGRF
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®[ER Loader
FIGRF
EIP
¥ Loged Link
HF MANET
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F0E
& Simulalion Efficizncy
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& LIER TCP Connection Reuse Tineout 80
@ |—F‘mmhn Circuil Sebap 'wWait Time 0
@ L Pramine Mackak L agrrend Sizs 1,000 Z
Kl el

Dietailerd... |

2 Set the duration of the simulation in the Duration field.using the drop-down menu
next to this field. This sets the duration simulation preference.

3 Setthe number of values collected for each statistic in the Values per statistic field.
This sets the num_collect_values simulation preference.

4 Control the recording of IER routes during the simulation by setting the attribute
OE > IER Record Route Interval (sec) as desired:

* Never—Disables the recording of IER routes for the entire scenario. Overrides
the configuration of all IERs.

¢ All—Enables the recording of all IER routes for the entire scenario. Overrides the
configuration of individual IERs.
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¢ Once—Records the route the first time the IER fires. Overrides the configuration
of all IERs.

* Default—Causes DES to respect recording settings on individual IERs.

e Edit...—Lets you set a numeric value. Overrides the configuration of all IERs.

Set the simulation attributes in the Global attributes window to the desired values.
The Attribute table displays all simulation attributes declared by models involved in
the scenario to be simulated and the values assigned to each attribute. Click on a
question mark icon to display information about the corresponding attribute. Click
on an Attribute Value to change it.

Click the Reports tab to select Statistics and Service Level Agreement (SLA)
reports for the simulation to collect. Reports are predefined sets of statistic probes.
Figure 6-4 Setting Simulation Parameters—Reports

—{Configure/Flun DES: UserGuide_CP_Scena =10 x|
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7 Set the following simulation parameters as necessary.

¢ Generate web report for simulation results checkbox—When selected,
simulation results are included in a report viewed from a web browser

¢ Minimum number of decimal places for statistics in output reports—Sets
the number of decimal places to use in number formatting. If you expect values
to differ in minute amounts, use a large number of decimal places.

¢ Number of entries displayed in 'Top N' reports—Sets the value of 'N'

e Statistics reports—Specifies the statistics reports to generate at the end of the
simulation. Each selected value is added to the reports simulation preference.

¢ Define Statistics Report (button)—Opens a dialog box used to define new

statistics reports
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e SLAs—Specifies the SLA reports to generate at the end of the simulation. Each
selected value is added to the sla_reports simulation preference.

e Define SLA Report (button)—Opens a dialog box used to define new SLA
reports

Click Detailed, if you want to open the dialog box in "detailed" mode. Detailed mode
lets you configure all DES parameters, some of which are not available in simple
mode. This dialog box contains a treeview of information categories for configuring
different aspects of the simulation.

Figure 6-5 Setting Simulation Parameters—Detailed Mode
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8.1 Set the attributes on the Common page to the desired values. Changes affect
only the current scenario.

If you need to set additional attributes, go to the appropriate pages by
selecting them in the treeview and setting the desired values. For further
details on the individual fields that can be configured for each page, refer to
the JCSS Technical Reference Manual.

Click Apply to save the current settings and keep the dialog box open, or click Run
to save the current settings, close the dialog box, and run the simulation
immediately.

= The simulation runs for set duration, displaying frequent progress updates in the
viewing window until completion. Upon completion, a summary of results
displays.

Figure 6-6 Summary of Results

Simulation Completed - Collating Results.

Ewvents: Total (1.721.717). Average Speed (11,453 events/sec)
Tirne: Elapsed (2 min. 30 sec), Simulated (3 min. 0 sec)
Simulation Log: 200 entries
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If fatal errors are present in the scenario when a simulation is run, the simulation
process quits. A pop-up dialog box will instruct you to access the Scenario
Conversion Log file, which details errors that correspond to incorrect scenario
elements requiring adjustment prior to a successful simulation. You can display the
log file, which resides on the same level as the nt.m file, using any text editor tools.

When the simulation is complete, a file named <project name>-<phase name>.ov
is saved in the same location as the nt.m file. This file will be used for results
analysis.

Note—Before a simulation is executed, certain parameters that influence the
behavior of the simulation can be configured. These parameters, which specify the
behavior of traffic during simulation, are configured through the Priority Table,
Decision Table, and System Element Table. Consult the JCSS Technical
Reference Manual for instructions.

End of Procedure 6-3

Viewing the Simulation Log File

You can display a list of errors compiled during the simulation. JCSS encounters
two major types of errors. The first can occur during scenario building, including
capacity planning analysis. The second can occur during a discrete event
simulation. The following section applies to the discrete event simulation only.
Please refer to Error Handling on page JCSS-8-1 for Scenario Builder error
handling.

Procedure 6-4 Display DES Simulation Log File

1 After a simulation execution, select DES > Open DES Log to display the log of
errors and significant simulation events maintained by JCSS during discrete event
simulation.

The DES log is written to a tab-delimited ASCII file. Because there may be many
events in a DES log, a Log Viewer is provided so that you can view only those
events of interest to you.
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Figure 6-7 Viewing the Simulation Log
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2 Click the module tabs to move between modules for which logs are available. The
Miscellaneous tab gives you access to session and error logs.

3 Use the treeview provided in the Logs pane to select from the available logs
associated with the selected module.

For text-based logs, the Selected Log pane displays a single pane with simple text
descriptions of events. For event-based logs, it displays two panes. The first pane
displays sections of the log. Select the section(s) that you want displayed. The
second pane displays the log data, one event per row.

3.1 Click and drag the vertical lines in the header row to resize columns.

3.2 Click on an entry in the Message column to open an edit pad containing the
full text of the message.

4 Check (or uncheck) the “Display logs for current scenario only” checkbox to specify
whether the treeview (in the Logs pane) should list all logs or only those for the
current scenario.

5 Click the “Open Advanced Viewer” button to open an advanced log viewer that
provides additional capabilities using a menu bar. The additional capabilities
include: changing which column is used to color-code a log entry, changing which
columns are visible or filterable, saving the current viewer settings, and exporting
the log information to a file.

6 Click the Close button to close the Log Viewer dialog box.

End of Procedure 6-4
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Viewing Web Reports

Use the following procedure to generate a web report that contains one or more
of the reports available in the Results Viewer.

Procedure 6-5 Generate Web Report

1

2

Right-click in the scenario and choose View Results to open the Results Browser.
Click on the DES Run (#) Tables tab.

Click the Generate Web Report button and select the results you want to generate
from the Select Tables for Web Report dialog box.

Select the Include Network Diagram checkbox, if you want the web report to
include a graphic of the network topology.

Click Generate.

Select a directory for the HTML files and click OK.

= The web report is created and opens in the default Web browser.

End of Procedure 6-5
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Viewing Recorded IER Routes

If you have recorded IER routes during a simulation, you can view the results as
described in this section. Note that when you view the recorded routes, a path
object is deployed in the workspace showing the route, shown as a blue dashed
line in the figure below.

Figure 6-8 Path Object Showing IER Route

| Scenario Builder: rr_test Scenario: interval_test [Subnet: top.Mw_Top]

File Edit View Scenarios Topology Traffic Protocols Capacity Flanning MetDoctor NetMapper Flow Analysis DES  Windows Help

ORS00 FE HE N EBAE A BER UK

| [412020N 03027100 B |

Procedure 6-6 View Recorded IER Routes

1 Select View > IERs > Display Recorded Routes (DES).
= The Route Report for IER Routes window displays.
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Figure 6-9 Route Report for IER Routes
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Show All Routes (button)—Shows all routes in the workspace.

Clear All Routes (button)—Clears all routes from the workspace.

Time—Simulation time of the firing.

Display—Specifies if the route is displayed. This field is a toggle. Click on the field
to change between Yes or No.

Status—Specifies if the firing completed.

Details—Shows a list of devices and links traversed by the route. See the figure
above for an example.

End of Procedure 6-6
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7 Results Analysis

Viewing Measures of Performance (MOP)

You can view the results of a simulation, represented by Measures of
Performance (MOPs). MOPs are statistics, displayed in graphs, which reflect
the ability of selected communications equipment to satisfactorily send and/or
receive information. Use the following procedure to display the MOPs.

Procedure 7-1 Display MOP Graphs

1 Select DES > Results > View Results. You can also right-click in the workspace
and select View Results from the shortcut menu, or click the View Results toolbar
button.

= The View Results window displays.

Note—To view results for a specific link, right-click on the link and select View
Results from the shortcut menu.

2 Select the checkbox(es) of desired MOP(s) in the treeview.

= A graphical preview of the MOP(s) displays in the Preview pane. Preview mode
does not allow graph interaction.

Figure 7-1 Viewing MOPs
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3 Use the graph options/filters drop-down menus to display the MOP graphs in a
variety of layouts.

4 To view the graph(s) in full detail, click Show.
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Figure 7-2 Sample Filtered Graphs
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End of Procedure 7-1

Interacting with MOP Graphs

Modify the look and style of a graph or manipulate properties as described in the
following procedure.

Procedure 7-2 Change MOP Graph View Properties

1 Examine statistics by placing the cursor over a segment of the trace.

= A tooltip displays the coordinates of the graph.

Figure 7-3 Example Graph Tool Tip

%: 09, 66858741722
1% 10k 26m 46s
Mearest Point:

|1 '99.4466700622 |
®: 10k 26m 40s

2 Zoom in on any segment of the trace by drawing a small box around the segment
with the cursor.
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Figure 7-4 Zooming In on a Trace

~

3 Resize the graph window as needed.

4 Right-click on the inner panel of a MOP graph to open a pop-up menu that allows
manipulation of graph properties. Right-click on the outer panel of a MOP graph to
open a pop-up menu with different graph-manipulation options.

Figure 7-5 Accessing Graph Panel Shortcut Menus
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End of Procedure 7-2

Finding Top Statistics

Sort statistics and find bottlenecks by using the Find Top Statistics feature.
Statistics can be exported to an Excel spreadsheet for post analysis, as
described in the following procedure.

Procedure 7-3 Find Top Statistics

1 Select Results > Find Top Statistics from the main menu.
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2 Select the statistic of interest from the Select Statistic for Top Results dialog box.

Figure 7-6 Selecting a Statistic of Interest
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3 Click the Find Top Statistics button. The top objects display in the Top Objects
dialog box.

Figure 7-7 Finding Top Results
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End of Procedure 7-3
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8 Error Handling

Technical Support Log Files

JCSS encounters two major types of errors. The first occurs during scenario
building, including capacity planning analysis. The second occurs while
executing a discrete event simulation. The following section applies to the
Scenario Builder only.

Sometimes program crashes cannot be consistently reproduced. Without a
reproducible set of steps to follow, resolution is difficult. In such cases, the
following information, gathered from the software installation where the error
occurred, can be helpful.

* OPNET Error Log File—This file, called err log, is located in the
\op_admin folder. It contains the function call stacks recorded by JCSS
when there is a recoverable error or a program abort. Error messages are
always appended to this file.

* JCSS Function Log File—This file, called nw_function log, islocatedin
the \op_admin folder. It contains the list of functions that were executed just
before the program aborted. This file also contains the following version
information:

— JCSS software (major release and update)

— Windows Operating System: The contents of this file are overwritten
when there is a program abort.

» JCSS Error Log File—This file, called nw_message log.txt, is located in
the \op admin folder. It contains error messages that were recorded by
JCSS during program execution.

e The project, scenario, and associated files in use when the error occurred

All of this information is automatically packaged into a zip file. The zip file is
called exception data-<time stamp>.zip,where<time stamp>isthe
time at which the crash occurred. In the event of a program abort, you should
send this zip file to JCSS Technical Support. The information contained in this
zip file will assist the developers in debugging the problem.

JCSS Help Desk Contact Information

For issues regarding the use of the software, please contact the JCSS Help
Desk by email at JCSS @ opnet.com or by phone at 240.497.3000 x2699. Note
that email and voice mail to the JCSS Help Desk are checked once a day,
Monday through Friday.

The PMO Contact email is JCSS @disa.mil.
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App A Glossary

B Broadcast Networks Network of radio system devices that are tuned to the
same frequency and belong to the same frequency hop group. All radio devices
belonging to same broadcast network hear transmissions by a given radio
device.

(o Connectivity Links Created based on the subscriber requirements.
Connectivity links are different from planning links in that they are connected to
actual devices instead of to organizations.

Courses of Action Define specific conditions or situations, such as when an
enemy uses chemical, biological, or nuclear weapons. It is important to note that
time phases and courses of action perform exactly the same way in JCSS. You
simply have the option of calling your scenario subdivisions either time phases
or courses of action.

/ IERs The acronym for Information Exchange Requirement. IERs are the
primary traffic representation in JCSS. A relationship between OPFACs is
needed to create an IER.

K Kernel Procedure An OPNET-provided function that supports the development
of protocols and algorithms. All Kernel Procedures start with op_.

m Mainframe Characterization Module MCE is an optional module that allows you
to import measured performance data and analyze it to create workloads
suitable for the mainframe models.

Mod_Dirs An environment attribute that specifies the folders in which files (i.e.,
project files) are located. The mod_dirs attribute is found under Edit >
Preferences.

MOPs The acronym for Measures of Performance. Analyze the results of a
simulation session to produce a set of MOPs. You can then manipulate the set
of MOPs, using data filters, and produce graphs of the data. The MOPs explain
various communication burdens, latency, and other critical performance
measures associated with communication infrastructures.

o Online Documentation An Adobe Acrobat manual that has information about
the OPNET models, kernel procedures, modeling concepts, etc. The manual
can be launched from OPNET Modeler by choosing the Online Documentation
option from the Help menu.
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OPFACs The acronym for Operational Facility. OPFACs are the fundamental
building blocks of JCSS. They are collections of communications devices that
are assigned to military units, which are used to construct Organizations.

Organizations Hierarchies of military units. An organization is a container that
can hold OPFACs and other organizations (sub-organizations).

P Planning Links Placeholders for the connectivity links that will be created
based on the subscriber requirements. These links can have organizations or
OPFACs as terminating points and show the anticipated bandwidth. Planning
links cannot be used for discrete even simulation and capacity planning
analyses.

Process Registry A model-wide registry in which any process mode can
register itself and any process model can obtain information about other
process models that are registered. For a list of kernel procedures available for
use in the process registry, refer to the OPNET Modeler online documentation
for more information.

Note—The OPNET Modeler documentation is not included with JCSS.

Projects Projects are containers for scenarios, time phases, or courses of
action. Related scenarios can be grouped under one project. JCSS enables you
to open and work with multiple projects simultaneously.

) Scenarios Scenarios are instances of C4l communications architectures that
consist of associated OPFACs and Organizations, Information Exchange
Requirements (IERs), and links. Scenarios are stored as part of a project
created within the Scenario Builder. Thus, projects act as containers for
scenarios and a single project may include several scenarios, that is, instances
of C4l communications architecture.

Server Characterization Editor SCE is an optional module that allows you to
import server performance information for analysis of the processes and
applications, and characterize these into workloads used as the basis for
simulation modeling.
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JCSS Help Desk
contact information, JCSS-8-1
JCSS interfaces, JCSS-1-5
ACE and ACE Whiteboard, JCSS-1-6
icon database, JCSS-1-5
mainframe characterization, JCSS-1-6
scenario builder, JCSS-1-5
server characterization, JCSS-1-6
system editor, JCSS-1-5

K
kernel procedure
defined, JCSS-A-1

L
launch JCSS, JCSS-2-1
launching JCSS, JCSS-2-1
how to, JCSS-2-1
system editor window, JCSS-2-1
library treeview
add units from, JCSS-3-1
line-of-sight
connectivity
enabling, JCSS-3-44
range
enabling, JCSS-3-44
line-of-sight (LOS)
connectivity and range
enabling, JCSS-3-44
line-of-sight (LOS) connectivity
displaying, JCSS-3-46
line-of-sight (LOS) range
displaying, JCSS-3-47
link
capacities
specify alternate, JCSS-5-4
specifying alternate, JCSS-5-4
deploy, JCSS-3-18
satellite
deploy, JCSS-3-20
verify, JCSS-3-25
link consistency
verify, JCSS-3-32
link devices via object palette, JCSS-3-17
link type
save as, JCSS-3-26
links
deploying, JCSS-3-18
satellite, JCSS-3-20
internal connectivity, JCSS-3-17
planning versus connectivity, JCSS-3-27
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log file change, JCSS-7-2
DES simulation MOP graph view properties
display, JCSS-6-6 change, JCSS-7-2
log files MOPs
technical support, JCSS-8-1 defined, JCSS-A-1
logical view
scenarios N
setting, JCSS-2-16 network
logical view selection dialog box, JCSS-2-17 evaluating a, JCSS-5-1
login and create new user profile, JCSS-2-2 optimizing a, JCSS-5-3
LOS connectivity network capacity optimiation
display, JCSS-3-46 perform a, JCSS-5-3
enable, JCSS-3-44 network evaluation
LOS connectivity and range perform a, JCSS-5-1
enable, JCSS-3-44 node model
LOS range open in Modeler, JCSS-3-16
display, JCSS-3-47 node models
enable, JCSS-3-44 opening in Modeler, JCSS-3-16
M o
mainframe characterization module object
defined, JCSS-A-1 copy, JCSS-3-13
manage scenarios, JCSS-3-37 cut, JCSS-3-13
managing optimization results, JCSS-5-8 cut or copy, JCSS-3-13
maps paste, JCSS-3-14
add, JCSS-2-13 object palette
border, JCSS-2-12 add broadcast networks from, JCSS-3-28
add a border map, JCSS-2-12 add planning links from, JCSS-3-26
selecting a, JCSS-2-12 adding planning links from, JCSS-3-26
image, JCSS-2-12 deploy IERs using, JCSS-4-1
add, JCSS-2-12 link devices via, JCSS-3-17
MIF, JCSS-2-13 objectpalette
add, JCSS-2-13 add external connectivity links from, JCSS-3-27
menu, JCSS-2-13 objects
measures of performance (MOP) cutting, copying, and pasting, JCSS-3-12
viewing, JCSS-7-1 online documentation
MIF map, add a, JCSS-2-13 defined, JCSS-A-1
MIF maps, JCSS-2-13 open node model in Modeler, JCSS-3-16
MIF menu, JCSS-2-13 opening node models in Modeler, JCSS-3-16
mod_dirs OPFAC
defined, JCSS-A-1 adding devices to, JCSS-3-10 to JCSS-3-11
model device
node add to, JCSS-3-11
open in Modeler, JCSS-3-16 OPFAC attributes, JCSS-3-3
opening in Modeler, JCSS-3-16 OPEACs
models defined, JCSS-A-2
custom optimization
creating with Device Creator, JCSS-3-15 compare results, JCSS-5-8
modifying units, JCSS-3-2 optimization results
MOP compare, JCSS-5-8
viewing, JCSS-7-1 managing, JCSS-5-8
MOP graph optimization settings
display, JCSS-7-1 save, JCSS-5-7
interacting with, JCSS-7-2 saving, JCSS-5-7
view properties optimizing a network, JCSS-5-3
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organization attributes, JCSS-3-2 viewing, JCSS-6-8
organizations reports
defined, JCSS-A-2 DoDAF
generating in Visio, JCSS-4-29
P web
paste an object, JCSS-3-14 display, JCSS-5-6
perform a network capacity optimization, JCSS-5-3 displaying, JCSS-5-6
perform a network evaluation, JCSS-5-1 requirements matrix
planning links reviewing, JCSS-3-34
defined, JCSS-A-2 requirements matrix information
defining, JCSS-3-26 provide, JCSS-3-35
planning links vs. connectivity links, JCSS-3-27 resuts
process registry optimization
defined, JCSS-A-2 managing, JCSS-5-8
profile results analysis, JCSS-7-1
terrain reviewing the requirements matrix, JCSS-3-34
view, JCSS-3-42 routing protocol visualization
project run a, JCSS-3-41
creating run routing protocol visualization, JCSS-3-41
importing from device configurations, JCSS-2-7 running a simulation, JCSS-6-3
creating a
set area of operations dialog box, JCSS-2-9 S
creating a new sample workflows, JCSS-1-2
importing analyst's workflow, JCSS-1-4
from VNE Server crisis action planner's workflow, JCSS-1-2
import modes, JCSS-2-8 operational planner's workflow, JCSS-1-3
top level unit dialog box, JCSS-2-9 satellite link
creating new, JCSS-2-5 deploy, JCSS-3-20
new save as
select equipment types dialog box, JCSS-2-7 link type, JCSS-3-26
projects save as link type, JCSS-3-26
defined, JCSS-A-2 save optimization settings, JCSS-5-7
Promina devices saving optimization settings, JCSS-5-7
configuring scenario
configure Promina devices, JCSS-3-32 creating new, JCSS-3-36
protocol configuration duplicating a, JCSS-3-36
visualizing, JCSS-3-41 logical view
protocols selection dialog box, JCSS-2-17
configuring, JCSS-3-39 viewing
menu items, JCSS-3-39 zoom
protocols menu items , JCSS-3-39 to all, JCSS-2-15
provide requirements matrix information, JCSS-3-35 to rectangle, JCSS-2-14
to selection, JCSS-2-14
R zooming in, JCSS-2-14
record |ER routes, JCSS-4-6 zooming out, JCSS-2-15
redo editing operations, JCSS-3-14 zooming/unzooming, JCSS-2-14
relationship scen;ar;oc célasszlf;%atlon
set, -2-
. elc;rt?:r:zhailb;lCSS-4-1 9 settir?g the, JCSS-2-10
. scenarios
re;;ftat'ng’ JOSS-4-19 defined, JCSS-A-2
IER defining ajgistits)nal, JCSS-3-35
manage, -3-37
w ee; port, JCSS-4-10 switch between, JCSS-3-37
generate, JCSS-6-8 viewing, JCSS-2-16
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scnearios view, JCSS-3-42
viewing thread
selecting settings for logical view of, JCSS-2-16 create
server characterization editor create a thread, JCSS-4-11
defined, JCSS-A-2 threads
set area of interest, JCSS-2-11 create
set IER color thresholds, JCSS-4-9 using DoDAF Editor, JCSS-4-27
set scenario classification, JCSS-2-10 creating, JCSS-4-11
setting area of interest, JCSS-2-11 from ACE Analyst, JCSS-4-14
setting scenario classification, JCSS-2-10 edit, JCSS-4-14
setting the scenario classification, JCSS-2-10 top statistics
shortcut menu find, JCSS-7-3
add units from, JCSS-3-2 finding, JCSS-7-3
simulation topology
running a, JCSS-6-3 building, JCSS-3-1
simulation execution, JCSS-6-1 deploy
simulation log file broadcast networks, JCSS-3-29
viewing the, JCSS-6-6 import
solutions from device configurations, JCSS-2-7
examine top, JCSS-5-10 initial topology dialog box, JCSS-2-6
examining top, JCSS-5-10 topology building, JCSS-3-1
specify advanced statistics for collection during simulation, traffic
JCSS-6-2 deploy
specify alternate link capacities, JCSS-5-4 using traffic wizard, JCSS-4-20
specify statistics for collection during simulation, JCSS-6-1 specification, JCSS-4-1
specifying alternate link capacities, JCSS-5-4 traffic specification, JCSS-4-1
standard applications traffic wizard
create and deploy from DoDAF Editor, JCSS-4-24 deploying traffic using, JCSS-4-20
statistics
advanced U
spemfylng. for collection during simulation, JCSS-6-2 undo editing operations, JCSS-3-14
device and link unit
_ choosing, JCSS-6-1 drill down into, JCSS-3-10
find top, JCSS-7-3 units
flndlr?g 'top, JCSS-7-? o . adding, JCSS-3-1
s'pecn‘ylng for coIIectllon during simulation, JCSS-6-1 drilling down into, JCSS-3-10
switch betwgen scenarios, JCSS-3-37 modifying, JCSS-3-2
system architecture, JCSS-1-7 user level
system editor window, JCSS-2-1 selecting
select the user level, JCSS-2-3
T selecting the, JCSS-2-3
task assistant user profile
open a workflow using, JCSS-2-4 adding new, JCSS-2-2
task selection dialog box, JCSS-2-4 create new, JCSS-2-2
using the, JCSS-2-3 creating, JCSS-2-2
technical support log files, JCSS-8-1 using object palette
template OPFAC deploy IERs using object palette, JCSS-4-1
creating, JCSS-3-9 using the task assistant, JCSS-2-3
template organization utility nodes
creating, JCSS-3-9 configuring, JCSS-3-32
terrain effect shading
display, JCSS-3-47 \Vj
terrgln effects shading verify a link, JCSS-3-25
dlgplaylng, JC88-3-47 verifying device connectivity, JCSS-3-25
terrain profile verifying link consistency, JCSS-3-32
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view

recorded IER routes, JCSS-6-9
view a terrain profile, JCSS-3-42
view IERs, JCSS-4-9
viewing

recorded IER routes, JCSS-6-9

simulation log file, JCSS-6-6

web reports, JCSS-6-8
viewing measures of performance (MOP), JCSS-7-1
viewing scenarios, JCSS-2-16
views

DoDAF

integrating, JCSS-4-21

Visio

generating DoDAF reports in, JCSS-4-29

reports

generating, JCSS-4-30

Visio reports

generating, JCSS-4-30
visualization

protocol configuration, JCSS-3-41

routing protocol

run, JCSS-3-41
visualizing protocol configuration, JCSS-3-41
VNE Server
import from, JCSS-3-48
importing from, JCSS-3-48

w
web report
generate, JCSS-6-8
web reports
display, JCSS-5-6
displaying, JCSS-5-6
viewing, JCSS-6-8

workflow panel, following sequential tasks in, JCSS-2-5

Z

zoom to all, JCSS-2-15

zoom to rectangle, JCSS-2-14
zoom to selection, JCSS-2-14
zooming in, JCSS-2-14

zooming out, JCSS-2-15
zooming/unzooming, JCSS-2-14
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