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Test Purpose/Scope: This Kernel Overview test provides a high level test of the full range of fundamental Kernel Platform functionality.  Each of the other Kernel Platform Compliance (KPC) tests provides a deeper (i.e. more thorough) test of a specific narrower range of Kernel Platform function.

This test also assures that the Graphical User Interface (GUI) presented to the user for basic system operation is consistent across all compliant POSIX-based DII COE platforms.  This test assures that the operations invoked and exercised have identical results that are consistent across all compliant Posix-based Defense Information Infrastructure (DII) Common Operating Environment (COE) platforms.

Description: This test procedure exercises the following basic icon functions:

A. sysadmin login - Verify sysadmin login, Profile Selector, Change Password Tool, command line accessibility, and icon accessibility

B. Adm Tool - Invokes the native operating system's administration tool. On Solaris, the Adm Tool icon invokes the Solaris admintool application. 

C. Change Machine ID (with DNS) - Allows the System Administrator to change the machine name or Internet Protocol (IP) address of the workstation.

D. Create Action - Allows the System Administrator to create a desktop action.

E. Dtterm - Opens a dtterm terminal window for the System Administrator to perform tasks that require the use of a command line.

F. Disk Manager - Allows the System Administrator to perform file system management tasks, including mounting and exporting file system partitions, formatting hard drives and hard drive partitions, displaying available hard disk space, and initializing diskettes.

G. Edit Local Hosts - Allows the System Administrator to manage the local host table, which lists the computers that can be accessed from the local workstation.

H. Network Installation Server and Segment Installer - Allows the System Administrator to load software segments onto a machine and make them available for other computers to install. Allows the System Administrator to install and/or remove software segments on the local workstation.

I. Set Routes - Allows the System Administrator to configure the workstation to connect to the wide area network through a default router.

J. Set System Time - Allows the System Administrator to set or change the value of the system time.

K. Text Editor - Invokes a text editor application.

L. Xterm - Opens an xterm terminal window for the System Administrator to perform tasks which require the use of a command line.

M. Reboot System - Allows the System Administrator to reboot the machine.

N. Shutdown System - Allows the System Administrator to prepare the machine for powering down.

O. secman login - Verify secman login, Profile Selector, Change Password Tool, command line accessibility, and icon accessibility

P. APM Client - Invokes the Account and Profile Manager client application. The APM Client administers user accounts, groups, profiles, and hosts.

Q. APM Server Reload - Shuts down and restarts the APM local server process

R. APM Server Stop - Shuts down the APM local server process.

S. APM Server Start - Restarts the APM local server process if it has been shut down by the Security Administrator. The APM local server communicates with the APM client and the APM master server to perform administrative operations.

T. Assign Passwords - Allows the Security Administrator to assign passwords to user accounts. This operation requires root access to the system.

U. Audit Log File Manager - Allows the Security Administrator to manage the audit log files, which record user login and logout information.

V. Edit APM Configuration - Invokes a graphical tool which allows the Security Administrator to edit the APM configuration settings.

W. Merge Host - Copies and synchronizes APM account and profile information from an APM host server to the APM master server. This operation adds an APM host to the APM administrative domain.

X. Profile Selector Configuration - Configures settings for the Profile Selector application.

Y. Remove Host - Removes a merged host from the APM administrative domain.

Z. Logout.
Overall Test Result:  The overall PASS/FAIL result for this test is determined as follows:  The overall test result is "PASS" if and only if all steps marked as PASS/FAIL steps in the Observed Result column, have a test step "PASS" result.

Test Step Results:  For each step with a "Circle One:  PASS/FAIL" in the Observed Result column, the tester compares the directly observed Candidate Platform behavior with the "PASS" criteria.  Unless other PASS criteria are noted in the test step, the test step result is "PASS" if and only if the Candidate Platform presents all of the behaviors and conditions described in the Expected Result column for that test step.  The test step result is "FAIL" if the Candidate Platform fails to satisfy any of the PASS criteria.

If the test step result is "PASS", the tester will circle "PASS" and note the actual behaviors and conditions presented in the Observed Result column.  If the observed result precisely matches the expected result, the Observed Result column for the step may contain the statement "as expected.”

If the test step result is "FAIL", the tester will circle "FAIL" in the Observed Result column and note the actual behaviors and conditions presented in the Observed Result column.  Additional documentation detailing the reasons for the test step failure is included in the Validation Test Report.

Note 1:  Due to the complexity of any Candidate Platform, it is impossible to completely specify all aspects of their operation in the space provided.  Many of the expected Candidate Platform behaviors for any test step are implicitly assumed based on industry practice, commercial testing or prior testing, and may not be explicitly described in the Expected Result column.  DISA reserves the right to consider implicit as well as explicit PASS/FAIL criteria which could adversely affect the ability of the Candidate Platform to satisfy DoD mission requirements when used as a component of the DII.

If implicit PASS/FAIL criteria are involved in a "FAIL" determination, the tester will circle "FAIL" in the Observed Result column and note the objectionable behavior in the Observed Result column at the point of observation during the test.  Additional documentation detailing the full rationale for the "FAIL" determination is to be included in the Validation Test Report.

Note 2:  Test steps which are "grayed out" (i.e., the entire table row is set to a gray background) are to be considered as waived by DISA for this test version only.  Grayed out test steps are not to be executed nor is observed behavior to be recorded.  These test steps may be returned to the overall test at a future date and are retained for information purposes only.  PASS/FAIL criteria identified in these test steps will not be used in the determination of the overall test result.

Note 3:  Lower case “s” in brackets [s] denotes a blank space; lower case “r” in brackets [r] denotes a carriage return; lower case “s” and “r” together in brackets [s] [r] denotes a blank space and carriage return.

Test Data/Media Required:  The following segments are required to execute this test:

1. OnlineDocs Segment Version 4.1.0.0.

Setup/Equipment Required:  This test requires a Validation Host and Candidate Platform configured as specified in the current version of the DII COE Setup Procedures for Kernel Platform Compliance (KPC) Validation Cell for Kernel V4.2.0.0P4 (Solaris 8) document.

Required Personnel:  One (1) tester.  The tester must be familiar with POSIX/UNIX application platforms, but need not be familiar with the Defense Information Infrastructure (DII) Common Operating Environment (COE).

Change History:

30 May 2001
Step P.1.8 - Added note in Operator Action - “Note:  If kpccp does not appear in the Assigned Hosts panel, double-click kpccp in the Available Hosts panel, which moves it to the Assigned Hosts panel.”
Step W.3.22 - Added note in Expected Result - “Note: SA Default may not be listed; if not, skip to step W.3.25.”  This change is related to a conflict in the APM merge host function (See APM Local Client or Master Validation Procedures, step C.1.6).  This conflict is resolved by running Kernel Overview before running other validation procedures.

End of Preamble

Start of Validation Procedure

	
	Operator Action
	Expected Result
	Observed Result

	A
	Verify sysadmin Login, Profile Selector, Change Password Tool, Command Line Accessibility, and Icon Accessibility

	A.1
	Verify sysadmin Login
	

	A.1.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Verify that the DII COE Login screen appears.
	The DII COE Login screen appears with the DoD security warning message and the Please enter your user name text box.
	Circle one:  PASS / FAIL



	A.1.2
	Log in as the System Administrator by typing sysadmin in the Please enter your user name text box and pressing ENTER.
	The password screen appears with the Please enter your password text box.
	Circle one:  PASS / FAIL



	A.1.3
	Type the password for the sysadmin account in the Please enter your password text box and press ENTER. 
	An INFORMATIONAL MESSAGE dialog box appears confirming COE login processing is complete.
	Circle one:  PASS / FAIL



	A.1.4
	Click OK in the INFORMATIONAL MESSAGE dialog box.
	The dialog box disappears.
	Circle one:  PASS / FAIL



	A.2
	Verify sysadmin Profile Selector Functionality
	

	A.2.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

On the CDE, click Profile Selector (the head with a question mark).
	The Profile Selector window appears with SA Default listed in the Selected Profiles panel.
	Circle one:  PASS / FAIL



	A.2.2
	Click Cancel.
	The Profile Selector window disappears.
	Circle one:  PASS / FAIL



	A.3
	Verify sysadmin Change Password Tool Functionality
	

	A.3.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

On the CDE, access the Change Password Tool by clicking the arrow above the Profile Selector icon. 
	The DII Tools menu appears.
	Circle one:  PASS / FAIL



	A.3.2
	Select Change Password Tool. 
	The Change your password window appears.
	Circle one:  PASS / FAIL



	A.3.3
	Enter an incorrect sysadmin password in the Old Password text box.
	Asterisks appear in the text box.
	Circle one:  PASS / FAIL



	A.3.4
	Enter a new password in the New Password and Password Confirm Text boxes.
	Asterisks appear in the text boxes.
	Circle one:  PASS / FAIL



	A.3.5
	Click Submit.
	A Status Summary dialog box appears indicating the validation by sysadmin failed.
	Circle one:  PASS / FAIL



	A.3.6
	Click OK.
	The Status Summary dialog box disappears.
	Circle one:  PASS / FAIL



	A.3.7
	On the CDE, access the Change Password Tool by clicking the arrow above the Profile Selector icon.
	The DII Tools menu appears.
	Circle one:  PASS / FAIL



	A.3.8
	Select Change Password Tool. 
	The Change your password window appears.
	Circle one:  PASS / FAIL



	A.3.9
	Enter the correct sysadmin password in the Old Password text box.
	Asterisks appear in the text box.
	Circle one:  PASS / FAIL



	A.3.10
	Enter a new password in the New Password and Password Confirm text boxes.

NOTE: This password change cannot be undone. All test personnel should be informed of the new password.
	Asterisks appear in the text boxes.
	Circle one:  PASS / FAIL



	A.3.11
	Click Submit.
	A Status Summary dialog box appears indicating successful password changes.
	Circle one:  PASS / FAIL



	A.3.12
	Click OK.
	The Status Summary dialog box disappears.
	Circle one:  PASS / FAIL



	A.3.13
	On the CDE, click Exit.
	A Logout Confirmation dialog box appears.
	Circle one:  PASS / FAIL



	A.3.14
	Click OK.
	The dialog box disappears and the DII COE Login screen appears.
	Circle one:  PASS / FAIL



	A.3.15
	Login as sysadmin using the new password.
	The desktop appears.
	Circle one:  PASS / FAIL



	A.4
	Verify Command Line Access
	

	A.4.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Right-click on the desktop.
	The Workspace Menu appears.
	Circle one:  PASS / FAIL



	A.4.2
	Select Tools > Terminal.

NOTE: This method is OS specific. Use the relevant method on the OS being tested and note it in the Observed Result column.

NOTE: This method should be used in all following test steps for the operator action “Open a Terminal window”.
	A Terminal window appears with a command line prompt.
	Circle one:  PASS / FAIL



	A.4.3
	At the command prompt type

id
NOTE: This command is OS specific. Use the relevant command on the OS being tested and note it in the Observed Results column.
	The system returns

uid=100(sysadmin) gid=1(other)
NOTE: This result is OS specific. The result should indicate the user is sysadmin.
	Circle one:  PASS / FAIL



	A.4.4
	At the command prompt type

pwd 

NOTE: This command is OS specific. Use the relevant command on the OS being tested and note it in the Observed Results column.
	The system returns

/h/USERS/local/sysadmin/Scripts 

NOTE: This result is OS specific. The result should indicate the above path.
	Circle one:  PASS / FAIL



	A.4.5
	At the command prompt type

exit
	The Terminal window disappears.
	Circle one:  PASS / FAIL



	A.5
	Verify Icon Access
	

	A.5.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Right-click on the desktop.

NOTE: This method is OS specific. Use the relevant method on the OS being tested and note it in the Observed Results column.
	The Workspace Menu appears.
	Circle one:  PASS / FAIL



	A.5.2
	Select Applications > Application Manager. 
NOTE: This method is OS specific. Use the relevant method on the OS being tested and note it in the Observed Results column.
	The Application Manager window appears.
	Circle one:  PASS / FAIL



	A.5.3
	Double-click DII_APPS.
	The Application Manager – DII_APPS window appears.
	Circle one:  PASS / FAIL



	A.5.4
	Double-click SysAdm.
	The Application Manager – SysAdm window appears with the following icons: ..(go up), Adm Tool, Change Machine ID, Create Action, DTterm, Disk Manager, Edit Local Hosts, Network Installation Server, Reboot System, Segment Installer, Set DNS, Set Routes, Set System Time, Shutdown System, Text Edit, XTerm.
	Circle one:  PASS / FAIL



	B
	Verify Adm Tool Functionality

	B.1
	Open the Adm Tool
	

	B.1.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Double-click Adm Tool.
	The Admintool:Users window appears. 

NOTE: This result is OS specific. The native operating system’s administration tool should be launched.
	Circle one:  PASS / FAIL



	B.1.2
	Select File > Exit.
	The Admintool:Users window disappears.
	Circle one:  PASS / FAIL



	C
	Change Machine ID Functionality 

	C.1
	Change the Machine  Name and IP Address Of the Workstation
	

	C.1.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Double-click Change Machine ID in the Application Manager – SysAdm window.
	The Change Machine Id window appears.
	Circle one:  PASS / FAIL



	C.1.2
	In the New Machine Name text box, enter

nohost

NOTE: If the /etc/resolv.conf file is installed on the system, the Change Machine ID tool checks the system's host name against the information in the Domain Name Service (DNS). If the System Administrator attempts to use the Change Machine ID tool to change the host name to one that is not found in the DNS, the machine ID will not be changed.
	nohost appears in the New Machine Name text box.
	Circle one:  PASS / FAIL



	C.1.3
	In the New Machine Address text box enter

10.0.0.1
	10.0.0.1 appears in the New Machine Address text box.
	Circle one:  PASS / FAIL



	C.1.4
	Click OK.
	An Input dialog box appears asking for the master APM authentication key.
	Circle one:  PASS / FAIL



	C.1.5
	Enter the master APM Authentication key.
	Asterisks appear in the text box.
	Circle one:  PASS / FAIL



	C.1.6
	Click OK.
	A Error dialog box appears with the message:

Could not change host ID!

Unable to verify hostname and ip address with DNS.
	Circle one:  PASS / FAIL



	C.1.7
	Click OK.
	The Error dialog box disappears.
	Circle one:  PASS / FAIL



	C.1.8
	In the New Machine Name text box enter

kpctest
	kpctest appears in the New Machine Name text box.
	Circle one:  PASS / FAIL



	C.1.9
	In the New Machine Address text box enter

204.34.175.193
	204.34.175.193 appears in the New Machine Address text box.
	Circle one:  PASS / FAIL



	C.1.10
	Click OK.
	An Input dialog box appears asking for the master APM authentication key.
	Circle one:  PASS / FAIL



	C.1.11
	Enter the master APM Authentication key.
	Asterisks appear in the text box.
	Circle one:  PASS / FAIL



	C.1.12
	Click OK.
	A Success dialog box appears with the message:

Operation completed successfully.

Reboot the system now?
	Circle one:  PASS / FAIL



	C.1.13
	Click Yes.
	The workstation reboots and the DII COE Login screen appears.
	Circle one:  PASS / FAIL



	C.2
	Verify ID Change
	

	C.2.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Login as sysadmin.
	The desktop appears.
	Circle one:  PASS / FAIL



	C.2.2
	Open a Terminal window.
	A Terminal window appears with a command line prompt.
	Circle one:  PASS / FAIL



	C.2.3
	At the command prompt type

cat /etc/hosts
	The contents of the /hosts file appear.
	Circle one:  PASS / FAIL



	C.2.4
	Verify that the following line appears in the listing:

204.34.175.193 kpctest loghost 
	A line containing the specified information is present. 

The additional text “kpccp.kpc.disa.mil” may also be present.

NOTE: Change Machine ID does not change aliases (i.e. kpccp.kpc.disa.mil).
	Circle one:  PASS / FAIL



	C.3
	Restore the Machine Name and IP Address Of the Workstation
	

	C.3.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Click Profile Selector.
	The Profile Selector window appears with SA Default listed in the Available Profiles panel.
	Circle one:  PASS / FAIL



	C.3.2
	Double-click SA Default.
	Profile SA Default moves to the Selected Profiles panel.
	Circle one:  PASS / FAIL



	C.3.3
	Click OK.
	The Profile Selector Results window appears indicating that SA Default has been successfully assumed.
	Circle one:  PASS / FAIL



	C.3.4
	Click Done.
	The Profile Selector Results window and Profile Selector window disappear.
	Circle one:  PASS / FAIL



	C.3.5
	Select Applications > Application Manager > DII_APPS > SysAdm.
	The Application Manager – SysAdm window appears.
	Circle one:  PASS / FAIL

	C.3.6
	Double-click Change Machine ID.
	The Change Machine Id window appears.
	Circle one:  PASS / FAIL



	C.3.7
	In the New Machine Name text box, enter

kpccp
	kpccp appears in the New Machine Name text box.
	Circle one:  PASS / FAIL



	C.3.8
	In the New Machine Address text box enter

204.34.175.195
	204.34.175.195 appears in the New Machine Address text box.
	Circle one:  PASS / FAIL



	C.3.9
	Click OK.
	An Input dialog box appears asking for the Master APM authentication key.
	Circle one:  PASS / FAIL



	C.3.10
	Enter the Master APM Authentication key.
	Asterisks appear in the text box.
	Circle one:  PASS / FAIL



	C.3.11
	Click OK.
	A Success dialog box appears with the message:

Operation completed successfully.

Reboot the system now?
	Circle one:  PASS / FAIL



	C.3.12
	Click Yes.
	The workstation reboots and the DII COE Login screen appears.
	Circle one:  PASS / FAIL



	D
	Create Action

	D.1
	Create A Desktop Action
	

	D.1.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Login as sysadmin.
	The desktop appears.
	Circle one:  PASS / FAIL



	D.1.2
	Select Applications > Application Manager > DII_APPS > SysAdm.
	The Application Manager – SysAdm window appears.
	Circle one:  PASS / FAIL



	D.1.3
	Double-click Create Action.
	The Create Action window appears.
	Circle one:  PASS / FAIL



	D.1.4
	In the Action Name (Icon Label) text box, enter Test Action.
	Test Action appears in the Action Name (Icon Label) text box.
	Circle one:  PASS / FAIL



	D.1.5
	In the Command When Action Is Opened (Double-clicked) text box, enter

/usr/openwin/bin/clock
NOTE: This method is OS specific. Use the relevant method on the OS being tested and note it in the Observed Results column.
	/usr/openwin/bin/clock appears in the Command When Action Is Opened (Double-clicked) text box.
	Circle one:  PASS / FAIL



	D.1.6
	Select File > Save.
	A Create Action – Confirmation dialog box appears with the message:

The new action Test Action has been placed in your home folder.
	Circle one:  PASS / FAIL



	D.1.7
	Click OK.
	The Create Action – Confirmation dialog box disappears.
	Circle one:  PASS / FAIL



	D.2
	Verify the New Desktop Action
	

	D.2.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Right-click on the desktop.

NOTE: This method is OS specific. Use the relevant method on the OS being tested and note it in the Observed Results column.
	The Workspace Menu appears.
	Circle one:  PASS / FAIL



	D.2.2
	Select Folders > File Manager - Home.
NOTE: This method is OS specific. Use the relevant method on the OS being tested and note it in the Observed Results column.
	A File Manager - Scripts window appears.
	Circle one:  PASS / FAIL



	D.2.3
	Verify that an icon named Test Action is present in the File Manager – Scripts window.
	The Test Action icon is present.
	Circle one:  PASS / FAIL



	D.2.4
	Double-click Test Action.
	A clock window appears on the screen.
	Circle one:  PASS / FAIL



	D.3
	Remove the New Desktop Action
	

	D.3.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Right-click Test Action.
	A drop-down menu appears.
	Circle one:  PASS / FAIL



	D.3.2
	Select Put in Trash.
	The Test Action icon disappears.
	Circle one:  PASS / FAIL



	D.3.3
	Select File > Close in the File Manager – Scripts window.
	The File Manager - Scripts window disappears.
	Circle one:  PASS / FAIL



	D.3.4
	Select File > Exit in the Create Action window.
	The Create Action window disappears.
	Circle one:  PASS / FAIL



	D.3.5
	Close the clock window.
	The clock window disappears.
	Circle one:  PASS / FAIL



	E
	DTterm

	E.1
	Setup
	

	E.1.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Double-click DTterm in the Application Manager – SysAdm window.
	A Terminal window appears with a login prompt.
	Circle one:  PASS / FAIL



	E.1.2
	At the login prompt type

sysadmin
	A Password prompt appears.
	Circle one:  PASS / FAIL



	E.1.3
	At the Password prompt type the sysadmin password.
	A warning message is displayed and then the command prompt appears.
	Circle one:  PASS / FAIL



	E.1.4
	At the command prompt type

id
NOTE: This command is OS specific. Use the relevant command on the OS being tested and note it in the Observed Results column.
	The system returns

uid=100(sysadmin) gid=1(other)
NOTE: This result is OS specific. The result should indicate the user is sysadmin.
	Circle one:  PASS / FAIL



	E.1.5
	At the command prompt type

pwd
NOTE: This command is OS specific. Use the relevant command on the OS being tested and note it in the Observed Result column.
	The system returns

/h/USERS/local/sysadmin/Scripts 

NOTE: This result is OS specific. The result should indicate the above path.
	Circle one:  PASS / FAIL



	E.1.6
	At the command prompt type

exit
	The Terminal window disappears.
	Circle one:  PASS / FAIL



	F
	Disk Manager

	F.1
	Verify That the Candidate Platform Can Share (Export) A Directory
	

	F.1.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Open a Terminal window.
	A Terminal window appears with a command line prompt.
	Circle one:  PASS / FAIL



	F.1.2
	At the command prompt type 

su -
	The Password prompt appears.
	Circle one:  PASS / FAIL



	F.1.3
	At the Password prompt type the root password.
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.1.4
	At the command prompt type

csh
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.1.5
	At the command prompt type

mkdir /kpchost.home2
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.1.6
	At the command prompt type

cd /home2
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.1.7
	At the command prompt type

echo > kpccp
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.1.8
	NOTE: Perform the following steps on the Validation Host (kpchost). 

Login as sysadmin.
	The desktop appears.
	Circle one:  PASS / FAIL



	F.1.9
	Open a Terminal window.
	A Terminal window appears with a command line prompt.
	Circle one:  PASS / FAIL



	F.1.10
	At the command prompt type 

su -
	The Password prompt appears.
	Circle one:  PASS / FAIL



	F.1.11
	At the Password prompt type the root password.
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.1.12
	At the command prompt type

csh
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.1.13
	At the command prompt type

mkdir /kpccp.home2
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.1.14
	At the command prompt type

cd /home2
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.1.15
	At the command prompt type

echo > kpchost
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.2
	Share and Mount Candidate Platform’s /home2
	

	F.2.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Double-click Disk Manager in the Application Manager – SysAdm window.
	The Disk Manager window appears.
	Circle one:  PASS / FAIL



	F.2.2
	Select the row containing /home2 in the Mounted On column.
	The row is highlighted.
	Circle one:  PASS / FAIL



	F.2.3
	Click Export FS.
	The Export/Unexport File Systems dialog box appears.
	Circle one:  PASS / FAIL



	F.2.4
	In the options text box enter 

rw=kpchost.kpc.disa.mil
	rw=kpchost.kpc.disa.mil appears in the text box.
	Circle one:  PASS / FAIL



	F.2.5
	Click Export.
	A Confirmation dialog box appears asking if the directory should be exported permanently. 
	Circle one:  PASS / FAIL



	F.2.6
	Click Yes.
	The dialog boxes disappear.
	Circle one:  PASS / FAIL



	F.2.7
	NOTE: Perform the following steps on the Validation Host (kpchost).

Select Applications > Application Manager > DII_APPS > SysAdm.
	The Application Manager – SysAdm window appears.
	Circle one:  PASS / FAIL



	F.2.8
	Double-click Disk Manager.
	The Disk Manager window appears.
	Circle one:  PASS / FAIL



	F.2.9
	Click Mount New.
	The Mount File System dialog box appears.
	Circle one:  PASS / FAIL



	F.2.10
	In the FILE SYSTEM text box enter

kpccp:/home2
	kpccp:/home2 appears in the text box.
	Circle one:  PASS / FAIL



	F.2.11
	In the MOUNT POINT text box enter

/kpccp.home2
	/kpccp.home2 appears in the text box.
	Circle one:  PASS / FAIL



	F.2.12
	Click MOUNT.
	A Confirmation dialog box appears asking if the directory should be mounted permanently. 
	Circle one:  PASS / FAIL



	F.2.13
	Click Yes.
	The dialog boxes disappear and a row for kpccp:/home2 appears in the Disk Manager window.
	Circle one:  PASS / FAIL



	F.2.14
	At the command prompt in the Terminal window, type

cd /kpccp.home2
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.2.15
	At the command prompt type

ls
	The file kpccp appears in the listing.
	Circle one:  PASS / FAIL



	F.2.16
	At the command prompt type 

cd /
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.2.17
	In the Disk Manager window, select the row containing /kpccp.home2 in the Mounted On column.
	The row is highlighted.
	Circle one:  PASS / FAIL



	F.2.18
	Click Unmount.
	A Confirmation dialog box appears asking if the directory should be unmounted permanently.
	Circle one:  PASS / FAIL



	F.2.19
	Click Yes.
	The dialog box disappears and the row for /kpccp.home2 disappears from the Disk Manager window.
	Circle one:  PASS / FAIL



	F.2.20
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

In the Disk Manager window, select the row containing /home2 in the Mounted On column.
	The row is highlighted.
	Circle one:  PASS / FAIL



	F.2.21
	Click Export FS.
	The Export/Unexport File Systems dialog box appears.
	Circle one:  PASS / FAIL



	F.2.22
	Click Unexport.
	A dialog box appears asking if the directory should be unexported permanently.
	Circle one:  PASS / FAIL



	F.2.23
	Click Yes.
	The dialog boxes disappear.
	Circle one:  PASS / FAIL



	F.3
	Share and Mount Validation Host’s /home2
	

	F.3.1
	NOTE: Perform the following steps on the Validation Host (kpchost).

In the Disk Manager window, select the row containing /home2 in the Mounted On column.
	The row is highlighted.
	Circle one:  PASS / FAIL



	F.3.2
	Click Export FS.
	The Export/Unexport File Systems dialog box appears.
	Circle one:  PASS / FAIL



	F.3.3
	In the options text box, enter 

rw=kpccp.kpc.disa.mil
	rw=kpccp.kpc.disa.mil appears in the text box.
	Circle one:  PASS / FAIL



	F.3.4
	Click Export.
	A Confirmation dialog box appears asking if the directory should be exported permanently. 
	Circle one:  PASS / FAIL



	F.3.5
	Click Yes.
	The dialog boxes disappear.
	Circle one:  PASS / FAIL



	F.3.6
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Click Mount New.
	The Mount File System dialog box appears.
	Circle one:  PASS / FAIL



	F.3.7
	In the FILE SYSTEM text box, enter

kpchost:/home2
	kpchost:/home2 appears in the text box.
	Circle one:  PASS / FAIL



	F.3.8
	In the MOUNT POINT text box enter

/kpchost.home2
	/kpchost.home2 appears in the text box.
	Circle one:  PASS / FAIL



	F.3.9
	Click MOUNT.
	A Confirmation dialog box appears asking if the directory should be mounted permanently. 
	Circle one:  PASS / FAIL



	F.3.10
	Click Yes.
	The dialog boxes disappear and a row for kpchost:/home2 appears in the Disk Manager window.
	Circle one:  PASS / FAIL



	F.3.11
	At the command prompt in the  Terminal window, type

cd /kpchost.home2
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.3.12
	At the command prompt type

ls
	The file kpchost appears in the listing.
	Circle one:  PASS / FAIL



	F.3.13
	At the command prompt type 

cd /
	The command prompt returns.
	Circle one:  PASS / FAIL



	F.3.14
	In the Disk Manager window, select the row containing /kpchost.home2 in the Mounted On column.
	The row is highlighted.
	Circle one:  PASS / FAIL



	F.3.15
	Click Unmount.
	A Confirmation dialog box appears asking if the directory should be unmounted permanently.
	Circle one:  PASS / FAIL



	F.3.16
	Click Yes.
	The dialog box disappears and the row for /kpchost.home2 disappears from the Disk Manager window.
	Circle one:  PASS / FAIL



	F.3.17
	NOTE: Perform the following steps on the Validation Host (kpchost).

In the Disk Manager window, select the row containing /home2 in the Mounted On column.
	The row is highlighted.
	Circle one:  PASS / FAIL



	F.3.18
	Click Export FS.
	The Export/Unexport File Systems dialog box appears.
	Circle one:  PASS / FAIL



	F.3.19
	Click Unexport.
	A dialog box appears asking if the directory should be unexported permanently.
	Circle one:  PASS / FAIL



	F.3.20
	Click Yes.
	The dialog boxes disappear.
	Circle one:  PASS / FAIL



	F.3.21
	Log out of the Validation Host (kpchost).
	The DII COE login screen appears.
	Circle one:  PASS / FAIL



	F.4
	Format and mount disk partition
	

	F.4.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

In the Disk Manager window, highlight the row with /test.
	The row with /test is highlighted.
	Circle one:  PASS / FAIL



	F.4.2
	Click Unmount.
	A Confirmation dialog box appears asking if the directory should be unmounted permanently.
	Circle one:  PASS / FAIL



	F.4.3
	Click Yes.
	The dialog box disappears and the row for /test disappears from the Disk Manager window.
	Circle one:  PASS / FAIL



	F.4.4
	In the Disk Manager window, click New FS.


	The New File System dialog box appears.
	Circle one:  PASS / FAIL



	F.4.5
	In the DISK DEVICE text box, enter

/dev/dsk/c0t0d0s7

NOTE: This step is platform specific. Enter the device name for the partition created but not mounted during Validation Cell setup here and in the following steps.
	/dev/dsk/c0t0d0s7 is displayed.
	Circle one:  PASS / FAIL



	F.4.6
	Click OK.
	A Please wait message box is displayed while the partition is formatted.  The message box disappears and the Disk Manager window reappears.

NOTE: The message box may disappear quickly.
	Circle one:  PASS / FAIL



	F.4.7
	Click Mount New.
	The Mount FILE SYSTEM dialog box displays.
	Circle one:  PASS / FAIL



	F.4.8
	In the FILE SYSTEM text box enter /dev/dsk/c0t0d0s7
	/dev/dsk/c0t0d0s7 appears in the textbox
	Circle one:  PASS / FAIL



	F.4.9
	In the MOUNT POINT text box enter

/home3
	/home3 appears in the text box.
	Circle one:  PASS / FAIL



	F.4.10
	Click Mount.
	The dialog box appears with the following message:
Mount FS Permanently? 
	Circle one:  PASS / FAIL



	F.4.11
	Click Yes.
	/dev/dsk/c0t0d0s7 shows /home3 in Mounted On column.  
	Circle one:  PASS / FAIL



	F.4.12
	Highlight the row with /home3 in the Mounted On column.
	The row with /home3 is highlighted.
	Circle one:  PASS / FAIL



	F.4.13
	Click Unmount.
	A Confirmation dialog box appears asking if the directory should be unmounted permanently.
	Circle one:  PASS / FAIL



	F.4.14
	Click Yes.
	The dialog box disappears and the row for /home3 disappears from the Disk Manager window.
	Circle one:  PASS / FAIL



	F.4.15
	Click Exit in the Disk Manager window.
	The Disk Manager window disappears.
	Circle one:  PASS / FAIL



	G
	Edit Local Hosts

	G.1
	Add A New Host
	

	G.1.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Double-click Edit Local Hosts in the Application Manager – SysAdm window.
	The Edit Hosts window appears.
	Circle one:  PASS / FAIL



	G.1.2
	Click Add.
	The Add Machine window appears.
	Circle one:  PASS / FAIL



	G.1.3
	In the MACHINE NAME text box, enter

newmachine
	newmachine appears in the MACHINE NAME text box.
	Circle one:  PASS / FAIL



	G.1.4
	In the MACHINE ADDRESS text box enter

169.254.0.100
	169.254.0.100 appears in the MACHINE ADDRESS text box.
	Circle one:  PASS / FAIL



	G.1.5
	Click OK.
	The Add Machine window disappears and newmachine shows up in the Edit Hosts window.
	Circle one:  PASS / FAIL



	G.1.6
	At the command prompt in the Terminal window type

cat /etc/hosts
	The contents of the /hosts file are displayed.
	Circle one:  PASS / FAIL



	G.1.7
	Verify that an entry exists for 

169.254.0.100 newmachine
	The line exists.
	Circle one:  PASS / FAIL



	G.2
	Delete A Host
	

	G.2.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Select newmachine in the Edit Hosts window.
	The line containing newmachine is highlighted.
	Circle one:  PASS / FAIL

	G.2.2
	Click Delete.
	A Confirmation Required dialog box appears with the following message

Are you sure you want to remove host 169.254.0.100?
	Circle one:  PASS / FAIL

	G.2.3
	Click Yes.
	The Confirmation Required dialog box disappears and newmachine is removed from the Edit Hosts window.
	Circle one:  PASS / FAIL

	G.2.4
	At the command prompt in the Terminal window type

cat /etc/hosts
	The contents of the hosts file are displayed.
	Circle one:  PASS / FAIL

	G.2.5
	Verify that the entry for 

169.254.0.100 newmachine 

has been removed.
	The line does not exist.
	Circle one:  PASS / FAIL

	G.2.6
	Click Close in the Edit Hosts window.
	The Edit Hosts window disappears.
	Circle one:  PASS / FAIL



	H
	Network Installation Server and Segment Installer

	H.1
	Load Segment To Candidate Platform
	

	H.1.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Insert the OnlineDocs (ONDOC) v 4.1.0.0 tape into the tape drive or, if using the KPC Test Data CD, insert the CD into the cdrom drive.
	The tape/CD is inserted.
	Circle one:  PASS / FAIL

	H.1.2
	Double-click Network Installation Server in the Application Manager – SysAdm window.
	The Segment Installation Server window appears.
	Circle one:  PASS / FAIL

	H.1.3
	If a tape is used, click Read Contents,


or,

if the KPC Test Data CD is used, proceed as follows:

Click Source,

Click CD-ROM,

Double-click “seg” in the Directories column,

Double-click ONDOC.tar in the Files column,
Click Read Contents.
	The Segment Installation Server window disappears while message boxes appear informing that the system is Checking media and that Read Content is in progress.

The Segment Installation Server window reappears with OnlineDocs listed under Select Software To Load.
	Circle one:  PASS / FAIL

	H.1.4
	Select OnlineDocs.
	OnlineDocs is highlighted.
	Circle one:  PASS / FAIL



	H.1.5
	Click Release Notes.
	A RELEASE NOTES window opens with Release Notes text.
	Circle one:  PASS / FAIL



	H.1.6
	Click OK.
	The RELEASE NOTES window disappears.
	Circle one:  PASS / FAIL



	H.1.7
	Click Requires.
	A REQUIRES SEGMENTS window opens listing segments required before installing OnlineDocs.
	Circle one:  PASS / FAIL



	H.1.8
	Click OK.
	The REQUIRES SEGMENTS window disappears.
	Circle one:  PASS / FAIL



	H.1.9
	Click Conflicts.
	An INFORMATIONAL MESSAGE dialog box opens informing that the Conflicts descriptor is not available.
	Circle one:  PASS / FAIL



	H.1.10
	Click OK.
	The dialog box disappears.
	Circle one:  PASS / FAIL



	H.1.11
	In the Available Disks panel select the row containing /home2.
	The row is highlighted.
	Circle one:  PASS / FAIL



	H.1.12
	Click Load.
	An ENTER A PASSWORD dialog box appears. 
	Circle one:  PASS / FAIL



	H.1.13
	Enter the APM Authentication key in the text box.
	Asterisks appear in the text box.
	Circle one:  PASS / FAIL



	H.1.14
	Click OK.
	Control returns to the Segment Installation Server window.

OnlineDocs appears in the list under Segments Currently Loaded on this Network Server.
	Circle one:  PASS / FAIL

	H.1.15
	Select Installed > View Installation Log.
	An Install Log window appears indicating OnlineDocs was successfully loaded on the kpccp Network Server.
	Circle one:  PASS / FAIL



	H.1.16
	Click OK.
	The Install Log window disappears.
	Circle one:  PASS / FAIL



	H.2
	Install the Loaded Segment On the Candidate Platform
	

	H.2.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Double-click Segment Installer in the Application Manager – SysAdm window.
	The  Installer window appears.
	Circle one:  PASS / FAIL

	H.2.2
	Click Select Source.
	The Select Source dialog box appears.
	Circle one:  PASS / FAIL



	H.2.3
	Select LOCAL in the Host panel and NETWORK in the Device panel.
	The LOCAL and NETWORK radio buttons are highlighted.
	Circle one:  PASS / FAIL



	H.2.4
	Click OK.
	The Select Source dialog box disappears.
	Circle one:  PASS / FAIL



	H.2.5
	Click Read Contents.
	The Installer window shows OnlineDocs listed under Select Software To Install.
	Circle one:  PASS / FAIL



	H.2.6
	Select OnlineDocs.
	OnlineDocs is highlighted.
	Circle one:  PASS / FAIL



	H.2.7
	Click Install.
	AN ENTER A PASSWORD dialog box appears.
	Circle one:  PASS / FAIL



	H.2.8
	Enter the APM Authentication key in the text box.
	Asterisks appear in the text box.
	Circle one:  PASS / FAIL



	H.2.9
	Click OK.
	The dialog box disappears. 

The Installer window shows OnlineDocs listed under Currently Installed Segments.
	Circle one:  PASS / FAIL

	H.3
	Verify Installation
	

	H.3.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Select Installed > View Installation Log.
	An Install Log window appears indicating OnlineDocs was successfully installed.
	Circle one:  PASS / FAIL

	H.3.2
	Click OK.
	The Install Log window disappears.
	Circle one:  PASS / FAIL



	H.4
	Test Segment De-installation
	

	H.4.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

In the list under Currently Installed Segments, select OnlineDocs.
	OnlineDocs is highlighted.
	Circle one:  PASS / FAIL

	H.4.2
	Click Deinstall Software.
	A RESPOND TO THE QUESTION dialog box appears to verify that you really want to remove the segment.
	Circle one:  PASS / FAIL

	H.4.3
	Click No.
	The Installer window reappears with OnlineDocs still listed in the Currently Installed Segments panel.
	Circle one:  PASS / FAIL



	H.4.4
	Click Deinstall Software.
	A RESPOND TO THE QUESTION dialog box appears to verify that you really want to remove the segment.
	Circle one:  PASS / FAIL



	H.4.5
	Click Yes.


	The Installer window appears.
	Circle one:  PASS / FAIL

	H.4.6
	Click Exit.
	The Installer window disappears.
	Circle one:  PASS / FAIL



	H.4.7
	In the Segment Installation Server window select OnlineDocs under Segments Currently Loaded on this Network Server.
	OnlineDocs is highlighted.
	Circle one:  PASS / FAIL

	H.4.8
	Click Deinstall Software.


	A RESPOND TO THE QUESTION dialog box appears to verify that you really want to remove the segment.
	Circle one:  PASS / FAIL

	H.4.9
	Click Yes.
	The dialog box disappears and the Segment Installation Server window reappears.
	Circle one:  PASS / FAIL

	H.4.10
	Click Exit.
	The Segment Installation Server window disappears.
	Circle one:  PASS / FAIL



	H.4.11
	Eject the tape or CD.
	The tape or CD ejects.
	Circle one:  PASS / FAIL



	I
	Set Routes

	I.1
	Setup
	

	I.1.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

At the command prompt in the Terminal window, type
netstat -nr
	Network routing information is displayed.
	Circle one:  PASS / FAIL

	I.1.2
	Verify that there is not a line containing default.
	There is no default listed.
	Circle one:  PASS / FAIL



	I.1.3
	Double-click Set Routes in the Application Manager – SysAdm window.
	The Default Router Setup window appears.
	Circle one:  PASS / FAIL



	I.1.4
	In the Default Router IP Address text box, enter

204.34.175.194
	204.34.175.194 appears in the text box.
	Circle one:  PASS / FAIL



	I.1.5
	Click OK.
	A Done dialog box appears informing that the operation completed successfully.  
	Circle one:  PASS / FAIL



	I.1.6
	Click OK.
	The dialog box and the Default Router Setup window disappear.
	Circle one:  PASS / FAIL



	I.1.7
	At the command prompt type

netstat -nr
	Network routing information is displayed.
	Circle one:  PASS / FAIL



	I.1.8
	Verify that a line containing default is listed.
	default is listed with the IP address 204.34.175.194.
	Circle one:  PASS / FAIL



	J
	Set System Time

	J.1
	Setup
	

	J.1.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Right-click on the desktop.

NOTE: This method is OS specific. Use the relevant method on the OS being tested and note it in the Observed Results column.
	The Workspace Menu appears.
	Circle one:  PASS / FAIL

	J.1.2
	Select Applications > OW Clock.

NOTE: This method is OS specific. Use the relevant method on the OS being tested and note it in the Observed Results column.
	A Clock window appears displaying the current local time in the current time zone.
	Circle one:  PASS / FAIL

	J.1.3
	Double-click Set System Time in the Application Manager – SysAdm window.

NOTE: The System Time window displays the local time as if the system time is GMT. Thus, the hour representation will be shifted by the GMT offset from the current local time. In the steps below, time entered into the System Time window will be interpreted, as GMT while the OW Clock display will be system time.

NOTE: The steps below may cause the screen lock to engage. If so, enter the sysadmin password and continue.
	A System Time window appears with a date time group (DTG) in the form ddhhmmZ MON YYYY, where:

dd represents the day of the month.

hh represents the hour (in GMT).

mm represents the minute.

Z is a constant (for Zulu time).

MON represents the three-letter month abbreviation.

YYYY represents the four-digit year.

The time displayed should be the same as the clock display shifted by the GMT offset.
	Circle one:  PASS / FAIL

	J.1.4
	In the Enter DTG text box change the third and fourth digits (hour) to a different value.
	The value appears in the text box.
	Circle one:  PASS / FAIL



	J.1.5
	Click OK.
	A Done dialog box appears indicating that the operation has completed successfully. 
	Circle one:  PASS / FAIL



	J.1.6
	Click OK.
	The dialog box and the System Time window disappear.
	Circle one:  PASS / FAIL



	J.1.7
	Activate the clock window and verify that the clock window displays the new time.
	The clock window displays the new time.
	Circle one:  PASS / FAIL



	J.1.8
	Double-click Set System Time.
	A System Time window appears.
	Circle one:  PASS / FAIL



	J.1.9
	Enter the current local time in the Enter DTG text box.
	The value appears in the text box.
	Circle one:  PASS / FAIL



	J.1.10
	Click OK.
	A Done dialog box appears indicating that the operation has completed successfully.
	Circle one:  PASS / FAIL



	J.1.11
	Click OK.
	The dialog box and the System Time window disappear. 
	Circle one:  PASS / FAIL



	J.1.12
	Activate the clock window and verify that the clock window displays the current time.
	The clock window displays the current time.
	Circle one:  PASS / FAIL



	J.1.13
	Close the clock window.
	The clock window disappears.
	Circle one:  PASS / FAIL



	K
	Text Editor

	K.1
	Use the Text Editor To Create A Test File
	

	K.1.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Double-click Text Edit in the Application Manager – SysAdm window.
	A Text Editor – (UNTITLED) window appears.
	Circle one:  PASS / FAIL

	K.1.2
	In the text window, enter the following text:

This text is test text.
	This text appears in the text window.
	Circle one:  PASS / FAIL



	K.1.3
	Select File > Save.
	A Text Editor - Save As dialog box appears.
	Circle one:  PASS / FAIL



	K.1.4
	Enter TestText in the Enter file name text box.
	TestText appears in the Enter file name text box.
	Circle one:  PASS / FAIL



	K.1.5
	Click OK.
	The Text Editor - Save As dialog box closes.
	Circle one:  PASS / FAIL



	K.2
	Verify Existence Of Test File
	

	K.2.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Right-click on the desktop.

NOTE: This method is OS specific. Use the relevant method on the OS being tested and note it in the Observed Results column.
	The Workspace Menu appears.
	Circle one:  PASS / FAIL

	K.2.2
	Select Folders > File Manager – Home. 

NOTE: This method is OS specific. Use the relevant method on the OS being tested and note it in the Observed Results column.
	A File Manager - Scripts window appears.
	Circle one:  PASS / FAIL

	K.2.3
	Verify that an icon named TestText is present in the File Manager – Scripts window.
	The TestText icon is present.
	Circle one:  PASS / FAIL



	K.2.4
	Double-click TestText.
	A Text Editor – Test Text window appears displaying the text:

This text is test text.
	Circle one:  PASS / FAIL



	K.3
	Delete the Test File
	

	K.3.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

In the File Manager - Scripts window, right-click TestText and select Put in Trash.

NOTE: This method is OS specific. Use the relevant method on the OS being tested and note it in the Observed Results column.
	The Test Text icon disappears.
	Circle one:  PASS / FAIL

	K.3.2
	Close the File Manager - Scripts, and both Text Editor - TestText windows.
	The File Manager - Scripts, and both Text Editor - TestText windows disappear.
	Circle one:  PASS / FAIL



	L
	XTerm

	L.1
	Setup
	

	L.1.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Double-click XTerm in the Application Manager – SysAdm window.
	A login window appears.
	Circle one:  PASS / FAIL

	L.1.2
	At the login prompt type

sysadmin
	A Password prompt appears.
	Circle one:  PASS / FAIL



	L.1.3
	At the Password prompt type the sysadmin password.
	The DoD Security Banner is displayed and then the command prompt appears.
	Circle one:  PASS / FAIL



	L.1.4
	At the command prompt type

id
NOTE: This command is OS specific. Use the relevant command on the OS being tested and note it in the Observed Results column.
	The system returns

uid=100(sysadmin) gid=1(other)
NOTE: This result is OS specific. The result should indicate the user is sysadmin.
	Circle one:  PASS / FAIL

	L.1.5
	At the command prompt type

pwd 

NOTE: This command is OS specific. Use the relevant command on the OS being tested and note it in the Observed Results column.
	The system returns

/h/USERS/local/sysadmin/Scripts 

NOTE: This result is OS specific. The result should indicate the above path.
	Circle one:  PASS / FAIL

	L.1.6
	At the command prompt type

exit
	The login window disappears.
	Circle one:  PASS / FAIL



	M
	Reboot System

	M.1
	Verify System Can Be Rebooted
	

	M.1.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Double-click Reboot System in the Application Manager – SysAdm window.
	A Reboot dialog box appears with the question:

Reboot machine?
	Circle one:  PASS / FAIL

	M.1.2
	Click No.
	The dialog box disappears.
	Circle one:  PASS / FAIL



	M.1.3
	Double-click Reboot System in the Application Manager – SysAdm window.
	A Reboot dialog box appears with the question:

Reboot machine?
	Circle one:  PASS / FAIL



	M.1.4
	Click Yes.
	The workstation reboots and the DII COE Login screen appears.
	Circle one:  PASS / FAIL



	N
	Shutdown System

	N.1
	Verify the System Shuts Down
	

	N.1.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Log in as sysadmin.
	The desktop appears.
	Circle one:  PASS / FAIL

	N.1.2
	Select Applications > Application Manager > DII_APPS > SysAdm.
	The Application Manager – SysAdm window appears.
	Circle one:  PASS / FAIL



	N.1.3
	Double-click Shutdown System.
	A Shut down dialog box appears.
	Circle one:  PASS / FAIL



	N.1.4
	Click No.
	The Shut down dialog box disappears.
	Circle one:  PASS / FAIL



	N.1.5
	Double-click Shutdown System in the Application Manager – SysAdmin window.
	A Shut down dialog box appears.
	Circle one:  PASS / FAIL



	N.1.6
	Click Yes.
	The system shuts down and a boot prompt is presented.
	Circle one:  PASS / FAIL



	N.1.7
	At the prompt enter the proper command for system boot.

(b or boot for SUN Solaris depending on the OS and hardware platform.)
	The system boots and the DII COE Login screen appears with the DoD security warning message and the Please enter your user name text box.
	Circle one:  PASS / FAIL



	O
	Verify secman Login, Profile Selector, Change Password Tool, Command Line Accessibility, and Icon Accessibility

	O.1
	Verify secman Login
	

	O.1.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Verify that the DII COE Login screen appears.
	The DII COE Login screen appears with the DoD security warning message and the Please enter your user name text box.
	Circle one:  PASS / FAIL



	O.1.2
	Log in as the Security Administrator by typing secman in the Please enter your user name prompt and pressing ENTER.
	The password screen appears with the Please enter your password text box.
	Circle one:  PASS / FAIL



	O.1.3
	Type the password for the secman account in the Please enter your password text box and press ENTER. 
	An Informational Message dialog box appears confirming COE logging processing is complete.
	Circle one:  PASS / FAIL



	O.1.4
	Click OK in the INFORMATIONAL MESSAGE dialog box.
	The dialog box disappears.
	Circle one:  PASS / FAIL



	O.2
	Verify secman Profile Selector Functionality
	

	O.2.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Click Profile Selector (the head with a question mark).
	The Profile Selector window appears with SSO Default listed in the Selected Profiles panel.
	Circle one:  PASS / FAIL

	O.2.2
	Click Cancel.
	The Profile Selector window disappears.
	Circle one:  PASS / FAIL



	O.3
	Verify secman Change Password Tool Functionality
	

	O.3.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Access the Change Password Tool from the CDE Panel by selecting the arrow above the Profile Selector icon. 
	The DII Tools menu appears.
	Circle one:  PASS / FAIL



	O.3.2
	Select the Change Password Tool menu item. 
	The Change your password window appears.
	Circle one:  PASS / FAIL



	O.3.3
	Click Cancel.
	The Change your password window disappears.
	Circle one:  PASS / FAIL



	O.4
	Verify Command Line Access
	

	O.4.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Open a Terminal window.
	A Terminal window appears with a command line prompt.
	Circle one:  PASS / FAIL



	O.4.2
	At the command prompt type

id
NOTE: This command is OS specific. Use the relevant command on the OS being tested and note it in the Observed Results column.
	The system returns

uid=101(secman) gid=36(admin)
NOTE: This result is OS specific. The result should indicate the user is secman.
	Circle one:  PASS / FAIL



	O.4.3
	At the command prompt type

pwd 

NOTE: This command is OS specific. Use the relevant command on the OS being tested and note it in the Observed Results column.
	The system returns

/h/USERS/local/secman/Scripts 

NOTE: This result is OS specific. The result should indicate the above path.
	Circle one:  PASS / FAIL



	O.4.4
	At the command prompt type

exit
	The Terminal window disappears.
	Circle one:  PASS / FAIL



	O.5
	Verify Icon Access
	

	O.5.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Right-click on the desktop.

NOTE: This method is OS specific. Use the relevant method on the OS being tested and note it in the Observed Results column.
	The Workspace Menu appears.
	Circle one:  PASS / FAIL



	O.5.2
	Select Applications > Application Manager
NOTE: This method is OS specific. Use the relevant method on the OS being tested and note it in the Observed Results column.
	The Application Manager window appears.
	Circle one:  PASS / FAIL



	O.5.3
	Double-click DII_APPS.
	The Application Manager – DII_APPS window appears.
	Circle one:  PASS / FAIL



	O.5.4
	Double-click SecAdm.
	The Application Manager – SecAdm window appears with the following icons: ..(go up), APM Client, APM Server Reload, APM Server Start, APM Server Stop, Assign Passwords, Audit Log File Manager, Edit APM Configuration, Merge Host, Profile Selector Config, Remove Host.
	Circle one:  PASS / FAIL



	P
	APM Client

	P.1
	Create A New Account, Profile, and Group On the Candidate Platform
	

	P.1.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Double-click APM Client.
	An Input dialog box appears asking for the master APM authentication key.
	Circle one:  PASS / FAIL



	P.1.2
	Enter the master APM Authentication Key.
	Asterisks appear in the text box.
	Circle one:  PASS / FAIL



	P.1.3
	Click OK.
	The Account and Profile Manager dialog box appears.
	Circle one:  PASS / FAIL



	P.1.4
	Select File > New Account.
	A Create Account window appears.
	Circle one:  PASS / FAIL



	P.1.5
	Click Identification.
	The Identification tab is displayed.
	Circle one:  PASS / FAIL



	P.1.6
	Enter the following values:

Login: AcctCon

Password: temp

Password Confirm: temp
Template: secman 

Home Server: EACH HOST
Manage As: Local
	Each item is filled in.
	Circle one:  PASS / FAIL



	P.1.7
	Click Hosts.
	The Hosts tab is displayed.
	Circle one:  PASS / FAIL



	P.1.8
	Verify kpccp appears in the Assigned Hosts panel.

Note:  If kpccp does not appear in the Assigned Hosts panel, double-click kpccp in the Available Hosts panel, which moves it to the Assigned Hosts panel.
	kpccp appears in the Assigned Hosts panel.
	Circle one:  PASS / FAIL



	P.1.9
	Click Submit.
	A Status Summary dialog box appears indicating the new user has been added.
	Circle one:  PASS / FAIL



	P.1.10
	Click OK.
	The Status Summary dialog box disappears.
	Circle one:  PASS / FAIL



	P.1.11
	Click Profiles.
	The Profiles tab is displayed.
	Circle one:  PASS / FAIL



	P.1.12
	Select File > New Profile.
	A Create Profile window appears.
	Circle one:  PASS / FAIL



	P.1.13
	In the Profile Name text box, enter 

ProCon.
	ProCon appears in the text box.
	Circle one:  PASS / FAIL



	P.1.14
	Select SSO Default from the Profile Template drop-down list.
	SSO Default is selected.
	Circle one:  PASS / FAIL



	P.1.15
	Click Features.
	The Features tab is displayed.
	Circle one:  PASS / FAIL



	P.1.16
	Select Sol Security Administration 4.2.0.0 from the Segments box.
	Sol Security Administration 4.2.0.0 is highlighted.
	Circle one:  PASS / FAIL



	P.1.17
	In the Features box, deselect the following items
Security Administration-APM Client

Security Administration-APM Server Start

Security Administration-Assign Passwords.
	These items are no longer checked.
	Circle one:  PASS / FAIL



	P.1.18
	Click Submit.
	A Status Summary dialog box appears indicating the new profile has been added.
	Circle one:  PASS / FAIL



	P.1.19
	Click OK.
	The Status Summary dialog box disappears.
	Circle one:  PASS / FAIL



	P.1.20
	Click Groups.
	The Groups tab is displayed.
	Circle one:  PASS / FAIL



	P.1.21
	Select File > New Group.
	A Create Group window appears.
	Circle one:  PASS / FAIL



	P.1.22
	In the Group Name text box, enter 

GrpCon.
	GrpCon appears in the text box.
	Circle one:  PASS / FAIL



	P.1.23
	Select admin from the Template drop-down list.
	admin is selected.
	Circle one:  PASS / FAIL



	P.1.24
	Click Accounts.
	The Accounts tab is displayed.
	Circle one:  PASS / FAIL



	P.1.25
	Double-click SSO in the Assigned Accounts panel.
	SSO moves to the Available Accounts panel.
	Circle one:  PASS / FAIL



	P.1.26
	Click Hosts.
	The Hosts tab is displayed.
	Circle one:  PASS / FAIL



	P.1.27
	Verify kpccp appears in the Assigned Hosts panel.
	kpccp appears in the Assigned Hosts panel.
	Circle one:  PASS / FAIL



	P.1.28
	Click Submit.
	A Status Summary dialog box appears indicating the new group has been added.
	Circle one:  PASS / FAIL



	P.1.29
	Click OK.
	The Status Summary dialog box disappears.
	Circle one:  PASS / FAIL



	P.1.30
	Click File > Exit.
	An Exit Confirmation dialog box appears.
	Circle one:  PASS / FAIL



	P.1.31
	Click Yes.
	The Account and Profile Manager dialog box disappears.
	Circle one:  PASS / FAIL



	P.2
	Create A New Account, Profile, and Group On the Validation Host
	

	P.2.1
	NOTE: Perform the following steps on the Validation Host (kpchost).

Login as secman.
	The desktop appears.
	Setup



	P.2.2
	Select Applications > Application Manager > DII_APPS > SecAdm.
	The Application Manager – SecAdm window appears.
	Setup



	P.2.3
	Double-click APM Client.
	An Input dialog box appears asking for the master APM authentication key.
	Setup



	P.2.4
	Enter the master APM Authentication Key.
	Asterisks appear in the text box.
	Setup



	P.2.5
	Click OK.
	The Account and Profile Manager dialog box appears.
	Setup



	P.2.6
	Select File > New Account.
	A Create Account window appears.
	Setup



	P.2.7
	Click Identification.
	The Identification tab is displayed.
	Setup



	P.2.8
	Enter the following values:

Login: AcctCon

Password: temp

Password Confirm: temp
Template: sysadmin 

Home Server: EACH HOST
Manage As: Local
	Each item is filled in.
	Setup



	P.2.9
	Click Submit.
	A Status Summary dialog box appears indicating the new user has been added.
	Setup 



	P.2.10
	Click OK.
	The Status Summary dialog box disappears.
	Setup



	P.2.11
	Click Profiles.
	The Profiles tab is displayed.
	Setup



	P.2.12
	Select File > New Profile.
	A Create Profile window appears.
	Setup



	P.2.13
	In the Profile Name text box, enter 

ProCon.
	ProCon appears in the text box.
	Setup



	P.2.14
	Select SA Default from the Profile Template drop-down list.
	SA Default is selected.
	Setup



	P.2.15
	Click Features.
	The Features tab is displayed.
	Setup



	P.2.16
	Select Sol System Administration 4.2.0.0 from the Segments box.
	Sol System Administration 4.2.0.0 is highlighted.
	Setup



	P.2.17
	In the Features box, deselect the following items:
System Administration-Change Machine ID

System Administration-Disk Manager

System Administration-Edit Local Hosts.
	These items are no longer checked.
	Setup



	P.2.18
	Click Submit.
	A Status Summary dialog box appears indicating the new profile has been added.
	Setup 



	P.2.19
	Click OK.
	The Status Summary dialog box disappears.
	Setup 



	P.2.20
	Click Groups.
	The Groups tab is displayed.
	Setup 



	P.2.21
	Select File > New Group.
	A Create Group window appears.
	Setup

 

	P.2.22
	In the Group Name text box, enter 

GrpCon.
	GrpCon appears in the text box.
	Setup 



	P.2.23
	Select other from the Template drop-down list.
	other is selected.
	Setup 



	P.2.24
	Click Accounts.
	The Accounts tab is displayed.
	Setup 



	P.2.25
	Double-click daemon, root and SA in the Assigned Accounts panel.
	daemon, root and SA move to the Available Accounts panel.
	Setup 



	P.2.26
	Click Hosts.
	The Hosts tab is displayed.
	Setup 



	P.2.27
	Verify kpchost appears in the Assigned Hosts panel.
	kpchost appears in the Assigned Hosts panel.
	Setup 



	P.2.28
	Click Submit.
	A Status Summary dialog box appears indicating the new group has been added.
	Setup 



	P.2.29
	Click OK.
	The Status Summary dialog box disappears.
	Setup 



	P.2.30
	Click File > Exit.
	An Exit Confirmation dialog box appears.
	Setup 



	P.2.31
	Click Yes.
	The Account and Profile Manager dialog box disappears.
	Setup 



	Q
	APM Server Reload

	Q.1
	Setup
	

	Q.1.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Double-click APM Server Reload.
	An INFORMATIONAL MESSAGE box appears: APM Server reloaded successfully.
	Circle one:  PASS / FAIL



	Q.1.2
	Click OK.
	The INFORMATIONAL MESSAGE box disappears.
	Circle one:  PASS / FAIL



	R
	APM Server Stop

	R.1
	Setup
	

	R.1.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Double-click APM Server Stop.
	An INFORMATIONAL MESSAGE box appears: APM Server successfully stopped.
	Circle one:  PASS / FAIL



	R.1.2
	Click OK.
	The INFORMATIONAL MESSAGE box disappears.
	Circle one:  PASS / FAIL



	R.1.3
	Double-click APM Server Stop.
	An INFORMATIONAL MESSAGE box appears: APM Server already stopped.
	Circle one:  PASS / FAIL



	R.1.4
	Click OK.
	The INFORMATIONAL MESSAGE box disappears.
	Circle one:  PASS / FAIL



	S
	APM Server Start

	S.1
	Setup
	

	S.1.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Double-click APM Server Start.
	An INFORMATIONAL MESSAGE box appears: APM Server started successfully.
	Circle one:  PASS / FAIL



	S.1.2
	Click OK.
	The INFORMATIONAL MESSAGE box disappears.
	Circle one:  PASS / FAIL



	S.1.3
	Double-click APM Server Start.
	An INFORMATIONAL MESSAGE box appears: APM Server is already running!
	Circle one:  PASS / FAIL



	S.1.4
	Click OK.
	The INFORMATIONAL MESSAGE box disappears. 
	Circle one:  PASS / FAIL



	T
	Assign Passwords

	T.1
	Setup
	

	T.1.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Double-click Assign Passwords.
	The Assign Passwords dialog box appears.
	Circle one:  PASS / FAIL



	T.1.2
	Click Cancel.
	The Assign Passwords dialog box disappears.
	Circle one:  PASS / FAIL



	U
	Audit Log File Manager

	U.1
	Setup
	

	U.1.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Double-click Audit Log File Manager.
	The Audit Log File Manager dialog box appears.
	Circle one:  PASS / FAIL

	U.1.2
	Click Cancel.
	The Audit Log File Manager dialog box disappears.
	Circle one:  PASS / FAIL



	V
	Edit APM Configuration

	V.1
	Setup
	

	V.1.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Double-click Edit APM Configuration.
	The Edit APM Configuration window appears.
	Circle one:  PASS / FAIL



	V.1.2
	In the Master Host text box, enter

kpchost
	kpchost appears in the text box.
	Circle one:  PASS / FAIL



	V.1.3
	Click Submit.
	A Done dialog box appears indicating: Operation completed successfully.
	Circle one:  PASS / FAIL



	V.1.4
	Click OK.
	The dialog box and the Edit APM Configuration window disappear.
	Circle one:  PASS / FAIL



	W
	Merge Host

	W.1
	Setup Candidate Platform
	

	W.1.1
	NOTE:  Perform the following steps on the Candidate Platform (kpccp).

Open a Terminal window.
	A Terminal window appears with a command line prompt.
	Circle one:  PASS / FAIL



	W.1.2
	At the command prompt type

su - 
	The Password prompt appears.
	Circle one:  PASS / FAIL



	W.1.3
	At the Password prompt type the root password.
	The command prompt returns.
	Circle one:  PASS / FAIL



	W.1.4
	At the command prompt type

csh
	The command prompt returns.
	Circle one:  PASS / FAIL



	W.1.5
	At the command prompt type

cd /h/COE/Comp/APM/bin
	The command prompt returns.
	Circle one:  PASS / FAIL



	W.1.6
	At the command prompt type

./APM_AuthMgr
	The Authentication Manager window appears.
	Circle one:  PASS / FAIL



	W.1.7
	Enter the local authentication key in the Key text box and record the key here.
	Asterisks appear in the text box.
	Circle one:  PASS / FAIL Local Authentication key:

___________________

	W.1.8
	Click Set Key.
	A Message dialog box appears indicating:  The local key is set.
	Circle one:  PASS / FAIL



	W.1.9
	Click OK.
	The Message dialog box disappears.
	Circle one:  PASS / FAIL



	W.1.10
	Click Close.
	The Authentication Manager window disappears.
	Circle one:  PASS / FAIL



	W.2
	Set Up Validation Host
	

	W.2.1
	NOTE: Perform the following steps on the Validation Host (kpchost).

Open a Terminal window.
	A Terminal window appears with a command line prompt.
	Setup



	W.2.2
	At the command prompt type

su - 
	A Password prompt appears.
	Setup



	W.2.3
	At the Password prompt type the root password.
	The command prompt returns.
	Setup



	W.2.4
	At the command prompt type

csh
	The command prompt returns.
	Setup



	W.2.5
	At the command prompt type

cd /h/COE/Comp/APM/bin
	The command prompt returns.
	Setup

 

	W.2.6
	At the command prompt type

./APM_AuthMgr
	The Authentication Manager window appears.
	Setup

 

	W.2.7
	Enter the master authentication key in the Key text box.
	Asterisks appear in the text box.
	Setup 



	W.2.8
	Click Set Master Key.
	A Confirm dialog box appears with the following message:

You will have to re-enter local auth keys after the master auth key is changed. 

Are you sure you want to initialize master key?
	Setup 

	W.2.9
	Click Yes.
	A Message dialog box appears indicating: Master authentication key is reset.
	Setup 



	W.2.10
	Click OK.
	The Message dialog box disappears.
	Setup 



	W.2.11
	Click Set Client’s Local Key.
	A Hosts List window appears.
	Setup 



	W.2.12
	In the Additional Host text box, enter

kpccp
	kpccp appears in the text box.
	Setup 



	W.2.13
	Click Add Host.
	A Set Key For New Host dialog box appears.
	Setup 



	W.2.14
	Enter the kpccp local key (from step W.1.7) here twice.
	Asterisks appear in the text boxes.
	Setup 



	W.2.15
	Click Submit.
	A Message dialog box appears indicating: Authentication keys are set.
	Setup 



	W.2.16
	Click OK.
	The Message dialog box disappears.
	Setup 



	W.2.17
	Click Close.
	The Hosts List window disappears.
	Setup 



	W.2.18
	Click Close.
	The Authentication Manager window disappears.
	Setup 



	W.3
	Run Merge On the Candidate Platform
	

	W.3.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Double-click Merge Host in the Application Manager – SecAdm window. 
	The MergeHost Tool dialog box appears with kpccp listed as the hostname of the New APM Domain Host and kpchost listed as the hostname of the Master APM Server.
	Circle one:  PASS / FAIL

	W.3.2
	Click OK.
	An Input dialog box appears asking for the Master APM authentication key.
	Circle one:  PASS / FAIL



	W.3.3
	Enter the master APM Authentication Key.
	Asterisks appear in the text box.
	Circle one:  PASS / FAIL



	W.3.4
	Click OK.
	A User Conflicts window appears.

AcctCon is highlighted in the left panel.
	Circle one:  PASS / FAIL



	W.3.5
	Click Use Master.
	The red text noting the conflicts turns to black.
	Circle one:  PASS / FAIL



	W.3.6
	Click Reset.
	The conflict is again indicated by red text.
	Circle one:  PASS / FAIL



	W.3.7
	Click Use New.
	The red text noting the conflicts turns to black.
	Circle one:  PASS / FAIL



	W.3.8
	Click Apply.
	A check is displayed next to AcctCon and secman is highlighted in the left panel.
	Circle one:  PASS / FAIL



	W.3.9
	Click Use New.
	The red text noting the conflicts turns to black.
	Circle one:  PASS / FAIL



	W.3.10
	Click Apply.
	A check is displayed next to secman and sysadmin is highlighted in the left pane.
	Circle one:  PASS / FAIL



	W.3.11
	Click Use Master.
	The red text noting the conflicts turns to black.
	Circle one:  PASS / FAIL



	W.3.12
	Click Apply.
	A check is displayed next to sysadmin and the right pane shows No more user conflicts.
	Circle one:  PASS / FAIL



	W.3.13
	Click OK.
	A Group Conflicts window appears.

GrpCon is highlighted in the left panel.
	Circle one:  PASS / FAIL



	W.3.14
	Click Use Master.
	The red text noting the conflicts turns to black.
	Circle one:  PASS / FAIL



	W.3.15
	Click Reset.
	The conflict is again indicated by red text.
	Circle one:  PASS / FAIL



	W.3.16
	Click Use New.
	The red text noting the conflicts turns to black.
	Circle one:  PASS / FAIL



	W.3.17
	Click Apply.
	A check is displayed next to GrpCon and admin is highlighted in the left pane.
	Circle one:  PASS / FAIL



	W.3.18
	Click Apply.
	A check is displayed next to admin and other is highlighted in the left panel.
	Circle one:  PASS / FAIL



	W.3.19
	Click Apply.
	A check is displayed next to other and the right pane shows No more group conflicts.
	Circle one:  PASS / FAIL



	W.3.20
	Click OK.
	A Profile Conflicts window appears. ProCon is highlighted in the left panel.
	Circle one:  PASS / FAIL



	W.3.21
	Click Use Master.
	The red text noting the conflicts turns to black.
	Circle one:  PASS / FAIL



	W.3.22
	Click Apply.
	A check is displayed next to ProCon and SA Default is highlighted in the left panel.

Note: SA Default may not be listed; if not, skip to step W.3.25.
	Circle one:  PASS / FAIL



	W.3.23
	Click Use New.
	The red text noting the conflicts turns to black.
	Circle one:  PASS / FAIL



	W.3.24
	Click Apply.
	A check is displayed next to SA Default and the right pane shows No more profile conflicts.
	Circle one:  PASS / FAIL



	W.3.25
	Click OK.
	A MergeHost Confirmation window appears with the following message:

Send commands to the Master APM server now?
	Circle one:  PASS / FAIL



	W.3.26
	Click OK.
	The MergeHost Status dialog box displays Finished.
	Circle one:  PASS / FAIL



	W.3.27
	Click OK.
	The MergeHost Status dialog box disappears.
	Circle one:  PASS / FAIL



	W.4
	Cleanup 
	

	W.4.1
	NOTE: Perform the following steps on the Validation Host (kpchost). 

Double-click Remove Host in the Application Manager – SecAdm window.
	The Remove Hosts window appears.
	Cleanup

	W.4.2
	Double-click kpccp in the Keep panel.
	kpccp moves to the Remove panel.
	Cleanup



	W.4.3
	Click Submit.
	An INFORMATIONAL MESSAGE dialog box appears indicating: The APM Server reloaded successfully.
	Cleanup



	W.4.4
	Click OK.
	A Completed dialog box appears indicating that kpccp has been removed.
	Cleanup



	W.4.5
	Click OK.
	The dialog box and Remove Hosts window disappear.
	Cleanup



	W.4.6
	In the Terminal window, at the command prompt, type

cd /h/COE/Comp/APM/bin
	The command prompt returns.
	Cleanup



	W.4.7
	At the command prompt type

./APM_AuthMgr
	The Authentication Manager window appears.
	Cleanup



	W.4.8
	Enter the master authentication key in the Key text box.
	Asterisks appear in the text box.
	Cleanup



	W.4.9
	Click Set Client’s Local Key.
	The Hosts List window appears.
	Cleanup



	W.4.10
	Select kpccp.
	kpccp is highlighted.
	Cleanup



	W.4.11
	Select Delete Host.
	A Confirm dialog box appears with the following message:

Delete the local authentication keys of these hosts?

kpccp
	Cleanup

	W.4.12
	Click Yes.
	The dialog box disappears.
	Cleanup



	W.4.13
	Click Close in the Hosts List window.
	The Hosts List window disappears.
	Cleanup



	W.4.14
	Click Close in the Authentication Manager window.
	The Authentication Manager window disappears.
	Cleanup

	W.4.15
	Double-click APM Client in the Application Manager – SecAdm window.
	An Input dialog box appears asking for the master APM authentication key.
	Cleanup



	W.4.16
	Enter the APM Master Authentication Key.
	Asterisks appear in the text box.
	Cleanup



	W.4.17
	Click OK.
	The Account and Profile Manager dialog box appears.
	Cleanup



	W.4.18
	Click Accounts.
	The Accounts tab is displayed.
	Cleanup



	W.4.19
	Select user AcctCon.
	AcctCon is highlighted.
	Cleanup



	W.4.20
	Select Edit > Delete.
	A Confirm window prompts for confirmation.
	Cleanup



	W.4.21
	Click Yes.
	A Status Summary window appears indicating the Account was successfully deleted.
	Cleanup



	W.4.22
	Click OK.
	Control returns to the Account and Profile Manager dialog box. The entry for AcctCon has been removed from the Accounts tab.
	Cleanup



	W.4.23
	Click Profiles.
	The Profiles tab is displayed.
	Cleanup



	W.4.24
	Select ProCon.
	ProCon is highlighted.
	Cleanup



	W.4.25
	Select Edit > Delete.
	A Confirm window prompts for confirmation.
	Cleanup



	W.4.26
	Click Yes.
	A Status Summary window appears indicating the Profile was successfully deleted.
	Cleanup



	W.4.27
	Click OK.
	Control returns to the Account and Profile Manager dialog box. The entry for ProCon has been removed from the Profiles tab.
	Cleanup



	W.4.28
	Click Groups.
	The Groups tab is displayed.
	Cleanup



	W.4.29
	Select GrpCon.
	GrpCon is highlighted.
	Cleanup



	W.4.30
	Select Edit > Delete.
	A Confirm window prompts for confirmation.
	Cleanup



	W.4.31
	Click Yes.
	A Status Summary window appears indicating the Group was successfully deleted.
	Cleanup



	W.4.32
	Click OK.
	Control returns to the Account and Profile Manager dialog box. The entry for GrpCon has been removed from the Groups tab.
	Cleanup



	W.4.33
	Log out of the Validation Host (kpchost).
	The DII COE login screen appears.
	Cleanup



	W.4.34
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Double-click Edit APM Configuration.
	The Edit APM Configuration window appears. 
	Circle one:  PASS / FAIL

	W.4.35
	In the Master Host text box, enter

kpccp
	kpccp appears in the text box.
	Circle one:  PASS / FAIL



	W.4.36
	Click Submit.
	A dialog box appears indicating:  

Operation completed successfully.
	Circle one:  PASS / FAIL



	W.4.37
	Click OK.
	The dialog box and the Edit APM Configuration window disappear.
	Circle one:  PASS / FAIL



	W.4.38
	In the Terminal window, type 
cd /h/COE/Comp/APM/bin
	The command prompt returns.
	

	W.4.39
	In the Terminal window, type 
./APM_BecomeOwnMaster
	The command prompt returns.
	

	W.4.40
	Double-click APM Client.
	An Input dialog box appears asking for the master APM authentication key.
	Circle one:  PASS / FAIL



	W.4.41
	Enter the local APM Master Authentication Key.
	Asterisks appear in the text box.
	Circle one:  PASS / FAIL



	W.4.42
	Click OK.
	The Account and Profile Manager dialog box appears.
	Circle one:  PASS / FAIL



	W.4.43
	Click Accounts.
	The Accounts tab is displayed.
	Circle one:  PASS / FAIL



	W.4.44
	Select user AcctCon.
	User AcctCon is highlighted.
	Circle one:  PASS / FAIL



	W.4.45
	Select Edit > Delete.
	A Confirm window prompts for confirmation.
	Circle one:  PASS / FAIL



	W.4.46
	Click Yes.
	A Status Summary window appears indicating the Account was successfully deleted.
	Circle one:  PASS / FAIL



	W.4.47
	Click OK.
	Control returns to the Account and Profile Manager dialog box. The entry for AcctCon has been removed from the Accounts tab.
	Circle one:  PASS / FAIL



	W.4.48
	Click Profiles.
	The Profiles tab is displayed.
	Circle one:  PASS / FAIL



	W.4.49
	Select ProCon.
	ProCon is highlighted.
	Circle one:  PASS / FAIL



	W.4.50
	Select Edit > Delete.
	A Confirm window prompts for confirmation.
	Circle one:  PASS / FAIL



	W.4.51
	Click Yes.
	A Status Summary window appears indicating the Profile was successfully deleted.
	Circle one:  PASS / FAIL



	W.4.52
	Click OK.
	Control returns to the Account and Profile Manager dialog box. The entry for ProCon has been removed from the Profiles tab.
	Circle one:  PASS / FAIL



	W.4.53
	Click Groups.
	The Groups tab is displayed.
	Circle one:  PASS / FAIL



	W.4.54
	Select GrpCon.
	GrpCon is highlighted.
	Circle one:  PASS / FAIL



	W.4.55
	Select Edit > Delete.
	A Confirm window prompts for confirmation.
	Circle one:  PASS / FAIL



	W.4.56
	Click Yes.
	A Status Summary window appears indicating the Profile was successfully deleted.
	Circle one:  PASS / FAIL



	W.4.57
	Click OK.
	Control returns to the Account and Profile Manager dialog box. The entry for GrpCon has been removed from the Groups tab.
	Circle one:  PASS / FAIL



	W.4.58
	Select File > Exit.
	An Exit confirmation window appears.
	Circle one:  PASS / FAIL



	W.4.59
	Click Yes.
	The Account and Profile Manager dialog box disappears.
	Circle one:  PASS / FAIL



	X
	Profile Selector Config

	X.1
	Setup
	

	X.1.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Double-click Profile Selector Config.
	The Profile Selector Configuration dialog box appears.
	Circle one:  PASS / FAIL

	X.1.2
	Click Cancel.
	The Profile Selector Configuration dialog box disappears.
	Circle one:  PASS / FAIL



	Y
	Remove Host

	Y.1
	Setup
	

	Y.1.1
	NOTE: Perform the following steps on the Candidate Platform (kpccp).

Double-click Remove Host.
	The Remove Hosts dialog box appears.
	Circle one:  PASS / FAIL

	Y.1.2
	Click Cancel.
	The Remove Hosts dialog box disappears.
	Circle one:  PASS / FAIL

	Z
	Logout

	Z.1
	Verify secman Logout
	

	Z.1.1
	Select EXIT button from CDE.


	A Logout Confirmation window appears.
	Circle one:  PASS / FAIL

	Z.1.2
	Select OK.
	System exits and the DII COE Login screen appears.
	Circle one:  PASS / FAIL




End of Validation Procedure

Kernel Overview VP
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