Validation Procedure for DII COE Kernel Platform Compliance:  Printer Services Overview

Test Title: Printer Services Overview Validation Procedure

Candidate  Platform:  __________________________________

Date: ________________________________________

Tester:  _____________________________________________

Estimated Runtime:  __1 Hour____________________

Start Time:  ___________________
End Time:  ____________

Actual Runtime:  ______________________________
Test Site/Organization:   ________________________________

Overall Test Result:  Circle One:  PASS / FAIL

Configuration Validated  

Hardware Platform:_______________________________________
System Software: ________________________________

 Network Type: __________________________________________
Printer: ________________________________________
 Local Devices (if any): _______________________________________________________________________________________

Test Purpose/Scope: This demonstration includes Print Manager, Print Administration and Printer functionality.

Description: The demonstration for testing will be performed on command line printing, remote printing and local printing, adding print drivers, adding printers and managing print jobs using the Print Manager.

These test procedures exercise the following basic functionality, with the relevant test steps identified in parenthesis:


-Login (A), and Logout (Z)


-Verify Accessibility of Printer Manger and Print Administration windows under SA_System Menu Bar (B)


-Set the Printer Domain Name (C)


-Set Up Two New Printers Using the New Print Domain Name (D)


-Print to the Newly Created Printer (E)


-Set up Printers on the Candidate Platform using the Validation Host as the Host (F & L)


-Print to the Newly Created Remote Printer (G)


-Delete All Printers Set in Print Domain (H)


-Set a New Name for the Printer Domain (I)


-Set up Two New Printers (J)


-Print to the Newly Created Printer (M)


-Add Access to a Remote Printer (N)


-Print to the Remote Printer (O)


-Test Candidate Platform Print Services (P)


-Command Line Printing (Q)


-Detect all Printer(s) Whose Host is(are) the Candidate Platform (R)


-Create a new profile with System Administration Privileges (S)


-Create a new User, Assigning the Newly Created Profile to it (T)


-Edit the PA Default Profile Permissions (U)


-Modify Current Printer Configuration Using Printer Administrator (V)


-Modify the PA Default Profile to Restrict user 'printman' from Making any Changes in Printer Administrator (W)


-Modify Current Printer Configuration Using Printer Administrator (X)


-Delete PA Default and User:printman Profiles (Y)


-Drivers (Z)

Overall Test Result:  The overall PASS/FAIL result for this test is determined as follows:  The overall test result is "PASS" if and only if all steps marked as PASS/FAIL steps in the Observed Result column, have a test step "PASS" result.

Test Step Results:  For each step with a "Circle One:  PASS/FAIL" in the Observed Result column, the tester compares the directly observed Candidate Platform behavior with the "PASS" criteria.  Unless other PASS criteria are noted in the test step, the test step result is "PASS" if and only if the Candidate Platform presents all of the behaviors and conditions described in the Expected Result column for that test step.  The test step result if "FAIL" if the Candidate Platform fails to satisfy any of the PASS criteria.

If the test step result is "PASS", the tester will circle "PASS" and note the actual behaviors and conditions presented in the Observed Result column.  If the observed result precisely matches the expected result, the Observed Result column for the step may contain the statement "as expected."

If the test step result is "FAIL", the tester will circle "FAIL" in the Observed Result column and note the actual behaviors and conditions presented in the Observed Result column.  Additional documentation detailing the reasons for the test step failure is included in the Validation Test Report.
Note 1:  Due to the complexity of any Candidate Platform,  it is impossible to completely specify all aspects of their operation in the space provided.  Many of the expected Candidate Platform behaviors for any test step are implicitly assumed based on industry practice, commercial testing or prior testing, and may not be explicitly described in the Expected Result column.  DISA reserves the right to consider implicit as well as explicit PASS/FAIL criteria which could adversely affect the ability of the Candidate Platform to satisfy DoD mission requirements when used as a component of the DII.

If implicit PASS/FAIL criteria are involved in a "FAIL" determination, the tester will circle "FAIL" in the Observed Result column and note the objectionable behavior in the Observed Result column at the point of observation during the test.  Additional documentation detailing the full rationale for the "FAIL" determination is to be included in the Validation Test Report.

Note2:  Test steps which are "grayed out" (i.e., the entire table row is set to a gray background) are to be considered as waived by DISA for this test version only.  Grayed out test steps are not to be executed nor is observed behavior to be recorded.  These test steps may be returned to the overall test at a future date and are retained for information purposes only.  PASS/FAIL criteria identified in these test steps will not be used in the determination of the overall test result.

Note3:  The symbol “(” (inverted triangle) denotes a blank space.  The “[RETURN]” symbol denotes a carriage return.

Test Data/Media Required:  Two files:  asciifile and printtest.ps located in the /home1/KPC/Printtest directory on the Validation Host.

Setup/Equipement Required:  The DII COE Validation Host must be running the Print Services and available to the Candidate Platform. The Candidate Platform must have at least one printer that can be attached to its serial or parallel port. The Candidate Platform should have a root, System Administrator, secman and a regular User account created before the validation test and be network ready.  This test requires two segments: the DII COE Common Application Segment:  Kernel Printer Drivers, and the DII COE Menus segment. (This should have been installed in the Kernel Overview test).

Required Personnel:  One Tester.  The tester is assumed to be very familiar with POSIX/UNIX application platforms, but may not be familiar with the Defense Information Infrastructure (DII) Common Operating Environment (COE).

Step
Operator Action
Expected Result
Observed Result

A
Login (Optional)





A.1
Power up the Candidate Platform. 

Optional: Use if not already powered up.
The DII COE login screen will appear.
Setup

A.2
Login to sysadmin account using the default sysadmin and appropriate password combination.

Optional:  Use if not already logged in.
Menu bar, security classification and CDE will appear.
Setup

A.3
Mount the KPC directory exported from the Validation Host from an xterm window.  Type:

su - root

mount KPChost: /home1/KPC /home1/KPC

exit

Optional:  Use if not already mounted.
A message confirms that the filesystem has been mounted.
Setup

A.4
Copy both “asciifile” and “printtest.ps” into the /h/USERS/local/sysadmin/Scripts directory.  Type:

su - root

cp /home1/KPC/Printtest/*<space> /h/USERS/local/sysadmin/Scripts

exit

Setup

B
Bring up both Printer Manager and Print Administration and verify the 

accessibility of these windows under the 

SA System Menu Bar.



B.1
Check the list of installed segments for the segment:  Kernel Printer Driver

1. Select the Software > Segment Installer option from the menu bar at the top of the screen.

2. Under the ‘Current Installed Segments’ portion of the Segment Installer, look for this segment.

NOTE:  If the segment Kernel Printer Driver is not installed at this time, please install it as appropriate.
Segment Installer window

Appears.
Setup

B.2
Close either by clicking on [Exit] or by double-clicking top left corner of Segment Installer.
Window closes and disappears.
Setup

B.3
Select SA System > Printer > Printer Manager  

from the menu bar at the top of the screen.

Circle one:  PASS / FAIL

B.3.1
Minimize the window by clicking either:

a. The inside upper right button (Minimize) OR

b. Typing:  <ALT> - F9.
The window minimizes as expected and is relocated in the lower left corner.
Circle one:  PASS / FAIL

B.3.2
Double-click the Printer Manager Icon.
Window returns to normal.
Circle one:  PASS / FAIL

B.3.3
Maximize the window by clicking either:

a. The outside upper right button (Maximize) OR

b. Typing:  <ALT> - F10.
Window is maximized as expected.
Circle one:  PASS / FAIL

B.3.4
Return to normal size by clicking the outside upper right button.
The window returns to normal size.
Circle one:  PASS / FAIL

B.3.5
Close by double-clicking top left corner.
Window disappears.
Circle one:  PASS / FAIL

B.3.6
Repeat steps B.1 through B.5 with the Printer Administrator.
Results will appear as 
Circle one:  PASS / FAIL

B.3.7
Select SA System > Printer > Print Administrator  

from the menu bar at the top of the screen.

Circle one:  PASS / FAIL

B.3.8
Minimize the window by clicking either:

c. The inside upper right button (Minimize) OR

d. Typing:  <ALT> - F9.
The window minimizes as expected and is relocated in the lower left corner.
Circle one:  PASS / FAIL

B.3.9
Double-click the Printer Manager Icon.
Window returns to normal.
Circle one:  PASS / FAIL

B.3.10
Maximize the window by clicking either:

c. The outside upper right button (Maximize) OR

d. Typing:  <ALT> - F10.
Window is maximized as expected.
Circle one:  PASS / FAIL

B.3.11
Return to normal size by clicking the outside upper right button.
The window returns to normal size.
Circle one:  PASS / FAIL

B.3.12
Close by double-clicking top left corner.
Window disappears.
Circle one:  PASS / FAIL

B.4
View the Print Manager window by reopening the Print Manager using Step B.3.

NOTE:  Observe that there are two sections regarding Print Manager.  (User Default and Other Printers.)

Circle one:  PASS / FAIL

B.4.1
Observe the following columns in the User Default section:

Host, Color, Status, Jobs in Queue, Queue Size

Circle one:  PASS / FAIL

B.4.2
Observer the following columns in the Other Printers section:

Host, Color, Status, Jobs in Queue, Queue Size

Circle one:  PASS / FAIL

B.4.3
Double Click on the [Close other Printers] button to close the ‘Other Printers section of the Printer Manager. 
The ‘Other Printers’ section of the Printer Manager disappears.
Circle one:  PASS / FAIL

B.4.4
Double Click again on the [Open other Printers] button to reopen the Other Printers section of the Printer Manager. 
The ‘Other Printers’ section of the Printer Manager reappears.
Circle one:  PASS / FAIL

B.4.5
Note the current date (in the lower left corner of the Printer Manager window) matches with today’s date and whose format is MM/DD/YR.

Circle one:  PASS / FAIL

B.4.6
View and access the Print Manager window options: 

File, Selected, View, Help 

NOTE: The ‘Help’ menu is not available.
Menu options appear as expected.
Circle one:  PASS / FAIL

C
Set the Printer Domain Name.



C.1
Select SA System > Printer > Printer Domain Config from the menu bar at the top of the screen.

Circle one:  PASS / FAIL

C.2
Set the Printer Domain Name

1. Type “print.domain” and click [OK].

2. When the question appears:  “The COE Printer Services is currently running.  Terminate Printer Services?” click [YES] and continue.

3.   When the message appears:  “Please reboot this  machine”, Click [OK].

NOTE:  If there are printers configured, the following message appears:  “There are printers configured for this domain, please delete all printers in Printer Administrator before continuing.”
1. Step 2 will appear.

2. The computer will take a few seconds and the message “Please reboot this machine” will appear.
Circle one:  PASS / FAIL

C.3
Select Hardware  > Reboot System



C.4
When the message appears, Do you want to shutdown and reboot the computer, Click [ok].
The system starts its’ Reboot process.
Circle one:  PASS / FAIL

D
Set up two New printers using the new Print Domain Name.



D.1
Select Printer >Printer Administrator from the menu bar at the top of the screen.
Printer Administrator window appears.
Circle one:  PASS / FAIL

D.2
Select Edit > Add Printer from within the Printer Administrator window.
Add Printer window appears.
Circle one:  PASS / FAIL

D.3
In the Add Printer box, type the following information:

Printer Name:

kpcnetlp
Host Name:

kpccp
Printer Model Type:
ASCII Printer

Description:

Network Printer
IP Server Host Name
kpcnetlp
IP Printer Name
kpcnetlp

Check the box marked ‘System Default Printer’.

Click [OK] when complete.

NOTE:  Leave the LP Server Host Name and the LP Printer Name boxes blank.
The Add printer box will disappear, leaving a printer icon denoting the ASCII printer appearing in the Printer Administrator window.
Circle one:  PASS / FAIL

D.4
Select Edit > Add Printer from within the Printer Administrator window.

Circle one:  PASS / FAIL

D.5
In the Add Printer box, type the following information:

Printer Name:

kpcnetlpps
Host Name:

kpccp
Printer Model Type:
PostScript Printer
Description:

Network Printer
IP Server Host Name
kpcnetlp
IP Printer Name
kpcnetlpps
Click [OK] when complete.
The Add printer box will disappear, leaving a printer icon denoting the PostScript  printer appearing in the Printer Administrator window
Circle one:  PASS / FAIL

D.6
Select File > Exit from the top of the Printer Administration window.
The Printer Administrator window disappears.
Circle one:  PASS / FAIL

E
Attempt to Print to the newly created printer.



E.1
Double-click on the File Manager Icon.
The File Manager Window opens.
Circle one:  PASS / FAIL

E.2
Click on and drag the file asciifile down to the printer Icon and Release.
The Printer Selector window opens.
Circle one:  PASS / FAIL

E.3
Click the [Print] button at the bottom of the Printer Selector window.
Window disappears and the file prints as expected.
Circle one:  PASS / FAIL

E.4
Double-Click the printer icon located at the bottom of the screen.
The Printer Manager window appears.
Circle one:  PASS / FAIL

E.5
Click on the KPCnetlpps Icon.
An orange/box box appears around the icon and corresponding line of information is highlighted.
Circle one:  PASS / FAIL

E.6
Select Selected > Set as User Default menu from within the Printer Manager window.

Select File > Exit when complete.
The KPCnetlpps icon appears in the User Default portion of the Printer Manager window.

The Printer Manager window disappears.
Circle one:  PASS / FAIL

E.7
From within the File Manager window, click on and drag the file printtest.ps to the printer icon.
The Printer Selector window opens.
Circle one:  PASS / FAIL

E.8
Click the [Print] button at the bottom of the Printer Selector window.
Window disappears and the file prints as expected.
Circle one:  PASS / FAIL

F
Set up another combination of printers on the Candidate Platform using the Validation Host as the host.



F.1
Select SA System > Printer > Printer Administrator.
Printer Administrator window appears.
Circle one:  PASS / FAIL

F.2
Select Edit > Add Printer from within the Printer Administrator window.
The Add Printer window opens.
Circle one:  PASS / FAIL

F.3
In the Add Printer box, type the following information:

Printer Name:

kpcnetlp2
Host Name:

kpccp
Printer Model Type:
ASCII Printer
Description:

Network Printer
IP Server Host Name
kpcnetlp
IP Printer Name
kpcnetlpps
Check the box marked ‘System Default Printer’.

Click [OK] when complete.

NOTE:  Leave the LP Server Host Name and the LP Printer Name boxes blank.
The Add Printer box will disappear, leaving a printer icon and corresponding info appearing in the Printer Administration box.
Circle one:  PASS / FAIL

F.4
Select Edit > Add Printer from within the Printer Administrator window.
The Add Printer window opens.
Circle one:  PASS / FAIL

F.5
In the Add Printer box, type the following information:

Printer Name:

kpcnetlp2ps
Host Name:

kpccp
Printer Model Type: 
PostScript Printer

Description:

Network Printer
IP Server Host Name
kpcnetlp

IP Printer Name
kpcnetlpps

Click [OK] when complete.
The Add Printer box will disappear, leaving a printer icon and corresponding info appearing in the Printer Administration box
Circle one:  PASS / FAIL

F.6
Select File > Exit from the top of the Printer Administration window.
The Printer Administrator window disappears.
Circle one:  PASS / FAIL

G
Attempt to Print to the newly created remote printer.



G.1
Double-click on the File Manager Icon.
The File Manager window opens.
Circle one:  PASS / FAIL

G.2
Click on and drag the asciifile down to the printer Icon and Release.
The Printer Selector window opens.
Circle one:  PASS / FAIL

G.3
Click the [Print] button at the bottom of the Printer Selector window.
The window disappears and the file is printed as expected.
Circle one:  PASS / FAIL

G.4
Double-Click the printer icon located at the bottom of the screen.
The Printer Manager window appears.
Circle one:  PASS / FAIL

G.5
Click on the KPCnetlp2ps Icon.
An orange/box box appears around the icon and corresponding line of information is highlighted.
Circle one:  PASS / FAIL

G.6
Select Selected > Set as User Default menu from within the Printer Manager window.


The KPCnetlp2ps icon appears in the User Default portion of the Printer Manager window.


Circle one:  PASS / FAIL

G.7
Select File > Exit when complete.
The Printer Manager window disappears.
Circle one:  PASS / FAIL

G.8
From within the File Manager window, click on and drag the file printtest.ps to the printer icon.
The Printer Selector window opens.
Circle one:  PASS / FAIL

G.9
Click the [Print] button at the bottom of the Printer Selector window.
Window disappears and the file prints as expected.
Circle one:  PASS / FAIL

H
Delete all printers currently set in the print domain.



H.1
Select SA System > Printer > Printer Administrator.
The Printer Administrator window opens.
Circle one:  PASS / FAIL

H.2
Click on any visible printer icon.

Circle one:  PASS / FAIL

H.3
Select Edit > Delete Printer from the Printer Administrator window.
A question will appear.
Circle one:  PASS / FAIL

H.4
When the question appears:  “Are you sure you want to Delete Printer <Name of Printer>?” Click [OK].
Printer is deleted.
Circle one:  PASS / FAIL

H.5
Repeat steps H.2 through H.4 until all printers are deleted.

Circle one:  PASS / FAIL

H.6
Select File > Exit from the Printer Administrator window.
The Printer Administrator window disappears.
Circle one:  PASS / FAIL

I
Set a new name for the Printer Domain.



I.1
Select SA System >Printer> Printer Domain Config from the menu bar at the top of the screen.
The ENTER A RESPONSE window appears.
Circle one:  PASS / FAIL

I.2
Type “print2.domain” and click the [OK] button again. Click the [ok] button again.
Information message window appears.
Circle one:  PASS / FAIL

I.3
Select Hardware >Reboot System from the menus at the top of the screen.
Reboot? Window appears.
Circle one:  PASS / FAIL

I.4
The question will appear “Do you want to shutdown and reboot the computer?” Click [OK].
The system starts the Reboot process.
Circle one:  PASS / FAIL

J
Set up two New printers using the new Print Domain Name.



J.1
Login in sysadmin.



J.2
Select SA System > Printer > Printer Administrator from menu bar at the top of the screen.
Printer Administrator window appears.
Circle one:  PASS / FAIL

J.3
Select Edit > Add Printer from within the Printer Administrator window.
Add Printer window appears.
Circle one:  PASS / FAIL

J.4
In the Add Printer box, type the following information:

Printer Name:

KPCnetlp3
Host Name:

KPCcp

Printer Model Type:
ASCII Printer

Description:

Network Printer

Click [OK] when complete.

NOTE:  Leave the LP Server Host Name and the LP Printer Name boxes blank.
The Add Printer window disappears and an Icon with the printer’s name will appear in the Printer Administrator window.
Circle one:  PASS / FAIL

J.5
Select Edit > Add Printer from within the Printer Administrator window.
The Add Printer window opens.
Circle one:  PASS / FAIL

J.6
In the Add Printer box, type the following information:

Printer Name:

KPCnetlp3ps
Host Name:

KPCcp

Printer Model Type:
PostScript Printer

Description:

Network Printer

Click [OK] when complete.
The Add Printer box will disappear, leaving a printer icon and corresponding info appearing in the Printer Administration box
Circle one:  PASS / FAIL

J.7
Select File > Exit from the Printer Administrator window.
The Printer Administrator window disappears.
Circle one:  PASS / FAIL

K
Attempt to print to each of the newly created printers.

Circle one:  PASS / FAIL

K.1
Double-click on the File Manager Icon.
Window opens.
Circle one:  PASS / FAIL

K.2
Click on and drag the asciifile down to the printer Icon and Release.
The Print Selector window Opens.


Circle one:  PASS / FAIL

K.3
Click the [Print] button at the bottom of the Printer Selector window to Print.
Window disappears and the file is printed as expected.
Circle one:  PASS / FAIL

K.4
Double-Click the printer icon located at the bottom of the screen.
The Printer Manager window appears.
Circle one:  PASS / FAIL

K.5
Click on the KPCnetlp3ps Icon.
An orange/box box appears around the icon and corresponding line of information is highlighted.
Circle one:  PASS / FAIL

K.6
Select Selected > Set as User Default menu from within the Printer Manager window.

Select File > Exit when complete.
The KPCnetlp3ps icon appears in the User Default portion of the Printer Manager window.

The Printer Manager window disappears.
Circle one:  PASS / FAIL

K.7
From within the File Manager window, click on and drag the file printtest.ps to the printer icon.
The Printer Selector window opens.
Circle one:  PASS / FAIL

K.8
Click the [Print] button at the bottom of the Printer Selector window.
Window disappears and the file prints as expected.
Circle one:  PASS / FAIL

L
Set up another printer on the Candidate Platform using the Validation Host as the host.

Circle one:  PASS / FAIL

L.1
Select SA System > Printer > Printer Administrator from the menu bar at the top of the screen.
Printer Administrator window appears.
Circle one:  PASS / FAIL

L.2
Select Edit > Add Printer from within the Printer Administrator window.
The Add Printer window appears.
Circle one:  PASS / FAIL

L.3
In the Add Printer box, type the following information:

Printer Name:

KPCnetlp4
Host Name:

KPChost

Printer Model Type:
ASCII Printer

Description:

Network Printer

Check the box marked ‘System Default Printer’.

Click [OK] when complete.
The Add Printer window disappears and the Printer Administrator window reappears.
Circle one:  PASS / FAIL

L.4
Select Edit > Add Printer from within the Printer Administrator window.
The Add Printer window opens.
Circle one:  PASS / FAIL

L.5
In the Add Printer box, type the following information:

Printer Name:

KPCnetlp4ps
Host Name:

KPCcp

Printer Model Type:
PostScript Printer

Description:

Network Printer

Click [OK] when complete.
The Add Printer box will disappear, leaving a printer icon and corresponding info appearing in the Printer Administration box
Circle one:  PASS / FAIL

L.6
Select File > Exit from the Printer Administrator window.
The Printer Administrator window disappears.
Circle one:  PASS / FAIL

M
Attempt to print to the newly created printer.



M.1
Double-click on the File Manager Icon.
The File Manager window opens.
Circle one:  PASS / FAIL

M.2
Click on and drag a any visible file down to the printer Icon and Release.
The Print Selector window opens.


Circle one:  PASS / FAIL

M.3
Click the [Print] button at the bottom to Print.
The Print Selector window disappears and the file prints  as expected.
Circle one:  PASS / FAIL

M.4
Double-Click the printer icon located at the bottom of the screen.
The Printer Manager window appears.
Circle one:  PASS / FAIL

M.5
Click on the KPCnetlp4ps Icon.
An orange/box box appears around the icon and corresponding line of information is highlighted.
Circle one:  PASS / FAIL

M.6
Select Selected > Set as User Default menu from within the Printer Manager window.

Select File > Exit when complete.
The KPCnetlp4ps icon appears in the User Default portion of the Printer Manager window.

The Printer Manager window disappears.
Circle one:  PASS / FAIL

M.7
From within the File Manager window, click on and drag the file printtest.ps to the printer icon.
The Printer Selector window opens.
Circle one:  PASS / FAIL

M.8
Click the [Print] button at the bottom of the Printer Selector window.
Window disappears and the file prints as expected.
Circle one:  PASS / FAIL

N
Add access to a remote printer



N.1
Select SA System > Printer > Printer Administrator from the menu bar at the top of the screen.
The Printer Administrator window opens.
Circle one:  PASS / FAIL

N.2
Select Edit > Add Remote Printer Access from the Printer Administrator window.
The AddRemotePrinter  window opens.
Circle one:  PASS / FAIL

N.3
In the AddRemotePrinter box, type the following:

Local Printer Name:
KPCrmtlp

Remote Host Name:
KPChost

Remote Printer Name: KPCrmtlp

Click [OK] when complete.
The AddRemotePrinter box disappears and an icon appears in the Printer Administrator window.
Circle one:  PASS / FAIL

O
Attempt to print to the remote printer.



O.1
Select SA System > Printer > Printer Manager from the menu bar at the top of the screen.
The Printer Manager window opens.
Circle one:  PASS / FAIL

O.2
Double click on the New Remote Printer.
The icon is highlighted.
Circle one:  PASS / FAIL

O.3
Select Selected  > Set as User default from the Printer Manager window to set the remote printer as the user default.
The Remote Printer is now the default printer.
Circle one:  PASS / FAIL

O.4
Double-click on the File Manager Icon.
The File Manager window opens.
Circle one:  PASS / FAIL

O.5
Select asciifile and drag it down to the printer Icon and Release.
The Print Selector window appears.


Circle one:  PASS / FAIL

O.6
Select the [Print] button at the bottom to Print.
Window disappears and the file is printed as expected.
Circle one:  PASS / FAIL

P
Test Candidate Platform Print Services



P.1
NOTE:  Before starting, make sure that on the Candidate Platform, a printer named "kcpnetlp" has been designated and is enabled as a network printer.

On the Validation Host, select SA System>Printer>Printer Admin from the menu bar at the top of the screen
The Printer Administrator window appears.
 Circle one:  PASS / FAIL

P.2
Select Edit>Add Remote Printer Access from the Printer Administration window.
The Add Remote Printer window appears.
 Circle one:  PASS / FAIL

P.3
In the Add Remote Printer box, type:

Local Printer Name:
kpcrmtlp
Remote host name:
kpccp
Remote Printer name:
kpcnetlp
The new printer appears as an icon in the Printer Administrator window.
 Circle one:  PASS / FAIL

P.4
Find and attach a parallel port type printer to the existing parallel port located in the back of the machine currently in test.
Results are as expected.
 Circle one:  PASS / FAIL

P.5
Select SA System > Printer > Printer Administrator 
The Printer Administrator window appears.
 Circle one:  PASS / FAIL

P.6
Select Edit > Add Printer from the Printer Administrator window.
The Add Remote Printer window appears.
Circle one:  PASS / FAIL 

P.7
In the Add Printer box, type the following information:

Printer Name:

KPCparallel

Host Name:

KPChost

Printer Model Type:
ASCII Printer

Printer Port Type:
Parallel Port

Description:

Parallel Printer

Click [OK] when complete.
The new printer appears as an icon in the Printer Administrator window.
 Circle one:  PASS / FAIL






Q
Command Line Printing



Q.1
From a command line verify Local, Remote and Network print capability using the  /etc/hosts file.

Circle one:  PASS / FAIL

Q.2
Open an xterm by selecting the following items: Application Manager > DII Apps > SA_default > xterm.
An xterm window will open.
Circle one:  PASS / FAIL

Q.3
Login to sysadmin account using the default sysadmin and appropriate password combination.
Cursor is positioned at the command line prompt.
Circle one:  PASS / FAIL

Q.4
Find and attach a parallel port type printer to the existing parallel port located in the back of the machine currently in test.
Results are as expected.
 Circle one:  PASS / FAIL

Q.5
Configure a local printer by performing the following:

Select SA System > Printer > Printer Administrator 
The Printer Administrator window appears.
 Circle one:  PASS / FAIL

Q.6
Select Edit > Add Printer from the Printer Administrator window.
The Add Remote Printer window appears.
 Circle one:  PASS / FAIL

Q.7
In the Add Printer box, type the following information:

Printer Name:


KPCparallel

Host Name:


KPChost

Printer Model Type:

ASCII Printer

Printer Port Type:

Parallel Port

Description:


Parallel Printer

Click [OK] when complete.
The new printer appears as an icon in the Printer Administrator window.
 Circle one:  PASS / FAIL

Q.8
Type: lp –d <local printer name> /etc/hosts
Print file as expected.
Circle one:  PASS / FAIL

Q.9
Type: lp –d <remote printer name> /etc/hosts
Print file as expected.
Circle one:  PASS / FAIL

Q.10
Type: lp –d  <network printer name > /etc/hosts
Print file as expected.
Circle one:  PASS / FAIL

R
Delect all printer(s) whose host is(are)  the Candidate Platform.



R.1
Select SA System > Printer > Printer Administrator from the menu bar at the top of the screen.
The Printer Administrator window opens.
Circle one:  PASS / FAIL

R.2
Click On A Printer ICON to delete.

Circle one:  PASS / FAIL

R.3
Select Edit > Delete > Printer from the Printer Administrator window.
A question appears whether or not to delete the printer.
Circle one:  PASS / FAIL

R.4
Click [OK].
Printer is deleted.
Circle one:  PASS / FAIL

R.5
Repeat steps P.2 through P.4 until all printers are deleted.

Circle one:  PASS / FAIL

R.6
Select File > Exit from the Printer Administrator window.
The Printer Administrator window disappears.
Circle one:  PASS / FAIL

S
Create a new profile with System Administration privileges 



S.1
Login to secman.

Circle one:  PASS / FAIL

S.2
Select Application Manager > DII_APPS > L:SSO_Default
L:SSO Default window

Appears.
Circle one:  PASS / FAIL

S.3
Double-click the Security Manager icon
EM_Security_Manager window appears.
Circle one:  PASS / FAIL

S.4
Select File > New Profile from the EM_Security_Manager window.
New Profile window appears.
Circle one:  PASS / FAIL

S.5
In the New Profile window, please fill in the appropriate information:

Profile ID:              PA Default

Account Group:     System Admin

Classification:        Unclassified

Scope:                    Local

Profile Lock:          Non-Lockable

Change all applications from Available to Assigned.

Click [OK] when complete.
The New Profile window disappears and a new profile:  PA Default is created.
Circle one:  PASS / FAIL

T
Create a new user, assigning the newly created profile to it.



T.1
Select File > New User from the EM_Security_Manager window.
The New User window appears.
Circle one:  PASS / FAIL

T.2
In the New User window, please fill in the appropriate information:

Login name:                   printman

Password/Password Confirmation:  trythis1

Default Profile:              PA Default

Scope:                            local

Under Optional Groups:

Assign the groups:        other

Under Profiles:

Assign the profile:        L:PA Default

Click [OK] when complete.
The New User window disappears and a new user ‘printman’ is created.
Circle one:  PASS / FAIL

T.3
Select File > Exit to close EM_Security_Manager
The EM_Security_Manager window disappears
Circle one:  PASS / FAIL

U
Edit the PA Default profile permissions



U.1
DoubleClick the ‘Edit Profiles’ icons under L:SSO_Default.
The User Profile window appears.
Circle one:  PASS / FAIL

U.2
Edit the PA Default profile inside the Edit Profiles window by highlighting the PA Default profile and clicking [Edit].
The Edit Profile window appears.
Circle one:  PASS / FAIL

U.3
Highlight Printers under the permissions sections of the Edit Profile window and click [Edit] at the bottom of that subsection.
The Edit Permissions window appears.
Circle one:  PASS / FAIL

U.4
Click all three check boxes:  View, Modify Changes, and Change Configuration.  

Click [OK] when complete
The printer permissions are updated.
Circle one:  PASS / FAIL

U.5
Click [OK] and [EXIT] to exit the Edit Profile and User Profiles window respectively.
Both windows disappear.
Circle one:  PASS / FAIL

U.6
Logout of secman.

Circle one:  PASS / FAIL

V
Attempt to modify current printer configuration using Printer Administrator.



V.1
Login as the new user ‘printman’

Circle one:  PASS / FAIL

V.2
Select SA System > Printer > Printer Administrator from the menus at the top of the screen.
The Printer Administrator window should appear.
Circle one:  PASS / FAIL

V.3
Attempt to either add, modify, or delete a printer.
All functions should be available to the user.
Circle one:  PASS / FAIL

V.4
Select File > Exit to close the Printer Administrator.
The Printer Administrator window should disappear.
Circle one:  PASS / FAIL

V.5
Logout of printman.



W
Modify the PA Default profile to restrict user ‘printman’ from making any changes in Printer Administrator.



W.1
Login as secman
User role is assumed.
Circle one:  PASS / FAIL

W.2
Select Application Manager > DII_APPS > L:SSO_Default and double-click on the Edit Profiles Icon.
The User Profiles window is displayed.
Circle one:  PASS / FAIL

W.3
Select SSO_Default and click [Edit]

Close all error windows then,

select the PA Default profile and Click [Edit]
An error message appears.

The Edit Profiles window is displayed.
Circle one:  PASS / FAIL

W.4
Highlight the ‘Printers’ name in the Edit Profiles window and click [Edit]
The Edit Permissions window is displayed.
Circle one:  PASS / FAIL

W.5
Uncheck all three boxes:  View, Modify Changes, and Change Configuration.

Click [OK] when complete.
The Edit Permissions window disappears.
Circle one:  PASS / FAIL

W.6
Click [OK] and [EXIT] to exit the Edit Profile and User Profiles window respectively.
Both windows dissapear.
Circle one:  PASS / FAIL

W.7
Logout of secman



X
Attempt to modify the current printer configuration using Printer Administrator



X.1
Login as printman

Circle one:  PASS / FAIL

X.2
Select SA System > Printer > Printer Administrator from the menus at the top of the screen.
An Error should appear explaining that you need to contact the System Administrator.
Circle one:  PASS / FAIL

X.3
Logout as printman

Circle one:  PASS / FAIL

Y
Delete both profile:  PA Default and user: printman



Y.1
Login as secman

Circle one:  PASS / FAIL

Y.2
Select Applications Manager > DII_APPS > L:SSO_Default > Security Manager.
The Security Manager window is displayed.
Circle one:  PASS / FAIL

Y.3
Select View > Users.  When the list of users are displayed, highlight the user ‘printman’ and choose View > Delete User.
A question will appear if you wish to delete the user.  Click [YES] and continue.

The user ‘printman’ is now deleted.
Circle one:  PASS / FAIL

Y.3
Select View > Profile.  When the list of profiles are displayed, highlight the profile ‘PA Default’ and choose View > Delete Profile
A question will appear if you wish to delete the profile.  Click [YES] and continue.
Circle one:  PASS / FAIL

Y.4
Logout as secman

Circle one:  PASS / FAIL

Z
Drivers (Optional)



Z.1
Logon as sysadmin.

Run the COEPrtInstallDriver tool from /h/COE/bin to install the drivers onto your machine.  Type:

/h/COE/bin/COEPrtInstallDriver <A Printer Driver of your choice> 

NOTE: Due to the fact that each site will have its own printers, every site must customize its own drivers and driver description files. (.ddf).  Each site can also utilize the data segment to install drivers that will “piggyback” current non-DII printer drivers so that they can be used through the DII COE.
Printer drivers customized for system install as expected
Circle one:  PASS / FAIL

Z.2
Access the Add Printer window from the Printer Administrator option.  Access the toggle for drivers.
Customized Printer drivers appear as expected.
Circle one:  PASS / FAIL

Z.3
Run the COEPrtRemoveDriver tool from /h/COE/bin to install the drivers onto your machine.  Type:

/h/COE/bin/COEPrtRemoveDriver <The driver chosen in step Y.1>
Printer drivers customized for system de-install as expected.
Circle one:  PASS / FAIL

Z.4
Access the Add Printer window from the Printer Administrator option.  Access the toggle for drivers.
Customized Printer drivers are not visible.
Circle one:  PASS / FAIL

Z.5
Logout (optional)

Not required.  Use if no further validation is to be done.



Z.6
Unmount the KPC directory exported from the Validation Host.  Type:

 “umount /home1/KPC”

Not required.  Use if no further validation is to be done.
A message confirms that the filesystem has been dismounted.
Shutdown

Z.7
Select System > Close All

Not required.  Use if no further validation is to be done.
All windows close.
Shutdown

Z.8
Select Exit button from CDE.

Not required.  Use if no further validation is to be done.
Logout confirmation window appears.
Shutdown

Z.9
Select Continue Logout
Not required.  Use if no further validation is to be done.
System exits and the DII COE login screen appears.
Shutdown

End of Printer Services Overview Validation Procedure
Print Overview
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