Validation Procedure for DII COE Kernel Platform Compliance: Security Manager (Local)
Validation Procedure for DII COE Kernel Platform Compliance:  Accounts & Profiles - Local

Test Title: Accounts & Profiles - Local Validation Procedure


Candidate Platform:






Date: ____________________________________________

Tester:  







Estimated Runtime:___3 Hours________________________
Start Time:  _____________
  End Time:  _____________

Actual Runtime:  ___________________________________
Test Site/Organization: _____________________________
Overall Test Result:  Circle One:  PASS / FAIL
Configuration Validated
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Printer: 
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Test Purpose/Scope: Test Accounts and Profiles - Local on a standalone machine.
Description: Test local profiles and local users ONLY on a standalone machine.

These test procedures exercise the following basic functionality, with the relevant test steps identified in parenthesis:


-Login (A), and Logout (Z)


-Create Local Users with Local Profiles (B)


-Add a Local Profile to an Existing User (C)


-Test Created Profiles and UNIX Permissions (D)


-Delete Local Profile from Local User and Delete Local Account (E,F,G)


-Create User with No Default Profile (H)

-Reuse of Previously Deleted Account (I)


-Safe Profile Assigned and  not Assigned to User (J,K)


-Safe Profile Coexitst with Other Profiles (L)


-Add Multiple Users (M)


-Users with Multiple Derivative Profiles (N)


-Interaction of Account Groups (O)


-Resume Previously Active Set of Profiles (P)

-Login with NO Available Profile.


-Two Users with Same Login Name in Same Scope (R)


-Two Profiles with Same Name in Same Scope (S)


-Two UNIX Groups with Same Name in Same Scope (T)




Overall Test Result:  The overall PASS/FAIL result for this test is determined as follows:  The overall test result is "PASS" if and only if all steps marked as PASS/FAIL steps in the Observed Result column, have a test step "PASS" result.

Test Step Results:  For each step with a "Circle One:  PASS/FAIL" in the Observed Result column, the tester compares the directly observed Candidate Platform behavior with the "PASS" criteria.  Unless other PASS criteria are noted in the test step, the test step result is "PASS" if and only if the Candidate Platform presents all of the behaviors and conditions described in the Expected Result column for that test step.  The test step result if "FAIL" if the Candidate Platform fails to satisfy any of the PASS criteria.

If the test step result is "PASS", the tester will circle "PASS" and note the actual behaviors and conditions presented in the Observed Result column.  If the observed result precisely matches the expected result, the Observed Result column for the step may contain the statement "as expected."

If the test step result is "FAIL", the tester will circle "FAIL" in the Observed Result column and note the actual behaviors and conditions presented in the Observed Result column.  Additional documentation detailing the reasons for the test step failure is included in the Validation Test Report.
Note 1:  Due to the complexity of any Candidate Platform,  it is impossible to completely specify all aspects of their operation in the space provided.  Many of the expected Candidate Platform behaviors for any test step are implicitly assumed based on industry practice, commercial testing or prior testing, and may not be explicitly described in the Expected Result column.  DISA reserves the right to consider implicit as well as explicit PASS/FAIL criteria which could adversely affect the ability of the Candidate Platform to satisfy DoD mission requirements when used as a component of the DII.

If implicit PASS/FAIL criteria are involved in a "FAIL" determination, the tester will circle "FAIL" in the Observed Result column and note the objectionable behavior in the Observed Result column at the point of observation during the test.  Additional documentation detailing the full rationale for the "FAIL" determination is to be included in the Validation Test Report.

Note2:  Test steps which are "grayed out" (i.e., the entire table row is set to a gray background) are to be considered as waived by DISA for this test version only.  Grayed out test steps are not to be executed nor is observed behavior to be recorded.  These test steps may be returned to the overall test at a future date and are retained for information purposes only.  PASS/FAIL criteria identified in these test steps will not be used in the determination of the overall test result.

Note3:  The symbol “(” (inverted triangle) denotes a blank space.  The “[RETURN]” symbol denotes a carriage return.

Test data and media required:  None.

Setup/Equipment Required:  Candidate Platform must be running in stand alone mode. 

Required Personnel:  One Tester.  The tester is assumed to be very familiar with POSIX/UNIX application platforms, but may not be familiar with Defense Information Infrastructure (DII) Common Operating Environment ( COE).




Step
Operator Action
Expected Result
Observed Result

A
Login (Optional)




A.1
Power up the Candidate Platform.
Optional: Use if not already powered up.
The DII COE login screen will appear.
Startup

A.2
Login to Secman account using the default Secman login and appropriate password combination.

Execute the following menu selection to proceed to the Security Manager menu.

Application Manager > DII_APPS > L:SSO_Default > Security Manager
Optional: Use if not already logged on.
Menu bar, security classification and CDE will appear.

The Security manager menu with the FILE, EDIT & VIEW selections will appear.
Startup

A.3
Mount the KPC directory exported from the Validation Host from an xterm window.  

Type:
su

mount  <Validation Host>: /home1/KPC /home1/KPC
exit
Optional:  Use if not already mounted.
A message confirms that the filesystem has been mounted.
Startup

B
Test basic ability to create a local user with local profiles. 



B.1
Create a new user using the following input criteria.

Open a new user window from Security Manager From the Security Manager window: 
 
File > New User.

A new user ‘test1’ is created.


Circle one:  PASS/FAIL

B.2
In the New User dialog box, Enter the following information:
Parameters:
Login name = test1

Default profile= SSO Default

Assigned UNIX Groups = <none>

Assigned Profiles = L:SSO Default

Scope = local


Circle one:  PASS /FAIL

B.3
Click [OK] when complete

Circle one:  PASS/FAIL

B.4
Confirm the addition of the new user (in secman).  Select:

View > User
'L:test1' should be visible and have an ‘X’ located in the L:SSO_Default  column.
Circle one:  PASS/FAIL

B.5
Confirm the addition of the new user (in sysadmin).

Logout of secman and login as sysadmin.
Menus should appear at the top of the screen.
Circle one:  PASS/FAIL

B.6
Retrieve an Xterm window and list files:
fgrep test1 /etc/group /etc/passwd


User ‘test1’ should not be listed in /etc/group and should only be listed in the /etc/passwd file with a GID = 36.
Circle one:  PASS/FAIL

C
Test ability to add a local profile to an existing user.



C.1
Assign local profile L:SA Default to user test1.
Log out of sysadmin
Profile is modified to access SA_Default privileges.

NOTE: Security Manager assigns new user to group admin by default in this context.
Circle one:  PASS/FAIL

C.2
Log in to secman

Circle one:  PASS/FAIL

C.3
Select Security Manager

Circle one:  PASS/FAIL

C.4
Select View > Users

Circle one:  PASS/FAIL

C.5
Scroll down the list that appears and highlight user ‘test1.’


Circle one:  PASS/FAIL

C.6
Modify the user either by

Double-clicking on the user box

   OR
Selecting Edit > Modify User

Circle one:  PASS/FAIL

C.7
Enter the appropriate information as follows:
Login name = test1
Default profile = <No Change>

Assigned UNIX Groups = <No Change>

Assign  Profiles = L:SA Default

Circle one:  PASS/FAIL

C.8
Click [OK] when complete.

Circle one:  PASS/FAIL

C.9
Confirm the change of information made in Step C.1

(in secman).


Select: View > User
'L:test1' should be visible and have an ‘X’ located in both the L:SSO_Default and 
L:SA_Default columns.
Circle one:  PASS/FAIL

C.10
Confirm the change of information made in Step C.1 (in sysadmin).
Logout of secman and login as sysadmin.
Menus should appear at the top of the screen.


Circle one:  PASS/FAIL

C.11
Retrieve an XTerm window and list files:

fgrep test1 /etc/group /etc/passwd


User ‘test1’ should be listed in /etc/group as a member of group ‘admin’ and in the /etc/passwd file with a GID = 36.  By default, the new user is assigned to the group (admin) of its creator (secman).
Circle one:  PASS/FAIL

D
Test created profiles and necessary UNIX permissions.



D.1
Restrict the availability/execution of profiles created in Step C.1

Login to system as 'test1'.
Both profiles are not allowed to be selected at the same time.
Circle one:  PASS/FAIL

D.2
Select Profile Select > L:SSO_Default
Select Application Manager > DII_APPS > L:SSO_Default > Profile Selector Config
Attempt to run applications from both profiles.

Circle one:  PASS/FAIL

D.3
Set Profile Selection Criteria to Single.



D.4
Activate the Profile Selector and attempt to add both the SSO Default and SA Default profiles.



D.5
Add availability/execution of profiles created in step C.1

Select Profile Select > L:SSO_Default


Circle one:  PASS/FAIL

D.6
Select Application Manager > DII_APPS > L:SSO_Default > Profile Selector Config.

Circle one:  PASS/FAIL

D.7
Set Profile Selection Criteria to Multiple.

Circle one:  PASS/FAIL

D.8
Activate the Profile Selector and attempt to add both SSO_Default and SA_Default profiles.

Circle one:  PASS/FAIL

D.9
Attempt to run applications from both profiles.

Circle one:  PASS/FAIL

D.10
Logout of  'test1'.


Applications should be available to run from both profiles.
Circle one:  PASS/FAIL

D.11
Add the UNIX group 'other' to user 'test1'.



Circle one:  PASS/FAIL

D.12
Login to secman.

Circle one:  PASS/FAIL

D.13
Select Security Manager.

Circle one:  PASS/FAIL

D.14
Select View > Users

Circle one:  PASS/FAIL


Scroll down the list that appears and highlight user 'test1'.

Circle one:  PASS/FAIL

D.15
Modify the user either by

Double-clicking on the user box
   OR
Select Edit > Modify User

Circle one:  PASS/FAIL

D.16
Enter the appropriate information as follows:
Parameters:
Login name = test1

Default profile = <No Change>

Assigned UNIX Groups = other

Assign  Profiles = <No Change>
Profile should be updated with UNIX group ‘other’ added to the UNIX Groups column in View User.
Circle one:  PASS/FAIL

D.17
Click [OK] when complete.

Circle one:  PASS/FAIL

D.18
Confirm the change of information made in Step C.1 (in sysadmin).

Logout of secman and login as sysadmin.

Menus appear at the top of the screen.


D.19
Retrieve an Xterm window and list files:


fgrep test1 /etc/group /etc/passwd


User 'test1' default GID in /etc/passwd should be 36 and test1 should be listed in /etc/group as both ‘admin’ and ‘other’
Circle one:  PASS/FAIL

E
Test capability to delete a local profile from a local user.



E.1
Modify user 'test1' by deassigning the 'SSO Default' profile.
Login to secman
Profile SSO Default should not appear to be connected anywhere with user ‘test1’.
Circle one:  PASS/FAIL

E.2
Select Security Manager

Circle one:  PASS/FAIL

E.3
Select View > Users

Circle one:  PASS/FAIL

E.4
Scroll down the list that appears and highlight user ‘test1.’

Circle one:  PASS/FAIL

E.5
Modify the user either by

Double-clicking on the user box

   OR
Select Edit > Modify User

Circle one:  PASS/FAIL

E.6
Enter the appropriate information as follows:
Parameters:
Login name = test1
Assigned UNIX Groups = <no change>
Assigned Profiles = remove SSO_Default

Circle one:  PASS/FAIL

E.7
Click [OK] when complete.

Circle one:  PASS/FAIL

E.8
Select View > User

Circle one:  PASS/FAIL

F
Verify deletion of local profile from local user.



F.1
Confirm Step F.1

Login as user ‘test1’.
User 'test1' should only be able to select and run applications from the SA Default profile.

Circle one:  PASS/FAIL

F.2
Select Profile Selector.

Circle one:  PASS/FAIL

F.3
Logout of ‘test1’.

Attempt to run applications associated with missing profile.

Circle one:  PASS/FAIL

G
Test deletion of user  account.



G.1
Delete user ‘test1’

Login as secman.

As expected.
Circle one:  PASS/FAIL

G.2
Select Security Manager.
The EM_Security Manager window should appear.
Circle one:  PASS/FAIL

G.3
Select:  View > Users and highlight ‘test1’ under the login column.
User 'test1' is highlighted.
Circle one:  PASS/FAIL

G.4
Select:  Edit > Delete User.
A User Delete box appears.
Circle one:  PASS/FAIL

G.5
Click [YES] to continue.
User's home directory (/h/USERS/local/test1) should be deleted.
Circle one:  PASS/FAIL

G.6
Log out of secman.

Circle one:  PASS/FAIL

G.7
Log in as sysadmin.

Circle one:  PASS/FAIL

G.8
Open a dtterm or xterm.

Circle one:  PASS/FAIL

G.9
cd /h/USERS/local

Circle one:  PASS/FAIL

G.10
Ls (l = the letter el)

Circle one:  PASS/FAIL

G.11
Log out of sysadmin.


Circle one:  PASS/FAIL

H
Test creation of user with no default profile. 



H.1
From secman:

Create a new user with the following parameters:


Login name = test1
Default profile = <none> 
Assigned UNIX Groups = <none>
Assigned Profiles = <none>

Security Manager should force selection of a default profile.  User accounts by definition must be assigned to one or more profiles.


Circle one:  PASS/FAIL

H.2
Select:  View > Users

The first profile listed in the Default 
Profile / Available list should be assigned.
Circle one:  PASS/FAIL

I
Test whether you can cleanly add an account with the same login name and UID as a previously deleted account.  Create a profile as a subset of an account group.




I.1
From secman:

Delete the ‘Safe Profile’ if one exists in the local scope.

Parameters:
Profile = delete 'Safe Profile'

No errors should be generated.

The ‘Safe Profile’ should be deleted from the user-profile DB.
Circle one:  PASS/FAIL

I.2
Create the profile 'SSO_peon' with account group of ‘Security Admin’ and assign several applications to the profile.  

Parameters:

Profile ID: = SSO_peon 

Account Group: = Security Admin
Classification: = <no change>

Scope: = local

Profile Lock: = <no change>

Applications: = assign several

No errors should be generated.

‘SSO_peon’ should appear under View > Profiles (local scope).


Circle one:  PASS/FAIL

I.3
From secman:

Create the profile 'SA_peon'  with account group of ‘System Admin’ and assign several applications to the profile

Parameters:

Profile ID: = SA_peon 

Account Group: = System Admin

Classification: = <no change>

Scope: = local

Profile Lock: = <no change>

Applications: = assign several
No errors should be generated.

'SA_peon’ should appear under View > Profiles (local scope).
Circle one:  PASS/FAIL

I.4
From secman:

Delete and re-create the account for user 'test1', this time using the default profile of 'SSO_peon'.  Don't assign any other Groups or Profiles to the user.


Parameters:

Login name = test1
Default profile = SSO_peon  
Assigned UNIX Groups = <none>
Assigned Profiles = <none>
No errors should be generated.


Circle one:  PASS/FAIL

I.5
Select View > Users
User 'test1' should have the ‘SSO_peon’ profile assigned in the user-profile DB.


I.6
Log out of secman.

Circle one:  PASS/FAIL

I.7
Log in to sysadmin.
User 'test1' default GID in /etc/passwd should be 36. User 'test1' should not be a member of any groups in /etc/group.
Circle one:  PASS/FAIL

I.8
Select Application Manager>DII Apps> 
SA_Default> Xterm

fgrep test1 /etc/passwd /etc/group

Circle one:  PASS/FAIL

I.9
Log out of sysadmin.
Should be able to login as user ‘test1’ and launch icon applications
Circle one:  PASS/FAIL

I.10
Login as user 'test1', select the 'SSO_peon' profile and try to run profiled applications.

Circle one:  PASS/FAIL

I.11
Use Profile Selector to select 'SSO_peon'.

Circle one:  PASS/FAIL

I.12
Attempt to run applications from 'SSO_peon' icon.

Circle one:  PASS/FAIL

I.13
Log out of 'test1'.

Circle one:  PASS/FAIL

J
Test Session Manager operation (when user's last profile has been deleted and a Safe Profile has not been assigned to the user).



J.1
From secman:

Select Application Manager> II_APPS> SSO_Default> Security Manager
No errors should be generated.


Circle one:  PASS/FAIL

J.2
Select View > Users

Circle one:  PASS/FAIL

J.3
Double-click user 'test1'.

Circle one:  PASS/FAIL

J.4
Deassign the ‘SSO_peon’ profile from the user 'test1'.

Parameters:

Login name = test1
Default profile = <no change>
Assigned UNIX Groups = <no 




change>
Assigned Profiles = deassign  



‘SSO_peon’

Circle one:  PASS/FAIL

J.5
Click [OK].

Circle one:  PASS/FAIL

J.6
Log out of secman.

Circle one:  PASS/FAIL

J.7
Log in as sysadmin.

Circle one:  PASS/FAIL

J.8
Select Application Manager> DII_APPS> SA_Default> DTterm. 


fgrep test1 /etc/passwd
User 'test1' default GID in /etc/passwd should be 36.


Circle one:  PASS/FAIL

J.9
Log out of sysadmin.

Circle one:  PASS/FAIL

J.10
Log in to system as 'test1' and examine the Application Manager window.
Session manager should login user 'test1'  
with no profiles
Circle one:  PASS/FAIL

J.11
Use the profile selector to select available profiles.

Circle one:  PASS/FAIL

J.1
Log out of sysadmin.

Circle one:  PASS/FAIL

K
Test Session Manager operation  (with the existence of a Safe Profile assigned to user ‘test1’.



K.1
From secman:

Create a local Safe Profile with account group of ‘Security Admin’ and assign one or more applications to it: 

In the Security Manager window, select File > New Profile and fill in the following information:

Profile ID: = Safe Profile 

Account Group: = Security Admin

Classification: = <no change>

Scope: = local
Profile Lock: = <no change>

Applications: = assign several

No errors should be generated.

The ‘Safe Profile’ should appear under View>Profiles.
Circle one:  PASS/FAIL

K.2
From secman:

Use the Security Manager to edit user ‘test1’.

Parameters:

Login name = test1
Assigned UNIX Groups = <no change>
Assigned Profiles = add Safe Profile
No errors should be generated. 


Circle one:  PASS/FAIL

K.3
Verify the 'Safe Profile' has been assigned to user ‘test1’.

Circle one:  PASS/FAIL

K.4
Login as user ‘test1’ and examine the available applications under Application Manager > DII_Apps.
User 'test1' should not be able to assume previous login profiles. The Security Manager should see that the user is assigned (but hasn't selected) the Safe Profile.
Circle one:  PASS/FAIL

K.5
Use the Profile Selector to select the available profiles.

Circle one:  PASS/FAIL

K.6
Log out of the ‘test1’ account.

Circle one:  PASS/FAIL

L
Test ability of Safe Profile to exist with other profiles.



L.1
From secman:

Add the 'L:SA_Default' profile and the UNIX group ‘other’ to user ‘test1’:

Open the Security Manager
No errors should be generated.

User 'test1' should be assigned to the ‘Safe_Profile’ & ‘SA_Default’ under View > User  .
Circle one:  PASS/FAIL

L.2
Choose View > Users
User 'test1' should be a member of group ‘other’ in   /etc/group.
Circle one:  PASS/FAIL

L.3
Select test1
User 'test1' default GID in  /etc/passwd should be 36.
Circle one:  PASS/FAIL

L.4
Fill in the following information:

Login name = test1
Assigned UNIX Groups = other
Assigned Profiles = L:SA Default

Circle one:  PASS/FAIL

L.5
Click [OK].


Circle one:  PASS/FAIL

L.6
View > User  .

Circle one:  PASS/FAIL

L.7
Log out of secman.

Circle one:  PASS/FAIL

L.8
Log in as sysadmin.

Circle one:  PASS/FAIL

L.9
Application Manager > Xterm


fgrep test1 /etc/group /etc/password

Circle one:  PASS/FAIL

L.10
Log out of sysadmin.




Circle one:  PASS/FAIL

L.2
1.
Login as user ‘test1’.

2.
Launch applications from both the ‘SA Default’ and ‘Safe Profile’ profiles.


No errors should be generated.

User 'test1' should be able to launch applications from both profiles.
Circle one:  PASS/FAIL

M
Test ability to add multiple users.



M.1
From secman:

Create a new user 'test2' as follows:

Open the Security Manager


No errors should be generated.

User should be assigned to the 
L:SSO Default.


Circle one:  PASS/FAIL

M.2
Select File > New User
User 'test2' should be a member of the UNIX group ‘nobody’ in  /etc/group.
Circle one:  PASS/FAIL

M.3
Fill in the following information:

Login name = test2
Default profile = SSO Default
Assigned UNIX Groups:

= nobody (Solaris)

= nogroup (HP-UX)

Assigned Profiles = L:SSO Default
User 'test2' default GID in /etc/passwd should be 36.
Circle one:  PASS/FAIL

M.4
Click [OK] when finished

Circle one:  PASS/FAIL

M.5
View > User  

Circle one:  PASS/FAIL

M.6
Log out of secman.

Circle one:  PASS/FAIL

M.7
Log in to sysadmin.

Circle one:  PASS/FAIL

M.8
Application Manager > XTerm

fgrep test2 /etc/group /etc/passwd

Circle one:  PASS/FAIL

M.9
Log out of sysadmin.

Circle one:  PASS/FAIL

M.10
From secman:

Create a new user 'test3' as follows:

Open the Security Manager
No errors should be generated.
Circle one:  PASS/FAIL

M.11
Select File > New User

Circle one:  PASS/FAIL

M.12
Fill in the following information:

Login name = test 3

Default profile = SA_peon

Assigned UNIX Groups = <none>

Assigned Profiles = L:SA_peon

Circle one:  PASS/FAIL

M.13
Click [OK] when finished.

Circle one:  PASS/FAIL

M.14
View > User  .
User 'test3' should be assigned to the 
‘SA_peon’ profile.
Circle one:  PASS/FAIL

M.15
Log out of secman.

Circle one:  PASS/FAIL

M.16
Log in to sysadmin.

Circle one:  PASS/FAIL

M.17
Application Manager > XTerm

fgrep test3 /etc/group /etc/passwd
User 'test3' should be a member of no 
groups in  /etc/group.
User 'test3' default GID in /etc/passwd should be 1.
Circle one:  PASS/FAIL

M.18
Log out of sysadmin.


Circle one:  PASS/FAIL

N
Test users with multiple derivative profiles.



N.1
From secman:

Create a new profile 'SA_grunt' with account group ‘System Admin’ and assign some applications to it.

Open the Security Manager


No errors should be generated.

The ‘SA_grunt’ profile should appear. 


Circle one:  PASS/FAIL

N.2
Select File > New Profile

Circle one:  PASS/FAIL

N.3
Fill in the following information:

Profile ID: = SA_grunt 

Account Group: = System Admin

Classification: = <no change>

Scope: = local

Profile Lock: = <no change>

Applications: = assign several



N.4
Click [OK] when finished.

Circle one:  PASS/FAIL

N.1
View > Profiles

Circle one:  PASS/FAIL

O
Test interactions of account groups.



O.1
From secman:

Add the ‘L:SA_grunt’ profile and UNIX group  'other'  to user 'test2'.

Parameters:

Login name = test 2
Assigned UNIX Groups = add other
Assigned Profiles = add SA_grunt
No errors should be generated.
Circle one:  PASS/FAIL

O.2
Click [OK] when finished.
User 'test2' should have the ‘SA_grunt’  &  SSO_Default’ profiles assigned  under 
View > User  .
Circle one:  PASS/FAIL

O.3
View > User  
User 'test2' should now be a member of the 'other' group in  /etc/group file. User 'test2' default GID in /etc/passwd should be 36.
Circle one:  PASS/FAIL

O.4
Log out of secman.

Circle one:  PASS/FAIL

O.5
From sysadmin:

Application Manager >Xterm 

fgrep test2 /etc/group /etc/passwd
No errors should be generated.

User ‘test2’ should be able to launch applications from both profiles.
Circle one:  PASS/FAIL

O.6
Log out of sysadmin.

Circle one:  PASS/FAIL

O.7
Log in as user 'test2'.

Circle one:  PASS/FAIL

O.8
Use the profile selector to activate both the 
‘L:SA grunt’ and ‘L:SSO Default’ profiles

Circle one:  PASS/FAIL

O.9
Examine DII_Apps for available profiles

Circle one:  PASS/FAIL

O.10
Click on each profile and launch an application from each folder.

Circle one:  PASS/FAIL

O.11
Log out 'test2'.



Circle one:  PASS/FAIL

P
Test session manager's ability to resume the previously active set of profiles.



P.1
Log back in as user 'test2'
No errors should be generated.

User should have both the ‘SA_grunt’ and ‘SSO Default’ profiles available.
Circle one:  PASS/FAIL

P.2
Examine the application manager to (or use the profile selector) to determine the profiles that are available.

Circle one:  PASS/FAIL

P.3
Log out 'test2'.



Circle one:  PASS/FAIL

Q
Test ability to login with NO available profile.  Delete user's only (and default) profile.



Q.1
From secman:

Remove the ‘SA_peon’ profile from user 'test3':

In Security Manager, select View > Users

Remove profile L:SA_peon from user test3
No errors should be generated.

User ‘test3’ profiles previously used are unavailable and the Safe Profile has been assigned by default
Circle one:  PASS/FAIL

Q.2
Click [OK] when finished.
The DII_Apps window should have only the Safe Profile’s application folders.
Circle one:  PASS/FAIL

Q.3
Log out of secman.
The profile selector should show that user ‘test3’ has only the Safe Profile assigned.
Circle one:  PASS/FAIL

Q.4
Log in to system as user ‘test3’.

Circle one:  PASS/FAIL

Q.5
Examine DII_Apps for available profiles.

Circle one:  PASS/FAIL

Q.6
Examine Profile Selector for assignable profiles.

Circle one:  PASS/FAIL

R
Test ability to detect two users with the same login name in the same scope.



R.1
From secman:

Create a new user 'test2' as follows:

Open the Security Manager
Should receive error message “duplicate user name”   (since the user 'test2' has already been defined).
Circle one:  PASS/FAIL


Select File > New User

Circle one:  PASS/FAIL


Fill in the following information:

Login name = test2
Default profile = SSO_Default
Assigned Profiles = L:SSO_Default

Circle one:  PASS/FAIL

R.1
Click [OK] when finished.

Circle one:  PASS/FAIL

S
Test ability to detect two profiles with the same name in the same scope.



S.1
From secman:

Create a new profile 'SA_peon' as follows:

Open the Security Manager
Should receive error message “duplicate profile name.  Profile ‘SA_peon’ was not added”    (since profile ‘SA_peon’  has already been defined).
Circle one:  PASS/FAIL

S.2
Select File > New Profile

Circle one:  PASS/FAIL

S.3
Fill in the following information:

Profile ID = SA_peon

Account Group = System Admin
Scope = local

Circle one:  PASS/FAIL

S.4
Click [OK] when finished.

Circle one:  PASS/FAIL

T
Test ability to detect two UNIX groups with the same name in the same scope.



T.1
From secman:

Create a new UNIX group 'admin' as follows:

Open Security Manager.


Should receive error message “duplicate group name” (since the UNIX Group 'admin' has already been defined).
Circle one:  PASS/FAIL

T.2
Select File > New Group.

Circle one:  PASS/FAIL

T.3
Fill in the following information:

UNIX group name = admin
Scope = local (not selectable in this context)
GID = <as assigned by security manager>

Circle one:  PASS/FAIL

T.4
Click [OK] when finished.

Circle one:  PASS/FAIL

T.5
From secman: 

View user information from COE Secman,        Security Manager:  View > Users.
Action should NOT have altered any of the UNIX group or user-profile database files.

Ensure that duplicate users ‘test2’ do not exist.


T.6
Log out of secman.

Circle one:  PASS/FAIL

T.7
From sysadmin:

Application Manager > Xterm.

Circle one:  PASS/FAIL

T.8
fgrep test2 /etc/etc/passwd
fgrep admin /etc/group
Ensure that duplicate groups ‘admin’ do not exist.
Circle one:  PASS/FAIL

T.9
Log out of sysadmin.

Circle one:  PASS/FAIL

Z
Logout (optional)




Z.1
Unmount the KPC directory exported from the Validation Host.  
Type: “umount /home1/KPC”
Not required.  Use if no further validation is to be done.
A message confirms that the filesystem has been dismounted.
Shutdown

Z.2
Login to secman and delete users: ‘test1’, ‘test2’, ‘test3’ and profiles ‘SSO_peon, SA_peon, Safe_Profile, and SA_grunt’

From sysadmin:

Confirm using an X-term window the deletion of all /h/USERS/local user and profile directories as appropriate.
All temporary users and profiles created have been deleted.
 Cleanup

Z.3
Select System > Close All

Not required.  Use if no further validation is to be done.
All windows close.
Shutdown

Z.4
Select Exit button from CDE
Not required.  Use if no further validation is to be done.
Logout confirmation window appears.
 Shutdown

Z.5
Select Continue Logout
Not required.  Use if no further validation is to be done.
System exits and the DII COE login screen appears.
 Shutdown
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